Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

nombre réponses : 8

#0 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 22/09/2012, à 13:57

tomhonor
Réponses : 2641

Bonjour,

Heureux possesseur Asus Zenbook UX32VDR4002V, je viens d'installer Ubuntu Quantal 12.10 :

$ mkdir /tmp/new_kernel
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-headers-3.6.0-999_3.6.0-999.201209170418_all.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-headers-3.6.0-999-generic_3.6.0-999.201209170418_amd64.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-image-3.6.0-999-generic_3.6.0-999.201209170418_amd64.deb
$ wget http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-image-extra-3.6.0-999-generic_3.6.0-999.201209170418_amd64.deb
$ sudo dpkg -i *.deb
Reboot
$ sudo add-apt-repository ppa:bumblebee/stable
$ sudo apt-get purge nvidia-current
$ sudo apt-add-repository 'deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu precise main' # no quantal repo at this moment...
$ sudo apt-get update
$ sudo apt-get install bumblebee bumblebee-nvidia 

Fonctionnement OK avec $ optirun glxspheres, cependant, le fonctionnement avec Google chrome n'est pas probant :

 $ optirun google-chrome 
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
Created new window in existing browser session.

chrome://gpu

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Compositing: Software only, hardware acceleration unavailable
3D CSS: Unavailable. Hardware acceleration unavailable
CSS Animation: Software only, hardware acceleration unavailable
WebGL: Unavailable. Hardware acceleration unavailable
WebGL multisampling: Unavailable. Hardware acceleration unavailable
Flash 3D: Unavailable. Hardware acceleration unavailable
Flash Stage3D: Unavailable. Hardware acceleration unavailable
Texture Sharing: Unavailable. Hardware acceleration unavailable
undefined: Software only, hardware acceleration unavailable
Problems Detected
Intel mesa drivers are crash-prone.: 76703
Accelerated 2d canvas is unstable in Linux at the moment.
Multisampling is buggy in Intel IvyBridge.: 116370
Stage3D is not supported on Linux.: 129848
Version Information
Data exported	Sat Sep 22 2012 14:52:51 GMT+0200 (CEST)
Chrome version	22.0.1229.64 (Official Build 157476) beta
Operating system	Linux 3.6.0-999-generic
Software rendering list version	2.8
ANGLE revision	1245
2D graphics backend	Skia
Driver Information
Initialization time	0
GPU0	VENDOR = 0x8086 [Intel Corporation], DEVICE= 0x0166 [3rd Gen Core processor Graphics Controller]
Optimus	false
AMD switchable	false
Driver vendor	
Driver version	
Driver date	
Pixel shader version	
Vertex shader version	
GL version	
GL_VENDOR	
GL_RENDERER	
GL_VERSION	
GL_EXTENSIONS	

Une idée ?

 $ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu quantal (development branch)
Release:	12.10
Codename:	quantal

$ uname -a
Linux hostname 3.6.0-999-generic #201209170418 SMP Mon Sep 17 08:19:54 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

 $ google-chrome --version
Google Chrome 22.0.1229.64 beta

$ nvidia-settings --version

nvidia-settings:  version 304.37  (buildd@komainu)  Tue Aug 28 15:11:01 UTC 2012
  The NVIDIA X Server Settings tool.

  This program is used to configure the NVIDIA Linux graphics driver.
  For more detail, please see the nvidia-settings(1) man page.

  Copyright (C) 2004 - 2010 NVIDIA Corporation.

$ optirun --version
optirun (Bumblebee) 3.0.1
Copyright (C) 2011 The Bumblebee Project
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

#1 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 24/09/2012, à 13:45

tomhonor
Réponses : 2641
cdjklm a écrit :

juste petite question,sert à quoi faire fonctionner chrome avec la nvidia?

Youtube Full HD, html5 + canvas 3D par exemple.

#2 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 25/09/2012, à 16:44

tomhonor
Réponses : 2641
ArchangeGabriel a écrit :

Pour Chrome, c'est pas possible car ça fait partie des programmes dont l'exécutable est protégé de telle sorte qu'on ne peut pas l'utiliser à travers VirtualGL.

Ok, merci pour la réponse. (dommage..)

Questions diverses :

[*]Je souhaite bidouiller avec CUDA 5.0.24 64 bits sous Ubuntu 12.10-beta : Puis-je/dois-je remplacer les drivers déjà installés par ceux proposés par l'installateur ?[/*]

[*]À quand une roadmap sur le wiki ? En effet, même si il y a un peu d'animation dans la branch develop, le dernier commit de la branche master commence à dater. (et si je suis pas content, rien de m'empêche de coder (sauf mon niveau en C peut-être...) [/*]

#3 Re : -1 »  Ordinateurs Portables - Technologie hybride (2 cartes) nVidia Optimus » Le 25/09/2012, à 20:36

tomhonor
Réponses : 2641
ArchangeGabriel a écrit :

@tomhonor : Pour CUDA c'est variable, normalement les drivers de base suffisent, après ça dépend peut-être des versions. Il y a quelques threads dans les Issues sur GitHub là-dessus.

L'installateur me propose :

$ sudo ./cuda_5.0.24_linux_64_ubuntu11.10.run 
Logging to /tmp/cuda_install_5227.log
Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 304.33? (yes/no/quit)
$ lsb_release -cr
Release:	12.10
Codename:	quantal
$ apt-cache policy nvidia-current
nvidia-current:
  Installed: 304.43-0ubuntu5
  Candidate: 304.51-0ubuntu1~precise~xup1
  Version table:
     304.51-0ubuntu1~precise~xup1 0
        500 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ precise/main amd64 Packages
 *** 304.43-0ubuntu5 0
        500 http://fr.archive.ubuntu.com/ubuntu/ quantal/restricted amd64 Packages
        100 /var/lib/dpkg/status

La dernier version pour ma carte Geforce GT 620M est la 304.51. (on est loin de la 306.23) La note de page du driver indique :

Note that the list of supported GPU products is provided to indicate which GPUs are supported by a particular driver version. Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available.

Pas très rassurant, mais c'est pas nouveau non plus.

ArchangeGabriel a écrit :

Pour la roadmap, il y en avait une sur GitHub, mais a priori on ne développe plus activement le projet sachant que les efforts à fournir pour les fonctionnalités supplémentaires sont assez grands, alors que pendant ce temps nvidia a commencé à s'occuper du support officiel et que PRIME commence à voir le jour dans les versions actuelles des composants système.

Le "Fuck Nvidia" aura peut-être servit à quelque chose...

Deux articles sur le sujet :
* http://www.h-online.com/open/news/item/ … 01627.html
* http://www.h-online.com/open/news/item/ … 97756.html
Sympa, mais ça ne donne pas de date de dispo...

Ubuntu 12.10 devrait cependant bien suppporter Optimus d'après launchpad.

D'où la question : Doit-on installer Bumblebee sous Ubuntu 12.10 vu que X Server 1.13 semble gérer Prime ?

P.S : N'hésitez pas à corriger si j'ai mis des conneries.

#4 -1 »  Mise à jour de mysql-server-5.0 sur debian 5.0.4 » Le 28/02/2010, à 14:15

tomhonor
Réponses : 2

Bonjour à tous,

Je tente de réaliser une mise à jour de mon serveur sous debian 5.0.4[1]. Voici ce que j'ai réalisé :

Version résumé de ce qui suit :
# aptitude update
# aptitude safe-upgrade
# aptitude reinstall mysql-server-5.0
# aptitude full-upgrade
# aptitude remove mysql-server-5.0
# aptitude full-upgrade
# /etc/init.d/mysql stop
Stopping MySQL database server: mysqld failed!
# kill -9 <mysqld process>
# aptitude full-upgrade
# ps -ef |grep mysql
# kill <process aptitude et dpkg>
# dpkg --configure -a

Du coté des logs, rien (mydql.err & mysql.log sont vides) mais il y a des choses du coté de syslog à la fin de ce post.


Quelle procédure dois-je adopter pour mettre à jour mysql-server-5.0 ?

ping:~/sql# aptitude update && aptitude full-upgrade
Atteint ftp://mir1.ovh.net lenny Release.gpg
Atteint ftp://mir1.ovh.net lenny/main Translation-fr    
Atteint ftp://mir1.ovh.net lenny Release                
Atteint http://security.debian.org lenny/updates Release.gpg
Ign http://security.debian.org lenny/updates/main Translation-fr
Atteint http://security.debian.org lenny/updates Release 
Prendre�: 1 ftp://mir1.ovh.net lenny/main Packages/DiffIndex
Ign ftp://mir1.ovh.net lenny/main Packages/DiffIndex
Prendre�: 2 ftp://mir1.ovh.net lenny/main Sources/DiffIndex
Ign ftp://mir1.ovh.net lenny/main Sources/DiffIndex
Atteint ftp://mir1.ovh.net lenny/main Packages
Atteint ftp://mir1.ovh.net lenny/main Sources
81% [Release gpgv 40771]^C
pong:~/sql# aptitude update && aptitude safe-upgrade
Atteint ftp://mir1.ovh.net lenny Release.gpg
Atteint ftp://mir1.ovh.net lenny/main Translation-fr    
Atteint ftp://mir1.ovh.net lenny Release                
Prendre�: 1 ftp://mir1.ovh.net lenny/main Packages/DiffIndex                 
Ign ftp://mir1.ovh.net lenny/main Packages/DiffIndex                   
Prendre�: 2 ftp://mir1.ovh.net lenny/main Sources/DiffIndex            
Ign ftp://mir1.ovh.net lenny/main Sources/DiffIndex                   
Atteint ftp://mir1.ovh.net lenny/main Packages                        
Atteint ftp://mir1.ovh.net lenny/main Sources           
Prendre�: 3 http://security.debian.org lenny/updates Release.gpg [835B]
Ign http://security.debian.org lenny/updates/main Translation-fr
Atteint http://security.debian.org lenny/updates Release
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
Atteint http://security.debian.org lenny/updates/main Packages
Atteint http://security.debian.org lenny/updates/main Sources
 835o t�l�charg�s en 1s (669o/s)
Lecture des listes de paquets... Fait

Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu      
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants ont �t� conserv�s�: 
  mysql-server-5.0 
Les paquets suivants seront mis � jour�: 
  dhcp3-client dhcp3-common dselect libapache2-mod-php5 libglib2.0-0 libglib2.0-data libkpathsea4 libmysqlclient15-dev 
  linux-libc-dev php5-cgi php5-cli php5-common php5-gd php5-mcrypt php5-mysql texlive-base-bin texlive-base-bin-doc 
  texlive-extra-utils tshark usbutils wireshark-common 
21 paquets mis � jour, 0 nouvellement install�s, 0 � enlever et 1 non mis � jour.
Il est n�cessaire de t�l�charger 0o d'archives. Apr�s d�paquetage, 49,2ko seront utilis�s.
Voulez-vous continuer�? [Y/n/?] Y
E: Impossible de localiser un fichier du paquet mysql-server-5.0. Cela signifie que vous devrez corriger ce paquet vous-m�me.
�criture de l'information d'�tat �tendu... Fait
E: Impossible de localiser un fichier du paquet mysql-server-5.0. Cela signifie que vous devrez corriger ce paquet vous-m�me.
E: Erreur interne�: impossible de cr�er la liste des paquets � t�l�charger



ping:~/sql# aptitude reinstall mysql-server-5.0
Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu      
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants seront R�INSTALL�S�: 
  mysql-server-5.0 
0 paquets mis � jour, 0 nouvellement install�s, 1 r�install�s, 0 � enlever et 21 non mis � jour.
Il est n�cessaire de t�l�charger 0o d'archives. Apr�s d�paquetage, 0o seront utilis�s.
E: Impossible de localiser un fichier du paquet mysql-server-5.0. Cela signifie que vous devrez corriger ce paquet vous-m�me.
�criture de l'information d'�tat �tendu... Fait
E: Impossible de localiser un fichier du paquet mysql-server-5.0. Cela signifie que vous devrez corriger ce paquet vous-m�me.
E: Erreur interne�: impossible de cr�er la liste des paquets � t�l�charger



ping:~/sql# aptitude full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu      
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants seront mis � jour�: 
  dhcp3-client dhcp3-common dselect libapache2-mod-php5 libglib2.0-0 libglib2.0-data libkpathsea4 libmysqlclient15-dev 
  linux-libc-dev mysql-server-5.0 php5-cgi php5-cli php5-common php5-gd php5-mcrypt php5-mysql texlive-base-bin 
  texlive-base-bin-doc texlive-extra-utils tshark usbutils wireshark-common 
Les paquets suivants sont RECOMMAND�S mais ne seront pas install�s�:
  libhtml-template-perl 
22 paquets mis � jour, 0 nouvellement install�s, 0 � enlever et 0 non mis � jour.
Il est n�cessaire de t�l�charger 0o/69,8Mo d'archives. Apr�s d�paquetage, 369ko seront lib�r�s.
Voulez-vous continuer�? [Y/n/?] Y
�criture de l'information d'�tat �tendu... Fait
Pr�configuration des paquets...
S�lection du paquet mysql-server-5.0 pr�c�demment d�s�lectionn�.
(Lecture de la base de donn�es... 53003 fichiers et r�pertoires d�j� install�s.)
Pr�paration du remplacement de mysql-server-5.0 5.0.51a-24+lenny2 (en utilisant .../mysql-server-5.0_5.0.51a-24+lenny3_i386.deb) ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg�: avertissement - ancien script pre-removal a retourn� un code d'erreur de sortie 1
dpkg - tentative d'ex�cution du script du nouveau paquet � la place ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg�: erreur de traitement de /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny3_i386.deb (--unpack)�:
 le sous-processus nouveau script pre-removal a retourn� une erreur de sortie d'�tat 1
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg�: erreur lors du nettoyage�:
 le sous-processus post-installation script a retourn� une erreur de sortie d'�tat 1
Pr�paration du remplacement de dhcp3-client 3.1.1-6+lenny3 (en utilisant .../dhcp3-client_3.1.1-6+lenny4_i386.deb) ...
D�paquetage de la mise � jour de dhcp3-client ...
Pr�paration du remplacement de dhcp3-common 3.1.1-6+lenny3 (en utilisant .../dhcp3-common_3.1.1-6+lenny4_i386.deb) ...
D�paquetage de la mise � jour de dhcp3-common ...
Pr�paration du remplacement de dselect 1.14.25 (en utilisant .../dselect_1.14.28_i386.deb) ...
D�paquetage de la mise � jour de dselect ...
Pr�paration du remplacement de php5-cli 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-cli_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-cli ...
Pr�paration du remplacement de php5-cgi 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-cgi_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-cgi ...
Pr�paration du remplacement de php5-mysql 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-mysql_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-mysql ...
Pr�paration du remplacement de php5-mcrypt 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-mcrypt_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-mcrypt ...
Pr�paration du remplacement de php5-gd 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-gd_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-gd ...
Pr�paration du remplacement de libapache2-mod-php5 5.2.6.dfsg.1-1+lenny4 (en utilisant .../libapache2-mod-php5_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de libapache2-mod-php5 ...
Pr�paration du remplacement de php5-common 5.2.6.dfsg.1-1+lenny4 (en utilisant .../php5-common_5.2.6.dfsg.1-1+lenny6_i386.deb) ...
D�paquetage de la mise � jour de php5-common ...
Pr�paration du remplacement de libglib2.0-0 2.16.6-2 (en utilisant .../libglib2.0-0_2.16.6-3_i386.deb) ...
D�paquetage de la mise � jour de libglib2.0-0 ...
Pr�paration du remplacement de libglib2.0-data 2.16.6-2 (en utilisant .../libglib2.0-data_2.16.6-3_all.deb) ...
D�paquetage de la mise � jour de libglib2.0-data ...
Pr�paration du remplacement de libkpathsea4 2007.dfsg.2-4+lenny1 (en utilisant .../libkpathsea4_2007.dfsg.2-4+lenny2_i386.deb) ...
D�paquetage de la mise � jour de libkpathsea4 ...
Pr�paration du remplacement de libmysqlclient15-dev 5.0.51a-24+lenny2 (en utilisant .../libmysqlclient15-dev_5.0.51a-24+lenny3_i386.deb) ...
D�paquetage de la mise � jour de libmysqlclient15-dev ...
Pr�paration du remplacement de linux-libc-dev 2.6.26-19lenny2 (en utilisant .../linux-libc-dev_2.6.26-21lenny3_i386.deb) ...
D�paquetage de la mise � jour de linux-libc-dev ...
Pr�paration du remplacement de texlive-base-bin 2007.dfsg.2-4+lenny1 (en utilisant .../texlive-base-bin_2007.dfsg.2-4+lenny2_i386.deb) ...
D�paquetage de la mise � jour de texlive-base-bin ...
Pr�paration du remplacement de texlive-base-bin-doc 2007.dfsg.2-4+lenny1 (en utilisant .../texlive-base-bin-doc_2007.dfsg.2-4+lenny2_i386.deb) ...
D�paquetage de la mise � jour de texlive-base-bin-doc ...
Pr�paration du remplacement de texlive-extra-utils 2007.dfsg.2-4+lenny1 (en utilisant .../texlive-extra-utils_2007.dfsg.2-4+lenny2_i386.deb) ...
D�paquetage de la mise � jour de texlive-extra-utils ...
Pr�paration du remplacement de tshark 1.0.2-3+lenny7 (en utilisant .../tshark_1.0.2-3+lenny8_i386.deb) ...
D�paquetage de la mise � jour de tshark ...
Pr�paration du remplacement de wireshark-common 1.0.2-3+lenny7 (en utilisant .../wireshark-common_1.0.2-3+lenny8_i386.deb) ...
D�paquetage de la mise � jour de wireshark-common ...
Pr�paration du remplacement de usbutils 0.73-10 (en utilisant .../usbutils_0.73-10lenny1_i386.deb) ...
D�paquetage de la mise � jour de usbutils ...
Traitement des actions diff�r�es (��triggers��) pour � man-db �...
Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
 /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
�chec de l'installation d'un paquet. Tentative de r�paration�: 
Param�trage de libkpathsea4 (2007.dfsg.2-4+lenny2) ...
Param�trage de linux-libc-dev (2.6.26-21lenny3) ...
Param�trage de texlive-base-bin-doc (2007.dfsg.2-4+lenny2) ...
Running mktexlsr. This may take some time... done.
Param�trage de usbutils (0.73-10lenny1) ...
Param�trage de php5-common (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de libmysqlclient15-dev (5.0.51a-24+lenny3) ...
Param�trage de texlive-extra-utils (2007.dfsg.2-4+lenny2) ...
Running mktexlsr. This may take some time... done.
dpkg�: erreur de traitement de mysql-server-5.0 (--configure)�:
 Le paquet est dans un �tat vraiment incoh�rent - vous devriez
 le r�installer avant de tenter de le configurer.
Param�trage de php5-cli (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de dselect (1.14.28) ...
Param�trage de libapache2-mod-php5 (5.2.6.dfsg.1-1+lenny6) ...
Reloading web server config: apache2apache2: Could not reliably determine the server's fully qualified domain name, using pong.2xyo.info for ServerName
.
Param�trage de dhcp3-common (3.1.1-6+lenny4) ...
Param�trage de php5-mysql (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de libglib2.0-0 (2.16.6-3) ...
Param�trage de texlive-base-bin (2007.dfsg.2-4+lenny2) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all.
	This may take some time... done.
Param�trage de libglib2.0-data (2.16.6-3) ...
Param�trage de dhcp3-client (3.1.1-6+lenny4) ...
Param�trage de php5-cgi (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de php5-gd (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de php5-mcrypt (5.2.6.dfsg.1-1+lenny6) ...
Param�trage de wireshark-common (1.0.2-3+lenny8) ...
Param�trage de tshark (1.0.2-3+lenny8) ...
Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
 mysql-server-5.0
Lecture des listes de paquets... Fait          
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu       
Initialisation de l'�tat des paquets... Fait
�criture de l'information d'�tat �tendu... Fait
Lecture des descriptions de t�ches... Fait     

�tat actuel�: 1 mise � jour restante [-21].




ping:~/sql# aptitude remove mysql-server-5.0
Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu       
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants seront ENLEV�S�: 
  mysql-server-5.0 
0 paquets mis � jour, 0 nouvellement install�s, 1 � enlever et 0 non mis � jour.
Il est n�cessaire de t�l�charger 0o d'archives. Apr�s d�paquetage, 84,1Mo seront lib�r�s.
�criture de l'information d'�tat �tendu... Fait
dpkg�: erreur de traitement de mysql-server-5.0 (--remove)�:
 Le paquet est dans un �tat incoh�rent - vous devriez
 le r�installer avant d'essayer de le supprimer.
Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
 mysql-server-5.0
E: Sub-process /usr/bin/dpkg returned an error code (1)
�chec de l'installation d'un paquet. Tentative de r�paration�: 
Lecture des listes de paquets... Fait          
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu       
Initialisation de l'�tat des paquets... Fait
�criture de l'information d'�tat �tendu... Fait
Lecture des descriptions de t�ches... Fait  



pong:~/sql# aptitude full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu      
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants seront mis � jour�: 
  mysql-server-5.0 
Les paquets suivants sont RECOMMAND�S mais ne seront pas install�s�:
  libhtml-template-perl 
1 paquets mis � jour, 0 nouvellement install�s, 0 � enlever et 0 non mis � jour.
Il est n�cessaire de t�l�charger 0o/26,7Mo d'archives. Apr�s d�paquetage, 418ko seront lib�r�s.
Voulez-vous continuer�? [Y/n/?] Y
�criture de l'information d'�tat �tendu... Fait
Pr�configuration des paquets...
S�lection du paquet mysql-server-5.0 pr�c�demment d�s�lectionn�.
(Lecture de la base de donn�es... 53003 fichiers et r�pertoires d�j� install�s.)
Pr�paration du remplacement de mysql-server-5.0 5.0.51a-24+lenny2 (en utilisant .../mysql-server-5.0_5.0.51a-24+lenny3_i386.deb) ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg�: avertissement - ancien script pre-removal a retourn� un code d'erreur de sortie 1
dpkg - tentative d'ex�cution du script du nouveau paquet � la place ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg�: erreur de traitement de /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny3_i386.deb (--unpack)�:
 le sous-processus nouveau script pre-removal a retourn� une erreur de sortie d'�tat 1
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg�: erreur lors du nettoyage�:
 le sous-processus post-installation script a retourn� une erreur de sortie d'�tat 1
Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
 /var/cache/apt/archives/mysql-server-5.0_5.0.51a-24+lenny3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
�chec de l'installation d'un paquet. Tentative de r�paration�: 
dpkg�: erreur de traitement de mysql-server-5.0 (--configure)�:
 Le paquet est dans un �tat vraiment incoh�rent - vous devriez
 le r�installer avant de tenter de le configurer.
Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
 mysql-server-5.0
Lecture des listes de paquets... Fait          
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu       
Initialisation de l'�tat des paquets... Fait
�criture de l'information d'�tat �tendu... Fait
Lecture des descriptions de t�ches... Fait


ping:~/sql# aptitude full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des d�pendances       
Lecture des informations d'�tat... Fait
Lecture de l'information d'�tat �tendu      
Initialisation de l'�tat des paquets... Fait
Lecture des descriptions de t�ches... Fait  
Les paquets suivants seront mis � jour�: 
  mysql-server-5.0 
Les paquets suivants sont RECOMMAND�S mais ne seront pas install�s�:
  libhtml-template-perl 
1 paquets mis � jour, 0 nouvellement install�s, 0 � enlever et 0 non mis � jour.
Il est n�cessaire de t�l�charger 0o/26,7Mo d'archives. Apr�s d�paquetage, 418ko seront lib�r�s.
Voulez-vous continuer�? [Y/n/?] Y
�criture de l'information d'�tat �tendu... Fait
Pr�configuration des paquets...
(Lecture de la base de donn�es... 53003 fichiers et r�pertoires d�j� install�s.)
Pr�paration du remplacement de mysql-server-5.0 5.0.51a-24+lenny2 (en utilisant .../mysql-server-5.0_5.0.51a-24+lenny3_i386.deb) ...
Stopping MySQL database server: mysqld.
Stopping MySQL database server: mysqld.
D�paquetage de la mise � jour de mysql-server-5.0 ...
Traitement des actions diff�r�es (��triggers��) pour � man-db �...
Param�trage de mysql-server-5.0 (5.0.51a-24+lenny3) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.

^Cdpkg�: erreur de traitement de mysql-server-5.0 (--configure)�:
 sous-processus post-installation script tu� par le signal (Interruption)
^C
E: Sub-process /usr/bin/dpkg exited unexpectedly
�chec de l'installation d'un paquet. Tentative de r�paration�: 
Param�trage de mysql-server-5.0 (5.0.51a-24+lenny3) ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
Processus arr�t
ping:~/sql# Starting MySQL database server: mysqld . .
ping:~/sql#  . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.

ping:~/sql# ps -ef |grep mysql
root      9779     1  0 12:43 ?        00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql     9819  9779  0 12:43 ?        00:00:01 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root      9820  9779  0 12:43 ?        00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root     14180 32746  0 14:00 pts/0    00:00:00 grep mysql


ping:~/sql# dpkg --configure -a
Param�trage de mysql-server-5.0 (5.0.51a-24+lenny3) ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.

Le syslog lors du dpkg --configure -a

Feb 28 14:06:40 ping mysqld_safe[14688]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
Feb 28 14:06:40 ping mysqld_safe[14688]: To do so, start the server, then issue the following commands:
Feb 28 14:06:40 ping mysqld_safe[14688]: /usr/bin/mysqladmin -u root password 'new-password'
Feb 28 14:06:40 ping mysqld_safe[14688]: /usr/bin/mysqladmin -u root -h ping.example.com password 'new-password'
Feb 28 14:06:40 ping mysqld_safe[14688]: 
Feb 28 14:06:40 ping mysqld_safe[14688]: Alternatively you can run:
Feb 28 14:06:40 ping mysqld_safe[14688]: /usr/bin/mysql_secure_installation
Feb 28 14:06:40 ping mysqld_safe[14688]: 
Feb 28 14:06:40 ping mysqld_safe[14688]: which will also give you the option of removing the test
Feb 28 14:06:40 ping mysqld_safe[14688]: databases and anonymous user created by default.  This is
Feb 28 14:06:40 ping mysqld_safe[14688]: strongly recommended for production servers.
Feb 28 14:06:40 ping mysqld_safe[14688]: 
Feb 28 14:06:40 ping mysqld_safe[14688]: See the manual for more instructions.
Feb 28 14:06:40 ping mysqld_safe[14688]: 
Feb 28 14:06:40 ping mysqld_safe[14688]: Please report any problems with the /usr/bin/mysqlbug script!
Feb 28 14:06:40 ping mysqld_safe[14688]: 
Feb 28 14:06:40 ping mysqld_safe[14688]: The latest information about MySQL is available on the web at
Feb 28 14:06:40 ping mysqld_safe[14688]: http://www.mysql.com
Feb 28 14:06:40 ping mysqld_safe[14688]: Support MySQL by buying support/licenses at http://shop.mysql.com
Feb 28 14:06:43 ping kernel: IPv6 addrconf: prefix with wrong length 56
Feb 28 14:06:44 ping mysqld_safe[14751]: ERROR: 1046  No database selected
Feb 28 14:06:44 ping mysqld_safe[14751]: 100228 14:06:44 [ERROR] Aborting
Feb 28 14:06:44 ping mysqld_safe[14751]: 
Feb 28 14:06:44 ping mysqld_safe[14751]: 100228 14:06:44 [Note] /usr/sbin/mysqld: Shutdown complete
Feb 28 14:06:44 ping mysqld_safe[14751]: 
Feb 28 14:06:45 ping mysqld_safe[14837]: started
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: The log sequence number in ibdata files does not match
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: the log sequence number in the ib_logfiles!
Feb 28 14:06:45 ping mysqld[14840]: 100228 14:06:45  InnoDB: Database was not shut down normally!
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: Starting crash recovery.
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: Reading tablespace information from the .ibd files...
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: Restoring possible half-written data pages from the doublewrite
Feb 28 14:06:45 ping mysqld[14840]: InnoDB: buffer...
Feb 28 14:06:46 ping mysqld[14840]: InnoDB: Last MySQL binlog file position 0 13847, file name /var/log/mysql/mysql-bin.000019
Feb 28 14:06:46 ping mysqld[14840]: 100228 14:06:46  InnoDB: Started; log sequence number 0 1868790931
Feb 28 14:06:47 ping mysqld[14840]: 100228 14:06:47 [Note] /usr/sbin/mysqld: ready for connections.
Feb 28 14:06:47 ping mysqld[14840]: Version: '5.0.51a-24+lenny3-log'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Debian)
Feb 28 14:07:00 ping /etc/init.d/mysql[15010]: 1 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf --bind-address=127.0.0.1 ping' resulted in
Feb 28 14:07:00 ping /etc/init.d/mysql[15010]: /usr/bin/mysqladmin: unknown variable 'bind-address=127.0.0.1'
Feb 28 14:07:00 ping /etc/init.d/mysql[15010]:

1 : Je sais que je suis sur un forum ubuntu mais c'est le même gestionnaire de paquet qui est utilisé..

#5 Re : -1 »  Mise à jour de mysql-server-5.0 sur debian 5.0.4 » Le 28/02/2010, à 14:25

tomhonor
Réponses : 2

Et pour le fun sad

ping:~/sql# /etc/init.d/mysql status
MySQL is stopped..
ping:~/sql# ps -ef|grep mysql
root     14799     1  0 14:06 pts/0    00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql    14839 14799  0 14:06 pts/0    00:00:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root     14840 14799  0 14:06 pts/0    00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
root     15868 32746  0 14:15 pts/0    00:00:00 grep mysql