Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 -1 »  Problème sur Evolution depuis la migration » Le 29/08/2014, à 17:22

stepson
Réponses : 0

Depuis ma migration j'ai un souci dans evolution :

Quand je veux marquer un message comme pourriel, je me fais copieusement insulter :

Échec du lancement de SpamAssassin (/usr/bin/sa-learn --spam --no-sync --local) : L\'exécution du processus fils « /usr/bin/sa-learn » a échoué (Aucun fichier ou dossier de ce type)

Il semblerait que sa-learn ne soit plus là. Comment le réinstaller ?

#1 -1 »  [REOPEN] Gdm ne démarre pas automatiquement après migration vers 14.04 » Le 27/08/2014, à 10:21

stepson
Réponses : 6

Impatient de migrer vers la nouvelle version depuis que ma machine me le propose, j'ai rongé mon frein plusieurs jours pour attendre que les habituels soucis majeurs soient réglés.
Bien m'en a pris, car je n'ai pas eu de souci pour migrer.... sauf que gdm ne démarre pas tout seul.

Au démarrage, je reste bloqué sur l'écran avec Ubuntu 14.04 et les petits points qui se colorient l'un après l'autre...(avec les touches de fonction adéquates, on voit la console et je vois que gdm démarre bien...bizarre. il démarre selon la console, mais n'est pas démarré dans les fait, c'est qu'il dot pour une raison obscure s'arrêter tout seul)

Pas grave me dis je, une petite lecture du forum....

CTRL+ALT+F1, je me connecte en mode shell....

sudo apt-get update
sudo apt-get dist-upgrade -y
sudo apt-get install ubuntu-desktop (me dit que j'ai la dernière version)

sudo service gdm restart


Jusque là ca va pas si mal, j'arrive à me connecter et je retrouve presque tous mes petits, une recherche sur le forum et je trouve comment masquer automatiquement le lanceur sympa.
Une première impression : c'est moche (les décorations de fenêtre par défaut, il va me falloir trouver un thème plus beau à mes yeux), par contre c'est beau (paradoxal non ? moche et beau !!!). OUI C'EST BEAU : pour la première fois depuis 1992, Linux est beau et affiche correctement les polices de caractères !! Ca fait enfin propre comparativement à Windows....
L'antialiasing correctement géré, un petit pas technique qui aurait pu être franchi il y a longtemps, mais un grand pas vers une adoption grand public de Linux.
Linux enfin presque aussi beau que Windows !!!

Bon par contre, il me faut de l'aide pour savoir quoi réinstaller pour que gdm (ou lightgdm, je ne suis pas raciste et je veux bien aller vers le plus beau des 2) démarre tout seul au démarrage.

#2 Re : -1 »  [REOPEN] Gdm ne démarre pas automatiquement après migration vers 14.04 » Le 27/08/2014, à 12:28

stepson
Réponses : 6

Merci du lien.
Je viens de tester ceci :

sudo apt-get clean lightdm
sudo apt-get purge lightdm
sudo apt-get install lightdm
sudo apt-get dist-upgrade

lightdm ne démarre pas au démarrage. Toujours obligé de le lancer à la main avec un sudo service lightdm restart en console.

mais, mais, je peux rentrer le login, mais ensuite j'arrive sur un affichage brouillé, impossible de faire quoi que ce soit.
passage en console et là un sudo service gdm restart et j'arrive sur ma session bien connectée.

je vois passer le splash screen nvidia (je le précise car j'ai cru lire des choses aussi sur cette carte graphique si le driver proprio était installé préalablement ce qui est mon cas).

#3 Re : -1 »  [REOPEN] Gdm ne démarre pas automatiquement après migration vers 14.04 » Le 27/08/2014, à 16:09

stepson
Réponses : 6

Eureka !

J'ai trouvé grâce à ce lien :

http://superuser.com/questions/747375/l … untu-14-04

sudo update-rc.d lightdm remove 
sudo update-rc.d lightdm defaults
sudo update-rc.d lightdm enable

Avec çà ca marche maintenant ;-)

#4 Re : -1 »  [REOPEN] Gdm ne démarre pas automatiquement après migration vers 14.04 » Le 29/08/2014, à 12:10

stepson
Réponses : 6

Grrr.... Ca a marché, ca marche plus....

Je vois dans le boot.log que gdm est démarré puis arrêté, kdm aussi, et lightdm ne veut pas démarrer car il n'est pas considéré comme le "default displaymanager".

J'ai fait ceci en plus :

sudo update-rc.d gdm remove
sudo apt-get clean gdm
sudo apt-get purge gdm
 

Mais pour le moment, toujours pareil, lightdm ne se lance pas.
Je vais virer kdm aussi pour qu'il n'y ait plus que lightdm et voir si ca suffit, sinon, il me faut reconfigurer lightdm mais avec dpkg il me dit qu'il est déjà configuré.

#5 Re : -1 »  [REOPEN] Gdm ne démarre pas automatiquement après migration vers 14.04 » Le 29/08/2014, à 12:42

stepson
Réponses : 6

Bon, je n'ai plus kdm ni gdm, j'ai fait à nouveau la manip avec sudo update-rc.d lightdm enable car lightdm ne démarrait plus du tout même tout seul.
Et là j'ai à nouveau le message dans boot.log :

 
Not starting X display manager (lightdm); it is not the default display manager.

#6 Re : -1 »  Migration 12.04 vers 14.04.1 plantée ? » Le 14/08/2014, à 03:11

stepson
Réponses : 22

Bon courage à toi !
J'ai appris à mes dépends de ne pas faire de mise à jour avant quelques jours voire semaines pour être sur que tout est bien corrigé.
J'attends un peu que plus de retours positifs arrivent.
Pas le temps de backuper et de tester en ce moment. Mais c'est tentant de cliquer sur "Mettre à niveau" puisque on est censé être sur une LTS ;-)
Je vais m'abstenir quelques jours et je tenterai quand je serai sur d'avoir une journée calme à perdre devant moi.

#7 Re : -1 »  Connexion as400 en php sous linux? » Le 29/07/2013, à 17:17

stepson
Réponses : 14

merci de cette discussion qui vient de me sauver.

j'avais zappé le coup du ldconfig.

Attention en architecture 64 bit récente c'est

/opt/ibm/iSeriesAccess/lib64/

le chemin à ajouter dans un ld.conf.d/XXX.conf

#8 -1 »  Power7 ? » Le 12/07/2013, à 15:52

stepson
Réponses : 6

Bonjour !

Fedora 18 propose une version optimisée pour Power7 (ppc64p7).
Existe-t'il la même chose sur Ubuntu ou Debian ?

En gros quelqu'un a-t'il fait tourner une ubuntu ou debian sur un "AS400" récent (ok on ne les appelle plus AS400 s'ils sont récents ;-) )

Je reçois une machine sous peu et j'ai une partition logique qui attend un linux. j'ai pas pris le redhat enterprise règlementaire pour économiser un peu. donc soit je pars sur fedora 18 pour rester sur du "certifié" (branche ppc64p7 officielle sur fedora) soit je met une ubuntu ou une debian.

mais le support de la partie power7 existe-t'il en dehors du giron redhat/fedora ?

#9 Re : -1 »  Power7 ? » Le 22/07/2013, à 17:56

stepson
Réponses : 6

Bonjour !
Merci de la réponse, j'ai moi aussi un peu de mal à savoir si ca va ou pas marcher.
Du coup, je vais faire une entorse à des années d'ubuntu et debian et repasser chapeau rouge (ou en tout cas Fedora 18).

#10 Re : -1 »  Power7 ? » Le 23/07/2013, à 11:56

stepson
Réponses : 6

le temps, toujours le temps.
je ne sais pas si j'aurai le temps de tester. je vais essayer de prévoir 1h pour tester ca et si ca marche pas je mets la Fedora 18 qui elle a une branche dédiée Power7 et testée/certifiée sur du matos récent IBM.

#11 Re : -1 »  Power7 ? » Le 23/07/2013, à 17:13

stepson
Réponses : 6

merci du lien.
en regardant d'autres liens autour de celui ci, je me rends compte que c'est peut être un peu périlleux avec pleins d'alien à faire pour transformer des rpm en deb.
par souci de simplicité, je vais peut être ne pas trop m'écarter du "standard" et de fedora qui en version 19 apporte encore plus d'optimisation pour les power7.

#12 Re : -1 »  Transformer archive evolution pour utilisation sous thunderbird/outloo » Le 21/10/2011, à 14:36

stepson
Réponses : 13

la solution à mon problème

et au passage la nouvelle doc d'évolution pas si facile à trouver !

je vais tester sous peu une migration d'evolution vers thunderbird (plus de 4Go de mails).

Supprimer les mails en double j'ai souvent ce souci avec des classements qui merdoient et evolution qu'on doit couper/relancer, mais un process continue de tourner en fond et si on refait un déplacement de messages, on se retrouve avec 2 ou 3 fois le même message... on peut dédupliquer.... je ne le savais pas... (bien que j'utilise depuis looongtemps evolution/ubuntu)

#13 Re : -1 »  Affichage sur 2 écrans » Le 21/09/2012, à 13:10

stepson
Réponses : 8

je suis sur le sujet depuis un moment aussi et marre de pas pouvoir "fiabiliser" la chose.
je voudrai pouvoir brancher mon video projecteur comme 2ième écran. j'y arrive, mais régulièrement ca merdoie les fenetres se perdent les pédales entre l'écran du portable et l'écran du video projecteur

AUO 1440x900
DELL4310WX 1280x800
Twinview, right of AUO

quand on fait "maximiser" sur les fenetres, le résultat est aléatoire, des fois ca maximise sur DELL des fois sur AUO
en passant en plein écran dans une video flash quand firefox est sur DELL4310WX, la maximisation se fait sur AUO...

le comportement varie selon que les fenetres sont maximisées ou pas.

comment faire pour que les options pleins écrans se fassent sur l'écran où est la fenetre source ?

de même comment faire pour que la config 2 écrans soit toujours active pour pas avoir à le refaire chaque fois que je branche le video projecteur ?

j'ai essayé de sauver dans le fichier de configuration X (/etc/X11/xorg.conf) mais ca n'a pas l'air d'etre suivi d'effet (je suis en train de tester l'astuce rm .config/monitors.xml)

#14 Re : -1 »  [Résolu] Fichiers PDF remplissable » Le 01/08/2012, à 10:34

stepson
Réponses : 9

marche pas avec le cerfa de demande de certificat d'immatriculation...
je suis pas encore en 12.04, j'ai pas migré, je suis encore en oneiric
j'installe acrobat reader pour voir...

avec acrobat reader pris dans les paquets ca marche. mais pas avec evince oneiric en tout cas sur ce formulaire là.

#15 Re : -1 »  conseils pour la montée de version : attendez ! » Le 14/11/2011, à 13:27

stepson
Réponses : 55
Aquilon a écrit :

Oui je sais et n'ai jamais dit ça au contraire.....j'utilisais ton exemple pour montrer que, quelqu'un qui préférait la stabilité et donc la tranquillité en passant de LTS en LTS, lorsqu'il choisissait d'utiliser une autre version connaissait les risques et prenait donc ses précautions.

Je le redis, je trouve effarant le nombre de personnes effectuant des MAJ sans prendre la peine de sauvegarder leur home et ralant après sur l'instabilité des versions "potentiellement plus" instables qu'une LTS.

si ce nombre est si important, c'est peut être que c'est la norme des utilisateurs quand on a la prétention de devenir une distribution grand public et qu'il faut le prendre en compte...

une option par défaut, pour par exemple ne proposer que les mises à jour LTS dans le gestionnaire de distrib serait bienvenu, par défaut c'est l'inverse, on fait aller vers le plus récent et de "l'instable".

le souci majeur d'une distrib linux est de ne pas suffisamment séparer l'os et les logiciels.
il faudrait avoir les versions récentes des logiciels majeurs plus souvent, même si l'os est LTS.... le hic, c'est que certaines versions majeures de soft nécessitent une version plus récente de l'os à cause de certaines librairies.

le problème est compliqué, simple à exprimer (par oppostion à complexe), mais compliqué à mettre en oeuvre.

#16 Re : -1 »  zeitgeist-datahub et darkstat » Le 14/11/2011, à 10:58

stepson
Réponses : 4

par contre, pourquoi c'est pas sur un dépot officiel et sur un ppa a coté ?

depuis ce jour, problème de dépendances et si je le retire, ca veut me retirer gnome...
rien fait pour le moment.

quelqu'un a le même souci (11.10, gnome-shell) ?

#17 Re : -1 »  zeitgeist-datahub et darkstat » Le 14/11/2011, à 15:18

stepson
Réponses : 4

résolu mon souci perso en enlevant les ppa de zeitgeist de mes sources actives.

#18 Re : -1 »  [Sondage] Gnome 3 ou Unity ? » Le 21/10/2011, à 15:01

stepson
Réponses : 317
sorrodje a écrit :

Je n'irai pas jusquà "pourrie" ni "blindé de bug"  qui me paraissent très excessifs ... mais la qualité et la robustesse est insuffisante;

la dessus, je rejoins christophe C (c'est pas mon 2ième pseudo même si c'est mon prénom et l'initiale de mon nom !!)

mon pc est proprement inutilisable quand je suis sur unity.... (et pourtant j'ai la tare suprême d'être informaticien, ingénieur, barbu sans barbe et linuxien depuis 1994)

(je ne précise pas unity 3D car unity, c'est unity 3D. on précise juste unity 2D qui est unity sans les effets 3D fournis par compiz. ouf. je pense avoir juste là ;-))
(c'est sans offense sorrodje, j'adore ton blog que je suis allé voir. tes mémos sur la virtualisation sont très sympas et utiles, sincèrement ! donc même si on a l'air de se chamailler, j'apprécie ce que tu dis).

je suis déçu par unity et au final, je sens que je vais finir par revenir à mes positions intégristes d'un temps et ne prendre que des distribs soutenues par des fondations et non des sociétés commerciales. du coup debian + gnome 3( avec shell ou panel selon la puissance de la machine ou les gouts).

il ne me reste plus qu'à trancher dans mon autodébat d'intégriste refoulé si je choisis thunderbird ou evolution.
j'avais abandonné thunderbird pour evolution que je trouvais mieux intégré à gnome et plus complet pour l'agenda (l'agenda de thunderbird, tout un poème ce lightning.... il m'en a fait bavé il y a quelques années et j'ai abandonné). maintenant je dois refaire un choix car gnome-shell m'a proposé thunderbird (j'ai viré l'icone et mis evolution à la place, j'ai les 2 softs sur la machine, mais je dois choisir maintenant).

et pour voir entre debian et ubuntu, là j'attends encore un peu car une petite couche de non intégrisme (medibuntu...) me plait bien quand même.. (même si on peut faire pareil sous debian)

#19 Re : -1 »  [Sondage] Gnome 3 ou Unity ? » Le 21/10/2011, à 16:00

stepson
Réponses : 317

sous 11.04 je n'ai pas eu de souci (sur le même PC, donc pas de différence de hardware). unity + compiz marchaient (même si quelques bugs par moment avec fermeture de la fenetre de recherche d'appli qu'il fallait réouvrir), mais pas de blocage de la machine.

sous 11.10, c'est le binz
(j'ai fait une mise à jour aussi et pas une réinstall complète, mais aimant me mettre dans la peau de l'utilisateur lambda, je fais des mises à jour même si on dit qu'il faut pas... ca a merdoyé, bug sur launchpad (au passage, efficaces les gars, un gentil sieur lallement m'a répondu, j'ai voulu cloturer puisque j'avais bidouillé entre temps. il a demandé que j'envoie quand même mes logs et au final c'était un souci lié à un calcul de dépendance lié à libcupsys, j'ai vu passé ca d'ailleurs dans les mises à jours automatique aujourd'hui !!). ils ont traité mon cas, l'ont mis en "bug dupliqué" d'un bug existant et les correctifs sont arrivés aujourd'hui (donc ca vaut le coup de soumettre proprement ses bugs de mise à jour sur launchpad !! ils le suivent même si il y a un post par ici qui dit que c'est le bazar. un bug documenté avec les logs qui vont bien, ils le traitent !! là, chapeau !)

j'ai aussi du 10.04 XFCE (qimo2.0) sur une autre machine (pc assemblé pour le fiston de 6 ans, le pc est plus vieux lui P4 1,7Ghz 512 Mo, matrox mga400)
(et du dual boot en windows 7 pour quelques cas où il me faut retourner sous windows) et un macbook pour les applis iphone (il est obligé d'avoir un mac pour publier des applis iphone, c'est verrouillé.)

en ce moment j'ai un peu de temps, du coup je bidouille et je fais des mises à jour. sinon, je reste LTS. trop de galères toutes distrib confondues. un temps mandriva (et même actionnaire, mais ca c'est pas une référence, j'ai presque tout perdu...) mais pas satisfait de la qualité des mises à jour j'avais migré ubuntu. plutôt satisfait de ubuntu depuis 2005 mais là, non...
c'est frustrant, ils nous donnent un super joujou, mais qui marche pas... (ou pas dans le délais que je veux bien lui donner. j'avais cette semaine. pas résolu mes soucis, basta. gnome-shell ;-) )

comment créer de la frustration et insatisfaction. en surfant, on voit quelques décus de gnome-shell, mais peu bloqués comme on l'est (je le suis ?) sous unity (3D).
laissons les vrais geeks ayant du temps débugger tout ca et dans quelques semaines on pourra faire un vrai comparatif fonctionnel non dénaturé par les soucis de stabilité.

#20 Re : -1 »  L'essayer, c'est l'adopter! » Le 21/10/2011, à 15:27

stepson
Réponses : 9

attention également avec libreoffice pour la partie powerpoint...
même si ca lit et écrit des pptx, tu vas avoir des surprises si les effets graphiques "modernes" des suites offices récentes sont utilisés.
libreoffice ne restitue pas correctement de nombreux effets graphiques récents de la suite office... (et comme ils sont "beaux" et que tout le monde les utilise, tu es vite dans la galère et tes présentations faites avec libreoffice font "plouc" vis à vis de présentations faites sous office... (c'est la plus value apportée par office qui sur le temps et la productivité sur une année à pondre des documents rentabilise largement son prix !!)

donc pour faire du travail collaboratif avec un groupe qui est sous windows, ben pas le choix, windows et suite office...

si tu dois faire du beau (sans perte de temps), windows + office.
si tu dois aller à l'essentiel et faire de l'efficace: linux + libreoffice.

#21 Re : -1 »  problème avec unity et compiz » Le 22/10/2011, à 14:25

stepson
Réponses : 14

ma solution temporaire : unity2D ou gnome-shell qui eux marchent sans plantage dans mon cas (vostro1720, carte graphique nvidia)
unitiy + compiz = instabilité assurée, et j'ai galéré une semaine.
il est urgent d'attendre.

#22 -1 »  [résolu] problème montage clé usb » Le 21/10/2011, à 18:53

stepson
Réponses : 4

xfce 4.6, lucid 10.04

lors d'un lsusb, je vois ma clé (que ce soit sur un port du bus usb 1 ou du bus usb 2), par contre rien ne se passe, pourtant dans "gestion des disques amovibles", il y a coché monter automatiquement. le montage automatique a marché à un moment donné.

si je fais un cat /etc/mtab, je n'ai pas la clé.

que vérifier ?

j'ai une souris usb, branché sur un port du bus 1.
elle marche nickel (mais ma souris ps2 ne marche pas)

j'ai fais un update et un upgrade en ayant ajouté le dépot medibuntu pour avoir la lecture des dvd sur qimo2.0 comme distrib de base.

je suis preneur de toute idée, je suis à court là.

#23 Re : -1 »  [résolu] problème montage clé usb » Le 22/10/2011, à 12:47

stepson
Réponses : 4

le souci c'est que fidsk -l ne renvoie rien pour la clé...:mad:

ca me tue ce truc.
je ne suis pas connecté sur le net avec le pc en question mais avec mon 2ième pc. je vais le mettre sur le réseau et me retenter un apt-get update puis apt-get dist-upgrade pour voir (en sudo bien sur)
pis j'ai vlc qui arrive aléatoirtement  à lire les dvd. le dvd est bien monté lui, (avec icone sur le bureau et on peut aller dans le dossier), mais le lancement de vlc (vlc dvd:///dev/dvd0 ne marche pas, en essayant avec un %d comme sur certains tuto non plus)
j'ai viré totem pour vlc à cause de ca, ca a marché un chouia, mais pas tout le temps.
mon fiston rale il veut voir son "wallace et gromit"...
je m'y recolle pour essayer de trouver une solution..

#24 Re : -1 »  [résolu] problème montage clé usb » Le 22/10/2011, à 17:47

stepson
Réponses : 4

alors, ca remarche...
j'ai reconnecté le PC sur le web (il ne l'est pas par défaut) et fait une mise à jour (apt-get update et apt-get dist-upgrade).

j'ai galéré un moment avec mplayer et gmplayer sans grands succès et j'ai au final remis vlc qui marche bien mais en prenant vlc /dev/dvd et non /dev/sr0 comme commande lors de l'insertion des dvd.

pour les clés, elles remontent correctement. j'avais bien l'option cochée dans les options avancées de thunar, mais ca ne montait pas.
à un moment donné je me suis retrouvé avec une session mixte anglais/francais et je me suis rendu compte que LC_ALL n'était plus définie.
après quelques manips de mise à jour de paquets, ca s'est retrouvé en fr_FR comme celà l'était.

mystère.