Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 -1 »  Quelle commande top ou htop pour occupation GPU et VRAM ? » Le 04/04/2016, à 11:36

ladsy
Réponses : 1

Bonjour,

Connaissez-vous une commande top / htop pour surveiller l'occupation de la composante ... graphique big_smile ?

Attention, je ne parle pas d'outils dédiés intel ou ati comme j'ai pu voir ça et là sur google mais bien d'une commande générique qui sera capable de travailler comme htop sur n'importe quel type de machine ... notamment un linux dans une machine virtuelle.

En effet, depuis que j'ai pris un écran 4K, ma VM ubuntu mate raame pas mal si je la colle en plein écran (mode fenêtré au max plus précisément).
J'ai gonflé mon vieux PC de 8 Go à 16 Go et la VM de 3 Go à 4 Go et ça a été mieux, mais pas autant qu'avant l'écran 4K quand je passais la VM de 2 Go à 3 Go (j'étais en 1920x1080).
Je me suis décidé à passer sa mémoire virtuelle de 256 Mo (ce qui n'est pas la taille 128 Mo par défaut dans VirtualBox) à carrément 512 Mo ( ma carte graphique a 1 Go de RAM ) ! Et là, la VM est plus "fluide" dans le mouvement des fenêtres et se lance plus vite.
J'aimerai donc faire des tests sur l'occupation de mémoire VRAM réelle pour voir ce qui est réellement employé par la VM et adapter la taille de la VRAM (histoire de continuer de lancer plusieurs machines en même temps, 2 au moins).

Pour le moment, au mieux je ne trouve que des commandes dédiées par constructeur ; et au pire .... le "top des cartes graphiques du moment". pas top sad

Merci d'avance pour votre aide.

#1 Re : -1 »  Quelle commande top ou htop pour occupation GPU et VRAM ? » Le 04/04/2016, à 15:29

ladsy
Réponses : 1

Petit correction ... VirtualBox ne supporte vraiment pas plus de 256 Mo de VRAM, je me suis trompé dans mes modifications en mettant 512 Mo dans le fichier de configuration, la correction a fait planter la VM à la relance (768 / 512 / 368 ... seuls 256 Mo sont acceptés).
Donc mon sentiment de gain de performance viens d'ailleurs.

Mais néanmoins, le problème reste entier et la question demeure : quid d'un "gpu"_top ?

#2 Re : -1 »  [Résolu] LibreOffice Calc: collage spécial impossible » Le 03/04/2016, à 18:00

ladsy
Réponses : 5

Bonjour,

Je remonte un peu grand-père du grenier ... mais en tombant sur le même problème sous Windows 10 / LibreOffice 5.1.2 (que je venais de réinstaller), l'ami google m'a fait pointer sur cette page ubuntu-fr qui m'a aidé pour trouver (Ubuntu qui résoud un problème sous Windows quoi ...). Donc, je partage mon expérience car la solution évoquée m'a permis d'en trouver une autre et ça pourra aider quelqu'un (dans 2 ans aussi big_smile).

Pour moi, sous windows donc, il a fallu supprimer le répertoire C:\Users\%USERPROFILE%\AppData\Roaming\LibreOffice, ce qui correspond à ~/.config/libreoffice ... dans les deux cas, on trouve un répertoire "4" dans ce répertoire, qui est l'endroit où sont stockées les configuration utilisateur de LibreOffice.
Cette méthode m'a évité de désinstaller / réinstaller le logiciel LibreOffice  (donc employer les droits root sous nunux pour aller taper dans /opt par exemple).
Le problème me semble donc plus lié à une corruption des paramétrages de LibreOffice propre à l'utilisateur, qu'à un problème système.


Ma méthode oblige par contre l'utilisateur à reparamétrer son LibreOffice .... mais ça n'impacte potentiellement pas tous les utilisateurs de la machine.

#3 Re : -1 »  [résolu] Accent Circonflexe » Le 09/08/2015, à 13:44

ladsy
Réponses : 17

Bonjour,
Je tombe sur cette page alors que sous Ubuntu Mate 15.04, j'ai le même problème.
C'était d'autant plus chiant que j'emploie un VirtualBox sous Windows hote pour lancer en guest le Ubuntu Mate installé en dual-boot hote ...

J'ai commencé par la suivre ... sans résultat !


Lien utile : https://bugs.launchpad.net/ubuntu/+sour … +bug/69896
Lien utile : https://forum.ubuntu-fr.org/viewtopic.php?id=362524
Lien utile : https://steftech.wordpress.com/2012/11/ … ntu-12-04/
C'est visiblement encore ces fichus paquets chinois installés defacto depuis la ubuntu 10.xx qui posent problème en laissant ... un paramétrage en_US quelques part.

En voulant installer im-switch (du 3eme lien), j'ai vu qu'il est juste introuvable !
Alors :
Lien utile : http://crunchbang.org/forums/viewtopic.php?id=18200
J'ai fait bêtement : sudo apt-get install ibus ibus-gtk ibus-pinyin
Puis en fait, je me suis aparçu (sans vraiment être certain que c'est l'apt-get qui a donné le résultat) :
Menu / Système / Méthodes de Saisie au clavier
Onglet / Méthode de Saisie
gicler le clavier anglais

.... pas besoin de reboote, je tape en ce moment sous Linux.

#4 Re : -1 »  [Résolu] scrip au démarage d'ubuntu » Le 14/05/2015, à 02:18

ladsy
Réponses : 16

Bonjour,
Peut-être que je ne comprends pas précisément ... mais tu nous parles de lancer Firefox ET de lancer un service.
Hors Firefox ne se lance que quand l'interface graphique est lancée ... donc quand le user est connecté.

Donc ton besoin est moins de lancer un script "comme un service unix (via /etc/rcX.d) " que "au lancement de l'utilisateur" .... sauf que là tu veux ton petit shell à toi et pas un soft prémaché par ubuntu ?
Du coup, pour 1 user donné, pourquoi tu le colles pas directement dans

$USER/.config/autostart

Regarde les indicator-power.desktop et autres .desktop pour t'inspirer .... il suffit de modifier le shell de Exec
Si c'est pour tous les utilisateurs ...

/etc/xdg/autostart

non ?

#5 -1 »  [Résolu] mount sda1_iso.gz - montage a la volée d'une iso gzip » Le 12/05/2015, à 22:46

ladsy
Réponses : 1

Bonjour,

Je me casse la tête sur un truc qui doit être tout con une fois qu'on a trouvé.

J'ai reçu un PC portable neuf et ai donc fait avant toute chose une sauvegarde bit à bit compressée à la volée du disque.
Les commandes sont :

dd if=/dev/sda | gzip > w541.iso.gz
dd if=/dev/sda1 | gzip > w541_sda1.iso.gz
dd if=/dev/sda2 | gzip > w541_sda2.iso.gz
dd if=/dev/sda2 | gzip > w541_sda2.iso.gz
dd if=/dev/sda3 | gzip > w541_sda3.iso.gz
dd if=/dev/sda4 | gzip > w541_sda4.iso.gz
dd if=/dev/sda5 | gzip > w541_sda5.iso.gz

Pour restaurer une partition, ou tout le disque, la commande de restauration sera du type :

gzip -dc ./w541.iso.gz | dd of=/dev/sda
gzip -dc ./w541_sda1.iso.gz | dd of=/dev/sda1
gzip -dc ./w541_sda2.iso.gz | dd of=/dev/sda2
gzip -dc ./w541_sda3.iso.gz | dd of=/dev/sda3
gzip -dc ./w541_sda4.iso.gz | dd of=/dev/sda4
gzip -dc ./w541_sda5.iso.gz | dd of=/dev/sda5

Si je veux vérifier qu'une sauvegarde est bonne, ou bien y copier un fichier, je peux toujours faire :

gunzip /w541_sda1.iso.gz
mount -t auto -o loop /w541_sda1.iso.gz ./w541_sda1

Ca marche dans le cas d'une partition petite ...
Mais dans le cas de tout le sda (iso disque de 500 Go) ou bien de sda4 qui fait 448,7G ... le fichier iso.gz d'environ 70 Go va vite devenir insuportable à décompresser avant montage.

J'aurai donc besoin d'une commande de décompression à la volée dans mon mount ... un peu style

gzip -dc ./w541_sda1.iso.gz | mount -o loop /dev/sda1

root@admlho00:~/Travail/# gzip -dc ./w541_sda5.iso.gz | mount -o loop /dev/sda1
mount: can't find /dev/sda1 in /etc/fstab

Sauf que ça le fais pas !

Idéalement, il me faut ça, que ce soit TRES simple à faire, à retenir, à écrire dans un tout petit fichier.txt et à appliquer avec une distribution linux minimaliste bootée sur clé usb dans le cas d'une restauration (après cata) du PC avec les ISO sauvegardées, ou de restaurer un fichier (comme les drivers dans une iso par exemple).


Solutions pas idéales que j'ai trouvé ... mais au moins qui me permettraient de travailler un peu : j'ai vu du squashfs, du avfs, du nbd-client ... je me casse les dents depuis 3h.
http://www.linuxguide.it/command_line/l … ds_fr.html
http://www.debianhelp.co.uk/ddcommand.htm
https://skywalker13.wordpress.com/2013/03/03/1333/
http://w3facility.org/question/is-it-po … n-the-fly/
https://blogs.gnome.org/muelli/2012/10/ … pped-file/

Que dalle ... ou je comprends rien, ou ça marche pas.

Squash ... non car je ne dois pas modifier mes iso, hors il faut une sorte de formatage de l'iso après le dd !
avfs, ça m'irait, mais les explications que j'ai trouvé ne me permettent d'avoir aucun résultat. Item pour nbd_client ... et puis il faut installer avfs ! Ce n'est pas installé par défaut dans une ubuntu ou une tomsrtbt que l'on télécharge en vitesse pour une intervention à l'arrache et loin de son environnement.

Auriez-vous une idée  pour un mount -o loop isosda1.gz   ??
Merci d'avance.



ps : si vous me dites faut faire bz plutôt que gz et que vous avez les commandes " dd | bz ", je suis preneur aussi.

#6 Re : -1 »  [Résolu] mount sda1_iso.gz - montage a la volée d'une iso gzip » Le 14/05/2015, à 02:07

ladsy
Réponses : 1

et bien, j'ai fini par trouver une solution ... enfin par trouver ce qui est juste évident : savoir employer avfs.
Alors pour ceux qui se casseront la tête comme moi ... déjà installer avfs (via synaptic)

Installer avfs (via synaptic).
Passer sous root pour faire les manipulations ... ou voir le problème de droits pour $USER
Considérer que ~/.avfs est la racine (un peu comme un chroot) et aller jusque dans le répertoire où se trouve les iso.gz.

$sudo su
$mountavfs
$cd ~/.avfs/media/root/481EA7CF1EA7B3FA/150511_w541/
$mkdir disque
$sudo mount -t auto -o ro,loop w541_sda1.iso.gz\# Disque
$sudo umount Disque
$umountavfs

on a son disque iso.gz monté dans le répertoire : ~/.avfs/media/root/481EA7CF1EA7B3FA/150511_w541/Disque

Ce qui m'induisait il semble en erreur : montage en read-only obligatoire (logique quoi) ET les pages web parlaient de #\ et pas \# à la fin du fichier à monter .... J'interprète que le # est mis pour "voir les fichiers dans le répertoire iso.gz\ ".

Nota que ça peut prendre un - cer - tain - temps à monter ... si le fichier compressé fait 28 Go, mais la partition réelle 480 Go par exemple roll:/

#7 Re : -1 »  Ubuntu 14.04, Nautilus et consommation mémoire (supprimé) » Le 02/10/2014, à 14:22

ladsy
Réponses : 2

Bonjour,

Je viens de me rendre compte du même problème ...
Cela se passe souvent quand je lance une machine virtuelle VirtualBox.
D'un seul coup, tout se ralentit : FF, chrome, passage d'une fenêtre à une autre. Il me faut tout clore très vite, puis j'ai fini par arriver à faire un gnome-terminal + htop et constater que nautilus est à 42 %.
En killant nautilus, le comportement redevient normal.

#8 -1 »  une commande GPULIMIT équivalente à cpulimit - deplacer vers forum CG » Le 12/08/2014, à 10:01

ladsy
Réponses : 5

Bonjour,

Tout est dans le titre en fait. Il me faut à minima une commande gpulimit que je trouve pas sur la toile.

Je commence de jouer avec un programme qui fait tourner à fond la carte graphique au point de mettre à genoux tout l'affichage ... même en lançant ce programme avec un ionice -c3 nice -19 monProgramme.

Alors, j'ai aussi tenté cpulimite -e monProgramme -l 80 .. mais l'affichage est à genoux.
Un peu comme quand je joue à 0Ad avec 8 bots et 300 unités : ça devient du tour par tour avec la souris .... et il y a un mouvement de souris de 3 cm sur l'écran toutes les 45 secondes.
Bref, invivable.

J'aimerai que ce monProgramme tourne un peu en tache de fond en ne mangeant le GPU ... QUE  ... quand je n'ai pas besoin du dit GPU et que ça ne m'empêche pas de faire du travail à côté. ... donc un nice -19 pour emploi de GPU, des I/O et ... d'une façon générale limiter l'utilisation du GPU.

Comment faire svp ?

Merci d'avance.




Edit : je m'aperçois que je me suis trompé de rubrique ... comment on fait pour déplacer cette question dans http://forum.ubuntu-fr.org/viewforum.php?id=27 ?

#9 Re : -1 »  une commande GPULIMIT équivalente à cpulimit - deplacer vers forum CG » Le 26/08/2014, à 23:09

ladsy
Réponses : 5

un chtit hup.
A vot bon coeur, M'sieur D'ames ?

#10 Re : -1 »  une commande GPULIMIT équivalente à cpulimit - deplacer vers forum CG » Le 04/09/2014, à 13:58

ladsy
Réponses : 5

Bonjour,
Merci pour ta suggestion, mais ça ne correspond pas exactement au besoin.
J'emploi fglrx, j'ai joué déjà sur la fréquence et la vitesse des ventilos.
Pour le moment, j'ai fini par utiliser seulement cela car ça correspond, par exemple.

aticonfig -v --pplib-cmd "set fanspeed 0 4" --od-enable --od-commitclocks --od-gettemperature --effective=now --pxl

Je pourrais ajouter un truc comme cela

Set new Clocks for 0   :  aticonfig --adapter=0 --od-setclocks=770,1126

Mais ça donne plus ou moins de performances ... et pas une limitation d'usage de GPU.

Modifier le code. Idée que je retiens pour le future ... au càs où big_smile
En effet ce n'est pas mon programme et cette solutiokn ne s'applique pas.
En outre ... et bien tu fais faire un noop au programme et donc force le programme à laisser du temps à l'ordonnanceur pour passer la main à un autre processus.
Cela veut dire que pendant que le programme a la main ... il tourne toujours à 100 % du processeur, jusqu'à ce qu'il passe la main.
C'est mieux que rien ... mais cela revient à ordonnancer dans le temps avec une préemption forcée (si je me souviens bien), ce n'est pas une limitation de ressources en matière de capacité.
Un peu comme d'appuyer à fond le pied de l'accélérateur et rouler de fait à 100 km/h, puis lever le pied 10 secondes toutes les 30 secondes, de fait redescendre à 50 km/h, pour avoir une vitesse moyenne de 80 km/h .... plutôt que de ne pas appuyer à fond sur le champignon pour toujours rouler à 80 km/h.

Le problème s'est posé pour le cas ou je lance un programme de minage qui a le chic pour bouffer le GPU sauvagement.
Mais je ne veux pas limiter le problème à 1 seul programme en particulier (raison pour laquelle je n'avais pas cité tout de suite le nom du programme car, ainsi que j'ai souvent constaté, tout un tas de monde ne se serait concentré que sur lui sans adopter une vision d'ensemble) et aurait tenté que de résoudre un problème de logiciel de minage que j'ai dont j'ai depuis supprimé le logiciel, sans résoudre mon problème global.

J'ai besoin d'une solution générique de limitation de GPU.
Idéalement ?????
Et bien je veux limiter l'usage du GPU à 80 % de sa performance... même pour Xorg , Unity, LibreOffice, Gimp (qui traite des grosses images), Chrome (qui devient tout gris un temps quand ça télécharge trop d'images) big_smile

ps : en outre, tu te doutes que mon besoin se porte sur une solution qui ne s'appliquera pas qu'aux cartes graphiques AMD/ATI, vu que j'ai aussi une nVidia sur un autre PC ........... et un i915 aussi sur un PC portable.

#11 Re : -1 »  une commande GPULIMIT équivalente à cpulimit - deplacer vers forum CG » Le 14/09/2014, à 18:47

ladsy
Réponses : 5

Bien dommage.
Cela m'aurait permis d'éviter le blocage de la machine ... car depuis, j'ai toujours la main sur mon PC, vu qu'il reste 20% de performance disponible  (hors cette saleté à pomper le GPU).
Vu que c'est possible avec les CPU, j'espérais cela possible avec les GPU.

Tampis.:rolleyes:

#12 Re : -1 »  [update 14.04] Messages au boot : diskfilter et dmraid / mdadm » Le 31/05/2014, à 22:34

ladsy
Réponses : 6

re up !
Je viens d'installer la 14.04 sur un beau raid 0 de 3 SSD en fakeraid ... et j'ai aussi ces messages :

dmraid-activate : WARNING: mdadm DDF assembly enabled by boot option
dmraid-activate : WARNING: mdadm IMSM assembly disabled by boot option

La machine semble tourner, mais je vois vraiment pas à quoi ça correspond.

Merci d'avance aussi.

#13 Re : -1 »  [update 14.04] Messages au boot : diskfilter et dmraid / mdadm » Le 09/08/2014, à 22:33

ladsy
Réponses : 6

Bonjour,
Je remonter un peu grand-père du grenier car j'avais toujours mon problème ... et que je ne suis pas le seul dans ce cas.

Avant manipulation :

ls /dev/mapper/isw_ebeeiabgeg_Volume1p3 
# / was on /dev/md126p3 during installation
UUID=b60c7e2b-f1f9-4463-976c-5c0a2ca7055f /  ext4  discard,noatime,nodiratime,errors=remount-ro 0    1

ls /dev/mapper/isw_ebeeiabgeg_Volume1p1
# /home was on /dev/md126p1 during installation
UUID=15995653-141b-4a8c-b8e6-376e49fd76e9 /home  ext4    discard,noatime,nodiratime 0  2

après manipulation ...

ls md*
md125  md125p1  md125p2  md125p3  md126  md126p1  md126p2  md126p3  md127

md:
imsm0  Volume0  Volume0p1  Volume0p2  Volume0p3  Volume1  Volume1p1  Volume1p2  Volume1p3
ls mapper*
control

En fait la manipulation était de modifier

gedit /etc/default/grub.d/dmraid2mdadm.cfg
GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT nomdmonddf nomdmonisw"
par
GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT nomdmonddf"

Les liens qui m'ont mis la puce à l'oreille ...
https://raid.wiki.kernel.org/index.php/RAID_setup
http://ubuntu.5.x6.nabble.com/Dmraid-to … 57892.html
http://package-import.ubuntu.com/diffs/dmraid
http://ubuntuforums.org/archive/index.p … 64766.html

Si je comprends bien, la Ubuntu, par défaut et au boot impose de "ne pas utiliser" une sorte de protocole de compréhension de raid qui est "ISW" vs un fameux "DDF".
Il y aurait un état de transition au sein des distributions.
L'ancien format étant /dev/md126p1 et le nouveau /dev/mapper/isw_ebeeiabgeg_Volume1p1 ...
Mais si on regarde un code source, on voit que systématiquement, le fait d'interdir IMSM fait un warning désagréable ...
En en sus, ça fait dans /var/log/dmesg.0 des erreurs du type :

[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-33-generic root=UUID=b60c7e2b-f1f9-4463-976c-5c0a2ca7055f ro elevator=deadline allow-discards root_trim=yes CONFIG_HZ=1000 nomdmonddf nomdmonisw


[   10.838835] systemd-udevd[887]: conflicting device node '/dev/mapper/isw_ebeeiabgeg_Volume0p1' found, link to '/dev/dm-1' will not be created
[   10.902668] systemd-udevd[878]: conflicting device node '/dev/mapper/isw_ebeeiabgeg_Volume1p1' found, link to '/dev/dm-5' will not be created
[   10.927433] systemd-udevd[879]: conflicting device node '/dev/mapper/isw_ebeeiabgeg_Volume1p2' found, link to '/dev/dm-6' will not be created

Bref ... la transition ne serait pas au point.
En giclant le nomdmonisw, et bien on reviendrait à la vielle mode sans les warning.

#14 -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 01:06

ladsy
Réponses : 10

Bonjour,

J'ai besoin d'imprimer un fichier PDF de schéma conçu depuis Xmind.

Ayant Xmind ... en version gratuite, je ne peux que faire une image ou imprimer en PDF : en plus, je dois au préalable envoyer la version numérique en format PDF.

Pour que les choses soient visibles, je n'ai pas pu faire plus petit que d'imprimer dans un format un peu ... iokolélé : 1 grosse page de 440 mm x 1792 mm (en gros si j'avais une table traçante ... elle pondrait une feuille de papier quasiment aussi grande que moi !!! ).
Ce qui revient en réalité à 6 pages A3 collées l'une à côté de l'autre par leur largeur (1792 = 6 * 297 ).

C'est un bôôô schéma et je suis tout content de mon travail qui m'a pris un temps fou.

Sauf que pour le présenter, le modifier en équipe sur un support plus pratique qu'un PC portable, j'ai besoin de l'imprimer ce travail : avec une imprimante ... A4 !
Puis de prendre du scotch et raccorder.

Il faut que je trouve le moyen de scinder ma grosse page 6xA3 en 12 pages A4  (vu que 1 page A3 = 2 pages A4 collées) .

Pour le moment, je n'arrive qu'à obtenir une seule page A4 avec tout le schéma ... illisible tant c'est tout petit.
Idéalement, il faudrait que le résultat soit un fichier PDF avec 12 pages A4 qui prennent en comptes les bordures de l'imprimante et les raccords au scotch.

Au secours, qui a une idée de piste ? Un soft miraculeux, ou une méthode pas à pas ?

Merci d'avance.

précision :
J'ai regardé ici :
http://forum.ubuntu-fr.org/viewtopic.php?id=1622141
http://forum.ubuntu-fr.org/viewtopic.php?id=806571&p=1
http://pythonhosted.org/pdftools.pdfpos … ape-images
Employé la commande :

pdfposter -p 12x1a4 entree.pdf sortie.pdf
meme
pdfposter -p 6x2a4 entree.pdf sortie.pdf
et cette version donne enfin 12 pages
pdfposter -p 2x6a4 adm.pdf pagex.pdf

Ca me donne un fichier de 6 pages A4 avec 3 morceaux de mon PDF tout coloriés en rouge sur fond blanc .... bref, c'est pas ce à quoi j'aurai pu penser.
Au mieux, j'ai 10 pages blanches barrée d'un trait rouge, et 2 pages avec une partie de mon texte.

Solution paliative ... scinder un png
Je viens de voir que Gimp importe très bien le PDF en image et j'en ai exporté un PNG propre.
Donc ... ben comment exporter de façon "propre, ie pas en faisant 12 copier > coller de morceaux d'image dans une nouvelle image à mettre en page dans LibreOffice" en PNG ? Ce serait bovidé comme solution et me prendrait un temps fou pour faire ça au pixel prêt.

#15 Re : -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 10:52

ladsy
Réponses : 10
JBF a écrit :

Essaye d'ouvrir le fichier PDF dans LibreOffice-Draw puis d'imprimer depuis LibreOffice-Draw. Normalement tu peux imprimer une mosaïque de feuilles A4 pour un document jusqu'à 300 cm x 300 cm. Je n'ai jamais fait aussi grand, mais j'ai déjà imprimé un schéma A2 sur 4 pages A4.
JBF

Bonjour et merci pour ta réponse.
Ca semble être sympa cette solution et sentir bon.
Mais pour le moment, je n'arrive pas à obtenir un fichier PDF qui a des "marges". Les traits, et le texte, vont bord à bord des pages et je crainds que ça ne fasse pareil en cas d'envoi à l'imprimante : donc des bouts de texte et des bouts de traits ne seront pas imprimés et il y aura des erreurs de raccord.
Voici ma manipulation :

Clic droit sur fichier.pdf
Ouverture avec LibreOffice Draw.
Dans LibreOffice Draw :

Fichier
Imprimer

Onglet Général :
Plage et exemplaires / Toutes les pages : coché

Onglet LibreOffice Draw :
Taille / Répartir sur plusieurs feuilles de papier : coché

Onglet Mise en page :
Mise en page / Pages par feuille : 1
Mise en page / Dessier une bordure autour de chaque page : coché

Onglet Options :
Options / Imprimer dans un fichier : coché

Normalement, j'ai pris en compte une "bordure" ...
Qu'aurais-je dû faire donc ?

Est-ce que l'outil d'impressions "sait" qu'il n'y a pas besoin de bordure pour un PDF, mais tiendra compte de celle de l'imprimante ?
Est-ce que tu as des bordure quand tu imprimes ?

.. bon tu me diras que j'ai qu'à tester, mais 21 pages A4 en brouillon, plus les X tests, (car c'est pas 12 pour lui), ça commence à être mauvais pour la planète.

#16 Re : -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 11:12

ladsy
Réponses : 10
b.poiraud a écrit :

Bonjour,
Merci aussi.
J'ai donc téléchargé Krop : http://arminstraub.com/downloads/krop/k … -1_all.deb
Installé les dépendances :

sudo apt-get install python-poppler-qt4 python-pypdf
sudo dpkg -i krop_0.4.6-1_all.deb

Et pour le moment, je viens (oh miracle) de scinder ma grosse pages en pages plus petites ... sauf que ce sont 6 pages A3 ... glups.

Manipulation :

Ouvrir Krop
Ouvrir fichier.pdf

Onglet Basic :
Save To : fichier-cropped.pdf (il met tout seul le nom en fait)
Rotate final PDF : no rotation
Wich pages to include : 1 (il n'y en a qu'une de toute façon au départ)

Onglet Advanced :
All pages : coché
Fit screen of device : 4:3 eReader (si je laisse Generic ... il colle toute la page)
J'ai testé : Nook ... plus que 3 pages !!!
J'ai testé : Custom : 210:297   - width:height ..... 4 pages ???????? mais pas ce que j'attends.

Settings for trimming margins / Padding : 5 (2 par défaut, mais je l'imprimante fait 5mm je crois)

Onglet Help :
Balance sur le CV à ralonge de l'universitaire, mais on trouve des screenshots explicatifs.

Voilà mon avancement ... je reviens pour dire si j'ai pu exporter en A4.


Tentative 2 :
En fait, l'objectif de Krop est plutôt de gicler les marges blanches inutiles pour qu'elles ne prennent pas toute la place sur un eBook ou une liseuse US.
C'est pour cela que l'on a que ces formats par défaut.
Sauf que l'outil ne semble pas tenir compte de la résolution ppp / dpi et qu'il est du coup impossible de redéfinir une page de sortie par calcul savants de conversion pouces / millimètres.
http://pdfcrop.sourceforge.net/ : on voit mieux que Krop ne fait que " faire correspondre " une page et pas la " découper " ....
http://fr.wikipedia.org/wiki/Format_de_papier
http://en.wikipedia.org/wiki/Comparison … ok_formats
http://www.unitjuggler.com/convertir-le … -en-m.html
http://bookclubs.barnesandnoble.com/t5/ … -p/1428032
Nook Simple Touch: 600 x 800 pixels
Nook HD: 900 x 1440 pixels
Nook HD+: 1280 x 1920 pixels
eBook de Krop : 600 x 730 pixels
La seule méthode pour transformer ma grosse page 6a3 en 12 petites pages A4 est de mettre des points à la main et de définir des espaces à la main comme cette photo : http://arminstraub.com/images/krop/scre … olumns.png
Ce qui donne bien 12 pages, mais est un résultat plutôt calamiteux, car tiré à la main. En sus, quand on définit tout à la main, il n'y a plus de prise en compte de 5 mm de marges et on nage en plein hasard pour espérer pouvoir les retrouver. Il faudra que je fasse 5 tests d'impression. Pas glop.

Donc, soit j'emploie Krop comme un krap (pas impossible) ... soit Krop ne peut pas aller pour mon besoin. Dommage car c'était bien parti.

Tentative 3:
J'ai pu obtenir 6 pages A3 ...
Au pire, je pense que je ferais imprimer les 6 pages par quelqu'un qui a une imprimante A3. Ca fera plus propre que du scotch partout au milieu... à voir.

#17 Re : -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 14:05

ladsy
Réponses : 10
JBF a écrit :
ladsy a écrit :

.. bon tu me diras que j'ai qu'à tester, mais 21 pages A4 en brouillon, plus les X tests, (car c'est pas 12 pour lui), ça commence à être mauvais pour la planète.

Ben il faut tester avec un document plus petit, par exemple un A3.

JBF

Fort juste ... ah quand on est en mode panique ... on boucle comme un programme BSOD de Microsoft et on réfléchit plus.
D'autant plus que j'ai aussi un schema2.pdf à scdinder et qu'il ne prend qu'une page A3.


Edition 2
J'ai testé avec une page A3 sur un schéma.
LibreOffice Draw m'imprime 4 pages .... et je n'ai aucun autre moyen de modifier pour lui dire d'imprimer en 2 pages (recentrer ou autre).
Pô glop.

#18 Re : -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 22:54

ladsy
Réponses : 10
Sciensous a écrit :

j'aime bien pdfshuffler
Une fois le pdf chargé, tu coupes par 'crop'
8)

Merci aussi wink
Installé via synaptic.
Par contre :

Je lance PdfShuffler via le Dash
File / Ajouter / fichier.pdf
Edit / Crop
Fenêtre Crop Selected Pages :
Left 50 % of width ... au moins pour avoir un découpage en largeur
Bouton valider.
Export sortie.pdf

Résultat : aucune modification. Je dois m'y prendre mal.

Je pense que PdfShuffler ne correspondra pas car clairement, il faut tronçonner 6 fois la grande feuille et que les options ne permettent de cropper qu'une seule fois.

#19 Re : -1 »  [resolu] page PDF de 6 pages A3 - comment imprimer en plusieurs A4? » Le 18/07/2014, à 23:03

ladsy
Réponses : 10
Brunod a écrit :

Cherche Posterazor linux wink

traduction : http://github.com/aportale/posterazor/r … /src/fr.ts
soft : http://prdownloads.sourceforge.net/post … z?download
S'installe via Synaptic par défaut de toute façon, puis petit paramètre pour mettre "ine franssé".

Point skiant : lui il prend une image ... retourne un PDF qui met du temps à s'afficher. On doit peut-être avoir de la perte de qualité ... autrement dit : tenter de faire un PNG avec un gros DPI

Le fonctionnement se fait pas à pas.

Etape 1 : ouvrir fichier.png via "image à découper" ... si on tente pdf, il vous engueule en disant que ce fichier ne peut être chargé ... alors on prend son petit Xmind et on se démerde pour faire un png de son schéma ... d'ailleurs, ça doit peut-être cafouiller au niveau du dimensionnement. Passons.
Suivant

Etape 2 :
Format DIN A4
Orientation Portrait
Bordures de : 0,5 cm
Suivant

Etape 3 :
Taille du recouvrement, on laisse En bas à droite par défaut et 1 cm par défaut ...

Etape 4 : Taille final du poster
Taille en nombre de pages :
Largeur 2 pages
Hauteur : 5,6697 pages
position image inchangé
Suivant 

Etape 5 : Enregistrer le poster
Bouton disquette
Nommer banzai.

Oh yeah ... on avance !
Enfin, j'ai un PDF avec 12 pages A4 et le contenu juste à imprimer.
J'imprime :... sauf que les deux premières pages sont !!!! blanches (j'ai réessayé).
les 10 autres sont parfaites, il y a bien ma gestion de raccord à faire (donc découper la page A4 pour que les lignes de schéma se collent).

Alors il faut que je voie ce que c'est que cette histoire de pages blanches.
PDF ?
Impression ?
dur.

En tout cas, ça semble partir dans la bonne direction.

Ca doit venir d'un problème d'impression car les deux premières pages semblent impec à l'affichage écran.

Bon, ça splite pas réellement un pdf, mais au moins j'ai pu atteindre mon objectif ponctuel.
Merci.

#20 Re : -1 »  désactiver les suggestions en ligne des tableaux de bord » Le 06/07/2014, à 17:21

ladsy
Réponses : 3

Bonjour, je sais que je redescend grand-père du grenier .... mais comme j'ai trouvé le lien en faisant une recherche google ...
réponse ici :
https://forum.ubuntu-fr.org/viewtopic.php?pid=16808431

à mettre en résolu si quelqu'un peut.

#21 Re : -1 »  Dash : Vitesse de recherche dans mes fichiers » Le 06/07/2014, à 17:22

ladsy
Réponses : 13

Bonjour,
Je ne sais pas si tu recherches encore, mais j'ai trouvé ton lien via google.
Pour le cas "Plus de suggestions", il y a Unity Tweak Tool à installer.
Overview / Unity / Search
Décocher "Show "More Suggestions"

Maintenant ... il faudrait une solution pour gicler dans la lens Application du Dash (touche Win + A ) les Greffons du tableau de bord qui me cassent tout autant les pieds.

un grep -r "Greffons du tableau de bord" /usr donne une présence dans :

/usr# grep -r "Greffons du tableau de bord" . 
Fichier binaire ./share/locale-langpack/fr/LC_MESSAGES/unity-scope-home.mo correspondant
Fichier binaire ./share/locale-langpack/fr/LC_MESSAGES/unity-lens-applications.mo correspondant

/usr# find . | grep unity-lens-applications
./share/doc/unity-lens-applications
./share/doc/unity-lens-applications/changelog.Debian.gz
./share/doc/unity-lens-applications/copyright

/usr# find . | grep unity-scope-home
./share/doc/unity-scope-home
./share/doc/unity-scope-home/changelog.Debian.gz
./share/doc/unity-scope-home/copyright
./share/locale-langpack/fr/LC_MESSAGES/unity-scope-home.mo
./share/dbus-1/services/unity-scope-home.service
./lib/x86_64-linux-gnu/unity-scope-home
./lib/x86_64-linux-gnu/unity-scope-home/unity-scope-home
root@admlho00:/usr# 

... mais cette saleté de unity-scope-home est un binaire et je ne vois même pas les paramètres à passer pour ne plus avoir les "greffons de tableau de bord affichés ... et seulement "Toutes les applications installées" et "tous les résultats"

#22 -1 »  14-04 - bureau nautilus - déplacer fichier .desktop lien vers page web » Le 03/07/2014, à 14:36

ladsy
Réponses : 0

Bonjour,
Depuis la Ubuntu 13.10, j'ai un problème avec certains fichiers sur le bureau de Unity / Nautilus.

J'ai l'habitude de glisser déplacer une URL depuis Firefox ou Chrome / Chromium, vers le bureau.
Ainsi, cela ne crée pas un bookmark dans le navigateur, mais un simple lien que je regarderai plus tard ... puis supprimerai.
Cela crée plus précisément un .desktop, un peu comme sous windows avec les fichiers .lnk / .link.

Par exemple, j'avais créé ce fichier-ci :

$ cat Edito\ Nuit\ du\ Hack\ 2014\ \|\ www.nuitduhack.com.desktop 
[Desktop Entry]
Encoding=UTF-8
Name=Lien vers Edito Nuit du Hack 2014 | www.nuitduhack.com
Type=Link
URL=http://www.nuitduhack.com/
Icon=text-html

Hors, j'ai quand même besoin de déplacer l'icône sur mon bureau ... exactement comme n'importe quel ficiher .txt ou répertoire.

Sauf qu'à la place de déplacer l'icône à sa nouvelle place, ça copie / colle le contenu du lien en une nouvelle page web !!!! Le .desktop reste quand à lui à sa place.
Je me retrouve donc avec une page html là ou je voulais garder simplement mon petit lien .desktop ... pour le supprimer plus tard.

Savez-vous comment désactiver cela ?

Merci d'avance.

#23 Re : -1 »  [Info]Greffon tableau de bord Unity » Le 29/06/2014, à 23:19

ladsy
Réponses : 1

Tiens, en cherchant comment désactiver l'affichage de ce fichus greffons, je tombe sur cette question ...
ça servirait à paramétrer des recherches ...
Pour moi, ça me semble juste une surcharge inutile.

#24 Re : -1 »  [resolu] fstab - monter une partition offset sda4p1 dans une partition » Le 15/05/2014, à 21:08

ladsy
Réponses : 14
maxire a écrit :

Euh non, en supprimant le paquet ntfs-3g, le problème est réglé, mais par contre tu perds l'accès aux utilitaires ntfs comme l'équivalent à chkdsk.

Plus précisément, avec le pilote ntfs par défaut, tu perds l'accès en lecture / écriture (non car il suffit de rajouter l'option rw, mais car ce pilote ntfs n'écrit pas, depuis le début). Du point de vue de la facilité d'usage, c'est pas forcément mieux que de ne pas pouvoir monter avec un utilisateur dont les droits ne sont pas privilégiés.
Ah par contre, tu retrouves en effet la possibilité de faire un mount /partoche avec tes utilisateurs.

Un peu bête qu'il n'y ait visiblement pas de PPA proposant un ntfs-3g intégré avec FUSE.