Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

nombre réponses : 25

#0 Re : -1 »  Fichier de config pure-ftpd écrasé » Le 13/10/2015, à 00:47

Valentin2105
Réponses : 3
sudo apt-get --reinstall pure-ftpd

Cette commande réinstallera Pure-FTPD avec ses fichiers & dépendances.

Si vous aviez modifier le fichier de configuration, vous avez totalement perdu votre configuration !!

D’où l'importance des backups ...

Cordialement,

#1 -1 »  Récupération Ecryptfs impossible.. » Le 08/09/2015, à 00:19

Valentin2105
Réponses : 7

Hello,

J'ai un problème avec un /home crypté depuis l'installation.

J'ai changer mon mot de passe user en ne pensant plus que mon home était crypté, ce que me bloqua au prochain reboot.

J'ai voulu bidouiller tout seul la modification de mot de passe de cryptage, mais je pense que j'ai fais une mauvaise manipulation et maintenant IMPOSSIBLE de récuperer mes données (Pourtant je connais mes deux mot de passes).

J'ai suivi plus de 10 topics (anglais / Français) mais aucun de résout mon problème...


Voici l'output de qque commandes :

valentin@r0g:~$ ecryptfs-mount-private 
Enter your login passphrase:
Inserted auth tok with sig [d53554ab15452e3a] into the user session keyring
Signature not found in user keyring
Perhaps try the interactive 'ecryptfs-mount-private'
valentin@r0g:~$ ecryptfs-unwrap-passphrase .ecryptfs/wrapped-passphrase 
Passphrase: 
maSuperpassphrase
root@r0g:~# ecryptfs-recover-private 
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/valenting/.Private].
Try to recover this directory? [Y/n]: Y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] Y
INFO: Enter your LOGIN passphrase...
Passphrase: 
Inserted auth tok with sig [d53554ab15452e3a] into the user session keyring
ERROR: The key required to access this private data is not available.
valentin@r0g:~$ ls -al .ecryptfs/
total 20
drwx------ 2 valentin valentin 4096 sept.  8 08:44 .
drwxrwxr-x 4 valentin valentin 4096 juin  25 08:39 ..
-rw-rw-r-- 1 valentin valentin    0 juin  25 08:39 auto-mount
-rw-rw-r-- 1 valentin valentin    0 juin  25 08:39 auto-umount
-rw------- 1 valentin valentin   15 juin  25 09:02 Private.mnt
-rw------- 1 valentin valentin   34 juin  25 08:39 Private.sig
-rw------- 1 valentin valentin   58 sept.  8 08:44 wrapped-passphrase

Le pire c'est que je connais ma passphrase et mon password de session, mais le problème semble être lié à auth tok sig ?

Je me suis créé un /home en attendant, mais j'aimerai bien au moins récupérer mes fichier tongue

J'ai essayer de recover depuis un LiveCd, il détecte bien ma partition, cependant il me dis que ma  LOGIN passphrase est incorrect et quand je rentre ma Wrapped passphrase, il me monte bien mon répertoire, mais que des dossiers Crypté visiblement, aucun accès réel au fichiers ...


Avez-vous une idée ?

Cordialement,

#2 Re : -1 »  Récupération Ecryptfs impossible.. » Le 08/09/2015, à 02:40

Valentin2105
Réponses : 7

Hello,

Voici les commandes :

sudo ecryptfs-add-passphrase --fnek
Passphrase: 
Inserted auth tok with sig [d53554ab15452e3a] into the user session keyring
Inserted auth tok with sig [ebe69da612bbeb6c] into the user session keyring
sudo mount -t ecryptfs /home/.ecryptfs/valenting/.Private/ /mnt/oldhome/
Passphrase: 
Select cipher: 
 1) aes: blocksize = 16; min keysize = 16; max keysize = 32
 2) blowfish: blocksize = 8; min keysize = 16; max keysize = 56
 3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24
 4) twofish: blocksize = 16; min keysize = 16; max keysize = 32
 5) cast6: blocksize = 16; min keysize = 16; max keysize = 32
 6) cast5: blocksize = 8; min keysize = 5; max keysize = 16
Selection [aes]: 1
Select key bytes: 
 1) 16
 2) 32
 3) 24
Selection [16]: 1
Enable plaintext passthrough (y/n) [n]: 
Enable filename encryption (y/n) [n]: y
Filename Encryption Key (FNEK) Signature [d53554ab15452e3a]: ebe69da612bbeb6c
Attempting to mount with the following options:
  ecryptfs_unlink_sigs
  ecryptfs_fnek_sig=ebe69da612bbeb6c
  ecryptfs_key_bytes=16
  ecryptfs_cipher=aes
  ecryptfs_sig=d53554ab15452e3a
WARNING: Based on the contents of [/root/.ecryptfs/sig-cache.txt],
it looks like you have never mounted with this key 
before. This could mean that you have typed your 
passphrase wrong.

Would you like to proceed with the mount (yes/no)? : y
Would you like to proceed with the mount (yes/no)? : n
Would you like to proceed with the mount (yes/no)? : yes
Would you like to append sig [d53554ab15452e3a] to
[/root/.ecryptfs/sig-cache.txt] 
in order to avoid this warning in the future (yes/no)? : no
Not adding sig to user sig cache file; continuing with mount.
Mounted eCryptfs
vouvrard@r0g:~$ >>> sudo ls /mnt/oldhome/
ECRYPTFS_FNEK_ENCRYPTED.FWb4W3i.gu79p-QbaRJVkjBlMUKNWj7QZqGX0oTqp0dmm8gZRkmcGPcyXk--
ECRYPTFS_FNEK_ENCRYPTED.FWb4W3i.gu79p-QbaRJVkjBlMUKNWj7QZqGX1Z2rEoPyt7CxqnZha35YeU--
ECRYPTFS_FNEK_ENCRYPTED.FWb4W3i.gu79p-QbaRJVkjBlMUKNWj7QZqGX2Ntt00PZBJXnFExPOuIrP---
ECRYPTFS_FNEK_ENCRYPTED.FWb4W3i.gu79p-QbaRJVkjBlMUKNWj7QZqGX4trMZ4Y4vx81GBTyIutbW---
ECRYPTFS_FNEK_ENCRYPTED.FWb4W3i.gu79p-QbaRJVkjBlMUKNWj7QZqGX5CLisl5JebKtVZsHnOsCo---

Le dossier monte bien, mais voici le contenu ...

#3 Re : -1 »  Récupération Ecryptfs impossible.. » Le 08/09/2015, à 04:18

Valentin2105
Réponses : 7

Il se peut que j'ai modifier par erreur ma wrapped passphrase, j'ai essayer pas mal de chose avec ecryptfs-*.
Que puis-je donc faire ?

Parceque si je connais la passphrase + password, je peux forcément récup mes données ?

#4 Re : -1 »  Récupération Ecryptfs impossible.. » Le 08/09/2015, à 19:34

Valentin2105
Réponses : 7
jamesbad000 a écrit :

Donc c'est certainement ça le problème. Et la solution est soit de ce rappeler de la wrapped passphrase d'origine. Soit de retrouver une ancienne version du fichier .ecryptfs/wrapped-passphrase et de se souvenir du mot de passe qui va avec pour extraire la wrapped passphrase avec la commande ecryptfs-unwrap-passphrase comme indiqué dans le lien que j'ai donné au début (étape 1)...

Ce que je ne comprend pas, c'est que je connais correctement ma wrapped passphrase (car il me l'affiche quand j'unwrap), donc je devrais pouvoir accèder à mes données ?

Il faudrait pas que je transfert cela sur un nouveau home crypté avec ecryptfs ?
Qu'elle serait la marche à suivre.

C'est bizarre, car tous les topics de Recover Ecryptfs ne marchent pas dans mon cas.

Voici ce qui s'affiche dans syslog, lorsque je monte et navigue dans les dossiers Crypté (en root, monté avec mount -t ecryptfs) :

Sep  9 04:36:32 r0g kernel: [67962.857648] ecryptfs_decode_and_decrypt_filename: Could not parse tag 70 packet from filename; copying through filename as-is 
Sep  9 04:36:32 r0g kernel: [67962.857653] Could not find key with description: [c6885b81b3a24bd4] 
Sep  9 04:36:32 r0g kernel: [67962.857653] process_request_key_err: No key 

Merci de ton aide en tous cas.

#5 -1 »  Ganeti avec Xen » Le 26/08/2015, à 09:36

Valentin2105
Réponses : 2

Hello,

Je vous présente ma configuration Ganeti avec l'hyperviseur Xen,

Cette configuration permet de faire des VMs Debian 8 et Ubuntu 14.04 avec :

- Propre Kernel
- Disque virtuelle pour /boot
- Configuration LVM pour le système
- Partition SWAP
- Paquets minimaux (vim, htop, screen ...)

Pour ceux qui ne connaissent pas Ganeti, c'est un "surcouche" de Xen, écrit par Google en Python,
Cela permet de gérer un cluster de plusieurs serveurs Xen, avec des disques distribués en DRBD.
Cela permet de migrer des VMs d'un serveur à l'autre sans les arrêter, d'avoir une grande stabilité et de se sentir sûr ! tongue

https://en.wikipedia.org/wiki/Ganeti

Il y a également un script qui permet d'automatiser simplement la création de VMs (par une API par exemple).

Si vous avez des questions n'hésitez pas.

Voici ma configuration sur Github.

#6 Re : -1 »  Ganeti avec Xen » Le 26/08/2015, à 12:27

Valentin2105
Réponses : 2
src a écrit :

Salut, intéressant, je ne connaissais pas.
C'est une API comme xapi/libvirt ?
Il y a une interface graphique ou du CLI ?
J'ai jeté un œil a ton github et c'est surout la partie déploiement qui est mentionnée smile
En tous cas c'est cool car Xen est énorme mais à part xapi + xencenter (ou xenorchestra) c'est pas pratique à gérer.

C'est pas vraiment une API,

C'est plusieurs services qui tourne sur chacun des serveurs,

Tout se fait en ligne de commande, il y a le master Ganeti qui contrôle les différents serveurs nodes (autant qu'on veut en théorie),

Ganeti est également utilisable via son API (des interfaces web existes), mais perso, en CLI ça fonctionne très bien.

C'est très puissant, par exemple, si un serveur est défaillant, en une commande, on migre toute les VM qu'il héberge vers d'autres serveurs.

C'est assez "compliqué" à assimiler, mais une fois bien configuré, ça tourne super bien.

#7 Re : -1 »  Possibilité d'être piraté? » Le 07/08/2015, à 02:36

Valentin2105
Réponses : 6

Pour moi tu n'es pas piraté,

RKhunter, va forcément te sortir des faux positifs, il faut éviter de l'utiliser comme un Antivirus sous Windows.

Je suis pas expert, mais je suis presque sûr que tu n'as pas à t'inquiéter.

Concernant le Capcha sur Google, ça m'est déjà arrivé en expérimentant des Google Dorks (requête que google n'aime pas trop),

Google à donc eu des recherches "frauduleuses" sur ton IP, est-tu seul sur ton IP ?

Cordialement,

#8 Re : -1 »  [Securité/Dev] Protéger un espace d'upload » Le 07/08/2015, à 02:30

Valentin2105
Réponses : 2

La backdoor PDF ne s’exécutera pas sur le serveur mais plutôt sur les PC des clients qui récupèrent les PDF wink

L'analyse AV permet de "garantir" à tes clients des fichiers propres !

#9 Re : -1 »  ubuntu server et squid » Le 26/01/2015, à 01:56

Valentin2105
Réponses : 6

Basiquement, tu peux faire ça :

(dans squid.conf)

acl whitelist dstdomain .example.com .google.com .bing.com
http_access allow whitelist

#10 Re : -1 »  ubuntu server et squid » Le 13/02/2015, à 07:18

Valentin2105
Réponses : 6

Il suffit que tu débloque l'https sur ton Pare-feu !

ça ne sert à rien de bloquer l'HTTPS si tu es dans un système de Whitelist,

Comme ça, seulement les sites HTTP et HTTPS présents dans ta whitelist seront accessible !

ça répond à ta question ?

#11 -1 »  [Votre AVIS] Sécurité Serveur » Le 26/01/2015, à 01:31

Valentin2105
Réponses : 7

Bonjour,

J'aimerai un peu "tester" la sécurité de mon serveur,

J'aimerai vos avis sur ma configuration :

--------------------------
-------- SSH -----------
--------------------------

- Port élevé sur TCP
- Protocol 2
- Login Root bloqué
- Login sur un seul user autorisé
- Mot de passe de 16 caractères
- Fail2ban ban l'IP après 3 ratés


--------------------------
-------- Apache2 -----
--------------------------

- Page d'accueil static (sans PHP, bootstrap simple)
- Login à la partie admin avec .htaccess
- Fail2ban ban l'IP après plusieurs ratés
- Token cachés (Prod)
- Rewrite automatique en HTTPS

--------------------------

Le tout est supervisé par LogWatch, avec un script Iptables avec seulement les ports voulus d'ouvert.
J'ai également un SAMBA sur mon réseau local.

Au niveau d'Apache, j'aimerai savoir si un formulaire de login en PHP (avec login:mpd dans Base MySQL) est plus sécuritaire qu'un .htaccess ?
Tout ce que je met dans mon dossier protégé par le .htaccess est vraiment innaccessible sans le pass ? Car il pourrait avoir des données sensibles.

( Par exemple si j'ai des applications webs avec de possibles failles derrière mon Htaccess, est-ce un risque ? )

Ce serveur à seulement SSH, HTTP, HTTPS de routé vers Internet,

Quelles possibles failles peuvent m'exposé sur ces ports ?

Merci de me donner une nouvelle vision,

Cordialement,

Valentin

#12 Re : -1 »  [Votre AVIS] Sécurité Serveur » Le 26/01/2015, à 12:27

Valentin2105
Réponses : 7
ssdg a écrit :

Pourquoi ne pas passer par un couple clef publique/privée? entre 8 caractères et un challenge sur 2048 (ou plus) bits, je choisi le second wink

Je l'ai mis en place, mais j'y accède depuis plusieurs machines, je vais déployer mes clés et fermer l'authentification par mot de passes !

Ensuite pour HTTP j'ai pas était très clair,

Dans sites-enabled, j'ai que "default-ssl"

Mon répertoire WWW se décompose comme ceci :

--------------------------------------------------------------------------------------------
Accueil - OUVERT (Static Bootstrap avec liens vers admin) --------------
-------- Admin - Protégé par HTAccess + Ban IP ------------------------------
------------------ Plusieurs outils PHP (qui peuvent contenir des failles) ---
--------------------------------------------------------------------------------------------
Ma question était donc, Est-ce que mon dossier Admin et tous ce qu'il contient (App + Fichiers) sont sécurisés seulement avec un .htaccess ?

Vis à vis du serveur, il s'agit d'un Debian Wheezy, à jours, avec le minimum de paquet installés (le nécéssaire).

Merci pour vos réponses en tout cas.

PS : Des outils de supervision à suggèrer ?

#13 Re : -1 »  [Votre AVIS] Sécurité Serveur » Le 26/01/2015, à 12:54

Valentin2105
Réponses : 7

Pour la clé, j'utilise bien une clé par périphériques.

Concrétement, comment désactiver le mot de passe pour le seul utilisateur (autre que root) ?

Pour ma configuration d'Apache2, il s'agit bien de la config par défaut, avec qques modifications (Caché version d'apache ...).

Mon Htaccess contient ceci :

AuthType Basic
AuthName "Restricted Access"
AuthUserFile /var/www/admin/.htpasswd
Require user valentin

Mon default-site-ssl contient :


<IfModule mod_ssl.c>
<VirtualHost _default_:443>
        ServerAdmin mon-mail

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

        SSLEngine on
        SSLCertificateFile    /etc/apache2/SSL/server.crt
        SSLCertificateKeyFile /etc/apache2/SSL/server.key

SSLProtocol -ALL +TLSv1 +TLSv1.1 +TLSv1.2
SSLHonorCipherOrder On
SSLCipherSuite ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:HIGH:!MD5:!aNULL:!EDH:!RC

En fait j'ai besoin d'avoir la page d'accueil "ouverte", pour afficher des infos, des liens ...
Parcontre, ma partie Admin, doit être sécurisé, et toutes les Apps contenus dans ce dossiers, doivent être innacessible sans se logguer (et l'IP est ba après 3 erreurs).

Le Htaccess me garantit pas ça  ?

Cordialement et encore merci pour vos réponses.

#14 Re : -1 »  Attaque ?? » Le 14/01/2015, à 20:17

Valentin2105
Réponses : 10

Hello !

T'utilise quoi comme appli sur les screenshoots ?

Si ils sont rentré, bannir l'ip de suffit pas, ils ont une backdoor, si c'est un serveur important vaut mieux bien vérifier,

netstat -ant

tu verras déjà si t'a une connexion sortante.
Après pk pas Chrookit ou rkhunter !

#15 -1 »  Problême batterie » Le 02/09/2014, à 02:24

Valentin2105
Réponses : 2

Bonjour,

J'ai un problème non-résolu depuis un petit moment,

Mon Applet de Batterie sous Ubuntu 14.04 NE FONCTIONNE PAS ...

Je m'explique, enfaite, il garde la valeur qu'il reçoit au démarrage de l'ordi et ne change JAMAIS.

C'est embêtant pour un laptop quoi..,

Cependant, la commande "acpi -i" me renvoie les bonnes valeurs concernant la charge, donc je sais pas pourquoi l'applet de s'Update pas.?

acpi -i
Battery 0: Discharging, 33%, 00:41:11 remaining
Battery 0: design capacity 5243 mAh, last full capacity 4874 mAh = 92%

Vous avez une idée ?

#16 Re : -1 »  Problême batterie » Le 03/09/2014, à 00:29

Valentin2105
Réponses : 2

Je suis d'accord avec toi, osef de l'applet, mais simplement POURQUOI bloque tongue
Ensuite si j'utilise conky, comment désactiver l'applet car ça fais chié d'avoir un pourcentage de batterie Faux ...

#17 -1 »  Pb dual-screen » Le 10/08/2014, à 02:21

Valentin2105
Réponses : 0

Bonjour,

J'ai un problème avec le dual-screen sous Xubuntu 14.04,
Quand j'utilise deux écran, tout fonctionne normalement, mais quand je débranche un écran pour "transporter" mon laptop et que je l'utilise avec uniquement son écran,
Les fenêtres qui était sur l'autre écran se trouve totalement inutilisable.. impossible de les ramener au premier écran !?

Vous avez une idée ?

#18 -1 »  quelques problêmes avec Xubuntu » Le 03/08/2014, à 01:35

Valentin2105
Réponses : 4

Bonjour,

J'ai deux principaux problèmes avec Xubuntu sous Mon R0G G55VW :

L'Applet de Batterie est hyper instable, ç-a-d qu'il ne suis pas quand je branche mon chargeur ou le débranche, en gros, il conserve la "valeur" qu'il possède au démarrage ...
C'est embêtant d'avoir un Laptop et de pas savoir combien il reste de batterie tongue !


Deuxième problême, mes touches de réglages de la luminosité ne marchent toujours pas, après avoir "tout" essayez :
J'ai modifier le /etc/default/grub, recharger le grub et toujours rien...,
J'ai installer https://github.com/DavidEGrayson/acpi4asus-dkms, toujours rien ...


et un dernier petit "truc", avec le pilote Nvidia, j'ai plus de Splashscreen, normal ?

Merci de m'éclairer, j'adore la liberté de XFCE mais ses petit blem me font un peu chi*er..

Cordialement

#19 Re : -1 »  quelques problêmes avec Xubuntu » Le 03/08/2014, à 07:20

Valentin2105
Réponses : 4

Pour la luminosité,

L'applet de Luminosité fonctionne à merveille,
cependant les touches FN ne fonctionnent pas, quel commande corresponds à l'applet luminosité pour que je les attribue aux touches FN ?

Mon plus gros problème vient de la batterie, qui fonctionne vraiment mal, il ne détecte même pas si mon pc est branché ou sur batterie ...

Une idée ?

#20 Re : -1 »  quelques problêmes avec Xubuntu » Le 04/08/2014, à 01:02

Valentin2105
Réponses : 4

Quand je branche / débranche le cable d'alim,
L'indicateur reste à la valeur qu'il à eu au démarrage ! rien ne change.

J'ai installé xfce4-battery-plugin 1.0.5, qui lui détecte parfaitement quand je branche et débranche.

Cependant  xfce4-indicator-plugin reste bloqué ...

#21 -1 »  Choix pilote graphique Nvidia... » Le 01/08/2014, à 01:45

Valentin2105
Réponses : 10

Bonjour,

Je possède un ROG G55VW, possèdant cette carte graphique :

valentin@RoG-VaL:~$ lspci |grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GTX 660M] (rev a1)

Voici le choix que me propose "Pilotes additionnels" :
1406850003.jpg

Le pilote libre fonctionne bien, cependant, j'aimerai bénéficier de "la puissance" de ma carte graphique.

Je suis sous Xubuntu 14.04, et à ma dernière installation, j'avais essayer quelques pilotes,
-un m'avais planter le serveur X, obliger de réinstaller Xubuntu.
-un second avait l'air de bien fonctionné, sauf que mon "splashscreen" était genre en 800x600..

Je me dis qu'il faut que j'en installe un qui ne soient pas dans les Pilotes Additionnels ?

Vous utilisez le quel ? le quel me conseillez-vous ?

Merci

#22 Re : -1 »  Choix pilote graphique Nvidia... » Le 01/08/2014, à 23:22

Valentin2105
Réponses : 10

Quel différence entre le premier et le troisième ?
N'aurai-je pas de problèmes graphiques ? comment restaurer ce choix via shell si mon Xorg plante ?

Merci de vos réponses

PS : Est-ce réellement mieux que le pilote libre  ?

#23 Re : -1 »  Choix pilote graphique Nvidia... » Le 02/08/2014, à 13:05

Valentin2105
Réponses : 10

Ok merci bien pour vos réponses ! smile

Dernière question, comment restaurer le pilote libre, en cas de casse de Xorg ? (via le shell)

#24 Re : -1 »  |résolu|RewriteRule Apache » Le 18/07/2014, à 01:34

Valentin2105
Réponses : 9

Non, cela ne fonctionne pas.

De toute façon j'ai laisser tomber le reverse proxy et je passe par tunnel SSH pour y accèder, ducoup localhost:9091 me suffit.

Merci de ton aide

smile