Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.
nombre réponses : 25

#0 Re : -1 »  Centralisation - linux pour photographes - » Le 29/07/2014, à 12:47

patrick L
Réponses : 299

je voudrais avoir autopano  mais la version linux est uniquement en 64 bits.   Alors est ce que kolor prevoit de mettre en place une version de autopano 3.5 pour linux 32 bits.

#1 Re : -1 »  Centralisation - linux pour photographes - » Le 29/07/2014, à 15:36

patrick L
Réponses : 299

merci de votre réponse

hugin je l'utilise mais je sais pas comment faire des panos en hdr  avec hugin. Et aussi hugin a tendance à arrondir les bords des panos assemblés.

#2 Re : -1 »  Darktable » Le 20/05/2014, à 17:43

patrick L
Réponses : 340

ctrl Z  sur une image et on voit en pleine taille (avec quand meme les menus à droite et à gauche).   en plus ca donne des rectangles avec les choses nettes...

#3 Re : -1 »  Darktable » Le 22/05/2014, à 14:32

patrick L
Réponses : 340

y  a pas de plein ecran  sur darktable... Si vous voulez avoir en plein ecran il y a la visionneuse. dartktable est un logiciel de retouche et pas de visualisation.

ca fonctionne ces touches uniquement en mode table lumineuse...  ensuite pour moi c'est pas un probleme...

#4 Re : -1 »  udev les rules et l'éxécution automatique » Le 08/07/2014, à 12:01

patrick L
Réponses : 11
oaxley a écrit :

reSalut, Fabux

Effectivement ce Forum n'est pas très réactif... Peut ^tre pas le bon endroit ou bien pb trop complexe.
Je reste cependant fort étonné que personne n'est jamais buté sur ce sujet.

Le souci est simple:

Un disque inconnu est pluggué sur le serveur.
Je cherche à détecter cet évènement, et proposer une action adaptée (formatage et nommage par exemple).
Ce même disque lors de sa seconde connexion (et a fortiori les suivantes), devra être reconnu comme valide, monté dans un FS et une action adaptée (backup par exemple) devra être lancée.

Voila ce sur quoi je bute, surtout la première action (le disque qui n'a jamais ete connecté)

Merci de ton aide.

Oaxley from Linux Moon


deterrage alors ...

bon je  juge pas ton projet...   bien que  !!! l'avis sur le formatage soit pertinent..   

j'ai rien essayé sur ta manip...   tu veux detecter un disque "inconnu"...   alors le plus simple est :


soit tu as des regles ...  sur les disques connus... 

subsystem=="usb", attrs{serial}=="FDTOIRODKR", action=="add",  SYMLINK+="connu_0001", LABEL="FIN"
subsystem=="usb", attrs{serial}=="FROREDKLMKR", action=="add",  SYMLINK+="connu_0002", LABEL="FIN"
#surtout pas oublier le disque du patron...
subsystem=="usb", attrs{serial}=="FDTOIEZEZOEZ", action=="add",  SYMLINK+="connu_0003", LABEL="FIN" 
## Ici le disque inconnu... 
subsystem=="usb",  action=="add" ,  run+="cequetuveux %k"
label="FIN"

#5 -1 »  erreur 0x80070035 sur client windows 7 partage kubuntu 14.04 [resolu] » Le 29/06/2014, à 21:35

patrick L
Réponses : 2

bonsoir et bonne semaine.

comme vous voyez j'ai remis samba en route en remettant la config précédente de samba.  Et sur windows je vois bien le nom de mon ordi s'afficher ,  PATRICK-WIN7 et la boite de login  et mot de passe et la liste des partages s'affiche.   Lorsque je veux ouvrir j'ai le message d'erreur windows  0x80070035 chemin réseau non trouvé...   et pourtant windows 7 charge bien la liste des partages déclarés ci dessous.   

et quand je veux lancer le partage windows 7 m'affiche le code d'erreur et des fois l'erreur est 0x80070043 reseau non trouvé.

alors je remets les infos du coté de kubuntu 14.04

$ [cat /etc/samba/smb.conf | sed  "/^[#;]/d"
[global]
        workgroup = LEJARE
        netbios name = patrick-win7
        server string = %h server (Samba, Ubuntu)
   wins support = yes
   interfaces = 127.0.0.0/8 eth0 192.168.10.0/24
        log file = /var/log/samba/log.%m
        max log size = 1000
        syslog = 0
        panic action = /usr/share/samba/panic-action %d
        security = user 
        encrypt passwords = true
        passdb backend = tdbsam                                                                                                                                                     
        obey pam restrictions = yes                                                                                                                                                 
        unix password sync = no                                                                                                                                                     
        passwd program = /usr/bin/passwd %u                                                                                                                                         
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully*.
        pam password change = yes 
        map to guest = bad user        

   socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192 
        usershare allow guests = no 

[printers]
        comment = All Printers
        browseable = no
        path = /var/spool/samba
        printable = yes
        guest ok = no
        read only = yes
        create mask = 0700

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
        browseable = yes
        read only = yes
        guest ok = no
   write list = root, @lpadmin

[sysvol]
        path = /var/lib/samba/sysvol
        read only = no

[netlogon]
        path = /var/lib/samba/sysvol/SERVER.APACHE2/scripts
        read only = no

[seagate]
        path            = /media/seagate500GO/patrick/
        comment         = "disque seagate 500 gigas"
        read only       = yes
        guest ok        = no
        public          = no
        browseable      = yes
        valid users = @sambausers
        write list      = patrick

[galerie]
        path            = /media/seagate500GO/patrick/Photos_triees/galerie
        comment         = "presentation des photos"
        read only       = yes
        guest ok        = no
        public          = no
        browseable      = yes
        valid users = @sambausers
        write list      = patrick

[transfert] 
        path            = /media/seagate500GO/patrick/divers
        comment         = "echange de documents"
        read only       = yes
        guest ok        = no
        public          = no
        browseable      = yes
        valid users     = @sambausers
        write list      = @sambausers 

patrick@patrick-win7:~$ sudo smbtree
[sudo] password for patrick: 
Enter root's password: 
LEJARE
        \\PATRICK-WIN7                  patrick-win7 server (Samba, Ubuntu)
                \\PATRICK-WIN7\brother-hl2035_freebox   laser sur freebox
                \\PATRICK-WIN7\print$           Printer Drivers
                \\PATRICK-WIN7\sysvol         
                \\PATRICK-WIN7\netlogon       
                \\PATRICK-WIN7\seagate          disque seagate 500 gigas
                \\PATRICK-WIN7\galerie          presentation des photos
                \\PATRICK-WIN7\transfert        echange de documents
                \\PATRICK-WIN7\IPC$             IPC Service (patrick-win7 server (Samba, Ubuntu))

patrick@patrick-win7:~$ sudo smbclient -L 192.168.10.1
Enter root's password: 
Domain=[LEJARE] OS=[Unix] Server=[Samba 4.1.6-Ubuntu]

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (patrick-win7 server (Samba, Ubuntu))
        transfert       Disk      echange de documents
        galerie         Disk      presentation des photos
        seagate         Disk      disque seagate 500 gigas
        netlogon        Disk      
        sysvol          Disk      
        print$          Disk      Printer Drivers
        brother-hl2035_freebox Printer   laser sur freebox
Domain=[LEJARE] OS=[Unix] Server=[Samba 4.1.6-Ubuntu]

        Server               Comment
        ---------            -------
        PATRICK-WIN7         patrick-win7 server (Samba, Ubuntu)

        Workgroup            Master
        ---------            -------
        LEJARE               PATRICK-WIN7

patrick@patrick-win7:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr d4:85:64:0a:0a:0a  
          inet adr:192.168.10.1  Bcast:192.168.10.255  Masque:255.255.255.0
          adr inet6: fe80::d685:64ff:fe0a:a0a/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:74920 erreurs:0 :0 overruns:0 frame:0
          TX packets:64443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:62227604 (62.2 MB) Octets transmis:9630483 (9.6 MB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:531 erreurs:0 :0 overruns:0 frame:0
          TX packets:531 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:77697 (77.6 KB) Octets transmis:77697 (77.6 KB)

usb0      Link encap:Ethernet  HWaddr 02:04:06:08:0a:0c  
          inet adr:169.254.255.2  Bcast:169.254.255.3  Masque:255.255.255.252
          adr inet6: fe80::4:6ff:fe08:a0c/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:4 erreurs:0 :0 overruns:0 frame:0
          TX packets:162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:712 (712.0 B) Octets transmis:20626 (20.6 KB)

patrick@patrick-win7:~$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

patrick@patrick-win7:~$ sudo cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat
group:          compat
shadow:         compat

hosts:          files mdns4_minimal [NOTFOUND=return] wins dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

un fichier log qui avec un message qui peut apporter une solution.   

patrick@patrick-win7:~$ cat   /var/log/samba/log.pcmaman 
  canonicalize_connect_path failed for service galerie, path /media/seagate500GO/patrick/Photos_triees/galerie
[2014/06/29 09:35:46.840941,  0] ../source3/smbd/service.c:784(make_connection_snum)
  canonicalize_connect_path failed for service galerie, path /media/seagate500GO/patrick/Photos_triees/galerie
[2014/06/29 09:35:46.843156,  0] ../source3/smbd/service.c:784(make_connection_snum)
  canonicalize_connect_path failed for service galerie, path /media/seagate500GO/patrick/Photos_triees/galerie
[2014/06/29 09:35:46.846343,  0] ../source3/smbd/service.c:784(make_connection_snum)
...
[2014/06/29 09:36:23.605410,  0] ../source3/smbd/service.c:784(make_connection_snum)                                                            
  canonicalize_connect_path failed for service transfert, path /media/seagate500GO/patrick/divers
 $

#6 Re : -1 »  erreur 0x80070035 sur client windows 7 partage kubuntu 14.04 [resolu] » Le 30/06/2014, à 21:24

patrick L
Réponses : 2

merci


ca serait bien possible que ca vienne de là....  j'avais prevu que le user carmen n'accede pas sur mon disque dur...  donc logique qu'il accede pas non plus via samba.    samba accepte l'acces et plante sur le refus du point de montage car carmen pas dans le groupe    Ca me pose un probleme mais je vais vérifier demain...   ca peut venir de là.

le un sept  2014 : alors merci 10 fois,     c'etait ca !!!

#7 Re : -1 »  problème script surveillance dernier fichier » Le 29/06/2014, à 09:05

patrick L
Réponses : 26
Postmortem a écrit :

Tu pourrais faire comme ça :

while fic=$(inotifywait -e create /tmp/test --format %w%f)
do
   ls -lc "$fic"
done

Ainsi, tu fais le ls que sur le fichier nouvellement créé.
Je pense que le "ls -clt" donne un classement bizarre car -c ne donne pas la date de création mais la date de dernier changement de statut.

s'il veut les fichiers par ordre de creation ou de modification...  il mets dans un fichier text.

liste="/tmp/files.list"
touch $liste
inotifywait -e create /tmp/test --format "%T %f" --time-format "%Y-%m%B-%d_%H-%M-%S" | do
  while read t f ; do
   echo " $t  : $f" >> $liste
done

#8 -1 »  kubuntu 14.04 et script bash interdit d'acces. [resolu] » Le 26/06/2014, à 14:35

patrick L
Réponses : 2

J'ai réinstallé y a quelques semaines kubuntu 14.04 et alors je me retrouve avec un soucis.    que je résouds via des copiés collés.   

j'ai repris une sauvegarde avant la réinstallation  complete + chargement de partitions. 

alors j'ai repris le dossier documents d'une sauvegarde via tar.  alors je me trouve avec un  soucis sur un script. 

le script est déchiffre.sh et le nom d'un fichier pour déchiffrer en aes...   

patrick@patrick-win7:~/Documents/Banque$ ll
total 2992
drwx------ 2 patrick patrick   4096 juin  26 14:17 ./
drwxr-xr-x 7 patrick patrick   4096 juin  26 11:34 ../
-rw------- 1 patrick patrick 662340 juin   9 12:21 BanqueDirecte.tif
-rw------- 1 patrick patrick 896960 juin   9 12:21 BanqueDirecte.tif.aes
-rw------- 1 patrick patrick 844220 juin   9 12:21 carteBleue.JPG.aes
-rw------- 1 patrick patrick 623397 juin   9 12:21 carteBleue.JPG.old
-rw------- 1 patrick patrick     61 juin   9 12:21 chiffre.sh
-rw------- 1 patrick patrick    502 juin  26 14:17 dechiffre.sh
-rw------- 1 patrick patrick     61 juin   9 12:21 .directory
-rw------- 1 patrick patrick     90 juin   9 12:21 e_cartebleue.txt.aes
-rw------- 1 patrick patrick     46 juin   9 12:21 e_cartebleue.txt.old
patrick@patrick-win7:~/Documents/Banque$ whoami
patrick
patrick@patrick-win7:~/Documents/Banque$ ./dechiffre.sh e_cartebleue.txt
bash: ./dechiffre.sh: Permission non accordée

alors je me mets en sudo  et

 
patrick@patrick-win7:~/Documents/Banque$ sudo ./dechiffre.sh e_cartebleue.txt
[sudo] password for patrick: 
sudo: ./dechiffre.sh: command not found
patrick@patrick-win7:~/Documents/Banque$

le script bash .... pour déchiffrer.

patrick@patrick-win7:~/Documents/Banque$ cat dechiffre.sh 
#!/bin/bash

echo "lancement script"
if [ ! -e $1.aes ] ; then 
        echo "$1.aes non trouvé" 
        exit 1
fi 
if [ echo  $1 | grep ".aes" ] ; then 
        echo "entrer nom de fichier sans l'extension .aes"
        exit  1
fi
openssl enc -a -d -aes-256-cbc -in $1.aes -out $1 || exit 2
# affiche les fichiers texte via cat 
echo $1  | grep -i ".txt$" && cat $1
#affiche les images 
echo $1 | grep -i ".tif$" && gimp $1
echo $1 | grep -i ".jpg$" && gimp $1
# on efface le fichier généré...
echo "effacement du fichier non chiffré : $1"
rm $1

patrick@patrick-win7:~/Documents/Banque$ 

merci de vos réponses...

resolu :  les droits du script etaient pas en exécution.

#10 Re : -1 »  écran noir après mise à jour kde » Le 18/06/2014, à 11:53

patrick L
Réponses : 6

bonjour


j'ai eu le meme probleme à un moment... je suis revenu sous  gnome et j'ai desinstallé...    j'ai réinstallé  et  le second téléchargement et réinstallation s'est bien passé.

Maintenant  je réinstalle kubuntu seul.   et ca marche normalement mise à part des problemes solutionables assez facilement.

#11 -1 »  plus de reseau en static [ résolu ] » Le 16/06/2014, à 20:55

patrick L
Réponses : 20

bonsoir et bonne semaine à tous.


il y a une semaine j'ai installé kubuntu 14.04 après avoir réorganisé les partitions...

alors  après l'installation le réseau se passait bien comme il faut entièrement en auto mais pour avoir les partages samba ce midi j'ai voulu mettre les ips en statique.
j'ai recopié les lignes de votre documentations dans /etc/network/interfaces

auto eth0
iface eth0 inet static
        address 192.168.10.1
        netmask 255.255.255.0
        gateway 192.168.10.50
        dns-nameservers (de free)


alors j'ai lancé la commande pour relancer le réseau
sudo /etc/init.d/networking restart
en vérifiant via la commande ifconfig le numéro ip ne fonctionnait pas...  alors j'ai voulu faire via  kde et en graphique...  dans le gestionnaire réseau j'ai modifié la connexion filaire 1 pour la passer en manuel...   numero ip 192.168.10.1 et les dns de free, je valide et il se passe rien. 

pas de modif d'enregistree dans le fichier /etc/network/interfaces

alors j'ai redémarré et là plus rien...  ni d'interfaces enregistrée dans l'outil de kde,   et plus de connection via firefox mais le ifconfig indique bien eth0 à mon adresse statique.   et les dns de free...  .240 et .241 sont dans le fichier resolv.conf (à ne pas modifier) et kde affiche un réseau avec un ? !!!!! 

alors merci d'avance de vos réponses.

#12 Re : -1 »  plus de reseau en static [ résolu ] » Le 16/06/2014, à 21:32

patrick L
Réponses : 20

merci de la réponse.


j'ai  192.168.10.6 la première adresse de la plage dhcp fournie par la freebox hd

#13 Re : -1 »  plus de reseau en static [ résolu ] » Le 16/06/2014, à 22:31

patrick L
Réponses : 20

oui....  et le masque j'ai les 255.255.255.0 classiques.   

j'ai  mis le fichier interfaces en dhcp classique...   que je donne là...   je me suis remis sur kubuntu 14.04  et en dhcp tout fonctionne. 


~$ cat  /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

mais en static plus rien...  je mets les commandes

~$ cat  /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

auto eth0
iface eth0 inet static
        address 192.168.10.1
        netmask 255.255.255.0
        gateway 192.168.10.1
        dns-nameservers  212.27.40.240, 212.27.40.241

sur la doc ici on me dit de mettre les dns de free !!!! sur http://doc.ubuntu-fr.org/tutoriel/comme … seau_local

par contre lorsque je rentre la commande

~$ sudo service networking restart
stop: Job failed while stopping
start: Job is already running: networking

idée de taper le classique

~$ cat /var/log/syslog | tail
Jun 16 21:40:38 patrick-win7 avahi-daemon[786]: New relevant interface eth0.IPv6 for mDNS.
Jun 16 21:40:38 patrick-win7 avahi-daemon[786]: Registering new address record for fe80::d685:64ff:fe0a:a0a on eth0.*.
Jun 16 21:40:38 patrick-win7 whoopsie[1100]: message repeated 52 times: [ offline]
Jun 16 21:40:38 patrick-win7 whoopsie[1100]: online
Jun 16 21:40:44 patrick-win7 ntpdate[6889]: adjust time server 91.189.94.4 offset -0.136198 sec
Jun 16 21:40:57 patrick-win7 NetworkManager[863]: <info> (eth0): IP6 addrconf timed out or failed.
Jun 16 21:40:57 patrick-win7 NetworkManager[863]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Jun 16 21:40:57 patrick-win7 NetworkManager[863]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Jun 16 21:40:57 patrick-win7 NetworkManager[863]: <info> Activation (eth0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Jun 16 22:17:01 patrick-win7 CRON[7144]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)

heure 22:24

je viens de faire deconnection reconnection  sur l'onglet réseau de la zone de notification  et aucun changement de numero ip

~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr d4:85:64:0a:0a:0a  
          inet adr:192.168.10.6  Bcast:192.168.10.255  Masque:255.255.255.0
          adr inet6: fe80::d685:64ff:fe0a:a0a/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:6699 erreurs:0 :0 overruns:0 frame:0
          TX packets:6743 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:5388036 (5.3 MB) Octets transmis:736841 (736.8 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:2850 erreurs:0 :0 overruns:0 frame:0
          TX packets:2850 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:267796 (267.7 KB) Octets transmis:267796 (267.7 KB)

#14 Re : -1 »  plus de reseau en static [ résolu ] » Le 17/06/2014, à 13:52

patrick L
Réponses : 20

merci à vous tous... ;)

sur les deux adresses  j'ai remarqué le probleme.


pour dire ma configuration  j'ai un ordinateur patrick_win7  en raison du dual boot avec windows.   raison de me mettre en dual boot...  c'est que j'ai un gps  et en cas de probleme sous linux de garder mon utilisation sous windows. 

ensuite j'ai des ordis sous windows ordi_parents,   ordi_enfants  et portable qui sont sous windows  (mais j'ai mis kubuntu 13.10 sur le portable avoir ma retouche photo et  besoins personnels en photo).   

je mets mes adresses ip en static pour partager un disque dur externe avec des données familiales dessus.   ce midi j'ai les fichiers de configs suivants

patrick@patrick-win7:~$ cat  /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

auto eth0
iface eth0 inet static
        address 192.168.10.1
        netmask 255.255.255.0
        gateway 192.168.10.50
patrick@patrick-win7:~$ cat /etc/resolv.conf
nameserver 212.27.40.240,
nameserver 212.27.40.241
patrick@patrick-win7:~$ ls /etc/ | grep "resolvconf"
resolvconf
patrick@patrick-win7:~$ ll /etc/ | grep "resolvconf"
drwxr-xr-x   5 root root     4096 avril 16 19:32 resolvconf/
lrwxrwxrwx   1 root root       29 juin   8 22:28 resolv_conf.sav -> ../run/resolvconf/resolv.conf
patrick@patrick-win7:~$ # j'ai renommé le lien comme ca je peux revenir en l'etat 
patrick@patrick-win7:~$ sudo ifconfig -a
eth0      Link encap:Ethernet  HWaddr d4:85:64:0a:0a:0a  
          inet adr:192.168.10.1  Bcast:192.168.10.255  Masque:255.255.255.0
          adr inet6: fe80::d685:64ff:fe0a:a0a/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:6491 erreurs:0 :0 overruns:0 frame:0
          TX packets:5819 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:6411857 (6.4 MB) Octets transmis:643657 (643.6 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:1067 erreurs:0 :0 overruns:0 frame:0
          TX packets:1067 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:82651 (82.6 KB) Octets transmis:82651 (82.6 KB)

patrick@patrick-win7:~$ sudo ifdown eth0
[sudo] password for patrick: 
patrick@patrick-win7:~$ sudo ifup eth0
patrick@patrick-win7:~$ cat /etc/resolv.conf
nameserver 212.27.40.240,
nameserver 212.27.40.241

en ayant corrigé l'horreur (là j'ai pas fait fort...)  de la passerelle  au meme ip que la carte reseau.  et surtout j'ai viré le gestionnaire réseau de kde...   Je pense que le probleme est un conflit entre le gestionnaire dans kde et les fichiers de configurations.  j'ai viré le gestionnaire et ca a l'air de marcher sans probleme.   Les adresses sont en static.   


sur les questions :
je mets en static pour mettre un partage samba linux (disque externe)  client windows 7.

je vais rebooter voir si ca le fait bien...   et ensuite je mets samba. logiquement c'est de recopier un fichier smb.conf d'une sauvegarde.

#15 Re : -1 »  plus de reseau en static [ résolu ] » Le 17/06/2014, à 14:41

patrick L
Réponses : 20

merci

j'ai recopié les lignes du fichier derriere le lien /etc/resolv.conf   vers /run/resolvconf/resolv.conf donc  et la premiere ligne a une ","

je reboote... voir si j'ai bien mis les choses correctement.

ca a l'air d'aller  je suis revenu avec du reseau..

---- résolu


pour moi le probleme est que l'outil de configuration se mets en conflit avec les fichiers de config /etc/network/interfaces

je vais etudier le conseil des baux permanents qui a l'air d'etre interessants.. j'aime bien centraliser les infos dans un seul endroit.

#16 Re : -1 »  plus de reseau en static [ résolu ] » Le 19/06/2014, à 12:48

patrick L
Réponses : 20

merci de vos conseils...

j'ai regardé ce qu'est le mtu.    c'est la taille maximale pouvant etre emise en une seule fois.   Sur linux j'ai pas rentré la valeur qui doit se mettre en auto.

sur le deplacement de l'ordi ailleurs...   je mets ma freebox en 192.168.10.50  et dejà le probleme est réglé...  mon ordi fixe est en 192.168.10.1 dejà je vais sur internet les deux se causent. 

J'ai un portable que je mets en auto,  et donc là en effet je me mets en dhcp et le portable se mets  automatiquement sur internet.    ensuite le probleme est si je veux aller sur un partage.  Si je suis chez un copain....   le dhcp me donne le numero et le copain me donne son numero ip et je vais un montage en cifs pour envoyer des fichers ou en recevoir  j'ai déjà fait et ca marche pas tres bien je poserais peut etre la question si je transfere en réseau chez un cousin qui connait assez bien tout ca.

dans l'utilisation que je peux avoir de mes ordinateurs (un bureau et un portable et un vieux qui date d'il y a longtemps que j'utilise plus mais ca pourrait se faire  pour faire un serveur de sauvegarde).



je trouve que votre solution de mettre des baux permanents   si je change de carte réseau et que je demande à 10 copains de mettre mon adresse mac chez eux et ensuite leur demande de tout changer !!!  alors que en static il  me suffit de me mettre en dhcp et j'ai dejà leur réseau...    je fais mes trucs dans mon coin et j'accede à leurs partages.  Et free peut fort bien faire un abonnement low cost et au revoir les baux permanents.   

et de programmer des baux permanents c'est dependre de l'autre et moi je suis pas d'accord.  Si un jour free plante et que le concurrent  change tout pour aller sur internet.   Là j'ai les ordis en static  au niveau de l'ordinateur et le switch fait le travail.

de configurer en général (sur la box) c'est bien quand on doit changer pour tout le monde...  mais si une personne a un probleme qui est du à la configuration générale,   là  c'est plus la meme chose.   J'ai été programmeur alors de mettre un fichier général  pour centraliser et le jour ou y a un bug concernant une personne et bien faut faire la modif et tout vérifier que ca concerne pas les autres. C'est comme comme ca que pitrak a bousillé ses fetes de noel.   dont les 18 ans de son fils !!!!

moi je dis tout le temps,  peut etre à vous faire reagir,  mais j'ai la config de mon ORDIPATRICK   et le portable est configuré différemment.   surtout rien mettre en commun entre les deux...   peut etre que je mettrais mon ordi et le portable en baux permanents mais surtout pas l'ordi des enfants et de ma mere.


si je fais une modif sur la freebox et que je fais une con. .. et alors les enfants plus rien qui marche.   Je fais marcher mes partages samba mais ma mere n'a plus rien.   je corrige pour ma mere et plus de portable..     c'est comme ca que pitrak  au boulot à trappes a planté l'anniversaire de ses enfants.

en programmation je fais pareil...   j'ai 4 modules qui ont besoin de la ligne serie et j'ai 4 ptlect pour lire dedans.

#17 Re : -1 »  [Résolu] mise à jour KDE 4.13.2 (kde-l10n-fr) » Le 18/06/2014, à 14:14

patrick L
Réponses : 15
Django84 a écrit :

Comment j'en suis arrivé là ? tout simplement en faisant une mise à jour avec le gestionnaire de paquets Muon.
Voici ce que retourne les diverses commandes que tu proposes. (un grand merci pour ton aide ! )

didier@ANTEC-III:~$ cat /etc/locale.conf | grep LANG=
cat: /etc/locale.conf: No such file or directory
didier@ANTEC-III:~$ sudo bash -c 'echo "LANG=\"fr_FR.UTF-8\""' >/etc/locale.conf
bash: /etc/locale.conf: Permission denied
didier@ANTEC-III:~$ rm ~/.config/locale.conf
rm: cannot remove '/home/didier/.config/locale.conf': No such file or directory
didier@ANTEC-III:~$ ^C
didier@ANTEC-III:~$ 

Serait-ce un problème de permission ?

oui mais pas exactement....


la ligne

didier@ANTEC-III:~$ sudo bash -c 'echo "LANG=\"fr_FR.UTF-8\""' >/etc/locale.conf 

ne marche pas parce que le sudo est valable pour la ligne sudo  bash ...   alors qu'il doit etre  pour /etc/locale.conf

alors il  faut  faire

didier@ANTEC-III:~$ bash -c 'echo "LANG=\"fr_FR.UTF-8\""' |  sudo tee /etc/locale.conf 

#18 -1 »  petit probleme exiftool » Le 13/06/2014, à 12:26

patrick L
Réponses : 2

bonjour et bon week end aux linuxiens

j'utilise exiftool pour organiser en masse des images dans des fichiers qui m'arrivent sous la forme (via foremost) sous la forme

414225872.jpg pas tres explicite....   je veux donc les trier selon la date de creation...    et les classer dans une arborescence via le tag exif 

je lance donc la commande

patrick@ordi$ exiftool -'fileName<DateTimeOriginal' -if 'not $dateTimeOriginal eq ""' -d "../../%Y/%m/img_%Y-%m%B-%d_%H-%M_%A.%%e" .

donc ca déplace bien et renomme les fichiers dans un dossier de classement temporaire sous la forme
2005/07/img_2005-07juillet-25_16-57_lundi.jpg

le probleme que j'ai est que foremost  récupère plusieurs fois la même image et lorsque je lance la commande sur un dossier entier...  il me fait une erreur

Error: '../../2005/07/img_2005-07juillet-25_16-57_lundi.jpg' already exists - ./128390232.jpg

ce que je voudrais c'est que meme si la cible est présente le fichier initial soit déplacé (ou effacé vu qu'il  se trouve en double). 


je vous remercie d'avance de vos réponses...

#19 Re : -1 »  petit probleme exiftool » Le 16/06/2014, à 20:03

patrick L
Réponses : 2

je sais que ca marche  mais ca remets les fichiers en double...  et souvent c'est la même image dedans

#20 -1 »  connaitre dernier bloc foremost lors interruption ctrl-c » Le 13/06/2014, à 13:52

patrick L
Réponses : 1

bonjour


j'ai une autre question de la journée...  avec foremost ....  enfin deux questions...

la premiere ici et la suivante à venir

alors je fais la commande sur un disque /dev/sdc1 partition à récupérer les données. 


sudo foremost -t jpg -T -q -a -s 5760 -o recup -i /dev/sdc1

et ca m'affiche


$ sudo foremost -t jpg -T -q -a -s 5760 -o recup -i /dev/sdc1
[sudo] password for patrick: 
Processing: /dev/sdc1
|***************************************************************************************************************************************************************************2****************************************************************************************************************************************************************************3****************************************************************************************************************************************************************************4****************************************************************************************************************************************************************************5****************************************************************************************************************************************************************************6****************************************************************************************************************************************************************************7****************************************************************************************************************************************************************************8****************************************************************************************************************************************************************************9****************************************************************************************************************************************************************************A****************************************************************************************************************************************************************************B*******************************************************************************************************************************************

et des fois  j'arrete le chargement des fichiers...   parce que j'ai pas envie de lancer en une fois et planter mon disque externe de copie des fichiers.

j'arrete  à un moment  pour reprendre le lendemain matin ou apres les courses ou...   

ensuite pour repartir  je dois calculer  le nouveau numero de bloc pour continuer la lecture.  alors je fais le calcul  de compter les **** comme etant un bloc..     alors le bloc par defaut est de 512 octets.   une ligne fait 180 * et alors j'ai 11 lignes d'affichées...   et donc la prochaine valeur est

5760 + 11 * 180 = 7740


et je repare systématiquement  à des numeros de fichiers à 0000.jpg   alors je sais plus du tout comment repartir à la fin du chargement précédent via l'option -s 7740

j'aimerais savoir comment avoir le numero de bloc à la fin du chargement interrompu.  pour le suivant... 

j'utilise foremost suite à une fois où j'ai perdu des photos suite  à une commande dangereuse. j'ai mis une commande cat  fichier.iso > /dev/sdb1  qui etait un disque de données et pas une clef usb  d'installation de ubuntu.

merci de me depanner de ce probleme qui date de longtemps.

#21 Re : -1 »  connaitre dernier bloc foremost lors interruption ctrl-c » Le 14/06/2014, à 00:49

patrick L
Réponses : 1

je me réponds à moi meme...  finalement j'ai laissé tourner foremost pendant des heures. J'ai lu  une page indiquant de laisser tourner... attention foremost va trouver une quantité enorme de la meme image doublons et les signatures sont pas les memes à cause des données exifs dedans et l'entete du fichier....   j'ai bien le truc de sauver les metadonnées, les virer, ensuite calculer la signature sha1 et remettre les métadonnées dans le fichier et comparer la signature avec une signature dans un fichier...  si oui on efface le fichier en doublon.  ou de deplacer dans un dossier doublon.

je mets comme résolu...

#22 Re : -1 »  recuperation de repertoire avec FOREMOST » Le 13/06/2014, à 13:23

patrick L
Réponses : 2

bonjour

moi je ferme en ecriture le disque externe.... ou alors je me mets en live si les effacements sont sur le home...   

je fais sudo fdisk -l  et je repere à l'aide de la taille du disque.... et disons qu'il soit /dev/sdb  alors je fais sudo umount /dev/sdb1  pour etre sur que personne n'ecrive dessus. 

ensuite je crée dans le disque de récupération un dossier recup et je me mets dans ce dossier et

sudo foremost -t jpg -T -q -a -s 5760 -o recup -i /dev/sdc1

#23 -1 »  inotifywait et ajout automatique dans archive tar.gz » Le 20/05/2014, à 19:08

patrick L
Réponses : 2

Je fais souvent des chargements de photos  sur un dossier monté d'un disque externe 500 gigas et je fais des sauvegardes manuelles dans des fichiers archives   périodiquement et à la main...   souvent en fin de chaque mois. 

via la commande inotifywait  je sais faire que l'on copie automatiquement  un fichier dans un autre dossier


inotifywait -e close_write -m -q --format "%w %f" test1/ | while read dossier file ; do cp  "$dossier$file" ~/testCopie; done &

cette commande me copie automatiquement des petits fichiers avec un débit faible.

alors je voudrais faire une commande d'archivage au fur et à mesure de l'arrivée des fichiers...   

tar -zcvf   /media/sauvegarde/photos/photos_2014-05-20.tar.gz  mais au fil de l'eau
un fichier arrive dans le dossier ou sous dossier de photos et ensuite ca le mette automatiquement dans l'archive...  sous la forme

/media/sauvegarde/patrick/photos/2014/Mars/2014-03-02.tar.gz

le probleme etant que l'on  ne puisse ajouter un fichier dans une telle archive.   alors j'ai deux solutions de créer un fichier temporaire qui liste les copies du jour  et à la fin de la journée alors l'archive est formée avec la listes des fichiers dans la journée.   

seconde soluce,   de faire un dossier avec la copie dans un dossier  sur le disque de sauvegarde et alors le tar.gz est  fait sur les dossier intermédiaire...  et là c'est vrai que les fichiers sont à deux endroits   mais je crains pour le temps de copie et la taille.


mais je préfèrerais mettre directement chaque fichier dans l'archive sans me poser de question.   est ce que ca existe un commande d'archivage de fichiers compressés que l'on ajoute un fichier nouveau ou le mettre à jour dans l'archive.   là  ca serait la meilleure solution possible.

#24 Re : -1 »  inotifywait et ajout automatique dans archive tar.gz » Le 22/05/2014, à 14:59

patrick L
Réponses : 2

merci  de votre réponse.   mais ca marche pas....

merci de la commande u pour réécrire seulement les fichiers recents. 
j'ai essayé  la commande
tar -rvf photos2014-05-20.tar.gz  et ca marchait pas et j'ai commis ma demande.


tiens j'ai  une idée...    comprimer les raws et les jpeg et les mettre dans l'archive tar ensuite ca me fait une archive tar de fichiers gz donc une archive photo2014-05-20.gz.tar   je vais faire un essai !!!

et bien il veut meme pas mettre les fichiers gz dans l'archive... j'ai lancé les commandes

$ for i in 1 2 3 4 ; do echo "blabla$i" > fichiier$i.txt ; done
$ for i in  1 2 3 ; do  tar -uzvf  archive.tar.gz  fichier$i.txt ; done

donc ca il veut pas....   

ensuite la seconde manip

$ for i in 1 2 3 ; do gzip fichier$i.txt ; done 
$ tar -rvf fichier*.gz  archive.tar

il reconnait que le fichier dedans est  compressé...   et sort en erreur....





sinon merci à vous de votre idée et réponse.