Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
nombre réponses : 25

#0 Re : -1 »  Topic des lève-tôt [partie 8] » Aujourd'hui à 11:54

moko138
Réponses : 86
sucarno a écrit :

Quelques années avant ma naissance, mon père connut une étrangère récemment arrivée dans notre village. (...)

  Très bien, cette histoire !

#1 Re : -1 »  Forcer le Montage d'un disque » Aujourd'hui à 12:12

moko138
Réponses : 12

Quelle version ? Quelle variante ?

Il serait intéressant, en démarrant en mode recovery ou d'une session live, d'avoir le contenu de fstab. ou mieux, un rapport bootinfo : http://doc.ubuntu-fr.org/tutoriel/boot-info

#2 Re : -1 »  Forcer le Montage d'un disque » Aujourd'hui à 12:27

moko138
Réponses : 12

Mais il s'agit d'une partition ntfs. Donc elle ne peut être indispensable au démarrage d'un linux !
  Tu dois pouvoir démarrer *buntu en mode recovery.
Et bien sûr aucune corruption du disque interne ne peut t'empêcher de démarrer ta bécane en session live.

#3 Re : -1 »  Forcer le Montage d'un disque » Aujourd'hui à 13:39

moko138
Réponses : 12

Ayant enfin compris que tu essayes de soigner un pc sous windows à l'aide d'une session live d'ubuntu, j'ai relu tout le fil et
1) A mon avis, les réponses #2 et #8 de J5012 sont très pertinentes.

2) j'ai noté ceci :

Error mounting /dev/sda2 at /media/ubuntu/DE700FCE700FABF9: Command-line
'mount -t "ntfs" -o (...) 
exited with non-zero exist status [b]18[/b]:

  Est-ce toi qui as tapé cette ligne avec ces guillemets inhabituels à ntfs ?
D'autre part le manuel de mount dit :

CODES DE RETOUR
       mount peut renvoyer les codes de retour suivants (les bits peuvent être associés par un OU binaire) :
       0      Succès.
       1      Invocation ou permissions incorrectes.
       2      Erreur système (plus de mémoire, échec de fork(), plus de périphérique loop disponible).
       4      Bogue interne à mount.
       8      Interruption par l'utilisateur.
       16     Problème d'écriture ou de verrouillage de /etc/mtab.
       32     Échec de montage.
       64     Succès de certains montages.

le code "18" n'admet qu'une résolution : 16 et 2.

Donc avec la session live de linux, lance une vérification de ta ram ("plus de mémoire")... si ton dvd n'est pas défectueux ("plus de périphérique loop disponible", "Problème d'écriture ou de verrouillage de /etc/mtab").

ps : oublie le mode recovery (c'est grosso modo le "démarrage sans échec" d'un linux installé)
  et une session live, c'est ce que tu pratiques, avec un cd de boot (ou une clef)
  Si ta ram est bonne, tu peux tenter la suggestion #8, si ta ram est défectueuse, je ne vois que la #2.

#4 Re : -1 »  Forcer le Montage d'un disque » Aujourd'hui à 14:35

moko138
Réponses : 12

Plutôt que graver un dvd, grave une clef usb ou carte SD : c'est réutilisable, quasi gratuit, plus rapide et moins bruyant.
  Pour tester la ram : c'est sans lancer linux. Dès la page où on a le choix entre "essayer sans installer" et "installer", tu as en bas de liste "Memtest".
Tu lances et tu laisses tourner deux heures : si l'affichage reste en bleu, c'est bon.
Si tu as des lignes en rouge, soit la ram est devenue défectueuse,
soit c'est un faux positif. Pour en avoir le coeur net, recommencer avec une usb live de Memtest gravée à partir d'une iso plus récente.

--------------

free -m

donne des détails sur la quantité de mémoire ;
top, ou mieux, pour avoir 5 secondes entre deux rafraîchissements :

top -d 5

est l'équivalent de Ctrl Alt Suppr (tapé une seule fois !)

#5 Re : -1 »  Disque ne s'automounte pas » Hier à 13:12

moko138
Réponses : 34
poumtatalia a écrit :

Pour info, il n'y a plus de disque externe.

Eh mais ça change tout !

Changer récursivement la propriété de tout ce qui se trouve sur Triteratops à poum: fait.

Impeccable.

Est-ce que ça pourrait être lié au fait que j'avais fait pointer des répertoires (documents, dossiers de profils de Thunderbirds...) vers Triteratops, et que comme il n'est plus dans le fstab, Ubuntu galère?

  Bien sûr ! tu as raison. Donc ta réaction...

[Edit] J'ai édité le fstab avec une clé usb live pour dé-commenter Tritératops,

...est parfaite...si tu as bien utilisé gksudo. Sinon on va vérifier quelques points.

mais no luck : ça n'y change rien...

Il faut redémarrer pour que ça prenne effet : l'as-tu fait ?
D'autre part, dans ton fstab, la ligne de "triton-tétras-taupe" il faut changer
- à coup sûr, le "0 0" final en "0 2" (sinon, cette partition ext4 ne sera jamais vérifiée !)
- peut-être, le fmask de 0177 en 0077, puisque une partie de ton /home y est déportée (sinon tout fichier que tu y placeras y perdra la possibilité d'être exécutable).

[Edit] Pour info j'ai lancé un bootinfo de boot repair, sans lancer aucune action. Le bilan est .

Je vais aller voir, en attendant de tes nouvelles !

#6 Re : -1 »  Disque ne s'automounte pas » Hier à 15:18

moko138
Réponses : 34

Pour les remerciements, attends que ça marche !

Quand tu dis "pareil !", veux-tu dire que tu as exactement les mêmes messages que les trois premiers du #10 ?

Idées en vrac :
Si ce n'est qu'à partir de la clef que tu as commis un sudo gedit, tu n'as pas pu corrompre ainsi les droits sur l'OS installé. Mais il y avait peut-être une corruption antérieure. Donc redonne

ls -la

et

cd /media && ls -la
Errors were found while checking the disk drive for /.
Press F to attempt to fix the errors, I to ignore, S to skip mounting, or M for manual recovery

Pourquoi sauter (skip) le montage ? au contraire ! C'est seulement si M, F puis I échouent qu'on se rabattra sur S.

Tu as dit  "j'avais fait pointer des répertoires (documents, dossiers de profils de Thunderbirds...) vers Triteratops". J'aimerais que tu détailles comment tu as procédé. Parce que je ne l'ai jamais fait mais je crois me souvenir qu'il y a deux méthodes, dont une utilise des lignes dans fstab. Lignes que tu n'as pas...

Nous avons plusieurs moyens à notre disposition : démarrer en live ou démarrer en recovery (tapoter la touche Majuscules pendant le boot).
Utiliser fsck. Extrait du man :

Le code de sortie retourné par fsck est la somme des conditions suivantes :
            0    - Aucune erreur
            1    - Erreurs du système de fichiers corrigées
            2    - Le système devrait être redémarré
            4    - Des erreurs non corrigées subsistent dans le système de fichiers
            8    - Erreur d'opération
            16   - Erreur d'utilisation ou de syntaxe
            32   - Fsck annulé par l'utilisateur
            128  - Erreur de bibliothèque partagée

Tu as obtenu 2.
Mais, après redémarrage, rien n'a changé : peux-tu confirmer ?

Je t'ai fait faire un

sudo chown -Rv poum /media/Triteratops

Mais peut-être

sudo chown -Rv poum:poum /media/Triteratops

était-il préférable ?
Dans cette hypothèse, soit on fait, à partir de la clef live, un chroot et bind, soit on attend d'avoir retrouvé autrement un montage normal en rw.

#7 Re : -1 »  Disque ne s'automounte pas » Hier à 15:59

moko138
Réponses : 34

"faire pointer des répertoires (...) vers Triteratops". (...)  une méthode utilise des lignes dans fstab : Cf. cette discussion, surtout le #16. (Mais tu peux te détendre en allant jusqu'en bas de la page).

#8 Re : -1 »  Disque ne s'automounte pas » Hier à 16:12

moko138
Réponses : 34

je viens de t'envoyer un mail urgent

#9 Re : -1 »  Disque ne s'automounte pas » Hier à 16:34

moko138
Réponses : 34

fstab : je n'ai pas vérifier si c'était réellement utile, mais j'ai lu qu'il fallait une ligne vide en fin de fstab (et en effet, j'en ai une sur ma Xubuntu 12.04).

Mais surtout, tu as une quantité impressionnante de vieux noyaux dans ta / !
Ils consomment énormément d'inodes ; pour voir, fais

df -i

(tu peux le faire en console) et purge-les dès que possible cf.la doc "suppression_des_anciens_noyaux".

#10 Re : -1 »  Disque ne s'automounte pas » Hier à 18:09

moko138
Réponses : 34

As-tu vu mon mail urgent ?

#11 Re : -1 »  Disque ne s'automounte pas » Hier à 19:12

moko138
Réponses : 34

Super !
Parenthèse explicative : les i-noeuds ou inodes sont comme des entrées d'index. Et elles sont en nombre limité. Comme les noyaux en utilisent énormément, il arrive fréquemment que des gens aient leurs pc bloqués, alors qu'ils ont plusieurs Go de libres. Libres mais non indexables donc non utilisables. FIN de la parenthèse.

Redonne

cat /etc/fstab

complet (sauf le mdp, oeuf corse)
et, darouine et triteratops montés,

ls -la /media
cd /media && ls -la

#12 Re : -1 »  Disque ne s'automounte pas » Hier à 20:12

moko138
Réponses : 34

Pardon, lapsus pour :

cd && ls -la

#13 Re : -1 »  Disque ne s'automounte pas » Hier à 22:03

moko138
Réponses : 34

N'ayant pas de certitude, j'ai contacté un cador pour nous sortir de là...

Au fait, puisque tu utilises un SSD, est-ce exprès que tu n'as pas suivi les recommandations de la doc, pour les options de montage de ta / ?

#14 Re : -1 »  Disque ne s'automounte pas » Hier à 22:31

moko138
Réponses : 34

Tu peux déjà préparer le piédestal...
En attendant, ouvrir - j'aurais dû y penser plus tôt - /var/log/dmesg avec un traitement de texte,
et y chercher les lignes contenant :
sdb et
error ou
cannot ou
warning
   devrait donner des indications.

#15 Re : -1 »  Disque ne s'automounte pas » Aujourd'hui à 09:03

moko138
Réponses : 34

Enfin ! c'était trop gros ! Ça crevait les yeux !

Rappel : tu avais un HD externe neuf de 3 To, "Livingstone", pour lequel tu avais défini des options de montage. Mais ce disque étant défectueux, tu l'as remplacé par un autre, de même taille, 'Triteratops". Et pour les options de montage, tu as copié-collé celles de "Livingstone".
  Sauf que, comme tu me l'as appris en #9, Triteratops n'est plus un disque branché en usb !
Donc je t'invite à rééditer ton fstab et à virer "uhelper=udisks," de la ligne de Triteratops. Et à redémarrer.

Un doute me vient : pourquoi ça marche avec Darouine ?

#16 Re : -1 »  Disque ne s'automounte pas » Aujourd'hui à 10:07

moko138
Réponses : 34
poumtatalia a écrit :

Questions subsidiaires :
[*]en théorie, si j'avais juste remplacé l'UUID du disque sur la ligne "Livingstone" de Triteratops, ça aurait du remplacer l'un par l'autre, non?[/*]

Vu que Livingstone était défectueux, impossible de le savoir.

Il y a une chose simple à tester : remplacer les options de montage actuelles de Triteratops par

ext4    defaults        0       2

Fais suivre, par acquit de conscience, d'un

sudo update-grub

et redémarre.

#17 Re : -1 »  Disque ne s'automounte pas » Aujourd'hui à 13:58

moko138
Réponses : 34

smile Je ne connais qu'une façon de réfrigérer correctement le caviar :
un méthanier de 100.000 tonnes.

  Pour le plaisir, redonne

df -i && df -h

Et, oui, suis les tutos sur les SSD.

#18 Re : -1 »  Explication d'une expression rationnelle » Aujourd'hui à 12:03

moko138
Réponses : 9

HS : @ tiramiseb : Je crois que mon mail s'est perdu ; s'il te plaît, pourrais-tu intervenir là, car je sèche.
Merci !
/HS

#20 Re : -1 »  Impossible de monter USB + Authentificaiton is required to unmount USB » Aujourd'hui à 00:17

moko138
Réponses : 13
julien.drouin.b a écrit :

En passant, je suis à nouveau capable de lire et voir son contenu (mais rien d'autre) ma clé USB Sandisk-cruzer depuis la dernière session où j'avais fait les manipulations que tu m'avais demandées

  Aucun souvenir (google non plus) : as-tu un lien ?
ADSL : haut-débit, en pratique.
  Donne le retour de

cd && cat .bash_history

Tiens ! ta clef sanDisk-cruzer est une clef U3 !

    Démonte et débranche toutes tes clefs et disques amovibles, puis,
dans ton fstab, tu vas commenter les deux lignes relatives à tes clefs, en mettant un # (touche AltGr 3) devant et tu rajouteras une ligne vide à la fin.

cd /media && sudo mv usb0 usb0.old
cd /media && sudo mv usb usb.old
cd && sudo chown -v julien:julien .gvfs
sudo rm /mnt/usb-SanDisk_Cruz*
cd && sudo rm .*authority && sudo reboot

#21 Re : -1 »  Impossible de monter USB + Authentificaiton is required to unmount USB » Aujourd'hui à 08:23

moko138
Réponses : 13
julien.drouin.b a écrit :
moko138 a écrit :

  Aucun souvenir (google non plus) : as-tu un lien ?

Que veux-tu dire par là ?

  Mais c'est toi-même qui as écrit en #8 :

En passant, je suis à nouveau capable de lire et voir son contenu (mais rien d'autre) ma clé USB Sandisk-cruzer depuis la dernière session où j'avais fait les manipulations que tu m'avais demandées

Et quand tu as écrit cela je ne t'avais pas encore demandé de lancer de commandes actives (les commandes que tu as passées en #7 sont uniquement descriptives)..
  A moins que tu ne te réfères à une autre discussion dont je n'ai pas le souvenir et dont je ne trouve pas trace dans google.
  Donc je ne comprends pas ce que tu veux dire. Merci de m'éclairer.

  Ton .bash_history montre que tu as gardé beaucoup d'habitudes windowsiennes : par exemple, pourquoi installer mp3tag.exe alors que tu peux éditer tes tags avec vlc, avec banshee, avec tagtool qui sont déjà installés dans ton système ?!
Quand tu as l'idée d'installer un .exe, il convient
- de définir d'abord la fonction que tu veux ; soit, en l'occurrence, "éditer des tags".
- de chercher dans la Doc, à l'aide du double champ de recherche en haut à droite de cette page ; et là tu trouves ton bonheur, et en dix fois plus léger en plus.

  Ton .bash_history contient des commandes imprudentes ("sudo su", par exemple) à ne pas refaire !
Un résultat est que tu as dans /mnt et dans /media plein de usb* appartenant à root au lieu de t'appartenir.
Quand tu as un doute, pose la question avant, sur le forum.
Là, il se peut qu'une réinstallation complète soit plus simple que la réparation...

Là je ne peux pas les éjecter proprement comme d'habitude. Ça me donne la même chose que tantôt :

Ta capture d'écran indique au contraire "erreur lors du montage" et des explications inquiétantes sur l'état de ta clef.

Est-ce que je les retire sauvagement à la main ou j'éteins mon ordi, les retire et rallume ?

Tu éteins.

Après pour mon fstab, est-ce que je fais les changements en ligne de commande ? Si oui, comment ?

Tu utilises la ligne de commande pour lancer gedit avec les droits admin :

gksudo gedit /etc/fstab

Comme tu es sous 13.10 que je n'utilise pas, il se peut que tu aies un message d'erreur : en ce cas tu copies (Ctrl Maj C) intégralement la fenêtre du terminal (commande ET retour) puis tu colles ici.

C'est ça ?

Oui pour les deux # ajoutés, mais ajoute une ligne vide en fin de fichier.

Après, je rentre les 5 lignes de commande ?

Oui, et j'attire ton attention sur deux points :
- il y a deux commandes qui contiennent "sudo rm" ; on n'a pas droit à l'erreur avec ça ; donc tu colles les lignes en évitant surtout de les retaper.
- dans le terminal, pour coller on fait Ctrl Maj V.

#22 Re : -1 »  Impossible de monter USB + Authentificaiton is required to unmount USB » Aujourd'hui à 10:56

moko138
Réponses : 13

Désolé, pour un dossier, la bonne commande est rmdir, donc, clef démontée débranchée :

sudo rmdir /mnt/usb-SanDisk_Cruz*
julien.drouin.b a écrit :

Ok excellent, merci pour les conseils
Oui... souvent je joue à l'apprenti-sorcier en ligne de commande smile

En effet, je t'avais dit :

gksudo gedit /etc/fstab

Comme tu es sous 13.10 que je n'utilise pas, il se peut que tu aies un message d'erreur : en ce cas tu copies (Ctrl Maj C) intégralement la fenêtre du terminal (commande ET retour) puis tu colles ici.

julien.drouin.b a écrit :

Je me suis arrêté après le 4e commande à cause de ça :

julien@Voyageur:~$ gksudo gedit /etc/fstab
Gtk-Message: Failed to load module "overlay-scrollbar"

(gedit:7364): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:7364): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Alors pourquoi as-tu continué avec ce qui suit ?!

julien a écrit :
julien@Voyageur:~$ cd /media && sudo mv usb0 usb0.old #(...)

J'ai fait une recherche disant comment supprimer un dossier : sudo rm -r
J'ai ensuite fait (j'ai taper "history" dans la console pour retracer mes 2 dernières lignes de commande après que mon ordi ait redémarré) :

  215  sudo rm -r /mnt/usb-SanDisk_Cruz*
  216  cd && sudo rm .*authority && sudo reboot

Résultats ?
- En redémarrant, le BIOS m'a montré la fenêtre de recovery mode. J'ai choisi "Ubuntu"
- En ouvrant, il m'a tout de suite montré 2-3 messages d'erreur. Chose que je n'ai pas d'habitude. Donc, il a pas aimé la manoeuvre

Remarque : le bios est le démarreur de la carte-mère. Le bios intervient bien avant le grub qui est sur le disque dur. C'est le grub qui t'a proposé un démarrage de l'OS en mode recovery.

Évidemment que l'OS n'a pas aimé.
D'autre part, un message d'erreur, ça se copie-colle,
parce que neuf fois sur dix ils contiennent le bon chemin vers la solution.

Pourquoi te tires-tu des balles dans le pied, et à répétition ?

  Dans ces conditions, je ne suis pas en mesure de continuer à t'aider.

#23 Re : -1 »  [souci permanent] Xubuntu Alt+ImprEcran + K » Hier à 17:17

moko138
Réponses : 19
b.poiraud a écrit :

Désolée, je

Avec ce pseudo-là, je t'imaginais dans le genre de Peter Ustinov... je vais devoir réviser mes batteries !
  En utilisant les balises-code (les <> bleus de la barre de mise en forme) comme indiqué , donne s'il te plaît les retours complets de

lspci

de

sudo fdisk -l && sudo parted -l

de

df -h && df -i

de

cat /proc/sys/vm/swappiness

et de

sudo lshw

  Merci !

#24 Re : -1 »  [souci permanent] Xubuntu Alt+ImprEcran + K » Hier à 22:17

moko138
Réponses : 19

Comme tu es la seule sur ce forum, je crois, à indiquer son sexe, et la seule à indiquer son âge, je croyais à un masque anti-profileurs, ou à n'importe quoi, comme ces avatars qui ne prétendent pas être un portrait ressemblant.
  Du coup, en relisant ta signature, je vois que tu concours avec nam1962 pour le nombre de convertis !
Encore un effort : ce soir, il en est à 43...