Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/12/2004, à 11:39

Yann

[Résolu] Clavier au qwerty au démarrage de gdm

Salut à tous,

  au démarrage de Ubuntu, malgré avoir configuré correctement mon clavier dans Gnome, je suis quand même en qwerty... pas pratique le qwerty pour taper son mot de passe big_smile
  Quelqu'un saurait comment changer ca?

  Merci d'avance!


Et pourtant moi, jsuis pas du genre délicat,
Dans un coin de la musse, j'ai posé mon matelas
- Paulo Anarkao

Hors ligne

#2 Le 22/12/2004, à 12:46

Groulala

Re : [Résolu] Clavier au qwerty au démarrage de gdm

Il y a moyen de sélectionner un clavier via la commande setxkbmap

Par exemple:

setxkbmap  fr  (pour la France)
setxkbmap  be (pour la belgique)

Mais je ne sais pas si le changement de clavier effectué sera opérationnel lors d'un redemarrage...

Hors ligne

#3 Le 22/12/2004, à 23:43

Chris

Re : [Résolu] Clavier au qwerty au démarrage de gdm

Tu peux éditer le fichier /etc/X11/XF86Config-4 et t'assurer que pour la section du clavier, tu as bien

Option          "XkbLayout"     "fr"

La section ressemble à ça chez moi

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
EndSection

Ça te réglera le problème wink

#4 Le 23/12/2004, à 21:16

Olivier P.

Re : [Résolu] Clavier au qwerty au démarrage de gdm

Il y a dans un menu (avec une icone de clavier) pour gérer ce genre de truc. Tu peux modifier la langue du clavier et donc passer en Français pour le azerty.


Olivier PATRY

Hors ligne

#5 Le 23/12/2004, à 21:49

Kagou

Re : [Résolu] Clavier au qwerty au démarrage de gdm

"sudo kbdconfig"

Petite explication:
Tu as du installer ton système avec le mauvais clavier. Donc à la base le système est en qwerty. Il faut reconfigurer ton système pour le bon clavier. Si en plus tu n'as pas sélectionné Français pour le pays, il te faut configurer les locales avec "sudo dpkg-reconfigure locales"

++

Dernière modification par Kagou (Le 23/12/2004, à 21:52)


«black-out» du Net français

http://www.laquadrature.net/HADOPI

Hors ligne

#6 Le 18/08/2006, à 01:38

J4Y

Re : [Résolu] Clavier au qwerty au démarrage de gdm

Bonsoir, je post cela ici car j'ai un probleme similaire à celui decrit ici mais je ne trouve pas la solution.

Apres avoir installé ubuntu , en selectionant ( sans aucun probleme ) ma region, la langue de mon clavier à l'installation etc..   et rebooter plusieure fois sans aucun probleme,  je me decide a installer les driver nvidia et ensuite apres m'etre renseigné en consultant quelques forums j'ai editer mon fichier xconf, pour lui ajouter une resolution ecran.. comme decris dans la procedure sur le forum je redemare ensute mon serverx

au redemarage de celui la tout se passe bien, sauf qu'as l'invite de login et pass mon clavier etait subitement en qwerty.

j'ai vite identifié le probleme, et je sais tapper mon login et mon pass en qwerty mais j'aimerais tout de meme le resoudre

j'ai cru comprendre kil fallais modifier le fichier /etc/X11/XF86Config-4
mais je ne le trouve pas  dans le repertoire X11 :s sad

ma question est donc la suivante: quel fichier dois-je editer pour signaler au serverx que mon clavier est azerty? ( belge )

( en plus dans les optio de l'invite de login ( ecran ubuntu ) ya des options de" langue " mais pas de clavier sad )

j'espere avoir ete suffisament clair...

merci

J4Y

#7 Le 20/08/2006, à 18:58

J4Y

Re : [Résolu] Clavier au qwerty au démarrage de gdm

up

#8 Le 17/06/2007, à 11:37

glattering

Re : [Résolu] Clavier au qwerty au démarrage de gdm

le fichier est maintenant /etc/X11/xorg.conf mais le changement à faire est le même.

EDIT: j'avais pas vu la date du post... (ça m'apprendra à faire des recherches tongue)


Membre de l'APRIL - « promouvoir et défendre le logiciel libre » -

Hors ligne