Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 29/03/2007, à 14:57

bebelAdrien

[Résolu] bash : permission denied

Bonjour j'ai un gros problème avec mon bash, pour lancer un exécutable je ne peux plus utiliser la commande

$ ./executable
bash: ./PSE: Permission non accordée

alors que 

$sh ./executable

fonctionne correctement.

Si ce n'est pas gênant quand on utilise la console pour faire du debbugage c'est déjà plus galère (C++ avec codeblocks ou Kdevelop)

Quelqu'un aurait-il une idée?

PS: j'ai vraiment pas envie de finir ma phase de programmation sur Windows wink

Dernière modification par bebelAdrien (Le 30/03/2007, à 15:53)

Hors ligne

#2 Le 29/03/2007, à 15:02

nikko

Re : [Résolu] bash : permission denied

Est-tu sûr que ton éxécutable a le droit d'éxécution de positionné?
Que t'affiche ?

ls -al executable

Hors ligne

#3 Le 29/03/2007, à 15:07

bebelAdrien

Re : [Résolu] bash : permission denied

Oui c'est bon de plus j'ai essayer avec de nombreux fichiers qui fonctionnaient avant, le pire c'est que j'ai essayer

sudo ./executable

et le problème est le même
pour info

$ls -al executable 
-rwxr-xr-x 1 adrien adrien 368885 2007-03-29 15:25 PSE

Donc ca ne vient pas de là surtout que la commande qui fonctionne est simplement "sh executable"
et ceci même avec un fichier basique de type

#! /bin/sh
ls

Merci pour la rapidité de ta réponse

Dernière modification par bebelAdrien (Le 29/03/2007, à 15:09)

Hors ligne

#4 Le 29/03/2007, à 21:57

nikko

Re : [Résolu] bash : permission denied

Bon je viens de lire un fil où quelqu'un avait le même problème.
Et il s'est rendu compte que le problème ne venait pas des fichiers qu'il essayait de lancer, mais de l'endroit où ils se trouvaient.

As-tu le même problème?
Si tu lances le fichier
#! /bin/sh
ls

depuis ton home tu as la même erreur ou bien?

Si ça t"intéresse le fil est là:
http://www.developpez.net/forums/archive/index.php/t-12189.html
et son problème était en fait qu'il n'arrivait pas à lancer les fichiers éxécutables sur une partition apparemment à cause de l'option "users" dans fstab.

Peut-être une piste.

Nikko

Hors ligne

#5 Le 30/03/2007, à 15:53

bebelAdrien

Re : [Résolu] bash : permission denied

Merci beaucoup c'était tout simplement ça, en fait j'ai modifier les droits de mon /home je ne sais pas pourquoi et du coup tout mes fichiers ne pouvaient pas s'exécuter.

Hors ligne

#6 Le 14/02/2014, à 00:27

psychonours

Re : [Résolu] bash : permission denied

coucou j'ai le meme probleme mais je ne sais pas comment corriger :
Apparement le probleme vient du fichier fstab, mais je ne sais pas comment le corriger

mon fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=45e55e80-70f2-4dd8-a3e8-05125bdd4a46 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c33b5783-592f-43a3-9b0f-7633043aee4a none            swap    sw              0       0

Qui peut me dire quoi modifier ??? Merci


Ubuntu 13.04 mais je suis un NewBi on the block ...

Hors ligne

Haut de page ↑