Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/10/2012, à 22:11

tobiasBora

Problème affichage textes depuis mise à jour

Bonjour,

Voila : je suis sous Kubuntu 12.04 et j'ai récemment fait une mise à jour des drivers libres intel. Cependant depuis cette mise à jour j'ai de gros problèmes d'affichage qui rendent ma distribution inutilisable : de nombreux logiciels (tous les gtk comme firefox et quelques autres) ont d'énormes bugs d'affichage dont un très embétant : tous les textes ont disparus, on ne voit que les images !

Savez-vous comment rétablir l'affichage ?

Merci d'avance,

Tobias.

Hors ligne

#2 Le 29/10/2012, à 10:02

φlip

Re : Problème affichage textes depuis mise à jour

Etrange.
Que dit ceci:

dpkg -l *-intel|grep ^i |awk '{print $2,$3}'

Hors ligne

#3 Le 29/10/2012, à 10:11

tobiasBora

Re : Problème affichage textes depuis mise à jour

Bonjour, merci pour ta réponse !

Alors cette commande renvoie :

xserver-xorg-video-intel 2:2.20.12+git20121022.4dfc8335-0ubuntu0sarvatt~precise

par contre, j'ai demandé sur le canal irc #ubuntu-fr comment résoudre ce problème et ils m'ont conseillé de suivre ce tuto pour passer en sna :
http://www.webupd8.org/2012/10/how-to-e … on-in.html
Mon affichage ne semble en effet plus avoir de problème (à par quelques bugs momentanés), mais par contre l'installation de ce ppa à déréglé le son et ma souris : synaptiks à été désactivé (et lorsque je le lance j'ai l'erreur :

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

) et maintenant le seul moyen que j'ai pour cliquer est de faire un clic dur, au lieu d’effleurer le touchpad ce qui est énervant. Je me demande si une réinstall ne serait pas la bienvenue...

Hors ligne

#4 Le 29/10/2012, à 11:36

φlip

Re : Problème affichage textes depuis mise à jour

Alors ça, ce n'est pas dans les dépôts ubuntu: +git20121022.4dfc8335-0ubuntu0sarvatt~precise

Tu as trouvé ça ou ?

Et pitié ..... avant de bricoler du "sna" ... vérifie déjà si ton système fonctionne normalement avec une installation normale et des dépôts normaux.

Commence par ça pour voir:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa

Tu devrais avoir ça dans precise:
xserver-xorg-video-intel 2:2.17.0-1ubuntu4

Je serais curieux de savoir ce que tu as comme problème avec les drivers intel officiels.

Dernière modification par φlip (Le 29/10/2012, à 11:45)

Hors ligne

#5 Le 29/10/2012, à 11:47

tobiasBora

Re : Problème affichage textes depuis mise à jour

J'ai trouvé ça dans le dépot ppa:xorg-edgers/ppa...

En fait je ne savais pas ce qu'étais exactement le sna, j'ai donc suivi les conseils qu'on m'a donné car au point ou j'en était ça ne pouvait pas être pire...


Pour la désinstallation j'y comprends plus rien : hier quand je l'ai lancé, il voulait me désinstaller les 3/4 des programmes déjà présents : skype, wine... Et aujourd'hui quand je le lance il me dit :

$ sudo ppa-purge ppa:xorg-edgers/ppa
Updating packages lists
PPA to be removed: xorg-edgers ppa
Warning:  Could not find package list for PPA: xorg-edgers ppa

alors qu'hier j'avais abandonné la désinstallation...

Hors ligne

#6 Le 29/10/2012, à 11:51

φlip

Re : Problème affichage textes depuis mise à jour

Avant d'installer des drivers de bricoleurs experts, peux-tu expliquer ce que tu avais comme problèmes avec les drivers libres d'Intel ?

+ lire ici http://forum.kubuntu-fr.org/viewtopic.php?id=1083751

Bien que RIEN à voir avec KDE.

Dernière modification par φlip (Le 29/10/2012, à 11:52)

Hors ligne

#7 Le 29/10/2012, à 11:56

tobiasBora

Re : Problème affichage textes depuis mise à jour

Une mise à jour des drivers d'intel à tout simplement bousillé mon affichage au point de rendre mon système inutilisable : dans toutes les applications non développées pour KDE en natif (gtk avec firefox, emacs...) n'avaient plus aucun caractère de texte. Et emacs sans lettres... c'est pas super intéressant ! Voici un aperçu de ce que ça donnait :
http://wstaw.org/m/2012/10/29/divers2.png

Et c'est là qu'on m'a conseillé ce dépot...

Dernière modification par tobiasBora (Le 29/10/2012, à 11:59)

Hors ligne

#8 Le 29/10/2012, à 12:05

φlip

Re : Problème affichage textes depuis mise à jour

Tu as voulu jouer à ppa: tu as perdu.
C'est une mise à jour de ppa qui t'a foiré ton système, mais pas une mise à jour de drivers intel.
Avec un liveCD, tu as ce problème d'affichage oui ou non ?
Si non, c'est que tu n'as aucun problème avec les drivers libres d'intel.

Hors ligne

#9 Le 29/10/2012, à 12:15

tobiasBora

Re : Problème affichage textes depuis mise à jour

En somme le dépot m'a presque réparé mon système... Il a juste fait planter la souris et optimus je crois.

Au moment où j'ai eu mon bug il n'y avait aucun ppa d'installé (à par le ppa de bumblebee) qui aurait pu entrer en concurence avec les drivers intel...

Voilà la maj que je soupsonne d'avoir fait tout planter :
http://wstaw.org/m/2012/10/29/plasma-desktopWe1952.png
http://wstaw.org/m/2012/10/29/plasma-desktopDK1952.png
http://wstaw.org/m/2012/10/29/plasma-desktopox1952.png

J'essaye de suite de lancer Kubuntu 12.10 en liveCD. Mais si le problème viens d'une maj d'intel, il n'y a aucune maj en principe dans les live CD non ?

Hors ligne

#10 Le 29/10/2012, à 12:21

φlip

Re : Problème affichage textes depuis mise à jour

x11proto-xf86vidmode-dev => X11 Video Mode extension wire protocol ?
Je ne sais même pas ce que c'est que ça.

" je suis sous Kubuntu 12.04 "
"J'essaye de suite de lancer Kubuntu 12.10 en liveCD."

Ça aurait été pas mal déjà de voir en 12.04 (= precise).

Au fait, ça ça dit quoi ?

lspci | grep VGA

Dernière modification par φlip (Le 29/10/2012, à 12:22)

Hors ligne

#11 Le 29/10/2012, à 12:38

tobiasBora

Re : Problème affichage textes depuis mise à jour

Avec le live CD 12.04, je n'ai aucun problème puisque je l'ai installé à partir de celui là, et 12.04 ne semble pas non plus avoir de problème.

Retour de la commande :

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1058 (rev ff)

Je pense que je vais re-partir sur une réinstalle propre...

Hors ligne

#12 Le 29/10/2012, à 12:39

φlip

Re : Problème affichage textes depuis mise à jour

Tu as deux cartes graphiques ???? Intel + Nvidia ???

"Je pense que je vais re-partir sur une réinstalle propre"

=> Si tu ne maîtrises pas apt, tu as peu de chance de t'en sortir avec du xorg en ppa.....
Réinstaller est le plus simple.

Dernière modification par φlip (Le 29/10/2012, à 12:42)

Hors ligne

#13 Le 29/10/2012, à 13:24

tobiasBora

Re : Problème affichage textes depuis mise à jour

Oui, la carte intel est ma carte principale, et la nvidia est la carte secondaire, plus puissante mais plus gourmande (technologie optimus)

Si je préfère la réinstallation, c'est justement car optimus semble avoir été touché également avec le ppa. Et qu'est-ce que tu veux dire par ne pas maitriser apt ?

Hors ligne

#14 Le 29/10/2012, à 13:41

φlip

Re : Problème affichage textes depuis mise à jour

Là tu compliques effectivement ..... avec ton Intel+Optimus+ppa .....

apt est un système très puissant, mais qui demande un peu d'apprentissage quand-même.

Debian package management

Dernière modification par φlip (Le 29/10/2012, à 13:44)

Hors ligne

#15 Le 29/10/2012, à 15:24

tobiasBora

Re : Problème affichage textes depuis mise à jour

Donc j'ai fait la mise à jour et j'ai toujours de petits problèmes avec les drivers intel (bon ils ne rendent pas mon système inopérant au moins cette fois), alors que je n'ai pas encore installé le moindre ppa.

Voilà un aperçu d'écran de bugs d'affichage que j'ai régulièrement :
http://wstaw.org/m/2012/10/29/bug.png
(les petits zigzags blanc en haut).

Ce n'est pas très grave, mais c'est un peu embétant, d'autant que quand il y a un problème de ce style, c'est souvent car un plus gros problème se cache en dessous.

Tu vois comment le réparer ? Est-ce qu'il y a une accélération matérielle a activer ou que sais-je ?

Dernière modification par tobiasBora (Le 29/10/2012, à 15:24)

Hors ligne

#16 Le 31/10/2012, à 08:08

φlip

Re : Problème affichage textes depuis mise à jour

Non, ce n'est pas normal.
Comment sais-tu si tu utilises ta carte intel ou nvidia ?

Que dit ceci:

grep Backend ~/.kde/share/config/kwinrc

dpkg -l libgl1*|grep ^i.*l|awk '{print $2,$3}'

Dernière modification par φlip (Le 31/10/2012, à 08:19)

Hors ligne

#17 Le 31/10/2012, à 09:57

tobiasBora

Re : Problème affichage textes depuis mise à jour

Alors pour la technologie optimus, tous les programmes et l'OS se lancent sur la carte intel par défaut, et le seul moyen d'exploiter la carte nvidia est de lancer un programme avec la commande "optirun" installée via bumblebee. Tant que l'on n'a pas installé ce logiciel (ce qui est mon cas pour le moment), seul la carte intel est utilisée, et la carte nvidia, bien qu'allumée (il faut installer bumblebee pour l'éteindre), n'est en aucun cas mis à contribution.

Pour le résultat des commandes,

$ grep Backend ~/.kde/share/config/kwinrc

ne renvoie rien
et voici le résultat de la deuxième commande :

$ dpkg -l libgl1*|grep ^i.*l|awk '{print $2,$3}'
libgl1-mesa-dri:amd64 9.0-0ubuntu1
libgl1-mesa-dri:i386 9.0-0ubuntu1
libgl1-mesa-glx:amd64 9.0-0ubuntu1
libgl1-mesa-glx:i386 9.0-0ubuntu1

Merci !

Dernière modification par tobiasBora (Le 31/10/2012, à 09:57)

Hors ligne

#18 Le 31/10/2012, à 11:34

φlip

Re : Problème affichage textes depuis mise à jour

kcmshell4 kwincompositing 

> options avancées : si tu vois OpenGL, essaie Xrender

Je ne sais pas si c'est normal que tu aies les librairies i386 ET amd64 d'installées, c'est peut-être un détail.

+ retour de

grep -A12 'Compositing' ~/.kde/share/config/kwinrc
uname -a

Hors ligne

#19 Le 31/10/2012, à 12:35

tobiasBora

Re : Problème affichage textes depuis mise à jour

Merci.

J'ai activé XRender, plus qu'à voir si ça replante. (le nombre de plantage avait sensiblement diminué, je n'en avait plus qu'un ou deux par heure) Je pense que ça devrait fonctionner, même si ça m'enlève certains effets graphiques. Et pour le système graphique qt je met natif ou raster ?

Pour le retour des fonctions :
avec opengl :

$ grep -A12 'Compositing' ~/.kde/share/config/kwinrc
[Compositing]
AnimationSpeed=3
Backend=OpenGL
Enabled=true
GLLegacy=false
GLTextureFilter=2
GLVSync=true
GraphicsSystem=native
HiddenPreviews=5
OpenGLIsUnsafe=false
UnredirectFullscreen=false
XRenderSmoothScale=false

avec xrender :

$ grep -A12 'Compositing' ~/.kde/share/config/kwinrc
[Compositing]
AnimationSpeed=3
Backend=XRender
Enabled=true
GLLegacy=false
GLTextureFilter=2
GLVSync=true
GraphicsSystem=native
HiddenPreviews=5
OpenGLIsUnsafe=false
UnredirectFullscreen=false
XRenderSmoothScale=false

et la dernière :

$ uname -a
Linux tobias-kub-port 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Merci pour l'astuce du Xrender, même si ça ne répare pas la source du problème (bug de opengl), ça à le mérite faire retrouver un système stable !

-- EDIT --
Et j'ai remarqué que le bug arrivait souvent lorsqu'il jouait des animations rapides comme avec Ctrl+Tab (le bug arrivait alors pendant le défilement des fenêtres ou après)

Dernière modification par tobiasBora (Le 31/10/2012, à 12:37)

Hors ligne

#20 Le 31/10/2012, à 22:10

φlip

Re : Problème affichage textes depuis mise à jour

Bon, je n'ai pas vu de problèmes spécifiques sur un Thinkpad carte Intel, mais je mets systématiquement en XRender pour chercher la performance.

Il semble que le passage de libgl1-mesa de V8.04 à V9 soulève quelques problèmes.
Un downgrade vers 8.0.4 peut être essayé, pour voir.
https://bugs.launchpad.net/ubuntu/+sour … ug/1042211

Liste des paquets à downgrader en 8.0.4 pour essai:

 libgl1-mesa-dri
 libgl1-mesa-glx
 libglapi-mesa
 libglu1-mesa
 libosmesa6
 libxatracker1

Dernière modification par φlip (Le 31/10/2012, à 22:52)

Hors ligne

#21 Le 02/11/2012, à 00:00

tobiasBora

Re : Problème affichage textes depuis mise à jour

Merci pour ce lien, je pense en effet que le problème viens de là. (c'est bien après une maj de mesa que tout à planté)

Par contre, par peur de faire encore une bétise, je ne sais pas comment downgrader : j'ai essayé d'ajouter le ppa, mais il ne contient aucun des paquets en rapport avec mesa (je l'ai donc supprimé), et je ne vois pas trop comment utiliser les fichiers donnés ici :
https://launchpad.net/ubuntu/+source/me … 4-1ubuntu1

Il faut que j'utilise la commande patch ?

Hors ligne

#22 Le 02/11/2012, à 18:54

φlip

Re : Problème affichage textes depuis mise à jour

Pas besoin de "ppa". Autant faire ça propre.
J'ai fait un script pour chercher proprement les bons paquets au bon endroit. Mais je n'ai l'ai pas ici ... pas avant mercredi.
J'ai même essayé mesa 8.0.4 sur un Thinkpad Intel en Quantal, mais je n'ai aucune différence en OpenGL entre mesa 8.0.4 et 9.0 (aucun souci / test sur le cube qui tourne).

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Ça voudrait dire qu'il y a Intel et Intel....
Ce qui est bizarre est que Debian SID utilise mesa 8.0.4, et ubuntu déjà 9.0, mais pas suffisamment testé apparemment.

Une chose intrigante: comment se fait-il que tu n'aies pas de souci en liveCD, mais seulement une fois installé ?

Je précise que j'installe toujours KDE sur xorg soit en netinstall ou alternate, donc peut-être pas le même résultat qu'en liveCD.

Dernière modification par φlip (Le 02/11/2012, à 18:58)

Hors ligne

#23 Le 02/11/2012, à 20:32

tobiasBora

Re : Problème affichage textes depuis mise à jour

Et bien j'attendrai ^^

Étant donné que cette erreur arrive de manière relativement aléatoire, je me dis que je n'ai peut être pas assez poussé loin le live CD pour voir apparaître cette erreur. D'ailleurs je me demande si elle n'est pas apparue une fois...

Alors oui, j'installe en effet kubuntu en mode graphique avec une installation standard. Tu penses que ça pourrait jouer ?

--EDIT--
Et j'ai essayé le cube et étrangement je n'ai aucun bug dessus ! Alors qu'il y a une manipulation qui plante presque systématiquement : laisser ctrl+tab (pour changer de fenêtre) appuyé pour faire changer les fenêtres très rapidement ! Et comme ça presque à chaque fois j'ai de jolies petites bandes blanches en haut de mon écran...

Dernière modification par tobiasBora (Le 02/11/2012, à 20:37)

Hors ligne

#24 Le 06/11/2012, à 21:14

φlip

Re : Problème affichage textes depuis mise à jour

Bon, pas sûr que mesa 9.0 soit l'unique source de problème.
Un bug aurait été introduit dans kde-workspace.

Pour "downgrader" mesa en 8.0.4, à essayer pour voir:

list="libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglu1-mesa libosmesa6 libxatracker1"
site="http://mirror.ovh.net/ubuntu//pool/main"

mkdir ~/mesa804 ; cd ~/mesa804 
[ "$(echo $(uname -i)|grep 86)" ] && I='i386' || I='amd64' ; echo $I
for P in $list; do wget $site/m/mesa/$(curl -s $site/m/mesa/ |egrep -o ">$P\_8.0.4.*$I.deb"|tr -d '>'|tail -n1); done
wget $site/l/llvm-3.0/libllvm3.0_3.0-4ubuntu1_$I.deb

sudo dpkg -i *.deb
sudo apt-get install -f

Vérification

dpkg -l '*mesa*' | grep ^i | awk '{print $2,"\t",$3}'

:

Dernière modification par φlip (Le 06/11/2012, à 21:33)

Hors ligne

#25 Le 15/11/2012, à 20:44

tobiasBora

Re : Problème affichage textes depuis mise à jour

Merci pour ce script, je l'essayerai dés que possible (pas trop le temps en ce moment, une coupure de mon ordi me serait fatale), mais par contre deux petites questions :
- Comment faire pour revenir à l'ancienne version ? J'ai juste à les désinstaller manuellement puis à réinstaller les versions des dépots ? Si je fais ça je ne risque pas d'avoir une coupure de mon affichage juste après la désinstallation ?
- Est-ce possible de faire une sauvegarde de mon système actuel (paquets, versions, configuration etc...) au cas où un bug arrive ? Ma question est d'ailleurs plus générale que pour ce cas particulier : pour vérifier si un ppa (j'ai dis un gros mot ?) ne va pas déstabiliser le système (par exemple si l'installation d'une nouvelle version de ffmpeg ne va pas m'empécher d'utiliser vlc), il serait très pratique de pouvoir sauvegarder l'état actuel pour le restaurer par la suite rapidement en cas de problème. Il me semble que linux mint le fait, il n'y a pas un équivalent (k)ubuntu ?

Dernière modification par tobiasBora (Le 15/11/2012, à 20:44)

Hors ligne

Haut de page ↑