Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 02/11/2012, à 23:11

dragon-melkior

apache n'exécute pas le contenu php

bonjour.

J'avais un serveur Ubuntu Server 9.10 Karmic sous lequel était un serveur apache. mes programmes php fonctionnaient très bien. là je viens de changer le cœur de mon serveur (carte mère, processeur et ram) et j'ai donc décidé de profiter de ce grand changement pour une nouvelle installation vers Ubuntu Server 12.04 qui est une LTS. mais ce faisant, apache n'exécute plus aucun programme php.

cela fait longtemps que je n'avais pas reconfiguré mon serveur et je ne me souviens plus comment configurer apache pour qu'il exécute le contenu php correctement.

actuellement, la page me retourne une page blanche tout simplement. comme si une erreur 500 se glissait mais je ne sais plus ou regarder ni quoi faire dans la config pour que les éventuelles erreurs PHP/MySQL s'affiche a mon écran (car dans les log je vois bien des entrées concernant des fonctions qui n'existe pas et j'en déduis que ma programmation n'est pas compatible avec la config actuelle du serveur.

selon les piste que j'ai, je serais très content, comme c'est un serveur local qui ne me sert qu'a moi, de pouvoir lire a l'écran les erreur MySQL ou PHP comme ça le faisait avant. comment faire ?

Hors ligne

#2 Le 03/11/2012, à 06:52

sechanbask

Re : apache n'exécute pas le contenu php

Est-ce le navigateur te propose de télécharger le script .php au lieu de l'exécuter ?

si c'est le cas, voici ma procédure que j'utilise pour installer apache sur ma debian (à adapter à tes besoins et normalement, il faut juste faire sudo à la place de # ):

Apache2 : serveur web

Sur une debian 6
Installation

# aptitude install apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 php5 php5-common

si depuis votre navigateur les fichiers PHP se téléchargent au lieu de se lancer sur le serveur :

    Vérifier que le module php5 est bien présent dans « /etc/apache2/mods-enabled/ ».
    Vérifier que le paquet « libapache2-mod-php5 » est bien installé et charger le module avec la commande « a2enmod php5 ».
    Vider le cache de votre navigateur avant de faire un nouveau test.
    Il faut éditer le fichier du module en question :

# nano /etc/apache2/mods-available/php5.conf 

et ajouter après <IfModule mod_php5.c> les 2 lignes suivantes

    AddType application/x-httpd-php .php .phtml .php3
    AddType application/x-httpd-php-source .phps

Puis faire relancer le service :

# service apache2 restart

sinon regarde dans les logs tu auras peut être une info pour te/nous mettre sur la piste:
sudo nano nano /var/log/apache2/error.log
nano /var/log/apache2/access.log

J'ai eu de très nombreux déboires avec les modifications Ubuntu 12.04 LTS notamment avec les services (pc et serveur), du coup je suis passer à debian, c'est pas plus compliqué mais c'est moins "innovant dans tous les sens" donc c'est plus stable et seule les mises à jour nécessaires sont proposées.

En tout cas bon courage !

Hors ligne

#3 Le 04/08/2013, à 12:47

neokal

Re : apache n'exécute pas le contenu php

Bonjour,
Je viens faire un petit up de ce forum car comme dragon-melkior je recherche une option bien particuliére du serveur apache.

dragon-melkior a écrit :

je serais très content, comme c'est un serveur local qui ne me sert qu'a moi, de pouvoir lire a l'écran les erreur MySQL ou PHP comme ça le faisait avant. comment faire ?

Ayant été habitué à développer sous easy PHP (eurk!) j'aimerais moi aussi savoir comment afficher les différents message d'erreur, c'est beaucoup plus simple pour débugger tout ça :-)
Merci par avance


Celui qui se transforme en bête se délivre de la douleur d'être un homme...

Hors ligne

#4 Le 07/08/2013, à 10:09

mazarini

Re : apache n'exécute pas le contenu php

Dans php.ini voir les paramètres :
error_reporting (détermine les erreurs ignorés ou reporter : mettre E_ALL ou E_ALL & E_STRICT)
display_error (détermine si les erreur sont loguées ou affichées à l'écran : mettre On de mémoire)


Macronite : Trouble de l'équilibre qui se manifeste par une tendance à pencher à droite

Hors ligne

#5 Le 07/08/2013, à 16:10

neokal

Re : apache n'exécute pas le contenu php

Merci ça marche impeccable )


Celui qui se transforme en bête se délivre de la douleur d'être un homme...

Hors ligne

#6 Le 21/03/2015, à 23:35

denokan

Re : apache n'exécute pas le contenu php

Bonjour
(Désolé de déterre un ancien message, mais ma recherche google m'a directement amené ici et je suppose que d'autres suivront...)

Visiblement la méthode d'activation pour les fichiers php dans le dossier des utilisateurs a changé : maintenant il convient plutôt de commenter la partie IfModule, plutôt que de la modifier.
Voici la fin du fichier php5.conf de ma debian7 fraîchement installée :

# Running PHP scripts in user directories is disabled by default
# 
# To re-enable PHP in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
<IfModule mod_userdir.c>
    <Directory /home/*/public_html>
        php_admin_value engine Off
    </Directory>
</IfModule>

Pour les anglophobes, ça dit simplement qu'il ne faut PAS modifier la valeur de php_admin_value pour la passer à engine On, car ça empêcherai par la suite de modifier cette valeur à l'aide d'un fichier .htaccess. J'ai donc commenté cette dernière partie, un petit redémarrage du service apache2, et tout fonctionne maintenant.

Hors ligne

Haut de page ↑