Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 26/08/2005, à 23:58

invité

XFCE4 et GLib (GModule) not found.

Bonjour,
j'ai telechargé xfce4-4.2.2-installer.bin
j'ai fait comme dans l'aide:
chmod +x xfce4-4.2.2-installer.bin
./xfce4-4.2.2-installer.bin
resultat:

Verifying file integrity... OK.
Extracting the installer... OK.
Checking for usable C compiler... gcc
Checking for usable C++ compiler... g++
Checking for GNU make... make
Checking for package config tool... pkg-config
Checking for GLib (GModule) >= 2.2.0... not found, see /home/anonym/.xfce4.installer-log for details
Cleaning up... OK.

j'ai cherché GLib dans synaptic et j'ai:
dbus-glib-1
libglib2.0-0
libglib2.0-data
libglib-perl

Tous sont installés.
Je n'ai pas fait apt-get install xfce4 car je n'ai pas encore configuré Internet (modem 56 K, AOL).

Est-ce que quelqu'un qui a installé Xfce4 sans synaptic pourrait m'aider?
Merci beaucoup.

#2 Le 27/08/2005, à 00:15

ffomnislash

Re : XFCE4 et GLib (GModule) not found.

j'ai pas non la glib 2.2 dans synaptic.

Je dirais, soit tu passe a breezy, soi tu compile la glib 2.2 + toutes ces dependances big_smile


-- Mon blog --

Hors ligne

#3 Le 27/08/2005, à 09:29

invité

Re : XFCE4 et GLib (GModule) not found.

ffomnislash a écrit :

tu compile la glib 2.2 + toutes ces dependances big_smile

j'ai télécharger glib ici (sous windows):
ftp://ftp.gtk.org/pub/gtk/v2.8/glib-2.8.1.tar.bz2

je suis newbie...comment tu fais pour compiler?
merci pour ta patience.

#4 Le 27/08/2005, à 10:52

invité

Re : XFCE4 et GLib (GModule) not found.

ok j'ai trouvé...
mais faut installé gtk+ (11 mo) maintenant
grrr...

#5 Le 27/08/2005, à 12:53

invité

Re : XFCE4 et GLib (GModule) not found.

configure: error: Package requirements (glib-2.0 >= 2.7.1    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.9.2) were not met.

il me dit qu'il ne trouve pas glib-2.0 alors que j'ai installe glib-2.8.1 sans erreur.
comprends pas.
Sinon je n'ai pas encore telecharge atk, pango et cairo.
vais-je voir un jour la fin...

voila ou j'en suis...
j'ai telecharge:
xfce4-4.2.2-installer.bin
glib-2.8.1
gtk+-2.8.2
pkg-config-0.19

tout ça fait + de 30 Mo telechargé sous windows en 56 K -> ça commence à me gaver.

bon si quelqu'un a installe Xfce4 avec le .bin et qui veuille bien m'aider...
merci.

#6 Le 27/08/2005, à 14:36

invité

Re : XFCE4 et GLib (GModule) not found.

Arfff il faut aussi télécharger les dependances des dépendances...
bon je vais laisser tomber :-(
car je ne vois pas la fin...
**************************************************************
j'installe atk-1.10.1
il me dit:

configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

**************************************************************
j'installe cairo-1.0.0 et il me dit:
configure: error: Cairo requires at least one font backend.
                  Please install freetype and fontconfig, then try again:
                  http://freetype.org/  http://fontconfig.org/
**************************************************************
quant à  Pango-1.10.0:

configure: WARNING: X development libraries not found
checking for pkg-config... /usr/local/bin/pkg-config
checking for fontconfig >= 1.0.1... configure: WARNING: No fontconfig found, skipping tests for FreeType and Xft
checking for cairo >= 0.5.2-head... configure: error: *** Didn't find any of FreeType, X11, or Win32.
*** Must have at least one backend to build Pango.
**************************************************************

et je ne sais même plus pour quelle paquet il fallait télecharger atk-1.10.1,cairo-1.0.0 et Pango-1.10.0...

ps: désolé pour les accents c'est gedit qui merde :-(

#7 Le 29/08/2005, à 17:33

StK

Re : XFCE4 et GLib (GModule) not found.

Il te faut libglib2.0-dev

sudo apt-get update
sudo apt-get install libglib2.0-dev

Hors ligne

Haut de page ↑