Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 28/08/2005, à 15:03

Guinux

Configuration Samba

Bonjour à vous, je viens vous demandez conseil car j'ai du mal avec la configuration de Samba      hmm

J'ai 3 PC, un sous winXP/Mandriva dans le bureau, un sous winXP/Ubuntu dans ma chambre, et un sous Ubuntu en serveur. Sur celui qui j'espere va enfin pouvoir me servir de serveur, j'ai Ubuntu sur un DD de 8Go et un DD de 40Go que je voudrais partager entre les deux autres PC, lecture et écriture. J'ai donc décidé de me servir de Samba. Mais étant un newbe et malgré mes recherches, ça reste du chinois pour le configurer big_smile

J'ai monté ce DD dans /mnt/, et j'aimerais donc partagé /mnt/, qu'elle ligne faut-il changer dans le smb.conf?

Pour l'instant pour faire au plus simple, je voudrais que les deux PC y accèdent sans loggin ni mdp, on verra plus tard...

Pour info mon groupe de travail est DOMICILE, et les 3 IP sont :

Serveur : 192.168.0.1
Bureau : 192.168.0.3
Chambre : 192.168.0.2

Les 3 PC sont relier à un switch lui, lui meme relier à ma freebox en mode routeur, IP 192.128.0.254.

Je voudrais donc savoir les lignes à changer dans mon smb.conf.

J'espere avoir été clair et que vous pourrez m'aider. Merci.

Hors ligne

#2 Le 28/08/2005, à 17:53

Guinux

Re : Configuration Samba

J'ai fait ça mais ça marche toujours pas :

Comment partager des dossiers en lecture/écriture à tout le monde (Authentication désactivée)?

   1. Lire Notes générales
   2. Lire Comment installer le serveur Samba pour partager des fichiers/dossiers?
   3.

sudo mkdir /home/public
sudo chmod 777 /home/public/
sudo cp /etc/samba/smb.conf /etc/samba/smb.conf_backup
sudo gedit /etc/samba/smb.conf

   4. Chercher cette ligne

...
;   security = user
...

   5. Remplacer avec la ligne suivante

   security = share

   6. Ajouter ces lignes à la fin du fichier

[public]
   comment = Public Folder
   path = /home/public
   public = yes
   writable = yes
   create mask = 0777
   directory mask = 0777
   force user = nobody
   force group = nogroup

   7. Sauver le fichier (exemple)
   8.

sudo testparm
sudo /etc/init.d/samba restart

J'ai remplacé le workgroup par DOMICILE et le path par : path = /mnt/

Si vous avez des idées pour m'aider...

Dernière modification par Guinux (Le 28/08/2005, à 17:56)

Hors ligne

#3 Le 28/08/2005, à 17:57

NicoA380

Re : Configuration Samba

Je me suis pas encore penché sur mes partages Samba, cependant il me semble qu'il y a une ligne à décommenter dans le smb.conf, une ligne qui contient "guest".

Sinon, pour ceux qui utilise samba régulièrement, vous êtes plutôt :
webmin (+module samba) ou Swat ou smb.conf (à la mano) ?

Hors ligne

#4 Le 28/08/2005, à 18:29

Guinux

Re : Configuration Samba

A mon avis je suis pas loin du résultat que je veux obtenir car sur Ubuntu sur le deuxième pc j'ai accès au serveur Samba sans mot de passe ni loggin et je peux copier des dossier sur mon DD depuis le serveur, par contre impossible de copier sur le serveur sad

Et depuis windows il y a une fenetre qui s'ouvre pour me demander un mot de passe et un loggin...

Hors ligne

#5 Le 28/08/2005, à 19:32

chimay

Re : Configuration Samba

mmhh je connais mieux la security = user, je te donne ma config
(qui fonctionne d'un linux vers un bsd mdr, cherche pas à
comprendre l'utilité profonde tongue). J'ai pas de ligne security, je suppose
que par défaut elle est sur user (samba déconseille sécurity = share, voir
http://web.mit.edu/rhel-doc/4/RH-DOCS/rhel-rg-fr-4/s1-samba-security-modes.html
que je découvre à l'instant). Essaie de commenter ou supprimer security = share

Dans la suite je suppose que ton compte nunux s'appelle toto. Ajoute :

hosts allow = localhost, 192.168.0.2, 192.168.0.3

dans la section [public] et fais un :

$ sudo -s
(ton passwd)
# smbpasswd -a toto
(nouveau mot de passe à définir, il sera utilisé par samba)
(retaper le meme mot de passe)

je te conseille de choisir ton passwd habituel, c plus simple ;-)

ensuite, de la machine windows, lorsqu'il te demande login/passwd
tu tapes toto et le mdp que tu viens de définir. Puis viens nous raconter
si ca marche ou si j'ai oublié qq chose :-)

sinon, dans ton fichier, tu as force user = nobody, c surement ca qui empeche
d'écrire dans ton dossier depuis ubuntu. Le force group aussi possiblement. L'absence
de hosts allow m'étonne aussi mais pas dit que ce soit nécessaire.

Dernière modification par chimay (Le 28/08/2005, à 19:42)


* Linux est écolo : le code est tout vert
* Un dauphin nage plus vite qu'un nautile nain
* Le but d'un système d'exploitation est d'exploiter l'ordinateur, pas l'utilisateur
* Un ordinateur est composé d'un piano, d'une mangeuse de fromage, d'une mémoire d'éléphant, d'une dalle, d'un lecteur de galette, et d'un moulin, le célèbre moulin de la galette

Hors ligne

#6 Le 28/08/2005, à 20:14

arvin

Re : Configuration Samba

Je te donne mon smb.conf: Il marche chez moi avec security=share

http://forum.ubuntu-fr.org/viewtopic.ph … 121#p64121


Mon blog pour Linux: http://jujuseb.com

Hors ligne

#7 Le 28/08/2005, à 20:28

Guinux

Re : Configuration Samba

Merci Chimay, alors après avoir commenter security = share, supprimer force user et force groupe, rajouter la ligne hosts hallow, j'ai accès à mon serveur depuis ubuntu en lecture mais pas en écriture, et idem pour mon pc avec l'adresse 192.168.0.3.

Par contre quand je repasse sous XP avec le 192.168.0.2, je n'ai pas accès au serveur...

Merci de ton aide, je vais voir avec le smb.conf de arvin.

Hors ligne

#8 Le 28/08/2005, à 21:07

Guinux

Re : Configuration Samba

:(Bon bah arvin ça me donne la même chose avec ton smb.conf wink

Y'a quand même un truc qui cloche, 192.168.0.3 ping sur 192.168.0.2, mais pas l'inverse, que ce soit sur Ubuntu ou XP. Et ce qui est bizarre c'est que je peux aller sur le serveur seulement depuis Ubuntu malgré que je ping sur 192.168.0.1 (le serveur) depuis les 2 OS...

Il reste donc quelques trucs à régler encore sad pour que je sois totalement satisfait, mais bon grâce à vous y'a quand même du mieu et ça fait plaisir merci wink

Donc si vous avez encore des idées pour mes problèmes n'hésitez pas!

Hors ligne

#9 Le 28/08/2005, à 23:01

NicoA380

Re : Configuration Samba

Tu as déjà joué avec Firestarter sur tes postes Ubuntu ?
Car même si Firestarter est fermé, ses dernières modifications restent effective (le firewall est intégré au noyau).
Ton firewall est désactivé le temps des testes ?

Si tu as peur de virer les firewall, débranche ton cable vers le modem, tu craindras rien tongue
Une fois que ça marche, réactive le firewall tout en testant.

Hors ligne

#10 Le 30/08/2005, à 11:29

sparky

Re : Configuration Samba

J'ai eu ces soucis pendant un moment, jusqu'à ce que je réalise que j'avais dans /etc/hosts

10.10.10.2 brol (je n'emploie pas ce subnet ni de machine nommée brol)

et dans le dns

10.10.10.5 brol

C'est con mais les bizarreries de cette mauvais config m'ont énervées une journée COMPLETE hmm.

Hors ligne

#11 Le 17/09/2005, à 13:48

arvin

Re : Configuration Samba

Un petit [résolu]
Au passage: http://www.nuxo.net/static.php?op=samba.php


Mon blog pour Linux: http://jujuseb.com

Hors ligne

#12 Le 18/09/2005, à 19:29

Guinux

Re : Configuration Samba

Non pas de résolu lol, il reste quelques trucs qui ne marchent pas mais j'ai pas eu le temps de rebosser dessus...

je suis désolé mais faudra fatalement que je fasse remonter ce post quand j'aurais le temps de rebosser dessus, donc si ça te dérange pas je mettrais un résolu quand tout sera parfaitement au point wink

A+

Hors ligne

#13 Le 12/10/2005, à 23:44

B_Pascal

Re : Configuration Samba

Salut à tous !
bon, c'est vrai que ce n'est pas évident, mais dans mon smb.conf j'ai l'habitude de ne pas trop me casser, et y a des truc, à mon avis, pour éviter des blèmes que je met tjr, voici:


[global]
# workgroup = NT-Domain-Name or Workgroup-Name
   workgroup = WORKGROUP

# 1) security_level.txt for details.
   security = user

# 1)You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents SINON pas #d'autentication Windôze
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd

# 1)Unix users can map to different SMB User names Fichier à créer avec dedans
##      Unix_name = SMB_name1 SMB_name2 ...------> root=administrateur... par exemple
  username map = /etc/samba/smbusers

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
   local master = yes
# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
   os level = 255
# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
   domain master = yes

#A éviter d'autre méthode d'autentification... a moins de s'y connaitre !!!!!! relatifs à   1)


[partages]
   comment = Partage pour les bécanes
   path = /partages
   valid users = root administrateur  #dans ce cas pas oublier d'autoriser root
   public = no
   writable = yes
   ;printable = no
   create mask = 0775
   browseable=yes

Bon mettons je travail tjr en root bien que ce ne soit pas trés prudent, et en cas de blème, je "ghost" mes linux..... et j'espère que ces quelques indication pourront aider !

Ah j'oubliai , important Pas oublier de mettre les passwd des user de Samba, la cmd en mode cosole est: (dans /etc/samba/ (meme endroit que smb.conf))   "smbpasswd -a <nom de l'user>" aprés faut mettre le password. Parce qu'il s'autentifie d'aprés ces passwd

bye !

Pascal

#14 Le 14/10/2005, à 17:41

Jnifoo

Re : Configuration Samba

SWAT est ton ami, ça permet de configurer avec pas mal d'explications derrière et l'administration du serveur se fait simplement ensuite.


Utilisateur de Ubuntu depuis la version 5.04

Hors ligne

Haut de page ↑