Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 11/11/2012, à 17:59

DenisS

Installation d'Eliot sur Quantal 64

Bonjour,

J'ai téléchargé le paquet eliot_2.0-1_amd64.deb depuis le site http://www.nongnu.org/eliot/, mais lorsque j'essaie de l'installer sur ma Quantal 64 bits, j'ai une erreur sur une dépendance non satisfaite.

denis@pc-denis:~$ sudo dpkg -i '/home/denis/Eliot/eliot_2.0-1_amd64.deb' 
Sélection du paquet eliot précédemment désélectionné.
(Lecture de la base de données... 196638 fichiers et répertoires déjà installés.)
Dépaquetage de eliot (à partir de .../Eliot/eliot_2.0-1_amd64.deb) ...
dpkg: des problèmes de dépendances empêchent la configuration de eliot :
 eliot dépend de libconfig++8 (>= 1.3.2-2) ; cependant :
  Le paquet libconfig++8 n'est pas installé.

dpkg: erreur de traitement de eliot (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf.index...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Des erreurs ont été rencontrées pendant l'exécution :
 eliot

libconfig++8 ne fait pas partie des paquets disponibles, bien que j'aie un libconfig++8-dev d'installé.

Comment faire pour mener à bien cette installation ? Y'a-t-il un dépôt particulier à activer pour libconfig++8 ?

Hors ligne

#2 Le 15/11/2012, à 16:38

IpkissEliot

Re : Installation d'Eliot sur Quantal 64

Bonjour,

Le paquet eliot_2.0-1_amd64.deb a été construit pour Ubuntu Precise. Comme Quantal fournit libconfig++9 au lieu de libconfig++8, le paquet n'est pas installable.
Je pense que le mieux serait de faire un nouveau paquet Eliot pour Quantal (donc basé sur libconfig++9). J'essaierai de faire ça la semaine prochaine...

Hors ligne

#3 Le 15/11/2012, à 19:30

DenisS

Re : Installation d'Eliot sur Quantal 64

Ceci explique sûrement cela smile

Par contre, synaptic ne m'affiche pas de libconfig++9, mais seulement une libconfig++8-dev en version 1.4.8-5 ainsi qu'une libconfig++dev (et pas de libconfig++8 tout court non plus).

Me manquerait-il quelque chose (un dépôt particulier, ou un paquet à installer) ?

Hors ligne

#4 Le 18/11/2012, à 12:49

IpkissEliot

Re : Installation d'Eliot sur Quantal 64

Je n'ai pas de Quantal sous la main pour vérifier, mais d'après cette page le paquet libconfig++9 devrait être disponible (et ça devrait être une dépendance de libconfig++-dev).
Je vais installer Quantal dans une VM, pour voir ce qu'il faut utiliser et pour faire le .deb...

Hors ligne

#5 Le 18/11/2012, à 13:17

DenisS

Re : Installation d'Eliot sur Quantal 64

En effet. Je viens de revérifier, et j'ai bien une libconfig++9.
C'est le filtre rapide de synaptic qui m'a trompé. Si je tape libconfig++, il ne me liste que la libconfig++8-dev. Si je tape libconfig++9, il me liste bien cette bibliothèque comme étant installée.

Ceci dit, ça ne règle pas le problème, puisqu'Eliot demande actuellement la libconfig++8, que je n'ai pas (et qui visiblement n'est plus fournie avec quantal).

Hors ligne

#6 Le 22/11/2012, à 16:21

IpkissEliot

Re : Installation d'Eliot sur Quantal 64

Bonjour,

Eliot est maintenant disponible pour Quantal, à la fois en 32 bits et 64 bits (grâce à un PPA).
La procédure d'installation (plus simple qu'avant) est détaillée sur le site d'Eliot (http://nongnu.org/eliot/).

Hors ligne

#7 Le 22/11/2012, à 17:33

DenisS

Re : Installation d'Eliot sur Quantal 64

Ça marche nickel pour moi.

Merci beaucoup !

Hors ligne

Haut de page ↑