Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 15/11/2012, à 20:13

yakoudbz

[Résolu] apt-get install * -dev

Bonjour,

Depuis que j'ai reinstaller xubuntu il y a une semaine, je n'arrvive pas a installer de paquets de devellopements (-dev) .
par exemple:

sudo apt-get install libgtk2.0-dev
[sudo] password for celestin: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libgtk2.0-dev : Dépend: libglib2.0-dev (>= 2.27.3) mais ne sera pas installé
                 Dépend: libgdk-pixbuf2.0-dev (>= 2.21.0) mais ne sera pas installé
                 Dépend: libpango1.0-dev (>= 1.20) mais ne sera pas installé
                 Dépend: libatk1.0-dev (>= 1.29.2) mais ne sera pas installé
                 Dépend: libcairo2-dev (>= 1.6.4-6.1) mais ne sera pas installé
                 Dépend: libx11-dev (>= 2:1.0.0-6) mais ne sera pas installé
                 Dépend: libxext-dev (>= 1:1.0.1-2) mais ne sera pas installé
                 Dépend: libxinerama-dev (>= 1:1.0.1-4.1) mais ne sera pas installé
                 Dépend: libxi-dev (>= 1:1.0.1-4) mais ne sera pas installé
                 Dépend: libxrandr-dev (>= 1:1.2.99) mais ne sera pas installé
                 Dépend: libxcursor-dev mais ne sera pas installé
                 Dépend: libxfixes-dev (>= 1:3.0.0-3) mais ne sera pas installé
                 Dépend: libxcomposite-dev (>= 1:0.2.0-3) mais ne sera pas installé
                 Dépend: libxdamage-dev (>= 1:1.0.1-3) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

ou encore

sudo apt-get install libxcb1-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libxcb1-dev : Dépend: libxcb1 (= 1.8.1-1) mais 1.8.1-1ubuntu0.1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

et ce ne sont que des exemples, tout les -dev me font pareil

Dernière modification par yakoudbz (Le 15/11/2012, à 21:43)

Hors ligne

#2 Le 15/11/2012, à 20:35

yakoudbz

Re : [Résolu] apt-get install * -dev

C'est Résolu, je pensais avoir fait un upgrade mais apparemment non 0_o...
Pour ceux qui aurait le meme problème:

sudo apt-get update
sudo apt-get upgrade

Dernière modification par yakoudbz (Le 15/11/2012, à 21:43)

Hors ligne

Haut de page ↑