Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 01/12/2012, à 11:30

Olivopiment

Des commandes qui persistent dans le terminal !

Bonjour à tous, après avoir cherché dans le forum, je n'ai pas trouvé la réponse à mon pb, donc j'ouvre ce topic.

J'ai voulu connecter ma Nexus 7 à mon Pc sous 12.10, en suivant un tuto expliqué la et la.

Tout s'est bien passé jusqu'au moment de redémarrer et taper les trois dernières commandes qui concernent "bashrc".
En effet j'ai eu des erreurs.
Ce qui me pose souci, c'est que non seulement la manip est restée bloquée là, mais surtout, ces commandes en erreur s'affichent des que je lance le terminal.
Je ne sais pas comment faire pour les enlever de là ?
Voici ce qui s'affiche lorsque je lance le terminal :

olivopiment a écrit :

Commande '“alias' non trouvée, vouliez-vous dire :
La commande '0alias' du paquet 'zeroinstall-injector' (universe)
“alias : commande introuvable
“alias android-disconnect=”fusermount -u /media/GalaxyNexus”
Commande '“alias' non trouvée, vouliez-vous dire :
La commande '0alias' du paquet 'zeroinstall-injector' (universe)
“alias : commande introuvable
“alias android-disconnect=”fusermount -u /media/GalaxyNexus”
olivopiment@olivopimentpc:~$

.

Merci de laisser une petite réponse, je suis complètement dépassé !
;-)


Ex-windowsien
Full ubuntu depuis 12.04 Precise Pangolin
Asus X42F, EeePC 1005HA sous ubuntu 12.10.
"L'ordinateur est une machine, il ne fait que ce qu'on lui demande, il suffit de savoir lui parler : c'est là que ça se corse !"

Hors ligne

#2 Le 01/12/2012, à 11:55

gl38

Re : Des commandes qui persistent dans le terminal !

Il me semble qu'il y a un défaut dans le tuto au sujet de .bashrc : il faudrait remplacer les > par des >.
Ce serait plus simple d'ouvrir le fichier .bashrc avec gedit et de copier ce qu'il disent dans le fichier, à moins qu'il n'y ait d'autres coquilles !
Cordialement,
Guy

Hors ligne

#3 Le 01/12/2012, à 12:12

pingouinux

Re : Des commandes qui persistent dans le terminal !

Bonjour,
Tu peux éventuellement montrer ton fichier ~/.bashrc

Hors ligne

#4 Le 01/12/2012, à 16:08

Olivopiment

Re : Des commandes qui persistent dans le terminal !

Merci de répondre si rapidement, j'ai testé en mettant ceci :

olivopiment  a écrit :

echo "alias android-connect=\"mtpfs -o allow_other /media/GalaxyNexus\"" ~/.bashrc
echo "alias android-disconnect=\"fusermount -u /media/GalaxyNexus\"" ~/.bashrc
source ~/.bashrc

.
En fait, j'ai l'impression que seule la dernière commande présente un souci, car les deux autres répondent apparemment de manière normale.
voici ce que j'obtiens :

olivopiment a écrit :

olivopiment@olivopimentpc:~$ echo "alias android-connect=\"mtpfs -o allow_other /media/GalaxyNexus\"" ~/.bashrc
alias android-connect="mtpfs -o allow_other /media/GalaxyNexus" /home/olivier/.bashrc
olivopiment@olivopimentpc:~$ echo "alias android-disconnect=\"fusermount -u /media/GalaxyNexus\"" ~/.bashrc
alias android-disconnect="fusermount -u /media/GalaxyNexus" /home/olivier/.bashrc
olivopiment@olivopimentpc:~$ source ~/.bashrc
Commande '“alias' non trouvée, vouliez-vous dire :
La commande '0alias' du paquet 'zeroinstall-injector' (universe)
“alias : commande introuvable
“alias android-disconnect=”fusermount -u /media/GalaxyNexus”
Commande '“alias' non trouvée, vouliez-vous dire :
La commande '0alias' du paquet 'zeroinstall-injector' (universe)
“alias : commande introuvable
“alias android-disconnect=”fusermount -u /media/GalaxyNexus”
olivopiment@olivopimentpc:~$


Ex-windowsien
Full ubuntu depuis 12.04 Precise Pangolin
Asus X42F, EeePC 1005HA sous ubuntu 12.10.
"L'ordinateur est une machine, il ne fait que ce qu'on lui demande, il suffit de savoir lui parler : c'est là que ça se corse !"

Hors ligne

#5 Le 01/12/2012, à 16:10

Olivopiment

Re : Des commandes qui persistent dans le terminal !

De plus, je joins une copie de mon fichier bashrc :

olivopiment a écrit :

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi
“alias android-connect=”mtpfs -o allow_other /media/GalaxyNexus” >> ~/.bashrc
echo “alias android-disconnect=\”fusermount -u /media/GalaxyNexus\”
“alias android-connect=”mtpfs -o allow_other /media/GalaxyNexus” >> ~/.bashrc

echo “alias android-disconnect=\”fusermount -u /media/GalaxyNexus\”

Je suppose que les "“" ne devraient pas se présenter comme ça, mais je ne sais pas vraiment comment faire ...

Dernière modification par Olivopiment (Le 01/12/2012, à 16:10)


Ex-windowsien
Full ubuntu depuis 12.04 Precise Pangolin
Asus X42F, EeePC 1005HA sous ubuntu 12.10.
"L'ordinateur est une machine, il ne fait que ce qu'on lui demande, il suffit de savoir lui parler : c'est là que ça se corse !"

Hors ligne

#6 Le 01/12/2012, à 16:23

pingouinux

Re : Des commandes qui persistent dans le terminal !

Dans .bashrc, il faut remplacer les 4 dernières lignes (celles qui ont des caractères bizarres), par celles-ci :

alias android-connect="mtpfs -o allow_other /media/GalaxyNexus"
alias android-disconnect="fusermount -u /media/GalaxyNexus"

Hors ligne

#7 Le 01/12/2012, à 16:26

gl38

Re : Des commandes qui persistent dans le terminal !

Tu n'as plus qu'à effacer la fin du fichier

“alias android-connect=”mtpfs -o allow_other /media/GalaxyNexus” >> ~/.bashrc
echo “alias android-disconnect=\”fusermount -u /media/GalaxyNexus\”
“alias android-connect=”mtpfs -o allow_other /media/GalaxyNexus” >> ~/.bashrc

echo “alias android-disconnect=\”fusermount -u /media/GalaxyNexus\”

et recommencer en utilisant ta deuxième référence.
Vérifie que dans .bashrc il y a bien quelque chose de décent.
Cordialement,
Guy

Hors ligne

#8 Le 05/12/2012, à 00:23

Olivopiment

Re : Des commandes qui persistent dans le terminal !

Merci les gars, en effet, le pb des commandes persistantes dans le terminal est résolu et ça c'est top cool !
Par contre, je n'arrive pas à accéder à ma nexus 7 à chaque fois, et quand j'utilise gMTP, il me met presque à chaque fois un message d'erreur quand je le lance, ou alors il se grise et devient très lent ... je crois que cela devrait être un autre topic, non ?

Dernière modification par Olivopiment (Le 05/12/2012, à 00:25)


Ex-windowsien
Full ubuntu depuis 12.04 Precise Pangolin
Asus X42F, EeePC 1005HA sous ubuntu 12.10.
"L'ordinateur est une machine, il ne fait que ce qu'on lui demande, il suffit de savoir lui parler : c'est là que ça se corse !"

Hors ligne

#9 Le 05/12/2012, à 10:44

cyberic

Re : Des commandes qui persistent dans le terminal !

Bonjour, Je viens d'avoir ma Nexus7 et elle n'est pas reconnue par mon pc sous Ubuntu-12.10 (64bits), impossible de charger mes films donc..alors que sur la Samsung Tab2 c'était facile..si on pouvait régler ce problème via le terminal ce serait cool..


- Asus S1-AT5NM10E - Ubuntu 14.04 (64 bits) - Intel® Atom™ D525 (onboard) Processor Socket 775 / integrated NVIDA ION II GT218 / DD 160Go+RAM 4 Go(2x2)+Chromium.
- Nexus7 (2013) 32 Go  Androïd 4.4.4  &  Motorola MotoG 8 Go  Androïd 4.4.4
  * Libre Office + Print Friendly & PDF + VLC et le coup de coeur "SweetHome"

Hors ligne

#10 Le 18/12/2012, à 20:52

kipof

Re : Des commandes qui persistent dans le terminal !

Comme toi Olivopiment j'ai gMTP qui se grise avec un message d'erreur hmm mes les transfert de fichiers passent même comme ça. Si il y'a une solution je prend.


Ubuntu 14.04 LTS 64 Bits en Dual avec Windows 7 64 Bits
Portable ASUS G53SW
i5-2410M 2.3GHz avec 6GO RAM
CG nVidia Geforce GTX460M

Hors ligne

#11 Le 27/12/2012, à 10:01

cyberic

Re : Des commandes qui persistent dans le terminal !

chez moi gMTP fonctionne bien depuis le début, je l’utilise pour tous mes transferts vers ma nexus7 smile

Dernière modification par cyberic (Le 27/12/2012, à 10:12)


- Asus S1-AT5NM10E - Ubuntu 14.04 (64 bits) - Intel® Atom™ D525 (onboard) Processor Socket 775 / integrated NVIDA ION II GT218 / DD 160Go+RAM 4 Go(2x2)+Chromium.
- Nexus7 (2013) 32 Go  Androïd 4.4.4  &  Motorola MotoG 8 Go  Androïd 4.4.4
  * Libre Office + Print Friendly & PDF + VLC et le coup de coeur "SweetHome"

Hors ligne

#12 Le 27/12/2012, à 10:10

J5012

Re : Des commandes qui persistent dans le terminal !

Olivopiment a écrit :

Merci les gars, en effet, le pb des commandes persistantes dans le terminal est résolu et ça c'est top cool !
Par contre, je n'arrive pas à accéder à ma nexus 7 à chaque fois, et quand j'utilise gMTP, il me met presque à chaque fois un message d'erreur quand je le lance, ou alors il se grise et devient très lent ... je crois que cela devrait être un autre topic, non ?

attention aux commandes echo >> qui permettent d'ajouter des lignes aux scripts sans re-editer !
ne pas confondre le guillemet simple ' et le guillemet double " ; deux guillemets simples '' ne sont pas equivalents a un guillemet double " !

Hors ligne

Haut de page ↑