Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 06/12/2012, à 15:30

touttou

Syslog

Salut,
voici un exercice que j'ai essayé de résodre:

configurer syslog afin que tous les logs d'authentification de niveau exactement debug soient affichés dans la console.


pour ce faire j'ai ajouté la ligne suivante à /etc/rsyslog.d/50-default.conf

auth.=debug        /dev/pts/0

le problème c'est que d'habitude pour tester j'utilise logger -p ...Mais pour cet exemple je ne sais pas comment tester que ça fonctionne .

Merci beaucoup

Hors ligne

#2 Le 09/12/2012, à 19:58

pode

Re : Syslog

touttou a écrit :
auth.=debug        /dev/pts/0

Essaie plutôt (c.à-d. avec ajout du |) :

auth.=debug        |/dev/pts/0

et un redémarrage du service :

service rsyslog restart

Le test suivant :

logger -p auth.debug "bonjour"

donne dans le terminal correspondant à /dev/pts/0 :

[pode@pode-HP-G72-Notebook-PC 19:56:58 ~]$ 
[pode@pode-HP-G72-Notebook-PC 19:56:58 ~]$ Dec  9 19:57:02 pode-HP-G72-Notebook-PC logger: bonjour

Hors ligne