Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/12/2012, à 17:38

Chre

[Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour les gens,

Depuis que je suis passé en LTS 12.04 64bits, je n'arrive plus à installer les pilotes propriétaires ATI (depuis http://support.amd.com/fr/gpudownload/l … g=English).

J'avais laissé tombé, tant pis pour les effets graphiques. Mais voilà, je fais désormais partie des beta-testeurs Steam, j'ai donc besoin de ces pilotes smile

J'ai téléchargé la dernière version stable de ces pilotes (12.10), et lorsque je lance l'installation, j'obtiens l'erreur suivante :

Supported adapter detected.

[Error]A previous installation of fglrx driver detected to be loaded.
User must uninstall existing fglrx driver
or run install with force option.
Forcing the installation is not recommended.

Mais elle est où cette ancienne installation ? (j'avais, me semble-t-il, tout désinstallé).
Le répertoire /usr/share/ati est vide, à l'exception d'un fichier .log et .txt.

J'ai une carte ATI RADEON HD 6770, une machine linux Ubuntu

Ubuntu 12.04.1 LTS

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS

Linux chre-i5-ubuntu 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


J'avoue que je suis perdu. Toute aide sera vraiment appréciée.
Merci d'avance.

Dernière modification par Chre (Le 16/12/2012, à 11:51)

Hors ligne

#2 Le 08/12/2012, à 18:05

SpiKe

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

Peut-être as-tu installé le pilote "fglrx" proposé par Ubuntu (qui n'est autre que le pilote Catalyst édité par AMD, mais dans une version testée par Canonical) ? Peux-tu retourner le résultat de la commande suivante :

apt-cache policy fglrx

Si ce paquet est installé, il te suffit normalement de le désinstaller proprement et de redémarrer tongue

De manière générale, il est recommandé d'installer le pilote fglrx qui figure dans les dépôts, plutôt que de passer par l'installateur générique d'AMD.
De plus, il me semble que des pilotes fglrx expérimentaux destinés à l'utilisation de Steam sont disponibles dans les dépôts Ubuntu.

Dernière modification par SpiKe (Le 08/12/2012, à 18:06)


Utilisateur d'ArchLinux + Gnome / Xfce.
Membre de l'équipe de traduction Xfce francophone.
Xonotic --> un fast-FPS fun et original avec une communauté sympa :-)

Hors ligne

#3 Le 09/12/2012, à 10:58

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

fglrx:
  Installé : (aucun)
  Candidat : 2:8.960-0ubuntu1.1
Table de version :
     2:8.960-0ubuntu1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/restricted amd64 Packages
        100 /var/lib/dpkg/status
     2:8.960-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/restricted amd64 Packages

Oui, les pilotes AMD proposés dans la config. Ubuntu, j'ai essayé, mais sans succès. C'est pour cela que j'ai essayé ceux fournis directement par AMD :
82089a8c-d58a-4ca0-86bb-ebcd8b8dd231.jpg
Le 1er choix, lorsque je l'active, s'installe, mais ne résoud rien. Le 2ème ne s'installe pas du tout (une erreur est survenue, installation impossible, ou quelque chose d'approchant).

Merci pour les pistes.

Hors ligne

#4 Le 11/12/2012, à 07:25

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

SpiKe a écrit :

Si ce paquet est installé, il te suffit normalement de le désinstaller proprement et de redémarrer tongue

Comment puis-je faire ceci ?

Hors ligne

#5 Le 12/12/2012, à 04:59

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Salut,

sudo apt-get remove fglrx puis: sudo rm /etc/X11/xorg.conf et reboot.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#6 Le 13/12/2012, à 12:59

kD

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

J'ai exactement le même problème avec le deuxième driver propriétaire ATI hmm


HP Pavilion DM4 1350sf Intel® Core™ i5 CPU M 480 - 2.67GHz - 4Go ram  -- XUBUNTU 14.04 -- 64 bits -- Firefox

Hors ligne

#7 Le 14/12/2012, à 04:30

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Il ne faut pas installer les pilotes proposes par jockey mais celui du site AMD conrespondant a ta CG, le 12.10 ou 12.11 beta. Vire a nouveau fglrx et xorg.conf reboot et install l'AMD en suivant le point 2.4 (--buildandinstallpkg) du lien ci-dessous:

http://doc.ubuntu-fr.org/catalyst


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#8 Le 14/12/2012, à 07:40

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

faucon50 a écrit :

Salut,

sudo apt-get remove fglrx puis: sudo rm /etc/X11/xorg.conf et reboot.

Avec le apt-get remove fglrx, j'obtiens le résultat suivant :

christian@chre-i5-ubuntu:~$ sudo apt-get remove fglrx
[sudo] password for christian: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet fglrx n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libutouch-evemu1 libutouch-geis1 libutouch-frame1 libutouch-grail1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
christian@chre-i5-ubuntu:~$

Ok pour la suppression de xorg.conf, puis le reboot.

Là, je relance l'installation du pilote ATI propriétaire (amd-driver-installer-catalyst-12.10-x86.x86_64.run), et j'obtiens toujours le message suivant :

A previous install of the fglrx driver has been detected. Please uninstall the older version before installing this version. Optionnally, run the installer with --force option to overwrite the existing driver. Forcing install is not recommended. See /usr/share/ati/fglrx-install.log for more details.

D'autres pistes ?
Merci.

Dernière modification par Chre (Le 14/12/2012, à 07:48)

Hors ligne

#9 Le 14/12/2012, à 08:35

gbagape

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Essayez ici Tutoriel d'installation fglrx
Je me suis servi.

Dernière modification par gbagape (Le 14/12/2012, à 08:37)


Skype: gbagapegb1
Yahoo:gbagape
Ubuntu User # 34906,http://linuxcounter.net/

Hors ligne

#10 Le 14/12/2012, à 10:42

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Essaye un coup: sudo apt-get remove fglrx-updates car il me semble qu'en virant fglrx il installe fglrx-updates sinon comme il dit:  Optionnally, run the installer with --force option to overwrite the existing drive, donc: sudo sh /usr/share/ati/fglrx-uninstall.sh --force et: sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#11 Le 15/12/2012, à 09:03

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

@gbagape : Merci pour le lien, je vais lire très attentivement ce foutu RTFM ; j'aimerais bien y comprendre qq chose à cette histoire smile

faucon50 a écrit :

Essaye un coup: sudo apt-get remove fglrx-updates car il me semble qu'en virant fglrx il installe fglrx-updates sinon comme il dit:  Optionnally, run the installer with --force option to overwrite the existing drive, donc: sudo sh /usr/share/ati/fglrx-uninstall.sh --force et: sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

sudo apt-get remove fglrx-updates

Effectivement, il y avait des choses à enlever smile

christian@chre-i5-ubuntu:~$ sudo apt-get remove fglrx-updates

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libutouch-evemu1 libutouch-geis1 libutouch-frame1 lib32gcc1 libutouch-grail1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  fglrx-amdcccle-updates fglrx-updates
0 mis à jour, 0 nouvellement installés, 2 à enlever et 7 non mis à jour.
Après cette opération, 220 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 625895 fichiers et répertoires déjà installés.)
Suppression de fglrx-amdcccle-updates ...
dpkg : avertissement : lors de la suppression de fglrx-amdcccle-updates, le répertoire « /usr/share/ati » n'était pas vide, donc il n'a pas été supprimé.
Suppression de fglrx-updates ...
Removing all DKMS Modules
Done.
update-alternatives: suppression de l'alternative sélectionnée manuellement - bascule de x86_64-linux-gnu_gl_conf vers le mode automatique
update-alternatives: utilisation de « /usr/lib/pxpress/ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf » (x86_64-linux-gnu_gl_conf) en mode automatique.
update-alternatives: avertissement: création de /usr/bin/amdcccle abandonnée car le fichier associé /usr/lib/fglrx/bin/amdcccle (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/share/applications/ubuntu-amdcccle.desktop abandonnée car le fichier associé /usr/share/fglrx/amdcccle.desktop (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/share/applications/ubuntu-amdccclesu.desktop abandonnée car le fichier associé /usr/share/fglrx/amdccclesu.desktop (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /etc/OpenCL/vendors/amdocl32.icd abandonnée car le fichier associé /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/bin/amdupdaterandrconfig abandonnée car le fichier associé /usr/lib/fglrx/bin/amdupdaterandrconfig (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: création de /usr/bin/amdxdg-su abandonnée car le fichier associé /usr/lib/fglrx/bin/amdxdg-su (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.
update-alternatives: avertissement: /usr/lib/x86_64-linux-gnu/xorg/extra-modules ne sera pas remplacé par un lien.
update-alternatives: utilisation de « /usr/lib/pxpress/alt_ld.so.conf » pour fournir « /etc/ld.so.conf.d/i386-linux-gnu_GL.conf » (i386-linux-gnu_gl_conf) en mode automatique.
update-alternatives: utilisation de « /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf » pour fournir « /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf » (x86_64-linux-gnu_gl_conf) en mode automatique.
update-alternatives: avertissement: /usr/lib/x86_64-linux-gnu/xorg/extra-modules ne sera pas remplacé par un lien.
update-alternatives: utilisation de « /usr/lib/i386-linux-gnu/mesa/ld.so.conf » pour fournir « /etc/ld.so.conf.d/i386-linux-gnu_GL.conf » (i386-linux-gnu_gl_conf) en mode automatique.
update-initramfs: deferring update (trigger activated)
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf.index...
Traitement des actions différées (« triggers ») pour « ureadahead »...
ureadahead will be reprofiled on next reboot
Traitement des actions différées (« triggers ») pour « initramfs-tools »...
update-initramfs: Generating /boot/initrd.img-3.2.0-34-generic
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place

Je poursuis :

sudo sh /usr/share/ati/fglrx-uninstall.sh --force

Là, qq chose ne va pas : le dossier /usr/share/ati est vide comme je l'ai précisé plus haut, donc cette instruction ne fonctionne pas. L'option --force que j'ai indiqué est fourni avec l'installeur, il s'agit donc plutôt de

sudo ./amd-driver-installer-catalyst-12.10-x86.x86_64.run --force

?

Enfin, pour

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

:

christian@chre-i5-ubuntu:$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de xorg-driver-fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-kernel-source pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle-updates pour l'expression rationnelle « fglrx_* »
Note : sélection de xorg-driver-fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-driver-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de xfree86-driver-fglrx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-updates pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-control-qt2 pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-updates-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-glx pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-modaliases pour l'expression rationnelle « fglrx_* »
Note : sélection de xfree86-driver-fglrx-dev pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-driver pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-control pour l'expression rationnelle « fglrx_* »
Note : sélection de fglrx-amdcccle-updates pour l'expression rationnelle « fglrx-amdcccle* »
Note : sélection de fglrx-amdcccle pour l'expression rationnelle « fglrx-amdcccle* »
Note : sélection de xorg-driver-fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Note : sélection de fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Note : sélection de xfree86-driver-fglrx-dev pour l'expression rationnelle « fglrx-dev* »
Le paquet fglrx-amdcccle n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-amdcccle-updates n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-dev n'est pas installé, et ne peut donc être supprimé
Le paquet fglrx-updates-dev n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libutouch-evemu1 libutouch-geis1 libutouch-frame1 lib32gcc1 libutouch-grail1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  fglrx* fglrx-updates* xorg-driver-fglrx*
0 mis à jour, 0 nouvellement installés, 3 à enlever et 7 non mis à jour.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 625622 fichiers et répertoires déjà installés.)
Suppression de fglrx ...
Purge des fichiers de configuration de fglrx ...
update-rc.d: /etc/init.d/atieventsd exists during rc.d purge (use -f to force)
dpkg : erreur de traitement de fglrx (--purge) :
 le sous-processus script post-removal installé a retourné une erreur de sortie d'état 1
Suppression de fglrx-updates ...
Purge des fichiers de configuration de fglrx-updates ...
Suppression de xorg-driver-fglrx ...
Purge des fichiers de configuration de xorg-driver-fglrx ...
Traitement des actions différées (« triggers ») pour « ureadahead »...
Des erreurs ont été rencontrées pendant l'exécution :
 fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ca ne se passe pas tout seul non plus ça...

Que fais-je ?

Hors ligne

#12 Le 15/12/2012, à 09:49

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Poste le contenu de:  /usr/share/ati/fglrx-install.log


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#13 Le 15/12/2012, à 10:37

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

faucon50 a écrit :

Poste le contenu de:  /usr/share/ati/fglrx-install.log

Supported adapter detected.

[Error]A previous installation of fglrx driver detected to be loaded.
User must uninstall existing fglrx driver 
or run install with force option. 
Forcing the installation is not recommended.

Hors ligne

#14 Le 15/12/2012, à 10:53

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Donne le retour de fglrxinfo. Essaye de rechercher ati dans nautilus et vire ce qui reste et retente l'install.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#15 Le 15/12/2012, à 11:05

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

J'ai refait un

$ sudo apt-get remove --purge fglrx fglrx-amdcccle

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet fglrx-amdcccle n'est pas installé, et ne peut donc être supprimé
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libutouch-evemu1 libutouch-geis1 libutouch-frame1 lib32gcc1 libutouch-grail1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  fglrx*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 625613 fichiers et répertoires déjà installés.)
Suppression de fglrx ...
Purge des fichiers de configuration de fglrx ...
dpkg : avertissement : lors de la suppression de fglrx, le répertoire « /usr/lib/x86_64-linux-gnu/xorg/extra-modules » n'était pas vide, donc il n'a pas été supprimé.
Traitement des actions différées (« triggers ») pour « ureadahead »...
ureadahead will be reprofiled on next reboot

Sinon

$ fglrxinfo
fglrxinfo : commande introuvable

Et maintenant, lorsque je lance l'installeur, ça passe !
Je reviens après pour vous dire le résultat de cette installation.

Hors ligne

#16 Le 15/12/2012, à 11:12

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bon, fglrxinfo : commande introuvable = pas installe.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#17 Le 15/12/2012, à 11:16

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

C'est beaucoup mieux semble-t-il smile :

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series  
OpenGL version string: 4.2.11931 Compatibility Profile Context

Quelles autres vérifications puis-je faire ?

Hors ligne

#18 Le 15/12/2012, à 11:17

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Parfait, fais fgl_glxgears, si ca fonctionne, tu peux mettre resolu.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#19 Le 15/12/2012, à 12:29

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

$ fgl_glxgears
Using GLX_SGIX_pbuffer
10647 frames in 5.0 seconds = 2129.400 FPS
12132 frames in 5.0 seconds = 2426.400 FPS
12117 frames in 5.0 seconds = 2423.400 FPS
12129 frames in 5.0 seconds = 2425.800 FPS
8510 frames in 5.0 seconds = 1702.000 FPS
8401 frames in 5.0 seconds = 1680.200 FPS
11240 frames in 5.0 seconds = 2248.000 FPS
12092 frames in 5.0 seconds = 2418.400 FPS
11963 frames in 5.0 seconds = 2392.600 FPS
12099 frames in 5.0 seconds = 2419.800 FPS
12163 frames in 5.0 seconds = 2432.600 FPS
12014 frames in 5.0 seconds = 2402.800 FPS
12114 frames in 5.0 seconds = 2422.800 FPS

Merci big_smile !

Hors ligne

#20 Le 15/12/2012, à 12:46

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Oups ! hmm

Du coup, j'ai voulu activer Compiz Rotation du Cube. Et là, boum dans Unity. Arpès reboot :

$ fglrxinfo
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  14
  Current serial number in output stream:  14

Késaco ?
Il faut que je réinstalle le pilote ATI ?

Hors ligne

#21 Le 15/12/2012, à 13:14

luclegeo

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

bonjour !

j'ai exactement le même souci, je viens de lire ces postes ... je my perd un peu...
Nous donner un recap de la manip a suivre pour avoir accès aux deux drivers ?

Merci d'avance smile

Hors ligne

#22 Le 15/12/2012, à 16:00

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Chre a écrit :

Késaco ?

Unity justement et son compere boiteux compiz. lol Desole, je ne n'utilise ni l'un ni l'autre.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#23 Le 15/12/2012, à 16:07

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

luclegeo a écrit :

Nous donner un recap de la manip a suivre pour avoir accès aux deux drivers ?

Deux drivers ?

Mon problème était le suivant : impossible d'installer le driver propriétaire ATI fourni ici : http://support.amd.com/fr/gpudownload/l … ng=English

En effet, l'installeur du programme me disait

Supported adapter detected.

[Error]A previous installation of fglrx driver detected to be loaded.
User must uninstall existing fglrx driver
or run install with force option.
Forcing the installation is not recommended.

ou encore

A previous install of the fglrx driver has been detected. Please uninstall the older version before installing this version. Optionnally, run the installer with --force option to overwrite the existing driver. Forcing install is not recommended. See /usr/share/ati/fglrx-install.log for more details.


Pour résoudre le problème, j'ai réalisé les opérations suivantes :

$ sudo apt-get remove fglrx
sudo rm /etc/X11/xorg.conf

Puis un reboot
Puis à nouveau les opérations suivantes :

$ sudo apt-get remove fglrx-updates
$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
$ sudo apt-get remove --purge fglrx fglrx-amdcccle

Et là, ok, j'ai pu installer les pilotes propriétaires d'ATI avec la commande

$sudo ./amd-driver-installer-catalyst-12.10-x86.x86_64.run

Ça marche big_smile

Par contre, j'ai voulu activer les effets "cube du bureau" de Compiz, et là plantage du bureau, reboot, et lorsque je relance la commande fglrxinfo pour vérifier, j'ai désormais l'erreur suivante :

$ fglrxinfo
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  14
  Current serial number in output stream:  14

Dois-je ouvrir un nouveau sujet ?

Hors ligne

#24 Le 15/12/2012, à 16:17

fcn50

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Chre a écrit :

sudo ./amd-driver-installer-catalyst-12.10-x86.x86_64.run

C'est sudo sh ./amd-driver-installer-catalyst-12.10-x86.x86_64.run et ca c'est pour une install rapide qui explosera a la prochaine maj de xorg! Perso je fais comme indique au #7.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#25 Le 16/12/2012, à 11:50

Chre

Re : [Résolu] Depuis Precise 12.04, impossible d'installer les pilotes ATI.

Bonjour,

J'ai donc à nouveau tout désinstallé à la main, puis réinstallé les pilotes avec l'installeur. Et c'est à nouveau OK. Je ne touche plus à Compiz alors hmm Je ferais un nouveau post sur ce sujet éventuellement. Je mets donc le statut résolu pour ce post.


faucon50 a écrit :
Chre a écrit :

sudo ./amd-driver-installer-catalyst-12.10-x86.x86_64.run

C'est sudo sh ./amd-driver-installer-catalyst-12.10-x86.x86_64.run et ca c'est pour une install rapide qui explosera a la prochaine maj de xorg! Perso je fais comme indique au #7.

Je ne comprends pas, il ne faut donc pas installer ces pilotes propriétaires ATI comme je l'ai fait ?

Hors ligne

Haut de page ↑