Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 02/09/2005, à 09:55

Tibolo

probleme avec certaines installations

Bonjour,

J'ai eu quelqu'un problèmes dernièrement avec certains installations tel que Clam AV 0.86.2 et Gaim

Bon voila, je commencerai par Clam AV : quand je lance le ./configure, il me demande d'installer 2 paquets :

[...]
checking for fseeko... yes
checking whether snprintf correctly terminates long strings... yes
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for zlib installation... /usr
configure: error: Please install zlib and zlib-devel packages

Alors que le paquet zlib est déjà installé  et le paquet zlib-devel n'existe pas :
Voila ça s'est le 1er problème.


Maintenant Gaim : en fait j'ai fais l'erreur de désinstaller Gaim lorsque j'ai installé aMSN en pensant que je n'en aurai plus besoin sad Quand j'essaye de le réinstaller avec le paquet déjà existant, j'ai cette erreur :

nicolas@koo:~$ sudo apt-get install gaim
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gaim: Depends: gaim-data (= 1:1.4.0-1ubuntu1~5.04ubp1) but 1:1.4.0-1ubuntu1~hoary1 is to be installed
E: Broken packages

le paquet gaim-data est déjà installé mad

j'ai essayé de téléchargé Gaim, mais lorsque je lance ./configure, j'ai d'abord une 1ere erreur :

[...]
checking for silcclient... Package silcclient was not found in the pkg-config search path.
Perhaps you should add the directory containing `silcclient.pc'
to the PKG_CONFIG_PATH environment variable
No package 'silcclient' found

mais il continue la vérification, c'est un peu plus loin lorsqu'il me fait une 2e erreur et qu'il s'arrete :

[...]
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GLIB is incorrectly installed.configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

le paquet Glib 2.0 est déja installé mad

bin voila les problemes que je rencontre, si quelqu'un pouvez m'aider s'il vous plait?
Désolé pour la longueur de mes explications mais j'ai voulu détailler bien pour que vous puissiez mieux analyser l'origine du problème. En fait je suis nouveau sur Linux et j'ai peur de faire quelquechose qui risque d'être irréversible

Merci d'avance pour vos réponses

Dernière modification par Tibolo (Le 02/09/2005, à 10:02)

Hors ligne

#2 Le 02/09/2005, à 10:38

Nanal

Re : probleme avec certaines installations

Ouvre synaptic et dans l'onglet état il doit y avoir une catégorie : locaux ou obsolétes.
Sélectionnes les paquets un à un et à chaque fois tu fais "Forcer la version du paquet" (ctrl+E) et tu passes le tout en hoary en ayant au préalable ajouter le dépot backport officiel.


Avatar : "the mirror of the sun" by bernie (deviantart.com)

Hors ligne

#3 Le 02/09/2005, à 12:17

Tibolo

Re : probleme avec certaines installations

et quel est le dépot backport officiel s'il te plait? smile

Hors ligne

#4 Le 02/09/2005, à 14:03

Nanal

Re : probleme avec certaines installations

deb http://archive.ubuntu.com/ubuntu hoary-backports main universe multiverse restricted


Avatar : "the mirror of the sun" by bernie (deviantart.com)

Hors ligne

#5 Le 02/09/2005, à 21:07

Tibolo

Re : probleme avec certaines installations

Ouvre synaptic et dans l'onglet état il doit y avoir une catégorie : locaux ou obsolétes.
Sélectionnes les paquets un à un et à chaque fois tu fais "Forcer la version du paquet" (ctrl+E) et tu passes le tout en hoary en ayant au préalable ajouter le dépot backport officiel.

bon pour gaim le probleme est réglé mais pour Clam AV, je ne retrouve pas les paquets zlib dans la catégorie locaux ou obsolètes neutral

Hors ligne

Haut de page ↑