Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 02/09/2005, à 10:10

EScTB

probleme au demarrage de gnome

Salut

j'ai un probleme lors du demarrage de gnome; il m'affiche se message d'erreurs et je ne sais pas a quoi il est du ni comment le supprimer.
voila le message:

Erreur lors de l'activation de la configuration XKB.
Cela peut arriver pour plusieurs raisons :
- un bogue dans la bibliothèque libxklavier
- un bogue dans le serveur X (xkbcomp, utilitaires xmodmap)
- serveur X avec une implémentation de libxkbfile incompatible

Données de version du serveur X :
The X.Org Foundation
60802000

Si vous rapportez cette situation comme une anomalie, veuillez inclure :
- Le résultat de <b>xprop -root | grep XKB</b>
- Le résultat de <b>gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd</b>

Ce message est apparu apres avoir fait un fglrxconfig lorsque j'ai installer les driver ati(qui marche tres bien) et n'apparait que au demarrage de gnome (aucun probleme avec enlightenment).

si quelqu'un a une idee pour le supprimer, dites le moi

Merci d'avance

Eric

#2 Le 02/09/2005, à 10:33

Nanal

Re : probleme au demarrage de gnome

Normalement il y a un autre message qui te demande si tu veux utiliser la configuration de Gnome ou celle du serveur X.

Pour résoudre ce problème manuellement il faut que tu édites le fichier /etc/X11/xorg.conf

sudo gedit /etc/X11/xorg.conf

ensuite tu cherches la section correspondant au clavier (keyboard) et tu dois changer le paragraphe comme ceci :

#    Option "XkbDisable"

    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105"
    Option "XkbLayout"    "fr-latin9"

EndSection

Normalement ça devrait régler le problème (si tu as un clavier AZERTY français)


Avatar : "the mirror of the sun" by bernie (deviantart.com)

Hors ligne

#3 Le 02/09/2005, à 10:48

EScTB

Re : probleme au demarrage de gnome

Salut

Merci pour cette reponse qui mon probleme

Effectivement j'ai eu ce 2eme message d'erreurs la premiere fois seulement

Encore merci

Eric

#4 Le 02/09/2005, à 11:12

EScTB

Re : probleme au demarrage de gnome

salut

j'ai eu un probleme mon serveur x ne voulait demarrer, j'ai refait un fglrxconfig pour que je puisse de nouveau revenir en graphique.

voila mon xorg.cong section input device, pourrait tu me montrer ce que je dois changer?
merci d'avance

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"kbd"
# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option "Protocol"   "Xqueue"

    Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#    Option "Xleds"      "1 2 3"

#    Option "LeftAlt"    "Meta"
#    Option "RightAlt"   "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"   "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"   "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"  "de"
# or:
#    Option "XkbLayout"  "de"
#    Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions" "ctrl:swapcaps"

# These are the default XKB settings for XFree86
#    Option "XkbRules"   "xfree86"
#    Option "XkbModel"   "pc101"
#    Option "XkbLayout"  "us"
#    Option "XkbVariant" ""
#    Option "XkbOptions" ""

#    Option "XkbDisable"

    Option "XkbRules"	"xfree86"
    Option "XkbModel"	"pc101"
    Option "XkbLayout"	"be"

EndSection

Eric

#5 Le 02/09/2005, à 11:40

tuxik

Re : probleme au demarrage de gnome

ton probleme avec Xkb du debut vient de la

# These are the default XKB settings for XFree86
#    Option "XkbRules"   "xfree86"
#    Option "XkbModel"   "pc101"

il faut mettre :

# These are the default XKB settings for XFree86
#    Option "XkbRules"   "xorg"
#    Option "XkbModel"   "pc101"

cela vient du faite qu'auparavant le serveur d'affichage sous linux etait xfree86. Mais depuis peu,c'est xorg qui s'en occupe.

Dernière modification par tuxik (Le 02/09/2005, à 11:41)

Hors ligne

#6 Le 02/09/2005, à 14:04

Nanal

Re : probleme au demarrage de gnome

Ces lignes en dessous qu'il doit modifié, celle que tu montres on un # en début de ligne donc ne sont pas interprétées (commentaires)


Avatar : "the mirror of the sun" by bernie (deviantart.com)

Hors ligne

Haut de page ↑