Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/12/2012, à 17:27

Piteur

{Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Bonjour.

Je souhaiterais reproduire le comportement du clavier que j'ai pu obtenir sur Ubuntu 12.04 (Unity), à savoir :

  • lorsque j'appuie sur la touche CAPS-LOCK, les majuscules sont activées
     

  • pour désactiver la touche CAPS-LOCK, j'appuie sur la touche SHIFT (située juste sous la touche "caps-lock").

C'est ce qui correspond au mode "typewriter", c'est à dire au fonctionnement des machines à écrire mécaniques. C'est ainsi que j'ai appris à dactylographier : devoir réappuyer sur CAPS-LOCK m'incommode pour désactiver la touche CAPS-LOCK (ralentissement de la saisie).

Quelqu'un saurait-il comment obtenir ce comportement du clavier sous Xfce ?

Merci pour toute réponse.

Dernière modification par Piteur (Le 26/12/2012, à 11:41)


Newbie parfait avec Ubuntu : soyez patient(e). Grand merci !
Acer Aspire 5733Z - Ubuntu 12.04 LTS - Unity 3D
Toshiba Satellite M40-331 - Xubuntu 12.04 LTS - Xfce

Hors ligne

#2 Le 19/12/2012, à 17:43

serged

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Le comportement aberrant du clavier français de Windows 9x (à l'époque on se demandait ce qu'avait Bill Gates contre les français...).

Comme on dit, chacun ses goûts (et la m... a le sien).
Tu dois pouvoir t'en tirer dans "Agencement clavier", onglet "Agencement" et cliquer sur "Options". Il y a plein d'options sur le comportement des touches "Majuscule" et "Verr-maj".


Linux-Mint Qiana 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#3 Le 19/12/2012, à 18:56

Piteur

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

serged a écrit :

Tu dois pouvoir t'en tirer dans "Agencement clavier", onglet "Agencement" et cliquer sur "Options". Il y a plein d'options sur le comportement des touches "Majuscule" et "Verr-maj".

Oui, pour Gnome. Sur le PC où Ubuntu est installé, tout, comme je l'ai dit, est en ordre de marche.
Mais je te parle de Xfce (soux Xubuntu)........ hmm


Newbie parfait avec Ubuntu : soyez patient(e). Grand merci !
Acer Aspire 5733Z - Ubuntu 12.04 LTS - Unity 3D
Toshiba Satellite M40-331 - Xubuntu 12.04 LTS - Xfce

Hors ligne

#4 Le 25/12/2012, à 13:21

The Uploader

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Salut

J'ai trouvé ça :

http://brainextender.blogspot.fr/2008/08/ubuntux11xorg-capslock-unlockcancel.html a écrit :

To get your Xorg desktop to behave like a typewriter regarding the caps lock key simply place this line

  Option "XkbOptions" "caps:shiftlock"

into your /etc/X11/xorg.conf file and restart your Xorg server, e.g. with CTRL-ALT-BACKSPACE.

Here is where to place the line in the file mentioned above:

Section "InputDevice"
   Identifier "Keyboard0"
   Driver "kbd"
   Option "XkbOptions" "caps:shiftlock"
EndSection

À tester...

edit : chez moi ça fonctionne avec le fichier /etc/X11/xorg.conf.d/10-keyboard.conf qui a pour contenu :

Section "InputClass"
    Identifier      "Keyboard Defaults"
    MatchIsKeyboard "on"
    Option          "XkbLayout" "fr"
    Option          "XkbModel" "asus_laptop"
    Option          "XkbOptions" "caps:shiftlock"
EndSection

On peut remplacer "asus_laptop" (qui correspond au clavier d'un ordinateur portable de marque Asus) par "pc105" par exemple.

C'est effectif après un redémarrage.

Dernière modification par The Uploader (Le 25/12/2012, à 13:44)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#5 Le 25/12/2012, à 18:57

p.lrt

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Merci pour l'astuce qui  fonctionne correctement chez moi mais avec le fichier : /usr/share/X11/xorg.conf.d/10-keyboard.conf

@+


ASUS K53E - Xubuntu 12-04  64bits   ---    SONY VGN38E Xubuntu 12-04 32bits

Hors ligne

#6 Le 25/12/2012, à 23:43

Piteur

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Je n'arrive pas à localiser l'un ou l'autre des fichiers mentionnés dans ce fil.

piteur@Toshiba-Satellite-M40-331:~$ locate xorg.conf
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/11-evdev-quirks.conf
/usr/share/X11/xorg.conf.d/11-evdev-trackpoint.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf
/usr/share/man/man5/xorg.conf.5.gz
/usr/share/man/man5/xorg.conf.d.5.gz

Comme je suis débutant dans le monde Linux, ce n'est pas très étonnant sad. Une aide ?

Merci.

Dernière modification par Piteur (Le 25/12/2012, à 23:48)


Newbie parfait avec Ubuntu : soyez patient(e). Grand merci !
Acer Aspire 5733Z - Ubuntu 12.04 LTS - Unity 3D
Toshiba Satellite M40-331 - Xubuntu 12.04 LTS - Xfce

Hors ligne

#7 Le 26/12/2012, à 02:02

The Uploader

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Il faut le créer, le fichier /usr/share/X11/xorg.conf.d/10-keyboard.conf

Il a pour le contenu ce que j'ai posté au dessus (sauf qu'il faut remplacer "asus_laptop" par "pc105").

Ce qui donne :

Section "InputClass"
    Identifier      "Keyboard Defaults"
    MatchIsKeyboard "on"
    Option          "XkbLayout" "fr"
    Option          "XkbModel" "pc105"
    Option          "XkbOptions" "caps:shiftlock"
EndSection

Dernière modification par The Uploader (Le 26/12/2012, à 02:03)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#8 Le 26/12/2012, à 11:38

Piteur

Re : {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

EX-CEL-LENT !!! Ça marche au petit poil ! big_smile

Merci beaucoup à The Uploader, mais aussi à p.lrt


Newbie parfait avec Ubuntu : soyez patient(e). Grand merci !
Acer Aspire 5733Z - Ubuntu 12.04 LTS - Unity 3D
Toshiba Satellite M40-331 - Xubuntu 12.04 LTS - Xfce

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » {Résolu] CAPS-LOCK : mode "typewriter" p. désactiver la touche (Xfce)

Haut de page ↑