Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 27/12/2012, à 01:59

PascalHambourg

Re : Problème de connection WIFI

Cela explique pourquoi le module n'est pas chargé.
On peut voir que les modules qui provoquent les erreurs ne proviennent pas du noyau 3.2 mais du paquet linux-backports-modules-cw-3.3-3.2.0-24-generic-pae. J'ignore si cela a un lien avec les erreurs.
Quelque chose dans la sortie de dmesg concernant ces modules pour essayer d'en savoir plus ?

EDIT : pour être sûr, tu as bien lancé la commande modprobe en root ou avec sudo ?

Dernière modification par PascalHambourg (Le 27/12/2012, à 02:03)

Hors ligne

#52 Le 27/12/2012, à 18:34

Vlx

Re : Problème de connection WIFI

Je suis connecté avec un cordon USB sur un telephone portable android en mode Modem.

La commande Modprobe a été exectuté dans le terminal tel que tu l'as écrite

Hors ligne

#53 Le 27/12/2012, à 18:41

PascalHambourg

Re : Problème de connection WIFI

Mais dans un terminal root ou après avoir exécuté su (l'invite doit se terminer par # et non $) ?
Sinon, il faut utiliser sudo <commande> pour l'exécuter en root.  En utilisateur standard, on n'a pas les droits pour charger des modules.

Hors ligne

#54 Le 27/12/2012, à 18:54

Vlx

Re : Problème de connection WIFI

En root.
( Quand je fais "su" , je tape mon mot de passe j'ai une erreur d'authentification ... Pourtant, c'est le bon hmm )

Hors ligne

#55 Le 27/12/2012, à 18:56

Vlx

Re : Problème de connection WIFI

OH MON DIEU CA MARCHE O_o

Je ne sais pas comment, mais ça marche !
( J'ai télécharger des paquets supplementaires à Ndiswrapper, un lien ? )

Hors ligne

#56 Le 27/12/2012, à 20:25

PascalHambourg

Re : Problème de connection WIFI

Vlx a écrit :

Quand je fais "su" , je tape mon mot de passe j'ai une erreur d'authentification ... Pourtant, c'est le bon

Si c'est ton mot de passe utilisateur que tu tapes, alors c'est normal : c'est le mot de passe root qu'il faut taper. Et s'il n'y en a pas, on ne peut pas utiliser su directement, il faut passer par sudo, par exemple "sudo -s" pour ouvrir un shell root.

Je ne sais pas comment, mais ça marche !
( J'ai télécharger des paquets supplementaires à Ndiswrapper, un lien ? )

Qu'est-ce qui marche au juste ? Et qu'as-tu fait exactement ? Si tu n'as pas récupéré le driver pour Windows sur ton système Linux, ndiswrapper n'y est probablement pour rien.

Dernière modification par PascalHambourg (Le 27/12/2012, à 20:27)

Hors ligne

#57 Le 27/12/2012, à 23:27

Vlx

Re : Problème de connection WIFI

C'est "sudo modprobe ath9k" !
Le seul hic, c'est qu'il faut le refaire à chaque redemarrage...
Une solution ?

Merci beaucoup Pascal pour ton aide précieuse et aux autres contributeurs à m'avancer dans mon problème smile

Hors ligne

#58 Le 28/12/2012, à 00:14

toutafai

Re : Problème de connection WIFI

Bizarre que le module ne se charge pas automatiquement...essaye cette manipulation pour le forcer au démarrage

sudo gedit /etc/modules

a la fin du fichier tu ajoute la ligne suivante

ath9k

Tombé dans l'informatique étant petit, j'en ai fait mon métier. Utilisateur d'Ubuntu depuis novembre 2006, actuellement sous 20.04 x64 (Que d'évolution
depuis Dapper Drake ! Ça rajeunit pas ^^^).

Hors ligne

#59 Le 28/12/2012, à 01:51

PascalHambourg

Re : Problème de connection WIFI

En effet c'est étonnant que le module ath9k ne soit pas chargé automatiquement alors que le matériel correspondant est présent. Il faudrait vérifier à tout hasard s'il ne fait pas l'objet d'un traitement particulier type blacklist dans /etc/modprobe.conf ou un fichier sous le répertoire /etc/modprobe.d/. Ceci devrait le faire :

grep -r ath9k /etc/modprobe*

Hors ligne

#60 Le 28/12/2012, à 16:37

toutafai

Re : Problème de connection WIFI

Effectivement, cette commande nous le dira...cela me rappelle un cas avec madwifi, ou c'etait dans blacklist-ath_pci.conf .... roll


Tombé dans l'informatique étant petit, j'en ai fait mon métier. Utilisateur d'Ubuntu depuis novembre 2006, actuellement sous 20.04 x64 (Que d'évolution
depuis Dapper Drake ! Ça rajeunit pas ^^^).

Hors ligne

#61 Le 28/12/2012, à 19:20

Vlx

Re : Problème de connection WIFI

/etc/modprobe.d/ath9k.conf:options ath9k nohwcrypt=1
/etc/modprobe.d/ath9k.conf:options ath9k nohwcrypt=1
/etc/modprobe.d/ath9k.conf:options ath9k nohwcrypt=1

Hors ligne

#62 Le 29/12/2012, à 00:28

PascalHambourg

Re : Problème de connection WIFI

C'est juste pour ajouter un paramètre au chargement du module (bizarre quand même que la même ligne y soit trois fois), donc ça n'explique pas le problème. Qu'affiche modinfo ath9k ?

Hors ligne