Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/12/2012, à 13:06

DaD92

Ouverture de session dans l'écran N°2

Salut à tous,

Nouvel utilisateur de linux depuis peu, j'ai un soucis que je n'arrive pas à résoudre seul.
J'ai 2 écran sur mon PC :
1 celui du portable, donc le principal
2 une TV branché en HDMI

Dans "affichage" l'écran de mon portable est configuré comme étant le principal par defaut, pourtant, quand je démarre le PC, l'écran de connection (où on tape son mot de passe) est systématiquement affiché sur la TV.

Au lancement d'apply, elles s'ouvrent quasi systématiquement aussi dans la TV.

Si quelqu'un à une piste pour régler ça, je suis preneur....

Merci
DaD

Hors ligne

#2 Le 26/12/2012, à 18:56

Maisondouf

Re : Ouverture de session dans l'écran N°2

C'est quoi comme carte écran ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 26/12/2012, à 18:58

DaD92

Re : Ouverture de session dans l'écran N°2

J'ai une Nvidia 260M

Hors ligne

#4 Le 26/12/2012, à 19:53

Maisondouf

Re : Ouverture de session dans l'écran N°2

Ok va dans 'nvidia-settings' et choisi avec cet utilitaire l'écran que tu veux comme écran principal.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 26/12/2012, à 19:54

DaD92

Re : Ouverture de session dans l'écran N°2

C'est déjà paramétré dans Nvidia setting... Je pige pas d'où ça vient.....

Mon fichier de config, ou cas où ça pourrait aidé...

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.51  (buildd@komainu)  Fri Oct 12 12:53:49 UTC 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LGD"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Dernière modification par DaD92 (Le 26/12/2012, à 20:10)

Hors ligne

#6 Le 26/12/2012, à 20:13

Maisondouf

Re : Ouverture de session dans l'écran N°2

Effectivement, nvidia-settings règle le fonctionnement du serveur X, mais pas celui de l'écran de login.

A mon avis il faut que tu regardes dans le setup du PC si il y a moyen de donner une préférence.


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 26/12/2012, à 20:14

DaD92

Re : Ouverture de session dans l'écran N°2

Et où est ce que je peux trouver ces paramètres, t'as une idée?

Hors ligne

#8 Le 26/12/2012, à 20:22

Maisondouf

Re : Ouverture de session dans l'écran N°2

Quand tu allumes le PC, il doit y avoir un message du style

appuyez sur <stroumph> pour accéder au SETUP

En général c'est <SUPR>, <DEL>, <F2> , ...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#9 Le 26/12/2012, à 20:24

DaD92

Re : Ouverture de session dans l'écran N°2

tu parle du bios?
si c'est ça, j'ai aucune option qui me permette de définir un écran par defaut. D'ailleur avant le lancement de l'interface graphique de Kubuntu, tout s'affiche dans l'écran du portable comme il se doit...

Hors ligne

#10 Le 26/12/2012, à 20:27

Maisondouf

Re : Ouverture de session dans l'écran N°2

AH bonne info !!!
Donc au boot pour le PC, le lcd est l'écran principal....
Je fouille le paramétrage de lightdm.....

Edit : euh kdm

Dernière modification par Maisondouf (Le 26/12/2012, à 20:27)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#11 Le 26/12/2012, à 20:44

Maisondouf

Re : Ouverture de session dans l'écran N°2

Si tu lances

kdm -nodaemon

ça dit quoi ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#12 Le 26/12/2012, à 20:55

DaD92

Re : Ouverture de session dans l'écran N°2

ça dit que c'est pas installé :

Le programme 'kdm' n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt-get install kdm

Hors ligne

#13 Le 26/12/2012, à 21:15

Maisondouf

Re : Ouverture de session dans l'écran N°2

ok alors c'est pas l'ecran KDE que t'as au login c'est celui de gnome (lightdm ou gdm) ou celui de XFCE (xdm).
Le tout est de savoir lequel est lancé pour pouvoir bricoler sa config....

ls /etc/init.d/*dm

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#14 Le 26/12/2012, à 21:23

DaD92

Re : Ouverture de session dans l'écran N°2

/etc/init.d/lightdm

si j'installais kdm, ça règlerais pas le problème?
Il a surement été désinstallé quand j'ai désinstaller gnome et viré les dépendance orpheline....

Dernière modification par DaD92 (Le 26/12/2012, à 21:34)

Hors ligne

#15 Le 26/12/2012, à 22:00

DaD92

Re : Ouverture de session dans l'écran N°2

Je devrais pouvoir faire ça, non :

sudo apt-get install kdm
sudo dpkg-reconfigure kdm

et je devrais me retrouvé avec le gestionnaire de session par defaut de kde....
Y'a un risque?

Hors ligne

#16 Le 26/12/2012, à 22:42

DaD92

Re : Ouverture de session dans l'écran N°2

bon, j'ai ré installer kdm et ça a régler mon problème, merci pour ton aide Maisondouf.

je vois que tu as un asus, tu as des led qui éclaire le pc? tu sais comment les contrôler sous linux? les miennes me font chier quand le pc est en veille, elles clignottent...

Hors ligne

#17 Le 27/12/2012, à 02:19

Maisondouf

Re : Ouverture de session dans l'écran N°2

J'ai une led sur la carte mère qui est allumée tout le temps (si il y a le 220V) et une led sur la façade du boitier qui s'éteint quand j'éteint, qui s'allume quand j'allume et....
qui clignote en veille.
Je sais bien que c'est Noël, mais mon PC c'est pas un sapin lol


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#18 Le 27/12/2012, à 02:21

DaD92

Re : Ouverture de session dans l'écran N°2

t'as du bol, j'ai une énorme led sur le capot qui clignote toute l'année smile

Hors ligne

Haut de page ↑