Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 29/12/2012, à 22:05

tatacharles

probleme serveur VSFTPD avec ssl

Bonjour,

j'ai récemment installé un serveur VSFTPD qui marche très bien en local et en accès par internet. mais des que je mets la config SSL ça ne marche plus.

Voila ma config vsftpd.conf pour le SSL :

# Options for SSL
# encrypted connections.

ssl_enable=YES
allow_anon_ssl=NO
force_local_data_ssl=NO
force_local_logins_ssl=YES


ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES

rsa_cert_file=/etc/ssl/private/vsftpd.cert.pem
rsa_private_key_file=/etc/ssl/private/vsftpd.key.pem

pasv_enable=YES
pasv_promiscuous=NO
pasv_min_port=1900
pasv_max_port=2000
pasv_address=87.XX.XX.XXX
port_promiscuous=NO

ssl_ciphers=HIGH




Voila ce que filezilla me renvoi :

Statut :    Connexion à 87.XX.XX.XX:21...
Statut :    Connexion établie, attente du message d'accueil...
Réponse :    220 Welcome everybody I'M THE BEST.
Commande :    AUTH TLS
Réponse :    234 Proceed with negotiation.
Statut :    Initialisation de TLS...
Statut :    Vérification du certificat...
Commande :    USER tata
Statut :    Connexion TLS/SSL établie.
Réponse :    331 Please specify the password.
Commande :    PASS ********
Réponse :    230 Login successful.
Commande :    OPTS UTF8 ON
Réponse :    200 Always in UTF8 mode.
Commande :    PBSZ 0
Réponse :    200 PBSZ set to 0.
Commande :    PROT P
Réponse :    200 PROT now Private.
Statut :    Connecté
Statut :    Récupération du contenu du dossier...
Commande :    PWD
Réponse :    257 "/srv/ftp/tata"
Commande :    TYPE I
Réponse :    200 Switching to Binary mode.
Commande :    PASV
Réponse :    227 Entering Passive Mode (87,XX,XX,XX,7,147).
Commande :    LIST
Réponse :    150 Here comes the directory listing.


Si quelqu'un à une solution je suis preneur smile ça fait déjà plusieurs jours que je cherche sans trouver de solution

édit : dans la config de la box j'ai ouvert le port 21
et ouvert une plage de port de 1900 à 2000 et mis en port de destination 1900

Dernière modification par tatacharles (Le 29/12/2012, à 22:35)

Hors ligne

#2 Le 30/12/2012, à 01:17

Maisondouf

Re : probleme serveur VSFTPD avec ssl

Je ne comprends pas ce qui ne marche pas...
Tu lances l'authentification tls et c'est ok
Tu fais le login/passwd et c'est ok
Tu fais 'pwd' et il répond  "/srv/ftp/tata"

C'est quoi qui va pas ?

EDIT : svp, utilise les crochets bleus '<>' en haut pour encadrer tes textes

Dernière modification par Maisondouf (Le 30/12/2012, à 01:18)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

Haut de page ↑