Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#51 Le 13/01/2013, à 21:03

PounkyM

Re : Installation de dovecot

Ok, je vais essayer de voir ça.

Et sinon, pour revenir à ma question du hostname, est-ce que mes fichiers hosts et hostname sont cohérents ? (post #43)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#52 Le 13/01/2013, à 21:17

sylvain1970

Re : Installation de dovecot

 % cat /etc/hostname 
raspberrypi
 % cat /etc/hosts
127.0.0.1	localhost
192.168.0.12 smtp.example.org smtp
192.168.0.12	raspberrypi

si tu regardes le tuto, ce n'est pas ce qui est indiqué :
hostname :
smtp.example.org

hosts :
127.0.0.1 localhost localhost.localdomain smtp smtp.example.org

Hors ligne

#53 Le 13/01/2013, à 21:25

PounkyM

Re : Installation de dovecot

Oui, mais mon problème, c’est que lorsque je fais comme dans le tuto, ça change le nom de ma machine :

[user@smtp ~] % cat /etc/hostname 
smtp.monNomDeDomaine.org
[user@smtp ~] % cat /etc/hosts
127.0.0.1 localhost localhost.localdomain smtp smtp.monNomDeDomaine
192.168.0.12 smtp.monNomDeDomaine smtp
192.168.0.12 raspberrypi

Maintenant, je n’ai plus user@raspberrypi…

Dernière modification par PounkyM (Le 13/01/2013, à 21:54)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#54 Le 13/01/2013, à 21:53

sylvain1970

Re : Installation de dovecot

Il est important de conserver user@raspberrypi ?
(ton domaine est indiqué dans ton post précédent dans le hostname)
Si oui, alors remet raspberrypi dans hostname.

Hors ligne

#55 Le 13/01/2013, à 21:54

PounkyM

Re : Installation de dovecot

Ben, c’est juste que ça fait bizarre d’avoir smtp en nom de machine quoi !

(merci pour ta remarque, j’ai corrigé)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#56 Le 24/01/2013, à 16:46

PounkyM

Re : Installation de dovecot

@src : Bon. N’ayant pas trop de temps devant moi, j’ai suivi le tuto de src, et victoire, j’arrive à envoyer des mails depuis Thunderbird… Mais par contre, je n’arrive pas à en recevoir!

Pourquoi ?


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#57 Le 24/01/2013, à 20:52

src

Re : Installation de dovecot

Ton domaine de messagerie existe-t-il sur internet ? As-tu redirigé le port 25 de ton routeur vers ton serveur ?
Je suis un peu surpris car mon tuto détaille la partie réception des mails, pour l'envoi c'est une simple note tongue


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#58 Le 24/01/2013, à 20:54

PounkyM

Re : Installation de dovecot

Pour le port 25, j’ai ouvert le port 25 de ma freebox vers mon serveur.

Pour mon domaine de messagerie, j’ai créé un champ A et MX smtp.monDomaine.org sur mon manager OVH… Est-ce bien ça dont tu parles ?


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#59 Le 24/01/2013, à 21:02

src

Re : Installation de dovecot

Le champ mx doit etre "mondomaine.org" et doit pointer vers "smtp.mondomaine.org"
Le champ A doit contenir "smtp.mondomaine.org"
Est-ce correct ?

Ensuite, sur ton serveur, dans le dpkg-reconfigure postfix tu dois spécifier "mondomaine.org" quand il te demande les domaines pour lesquels il faut accepter le courrier.

Ensuite si Postfix et Dovecot sont bien tous deux en maildir, tu devrais voir les mails arriver dans thunderbird !

Dernière modification par src (Le 24/01/2013, à 21:03)


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#60 Le 24/01/2013, à 21:12

PounkyM

Re : Installation de dovecot

Voici les différents champs que j’ai dans OVH :

.nomDeDomaine.org MX1 smtp.nomDeDomaine.org
.nomDeDomaine.org A IP_de_mon_serveur
smtp.nomDeDomaine.org A IP_de_mon_serveur

J’ai fait un dpkg-reconfigure dans postfix et j’ai bien spécifié monDomaine.org…

Dernière modification par PounkyM (Le 24/01/2013, à 21:13)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#61 Le 24/01/2013, à 21:45

src

Re : Installation de dovecot

Regarde tes logs postfix !
/var/log/mail.log


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#62 Le 24/01/2013, à 21:46

PounkyM

Re : Installation de dovecot

Justement, mes logs sont vides !


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#63 Le 24/01/2013, à 22:12

PounkyM

Re : Installation de dovecot

Or, j’imagine que si un mail avait été envoyé, cela aurait été notifié dans les logs non ?

Du coup… J’ai des doutes sur l’envoi des mails de tout à l’heure…


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#64 Le 24/01/2013, à 22:39

PounkyM

Re : Installation de dovecot

Par ailleurs, j’aimerais supprimer mon utilisateur (parce que je l’avais créé il y a longtemps) mais comme je me souviens pas de son mot de passe, je préfère le supprimer pour en créer un nouveau… Mais :

 % sudo /usr/sbin/deluser user
Removing user `user1' ...
Warning: group `user1' has no more members.
userdel: user user1 is currently used by process 20082
/usr/sbin/deluser: `/usr/sbin/userdel user1' returned error code 8. Exiting.

% ps aux | grep 20082
user1     20082  0.0  1.1   5996  2208 ?        S    20:08   0:00 dovecot/imap

Est-ce que c’est un bon signe ?


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#65 Le 24/01/2013, à 23:11

src

Re : Installation de dovecot

Pour redéfinir le mot de passe de ton utilisateur, tu peux le faire depuis root :

# passwd user

Quel est le résultat de la commande :

# service postfix status

Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#66 Le 24/01/2013, à 23:13

PounkyM

Re : Installation de dovecot

Ok, j’ai redéfini un mot de passe.

Pour l’était de postfix, il semble bien en marche :

% sudo service postfix status 
sudo: service: command not found
 % sudo /etc/init.d/postfix status 
[ ok ] postfix is running.

"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#67 Le 24/01/2013, à 23:18

PounkyM

Re : Installation de dovecot

J’ai essayé à nouveau de créer un compte sur Thunderbird et j’ai mis :

Serveur entrant : IMAP nomdedomaine.org port 143  STARTTLS mot de passe normal
Serveur sortant : SMTP stmp.free.fr:465 (défaut)

Quand je valide, Thunderbird m’avertit : « paramètre du courrier sortant : mail.nomdedomaine.org n’utilise pas de chiffrement »… C’est dangereux ?


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#68 Le 24/01/2013, à 23:22

src

Re : Installation de dovecot

Ton envoi de mail fonctionne bien mais tu ne passe pas par ton serveur, tu passe par Free, donc c'est hors sujet.
L'important c'est que l'IMAP passe. Mais tu dois mettre le port 993 et sécurité SSL.


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#69 Le 24/01/2013, à 23:25

PounkyM

Re : Installation de dovecot

Alors, quand je choisis 993, il m’indique : « Thunderbird n’a pas réussi à trouver les paramètres pour votre compte courrier »


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#70 Le 25/01/2013, à 15:36

PounkyM

Re : Installation de dovecot

Up!


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#71 Le 25/01/2013, à 23:22

PounkyM

Re : Installation de dovecot

Up-up-up!


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#72 Le 26/01/2013, à 10:08

src

Re : Installation de dovecot

Le fait que Thunderbird ne détecte pas tes paramètres ne veut pas dire que c'est incorrect.
Il faut que tu fasse la configuration manuelle. Quand il commence à chercher les paramètres tu dois cliquer sur "configuration manuelle".

Pour la ligne IMAP tu spécifies le N° de port (ce qui va compléter le champ SSL) puis tu mets "Mot de passe normal" dans le champ "authentification".

Dans l'identifiant un peu plus bas tu mets le nom du compte utilisateur que tu as créé.

Si thunderbird continue à te bloquer essaie avec seamonkey, il n'y a pas de détection automatique donc c'est plus souple.

Dernière modification par src (Le 26/01/2013, à 10:09)


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#73 Le 26/01/2013, à 13:09

PounkyM

Re : Installation de dovecot

Oui c’est ce que je faisais la config manuelle sauf que lorsque j’ai tout bien rempli (IMAP nomdedomaine.org 993 SSL mdp normal // SMTP free.fr) et que je valide, il mouline sans fin sur « vérification du mot de passe »… Et fini par me dire : « L’identifiant ou le mot de passe est invalide »…

Pourtant, j’ai vérifié que c’était le bon mot de passe en me connectant au serveur via le mot de passe que j’avais entré et il est correct. :x

Dernière modification par PounkyM (Le 26/01/2013, à 13:11)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#74 Le 26/01/2013, à 16:34

PounkyM

Re : Installation de dovecot

Pour être sûr que j’ai bien configuré Postfix, j’ai refait un dpkg-reconfigure et voici ce que j’ai mis :

% sudo /usr/sbin/dpkg-reconfigure postfix
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
setting synchronous mail queue updates: false
setting myorigin
setting destinations: nomdedomaine.org, raspberrypi, localhost.localdomain, localhost
setting relayhost: 
setting mynetworks: 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
clearing mailbox_command
setting mailbox_size_limit: 0
setting recipient_delimiter: *
setting inet_interfaces: all
setting inet_protocols: all
WARNING: /etc/aliases exists, but does not have a root alias.

Postfix is now set up with the changes above.  If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed.  To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
[ ok ] Starting Postfix Mail Transport Agent: postfix.

EDIT : à un moment une question était : « Use procmail for local delivery » et j’ai mis « no » mais par défaut c’était mis sur yes, et avant j’avais laissé sur yes… c’était peut-être ça le problème ?)

Dernière modification par PounkyM (Le 26/01/2013, à 16:36)


"La liberté est un bagne aussi longtemps qu'un seul homme est asservi sur la terre"

Hors ligne

#75 Le 26/01/2013, à 17:49

src

Re : Installation de dovecot

Peu importe, Thunderbird se connecte à Dovecot, pas à Postfix.
Tu peux vérifier que Dovecot tourne avec la commande service dovecot status.

Question, tu fais tes manips en réseau local ? Parce que dans ce cas essaie de mettre l'IP du serveur et pas son nom de domaine.
Le nom de domaine est l'IP extérieure et si tu fais tout en local cela peut poser des soucis.


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

Haut de page ↑