Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#126 Le 09/09/2013, à 14:08

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

symba a écrit :

Oui merci beaucoup pour ton aide.
Une fois qu'on a compris le conflit ça va mieux, mais j'avais du mal à identifier ce que relève d'un dépôt ou d'un autre.
Du coup il vaut mieux que je supprime carrément mon dépôt qgis dans synaptic?

Edit: en fait le dépôt est déjà décoché.

Tu peux le supprimer carrement oui. De toute façon avec ce dépôt tu fais une croix sur l'ecw donc vu que pour toi c'est primordial tu peux le supprimer ...

Hors ligne

#127 Le 19/09/2013, à 14:23

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Salut kikislater,
je ne voudrais pas trop te remobiliser sur cette question mais j'utilise Qgis 2.0 sur  13.04 en 32bits et je n'arrive plus à ouvrir les ecw (j'utilisais avant 1.8 sous 12.10).
j'ai chaque jours besoin de qgis donc j'ai essayé de gérer à partir de vos interventions mais je ne m'en sorts plus à tel point que j'ai peur de déstabiliser mon système (la logithèque ne voulait plus fonctionner l'autre)
Pourrais tu m'aider ?

Merci d'avance

Hors ligne

#128 Le 19/09/2013, à 14:36

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Ah tiens, la v2.0 est sur le ppa en effet !

Je veux bien la réponse de ça :

gdalinfo --formats | grep ECW
apt-cache policy gdal-bin
apt-cache policy gdal
apt-cache policy libgdal-ecw
apt-cache policy libgdal-ecw-src
ls /usr/lib/gdalplugins
ls /usr/src/

Hors ligne

#129 Le 19/09/2013, à 16:56

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Superbe réactivité merci !
Donc :

gdalinfo --formats | grep ECW ne donne rien

ensuite

gdal-bin:
  Installé : 1.10.0-1~raring1
  Candidat : 1.10.0-1~raring1
 Table de version :
 *** 1.10.0-1~raring1 0:/
        100 /var/lib/dpkg/status
     1.9.0-3.1ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
N: Impossible de trouver le paquet gdal
N: Impossible de trouver le paquet libgdal-ecw
libgdal-ecw-src:
  Installé : 1.10.0-1~raring4
  Candidat : 1.10.0-1~raring4
 Table de version :
 *** 1.10.0-1~raring4 0
        100 /var/lib/dpkg/status
ls: impossible d'accéder à /usr/lib/gdalplugins: Aucun fichier ou dossier de ce type
libgdal-ecw-1.10.0.tar.gz       linux-headers-3.8.0-30
linux-headers-3.8.0-29          linux-headers-3.8.0-30-generic
linux-headers-3.8.0-29-generic  virtualbox-4.2.10

et après avoir bricolé de mon côté en débutant que je suis la logithèque ne se lance plus, synaptic m'informe que le pacquet Qgis est cassé et la commande sudo install qgis me donne :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Pas super ...

Hors ligne

#130 Le 19/09/2013, à 19:00

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Il manque du  coup le :
apt-cache policy qgis*

Hors ligne

#131 Le 19/09/2013, à 19:34

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

voici pour apt-cache policy qgis*

qgis-plugin-grass-common:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
python-qgis-common:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
qgis-api-doc:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
qgis-plugin-grass:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     2.0.1-1~raring1 0
        100 /var/lib/dpkg/status
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis1.4.0-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1.7.5:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis1.8.0:
  Installé : 1.8.0-2~raring12
  Candidat : 1.8.0-2~raring12
 Table de version :
 *** 1.8.0-2~raring12 0
        100 /var/lib/dpkg/status
qgis:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
qgit:
  Installé : (aucun)
  Candidat : 2.4-1
 Table de version :
     2.4-1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis-gui1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
python-qgis:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     2.0.1-1~raring1 0
        100 /var/lib/dpkg/status
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
qgis-providers:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis2.0.1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-mapserver:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
python2.7-qgis:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-common:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
qgis-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-providers-common:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis0:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis1-dev:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libqgis-dev:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages
libqgis-core1:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
qgis-sqlanywhere1.7.5:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages

Hors ligne

#132 Le 19/09/2013, à 20:27

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

sudo apt-get remove libqgis1.8.0 libqgis

Pour ta version de qgis il ne propose pas la 2.0 dans ta configuration. Tu peux refaire un

sudo apt-get update 

et renvoyer le résultat de apt-get update et de apt-cache policy qgis

Dernière modification par kikislater (Le 19/09/2013, à 20:28)

Hors ligne

#133 Le 20/09/2013, à 08:09

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

tu veux dire que la v2 de qgis n'est pas supportée par 13.04 (et ne prend pas encore en charge les ecw) ?

ce qui veut dire que je ne dois installer la V1.8 si je veux pouvoir utiliser des ecw ?

c'est ça ?

donc apres sudo apt-get remove libqgis1.8.0 libqgis

sudo apt-get update  me donne

Réception de : 1 http://fr.archive.ubuntu.com raring Release.gpg [933 B]       
Réception de : 2 http://extras.ubuntu.com raring Release.gpg [72 B]            
Réception de : 3 http://archive.canonical.com raring Release.gpg [933 B]       
Réception de : 4 http://fr.archive.ubuntu.com raring-updates Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Réception de : 5 http://security.ubuntu.com raring-security Release.gpg [933 B]
Réception de : 6 http://fr.archive.ubuntu.com raring-backports Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring/main Sources                           
Atteint http://archive.canonical.com raring/partner i386 Packages              
Réception de : 7 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://fr.archive.ubuntu.com raring Release                            
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Réception de : 8 http://fr.archive.ubuntu.com raring-updates Release [40,8 kB] 
Réception de : 9 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 10 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Réception de : 11 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Réception de : 12 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 13 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Réception de : 14 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-fr                 
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Ign http://archive.canonical.com raring/partner Translation-en                 
Réception de : 15 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr          
Ign http://extras.ubuntu.com raring/main Translation-en                        
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en          
Réception de : 16 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr          
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en
Atteint http://security.ubuntu.com raring-security/main Translation-en  
Réception de : 17 http://fr.archive.ubuntu.com raring-updates/main Sources [68,5 kB]
Réception de : 18 http://fr.archive.ubuntu.com raring-updates/restricted Sources [14 B]
Réception de : 19 http://fr.archive.ubuntu.com raring-updates/universe Sources [72,3 kB]
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Réception de : 20 http://fr.archive.ubuntu.com raring-updates/multiverse Sources [2 266 B]
Réception de : 21 http://fr.archive.ubuntu.com raring-updates/main i386 Packages [174 kB]
Atteint http://security.ubuntu.com raring-security/restricted Translation-en   
Réception de : 22 http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages [14 B]
Réception de : 23 http://fr.archive.ubuntu.com raring-updates/universe i386 Packages [147 kB]
Atteint http://security.ubuntu.com raring-security/universe Translation-en
Réception de : 24 http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages [3 864 B]
Réception de : 25 http://fr.archive.ubuntu.com raring-updates/main Translation-en [83,3 kB]
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en    
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources             
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
841 ko réceptionnés en 26s (31,2 ko/s)
Lecture des listes de paquets... Fait

et apt-cache policy qgis renvoi :

qgis:
  Installé : (aucun)
  Candidat : 1.7.4+1.7.5~20120320-1.1
 Table de version :
     1.7.4+1.7.5~20120320-1.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe i386 Packages

Hors ligne

#134 Le 20/09/2013, à 09:47

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Tu as donc supprimé le dépôt du ppa !
Allez hop on reprend depuis le début :

# 1 - Installation de la lib ECW 3.3
cd /tmp/
wget -c http://www.riderducoin.com/ubuntu1/pool/main/libe/libecwj2/libecwj2_3.3-3_i386.deb
sudo dpkg -i libecwj2_3.3-3_i386.deb
sudo ldconfig


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:unbuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

# 3 - Compilation automatique de la lib ecw pour gdal
sudo gdal-ecw-build /usr

# 4 - Vérification du support ecw dans gdal 
gdalinfo --formats | grep ECW

Tu le renvoies chaque étape et je te dirais si ça bloque ou pas

Hors ligne

#135 Le 20/09/2013, à 12:46

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

oui désolé j'avais essayé de tout enlever pour mieux réinstaller ...
pb d'internet oblige je viens de relancer mon terminal pour te donner les résultats des commandes que voici :

donc pour wget -c http://www.riderducoin.com/ubuntu1/pool … 3_i386.deb:

--2013-09-20 13:35:32--  http://www.riderducoin.com/ubuntu1/pool/main/libe/libecwj2/libecwj2_3.3-3_i386.deb
Résolution de www.riderducoin.com (www.riderducoin.com)... 213.186.33.19
Connexion vers www.riderducoin.com (www.riderducoin.com)|213.186.33.19|:80... connecté.
requête HTTP transmise, en attente de la réponse... 416 Requested Range Not Satisfiable

    Le fichier a déjà été complètement récupéré; rien à faire.

pour sudo dpkg -i libecwj2_3.3-3_i386.deb :

(Lecture de la base de données... 205438 fichiers et répertoires déjà installés.)
Préparation du remplacement de libecwj2 3.3-3 (en utilisant libecwj2_3.3-3_i386.deb) ...
Dépaquetage de la mise à jour de libecwj2 ...
Paramétrage de libecwj2 (3.3-3) ...

pour sudo add-apt-repository -y ppa:unbuntugis-unstable :

Error reading https://launchpad.net/api/1.0/~unbuntugis-unstable/+archive/ppa: Not Found

ya problème sur le dépot ?

pour sudo apt-get update :

(Lecture de la base de données... 205438 fichiers et répertoires déjà installés.)
Préparation du remplacement de libecwj2 3.3-3 (en utilisant libecwj2_3.3-3_i386.deb) ...
Dépaquetage de la mise à jour de libecwj2 ...
Paramétrage de libecwj2 (3.3-3) ...
manu@Samusung-Emmanuel:/tmp$ sudo ldconfig
manu@Samusung-Emmanuel:/tmp$ sudo add-apt-repository -y ppa:unbuntugis-unstable
Error reading https://launchpad.net/api/1.0/~unbuntugis-unstable/+archive/ppa: Not Found
manu@Samusung-Emmanuel:/tmp$ sudo apt-get update
Atteint http://extras.ubuntu.com raring Release.gpg                                                                                                   
Atteint http://fr.archive.ubuntu.com raring Release.gpg                                                                                               
Atteint http://archive.canonical.com raring Release.gpg                                                                                               
Ign http://ppa.launchpad.net raring Release.gpg                                                                                                       
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                                                                            
Atteint http://archive.canonical.com raring Release                                                                                        
Ign http://ppa.launchpad.net raring Release                                                                                                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg                                                                                     
Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]                                                            
Atteint http://archive.canonical.com raring/partner i386 Packages                                                                                     
Atteint http://extras.ubuntu.com raring Release                                                                                            
Atteint http://extras.ubuntu.com raring/main Sources                                                                                                  
Réception de : 2 http://security.ubuntu.com raring-security Release [40,8 kB]                                                                         
Atteint http://fr.archive.ubuntu.com raring Release                                                                                                   
Atteint http://extras.ubuntu.com raring/main i386 Packages                                                                                            
Atteint http://fr.archive.ubuntu.com raring-updates Release                                                                                           
Réception de : 3 http://security.ubuntu.com raring-security/main Sources [42,1 kB]                                                                    
Atteint http://fr.archive.ubuntu.com raring-backports Release                                                                                         
Atteint http://fr.archive.ubuntu.com raring/main Sources                                                                                              
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                                                                                        
Réception de : 4 http://security.ubuntu.com raring-security/restricted Sources [14 B]                                                                 
Atteint http://fr.archive.ubuntu.com raring/universe Sources                                                                                          
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                                                                                        
Réception de : 5 http://security.ubuntu.com raring-security/universe Sources [9 279 B]                                                                
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                                                                                        
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages                                                                                  
Réception de : 6 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]                                                    
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages                                                                                    
Réception de : 7 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]                                                               
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages                                                                                  
Ign http://archive.canonical.com raring/partner Translation-fr_FR                                                                                     
Ign http://archive.canonical.com raring/partner Translation-fr                                                                                        
Ign http://archive.canonical.com raring/partner Translation-en                                                                                        
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                                                                                            
Réception de : 8 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]                                                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                                                                                       
Ign http://extras.ubuntu.com raring/main Translation-fr                                                                                               
Err http://ppa.launchpad.net raring/main i386 Packages                                                                                                
  404  Not Found
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                                                                                       
Réception de : 9 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]                                                          
Ign http://extras.ubuntu.com raring/main Translation-en                                                                                               
Ign http://ppa.launchpad.net raring/main Translation-fr_FR                                                                                            
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr                                                                                 
Ign http://ppa.launchpad.net raring/main Translation-fr                                                                                               
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en                                                                                 
Réception de : 10 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]                                                       
Ign http://ppa.launchpad.net raring/main Translation-en                                                                                               
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr                                                                                 
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en                                                                                 
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr                                                                                   
Atteint http://security.ubuntu.com raring-security/main Translation-en                                                                                
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en                                                                                   
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources                                                                                      
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources                                                                                
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources                                                                                  
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources                                                                                
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en                                                                          
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages                                                                                
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages                                                                          
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages                                                                            
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages                                                                          
Atteint http://security.ubuntu.com raring-security/restricted Translation-en                                                                          
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en                                                                               
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en                                                                         
Atteint http://security.ubuntu.com raring-security/universe Translation-en                                                                            
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en                                                                         
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en                                                                           
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources                                                                                    
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources                                                                              
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources                                                                                
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources                                                                              
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages                                                                              
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages                                                                        
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages                                                                          
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages                                                                        
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en                                                                             
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en                                                                       
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en                                                                       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en                                                                         
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR                                                                                 
Ign http://security.ubuntu.com raring-security/main Translation-fr                                                                                    
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR                                                                           
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr                                                                              
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR                                                                           
Ign http://security.ubuntu.com raring-security/restricted Translation-fr                                                                              
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR                                                                             
Ign http://security.ubuntu.com raring-security/universe Translation-fr                                                                                
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                                                                                        
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
246 ko réceptionnés en 31s (7 922 o/s)
W: Impossible de récupérer http://ppa.launchpad.net/unbuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

pour sudo apt-get install -y qgis libgdal-ecw-src:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

pour sudo gdal-ecw-build /usr :

Extracting GDAL/ECW tarball
Building GDAL/ECW plugin
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking C_WFLAGS for maximum warnings... -Wall -Wdeclaration-after-statement
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking CXX_WFLAGS for maximum warnings... -Wall
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert i686-pc-linux-gnu file names to i686-pc-linux-gnu format... func_convert_file_noop
checking how to convert i686-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... no
checking for mawk... mawk
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... g++ -E
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for ranlib... (cached) ranlib
checking for g++ -shared ... yes
checking for dlopen in -ldl... yes
checking for nanosleep in -lrt... yes
checking for sin in -lm... yes
checking for ANSI C header files... (cached) yes
checking assert.h usability... yes
checking assert.h presence... yes
checking for assert.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking for unistd.h... (cached) yes
checking dbmalloc.h usability... no
checking dbmalloc.h presence... no
checking for dbmalloc.h... no
checking for dlfcn.h... (cached) yes
checking for stdint.h... (cached) yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking values.h usability... yes
checking values.h presence... yes
checking for values.h... yes
checking float.h usability... yes
checking float.h presence... yes
checking for float.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking direct.h usability... no
checking direct.h presence... no
checking for direct.h... no
checking whether byte ordering is bigendian... no
checking for 64bit integer type... long long
checking for 64bit file io... yes
checking for stat64... yes
checking for fopen64... yes
checking for ftruncate64... yes
checking size of int... 4
checking size of unsigned long... 4
checking size of void*... 4
checking for int8... no
checking for int16... no
checking for int32... no
checking native cpu bit order... lsb2msb
checking for vprintf... yes
checking for _doprnt... no
checking for snprintf... yes
checking for vsnprintf... yes
checking for atoll... yes
checking for strtof... yes
checking for getcwd... yes
checking whether strtof is declared... yes
checking for readlink... yes
checking for lstat... yes
checking for posix_spawnp... yes
checking for vfork... yes
checking for gmtime_r... yes
checking for localtime_r... yes
checking for setlocale... yes
checking whether GCC 4.1 atomic builtins are available... yes
checking for gdal-config... /usr/bin/gdal-config
using /usr/lib/gdalplugins/1.10 as GDAL shared library autoload directory
checking for libNCSEcw.so or libecwj2... found in /usr/lib.
checking for NCSECWClient.h in /usr/include... found.
checking for ECWJP2BuildNumber.h in /usr/include... not found.
configure: creating ./config.status
config.status: creating GDALmake.opt
config.status: WARNING:  'GDALmake.opt.in' seems to ignore the --datarootdir setting
config.status: executing libtool commands
sed: can't read ./ltmain.sh: No such file or directory
sed: can't read libtoolT: No such file or directory
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwdataset.o ecwdataset.cpp
In file included from ecwdataset.cpp:30:0:
gdal_ecw.h: In member function ‘virtual bool VSIIOStream::Write(void*, UINT32)’:
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength >> 8)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength & 255)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
ecwdataset.cpp: In member function ‘CPLErr ECWRasterBand::OldIRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int)’:
ecwdataset.cpp:715:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::AdviseRead(int, int, int, int, int, int, GDALDataType, int, int*, char**)’:
ecwdataset.cpp:1501:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In member function ‘virtual CPLErr ECWDataset::IRasterIO(GDALRWFlag, int, int, int, int, void*, int, int, GDALDataType, int, int*, int, int, int)’:
ecwdataset.cpp:1894:18: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In static member function ‘static CNCSJP2FileView* ECWDataset::OpenFileView(const char*, bool, int&, bool)’:
ecwdataset.cpp:2221:22: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwdataset.cpp: In function ‘int ECWTranslateFromWKT(const char*, char*, int, char*, int, char*)’:
ecwdataset.cpp:2860:19: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwcreatecopy.o ecwcreatecopy.cpp
In file included from ecwcreatecopy.cpp:30:0:
gdal_ecw.h: In member function ‘virtual bool VSIIOStream::Write(void*, UINT32)’:
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength >> 8)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength & 255)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
ecwcreatecopy.cpp: In member function ‘virtual CNCSError GDALECWCompressor::WriteReadLine(UINT32, void**)’:
ecwcreatecopy.cpp:222:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:224:16: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr GDALECWCompressor::Initialize(const char*, char**, int, int, int, const char* const*, int, GDALDataType, const char*, double*, int, const GDAL_GCP*, int)’:
ecwcreatecopy.cpp:1012:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp:1019:62: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In function ‘GDALDataset* ECWCreateCopy(const char*, GDALDataset*, int, char**, GDALProgressFunc, void*, int)’:
ecwcreatecopy.cpp:1168:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
ecwcreatecopy.cpp: In member function ‘CPLErr ECWWriteDataset::Crystalize()’:
ecwcreatecopy.cpp:1706:15: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o jp2userbox.o jp2userbox.cpp
In file included from jp2userbox.cpp:30:0:
gdal_ecw.h: In member function ‘virtual bool VSIIOStream::Write(void*, UINT32)’:
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength >> 8)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength & 255)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::Parse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:104:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp: In member function ‘virtual CNCSError JP2UserBox::UnParse(CNCSJP2File&, CNCSJPCIOStream&)’:
jp2userbox.cpp:123:23: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
jp2userbox.cpp:127:17: attention : deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -g -O2 -fPIC  -Wall  -I/usr/include/gdal -DFRMT_ecw -I-I/usr/include/gdal  -I/usr/include  -c -o ecwasyncreader.o ecwasyncreader.cpp
In file included from ecwasyncreader.cpp:30:0:
gdal_ecw.h: In member function ‘virtual bool VSIIOStream::Write(void*, UINT32)’:
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength >> 8)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
gdal_ecw.h:370:75: attention : narrowing conversion of ‘(((VSIIOStream*)this)->VSIIOStream::nCOMLength & 255)’ from ‘int’ to ‘GByte {aka unsigned char}’ inside { } is ill-formed in C++11 [-Wnarrowing]
g++ -shared   ecwdataset.o ecwcreatecopy.o jp2userbox.o ecwasyncreader.o  -L/usr/lib -lNCSEcw -lNCSEcwC -lNCSCnet -lNCSUtil \
		-o gdal_ECW_JP2ECW.so
install -d /usr/lib/gdalplugins/1.10
cp gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.10

et enfin pour gdalinfo --formats | grep ECW :

  ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
  JP2ECW (rw+v): ERDAS JPEG2000 (SDK 3.x)

Hors ligne

#136 Le 20/09/2013, à 14:47

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Euh en effet j'ai mal tapé le dépôt !
Il faut que tu supprimes celui que je t'ai fait rajouté unbuntugis au lieu de ubuntugis...


# 2 - Ajout du dépôt PPA UBUNTUGIS
sudo add-apt-repository -y ppa:ubuntugis-unstable
sudo apt-get update
sudo apt-get install -y qgis libgdal-ecw-src

Dernière modification par kikislater (Le 20/09/2013, à 14:47)

Hors ligne

#137 Le 20/09/2013, à 16:49

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

en fait j'ai tout un tas de ppa gis-unstable dans le gestionaire de mises à jour mais ils sont décochés donc ne devraient pas poser de pbs ?

le résultat de sudo add-apt-repository -y ppa:ubuntugis-unstable :

Error reading https://launchpad.net/api/1.0/~ubuntugis-unstable/+archive/ppa: Not Found

celui de sudo apt-get update :

Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release.gpg                            
Atteint http://archive.canonical.com raring Release.gpg                        
Ign http://ppa.launchpad.net raring Release.gpg                                
Atteint http://fr.archive.ubuntu.com raring Release.gpg                        
Réception de : 2 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Ign http://ppa.launchpad.net raring Release                                    
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg              
Atteint http://extras.ubuntu.com raring/main Sources                           
Atteint http://archive.canonical.com raring/partner i386 Packages              
Réception de : 3 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://fr.archive.ubuntu.com raring Release                            
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Atteint http://fr.archive.ubuntu.com raring-updates Release                    
Réception de : 4 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Réception de : 5 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Réception de : 6 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 7 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Réception de : 8 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Réception de : 9 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 10 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Atteint http://security.ubuntu.com raring-security/main Translation-en         
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-fr                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Ign http://archive.canonical.com raring/partner Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://extras.ubuntu.com raring/main Translation-en                        
Err http://ppa.launchpad.net raring/main i386 Packages                         
  404  Not Found
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr   
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en   
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr   
Atteint http://security.ubuntu.com raring-security/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en          
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr            
Atteint http://security.ubuntu.com raring-security/universe Translation-en     
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en            
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources               
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources           
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages         
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages     
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en        
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en    
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources             
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
246 ko réceptionnés en 33s (7 441 o/s)
W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et celui de sudo apt-get install -y qgis libgdal-ecw-src :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#138 Le 20/09/2013, à 16:52

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Manush a écrit :

en fait j'ai tout un tas de ppa gis-unstable dans le gestionaire de mises à jour mais ils sont décochés donc ne devraient pas poser de pbs ?

le résultat de sudo add-apt-repository -y ppa:ubuntugis-unstable :

Error reading https://launchpad.net/api/1.0/~ubuntugis-unstable/+archive/ppa: Not Found

celui de sudo apt-get update :

Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release.gpg                            
Atteint http://archive.canonical.com raring Release.gpg                        
Ign http://ppa.launchpad.net raring Release.gpg                                
Atteint http://fr.archive.ubuntu.com raring Release.gpg                        
Réception de : 2 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Ign http://ppa.launchpad.net raring Release                                    
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg              
Atteint http://extras.ubuntu.com raring/main Sources                           
Atteint http://archive.canonical.com raring/partner i386 Packages              
Réception de : 3 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://fr.archive.ubuntu.com raring Release                            
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Atteint http://fr.archive.ubuntu.com raring-updates Release                    
Réception de : 4 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Réception de : 5 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Réception de : 6 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 7 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Réception de : 8 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Réception de : 9 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 10 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Atteint http://security.ubuntu.com raring-security/main Translation-en         
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-fr                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Ign http://archive.canonical.com raring/partner Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://extras.ubuntu.com raring/main Translation-en                        
Err http://ppa.launchpad.net raring/main i386 Packages                         
  404  Not Found
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr   
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en   
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr   
Atteint http://security.ubuntu.com raring-security/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en          
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr            
Atteint http://security.ubuntu.com raring-security/universe Translation-en     
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en            
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources               
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources           
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources         
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages         
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages     
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages   
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en        
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en    
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources             
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
246 ko réceptionnés en 33s (7 441 o/s)
W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et celui de sudo apt-get install -y qgis libgdal-ecw-src :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 qgis : Dépend: libgdal1 (>= 1.9.0) mais ne sera pas installé
        Dépend: libqgis1.7.5 mais ne sera pas installé
        Dépend: qgis-providers (= 1.7.4+1.7.5~20120320-1.1) mais ne sera pas installé
        Recommande: qgis-plugin-grass mais ne sera pas installé
        Recommande: python-qgis mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Ouais pardon encore manque de rigueur c'est ça :

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

Hors ligne

#139 Le 20/09/2013, à 17:07

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

aucun pbs !

donc j'ai relancé sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable :

Vous allez ajouter le PPA suivant à votre système :
 Unstable releases of Ubuntu GIS packages. These releases are more bleeding edge and while generally they should work well, they dont receive the same amount of quality assurance as our stable releases do.
 Plus d’info : https://launchpad.net/~ubuntugis/+archive/ubuntugis-unstable
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmpz07pu4/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmpz07pu4/pubring.gpg » a été créé
gpg: demande de la clef 314DF160 sur le serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmpz07pu4/trustdb.gpg : base de confiance créée
gpg: clef 314DF160 : clef publique « Launchpad ubuntugis-stable » importée
gpg: Quantité totale traitée : 1
gpg:               importées : 1  (RSA: 1)
OK

puis rechargé sudo apt-get update :

Atteint http://fr.archive.ubuntu.com raring Release.gpg
Atteint http://archive.canonical.com raring Release.gpg                        
Réception de : 1 http://security.ubuntu.com raring-security Release.gpg [933 B]
Atteint http://extras.ubuntu.com raring Release.gpg                            
Réception de : 2 http://ppa.launchpad.net raring Release.gpg [316 B]           
Atteint http://fr.archive.ubuntu.com raring-updates Release.gpg                
Réception de : 3 http://security.ubuntu.com raring-security Release [40,8 kB]  
Atteint http://extras.ubuntu.com raring Release                                
Atteint http://archive.canonical.com raring Release                            
Ign http://ppa.launchpad.net raring Release.gpg                                
Atteint http://fr.archive.ubuntu.com raring-backports Release.gpg              
Atteint http://archive.canonical.com raring/partner i386 Packages              
Atteint http://extras.ubuntu.com raring/main Sources                           
Réception de : 4 http://ppa.launchpad.net raring Release [9 758 B]             
Atteint http://fr.archive.ubuntu.com raring Release                            
Réception de : 5 http://security.ubuntu.com raring-security/main Sources [42,1 kB]
Atteint http://extras.ubuntu.com raring/main i386 Packages                     
Atteint http://fr.archive.ubuntu.com raring-updates Release                    
Ign http://ppa.launchpad.net raring Release                                    
Atteint http://fr.archive.ubuntu.com raring-backports Release                  
Réception de : 6 http://ppa.launchpad.net raring/main i386 Packages [28,4 kB]  
Réception de : 7 http://security.ubuntu.com raring-security/restricted Sources [14 B]
Atteint http://fr.archive.ubuntu.com raring/main Sources                       
Réception de : 8 http://security.ubuntu.com raring-security/universe Sources [9 279 B]
Atteint http://fr.archive.ubuntu.com raring/restricted Sources                 
Réception de : 9 http://security.ubuntu.com raring-security/multiverse Sources [2 266 B]
Atteint http://fr.archive.ubuntu.com raring/universe Sources                   
Réception de : 10 http://security.ubuntu.com raring-security/main i386 Packages [109 kB]
Atteint http://fr.archive.ubuntu.com raring/multiverse Sources                 
Atteint http://fr.archive.ubuntu.com raring/main i386 Packages                 
Atteint http://fr.archive.ubuntu.com raring/restricted i386 Packages           
Atteint http://fr.archive.ubuntu.com raring/universe i386 Packages             
Réception de : 11 http://security.ubuntu.com raring-security/restricted i386 Packages [14 B]
Atteint http://fr.archive.ubuntu.com raring/multiverse i386 Packages           
Réception de : 12 http://security.ubuntu.com raring-security/universe i386 Packages [37,1 kB]
Réception de : 13 http://security.ubuntu.com raring-security/multiverse i386 Packages [3 864 B]
Atteint http://fr.archive.ubuntu.com raring/main Translation-fr                
Ign http://archive.canonical.com raring/partner Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring/main Translation-en                
Ign http://archive.canonical.com raring/partner Translation-fr                 
Atteint http://security.ubuntu.com raring-security/main Translation-en         
Ign http://extras.ubuntu.com raring/main Translation-fr_FR                     
Ign http://archive.canonical.com raring/partner Translation-en                 
Ign http://extras.ubuntu.com raring/main Translation-fr                        
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-fr          
Ign http://extras.ubuntu.com raring/main Translation-en                        
Atteint http://fr.archive.ubuntu.com raring/multiverse Translation-en          
Atteint http://security.ubuntu.com raring-security/multiverse Translation-en   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-fr   
Atteint http://fr.archive.ubuntu.com raring/restricted Translation-en   
Atteint http://fr.archive.ubuntu.com raring/universe Translation-fr     
Atteint http://security.ubuntu.com raring-security/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring/universe Translation-en     
Atteint http://fr.archive.ubuntu.com raring-updates/main Sources        
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Sources  
Atteint http://security.ubuntu.com raring-security/universe Translation-en
Atteint http://fr.archive.ubuntu.com raring-updates/universe Sources    
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Sources  
Atteint http://fr.archive.ubuntu.com raring-updates/main i386 Packages  
Atteint http://fr.archive.ubuntu.com raring-updates/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com raring-updates/universe i386 Packages
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com raring-updates/main Translation-en 
Atteint http://fr.archive.ubuntu.com raring-updates/multiverse Translation-en
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring-updates/restricted Translation-en
Err http://ppa.launchpad.net raring/main i386 Packages                  
  404  Not Found
Atteint http://fr.archive.ubuntu.com raring-updates/universe Translation-en
Ign http://ppa.launchpad.net raring/main Translation-fr_FR              
Atteint http://fr.archive.ubuntu.com raring-backports/main Sources      
Ign http://ppa.launchpad.net raring/main Translation-fr                 
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Sources
Ign http://ppa.launchpad.net raring/main Translation-en                 
Atteint http://fr.archive.ubuntu.com raring-backports/universe Sources  
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Sources       
Atteint http://fr.archive.ubuntu.com raring-backports/main i386 Packages       
Atteint http://fr.archive.ubuntu.com raring-backports/restricted i386 Packages 
Ign http://security.ubuntu.com raring-security/main Translation-fr_FR          
Atteint http://fr.archive.ubuntu.com raring-backports/universe i386 Packages   
Ign http://security.ubuntu.com raring-security/main Translation-fr             
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse i386 Packages 
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr_FR    
Ign http://security.ubuntu.com raring-security/multiverse Translation-fr       
Ign http://security.ubuntu.com raring-security/restricted Translation-fr_FR    
Atteint http://fr.archive.ubuntu.com raring-backports/main Translation-en      
Ign http://security.ubuntu.com raring-security/restricted Translation-fr       
Ign http://security.ubuntu.com raring-security/universe Translation-fr_FR      
Ign http://security.ubuntu.com raring-security/universe Translation-fr         
Atteint http://fr.archive.ubuntu.com raring-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com raring-backports/universe Translation-en  
Ign http://fr.archive.ubuntu.com raring/main Translation-fr_FR                 
Ign http://fr.archive.ubuntu.com raring/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com raring-backports/universe Translation-fr
284 ko réceptionnés en 22s (12,5 ko/s)
W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

et sudo apt-get install -y qgis libgdal-ecw-src :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgdal-ecw-src est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libqgis1.8.0 python-central
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libqgis2.0.1 python-qgis python-qgis-common qgis-common qgis-plugin-globe
  qgis-plugin-globe-common qgis-plugin-grass qgis-plugin-grass-common
  qgis-providers qgis-providers-common
Les NOUVEAUX paquets suivants seront installés :
  libqgis2.0.1 python-qgis python-qgis-common qgis qgis-common
  qgis-plugin-globe qgis-plugin-globe-common qgis-plugin-grass
  qgis-plugin-grass-common qgis-providers qgis-providers-common
0 mis à jour, 11 nouvellement installés, 0 à enlever et 17 non mis à jour.
Il est nécessaire de prendre 0 o/42,9 Mo dans les archives.
Après cette opération, 121 Mo d'espace disque supplémentaires seront utilisés.
Sélection du paquet libqgis2.0.1 précédemment désélectionné.
(Lecture de la base de données... 205438 fichiers et répertoires déjà installés.)
Dépaquetage de libqgis2.0.1 (à partir de .../libqgis2.0.1_2.0.1-1~raring1_i386.deb) ...
Sélection du paquet python-qgis-common précédemment désélectionné.
Dépaquetage de python-qgis-common (à partir de .../python-qgis-common_2.0.1-1~raring1_all.deb) ...
Sélection du paquet python-qgis précédemment désélectionné.
Dépaquetage de python-qgis (à partir de .../python-qgis_2.0.1-1~raring1_i386.deb) ...
Sélection du paquet qgis-providers-common précédemment désélectionné.
Dépaquetage de qgis-providers-common (à partir de .../qgis-providers-common_2.0.1-1~raring1_all.deb) ...
Sélection du paquet qgis-providers précédemment désélectionné.
Dépaquetage de qgis-providers (à partir de .../qgis-providers_2.0.1-1~raring1_i386.deb) ...
Sélection du paquet qgis-common précédemment désélectionné.
Dépaquetage de qgis-common (à partir de .../qgis-common_2.0.1-1~raring1_all.deb) ...
Sélection du paquet qgis précédemment désélectionné.
Dépaquetage de qgis (à partir de .../qgis_2.0.1-1~raring1_i386.deb) ...
Sélection du paquet qgis-plugin-globe-common précédemment désélectionné.
Dépaquetage de qgis-plugin-globe-common (à partir de .../qgis-plugin-globe-common_2.0.1-1~raring1_all.deb) ...
Sélection du paquet qgis-plugin-globe précédemment désélectionné.
Dépaquetage de qgis-plugin-globe (à partir de .../qgis-plugin-globe_2.0.1-1~raring1_i386.deb) ...
Sélection du paquet qgis-plugin-grass-common précédemment désélectionné.
Dépaquetage de qgis-plugin-grass-common (à partir de .../qgis-plugin-grass-common_2.0.1-1~raring1_all.deb) ...
Sélection du paquet qgis-plugin-grass précédemment désélectionné.
Dépaquetage de qgis-plugin-grass (à partir de .../qgis-plugin-grass_2.0.1-1~raring1_i386.deb) ...
Ajout de « détournement de /usr/bin/qgis en /usr/bin/qgis.bin par qgis-plugin-grass »
Ajout de « détournement de /usr/bin/qbrowser en /usr/bin/qbrowser.bin par qgis-plugin-grass »
Traitement des actions différées (« triggers ») pour « mime-support »...
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « shared-mime-info »...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libqgis2.0.1 (2.0.1-1~raring1) ...
Paramétrage de python-qgis-common (2.0.1-1~raring1) ...
Paramétrage de python-qgis (2.0.1-1~raring1) ...
Paramétrage de qgis-providers-common (2.0.1-1~raring1) ...
Synchronizing CRS database with GDAL/PROJ definitions.
Loaded 465/466 from /usr/share/gdal/1.10/gcs.csv
Loaded 3790/3831 from /usr/share/gdal/1.10/pcs.csv
Loaded 147/148 from /usr/share/gdal/1.10/vertcs.csv
Loaded 61/62 from /usr/share/gdal/1.10/compdcs.csv
Loaded 129/130 from /usr/share/gdal/1.10/geoccs.csv
Loading epsg.wkt
Loading esri_extra.wkt
5044 WKTs loaded
CRS update (inserted:1248 updated:934 deleted:1 errors:0)
2182 CRSs updated.
Paramétrage de qgis-providers (2.0.1-1~raring1) ...
Paramétrage de qgis-common (2.0.1-1~raring1) ...
Paramétrage de qgis (2.0.1-1~raring1) ...
Paramétrage de qgis-plugin-globe-common (2.0.1-1~raring1) ...
Paramétrage de qgis-plugin-globe (2.0.1-1~raring1) ...
Paramétrage de qgis-plugin-grass-common (2.0.1-1~raring1) ...
Paramétrage de qgis-plugin-grass (2.0.1-1~raring1) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place

et là ..... CA MARCHE !!!

super grand merci pour ton aide et ta patience !

je ne suis pas sur de vraiment voir d'où venait exactement le pb mais ça marche

passes un très bon we et très bonne continuation à toi

wink

Hors ligne

#140 Le 20/09/2013, à 17:10

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Tu as ça qui n'est pas bon :

W: Impossible de récupérer http://ppa.launchpad.net/ubuntugis-unstable/ppa/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

C'est la mauvaise ligne que je t'ai donné. Pour le nettoyer, tu peux redonner :

ls /etc/apt/sources.list.d/

Hors ligne

#141 Le 20/09/2013, à 17:17

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

oui

ubuntugis-ppa-raring.list
ubuntugis-ppa-raring.list.save
ubuntugis-ubuntugis-unstable-raring.list
ubuntugis-ubuntugis-unstable-raring.list.save
ubuntugis-unstable-ppa-raring.list
ubuntugis-unstable-ppa-raring.list.save
unbuntugis-unstable-ppa-raring.list
unbuntugis-unstable-ppa-raring.list.save

Hors ligne

#142 Le 21/09/2013, à 13:38

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

est ce qu'il me reste une manip à faire (pour nettoyer comme tu explique dans ton dernier message) ou c'est ok et je peux passer le post en RESOLU ?

Merci encore pour ton aide wink

Hors ligne

#143 Le 21/09/2013, à 18:22

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Il reste une manip !

Donc le plus simple :

sudo rm -rf /etc/apt/sources.list.d/ubuntugis*
sudo rm -rf /etc/apt/sources.list.d/unbuntugis*
sudo apt-get update
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get update 

Et voilà ce sera fini

Hors ligne

#144 Le 08/10/2013, à 15:07

bonuscad

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Bonjour,
Bonjour,
Juste un remerciement particulier à kikislater pour ce fil sur les ECW, il m'a permis (non sans mal) à rendre effectif la lecture des ECW sous QGis 2.0 sous un un environnement Xubuntu 12.04 LTS.

Question (bien que tout soit fonctionnel), est ce normal que seule la commande apt-cache policy gdal ne me renvoie rien? (N: Impossible de trouver le paquet gdal)
C'est juste par curiosité...

Merci encore, car j'aurais bien été incapable de mettre ceci en place sans ce fil de discussion.

Hors ligne

#145 Le 08/10/2013, à 15:15

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

bonuscad a écrit :

Bonjour,
Bonjour,
Juste un remerciement particulier à kikislater pour ce fil sur les ECW, il m'a permis (non sans mal) à rendre effectif la lecture des ECW sous QGis 2.0 sous un un environnement Xubuntu 12.04 LTS.

Question (bien que tout soit fonctionnel), est ce normal que seule la commande apt-cache policy gdal ne me renvoie rien? (N: Impossible de trouver le paquet gdal)
C'est juste par curiosité...

Merci encore, car j'aurais bien été incapable de mettre ceci en place sans ce fil de discussion.

big_smile

Oui le paquet s'appelle gdal-bin et non plus gdal c'est un méta paquet : https://launchpad.net/ubuntu/+source/gdal

Donc si tu fais

apt-cache policy gdal-bin 

tu devrais avoir une réponse ou encore

apt-cache policy gdal*

Je suis content que certaines personnes puissent utiliser apt-cache policy à présent. Est-ce de ma faute ou pas ?

Hors ligne

#146 Le 08/10/2013, à 16:02

bonuscad

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

kikislater a écrit :

big_smile

Oui le paquet s'appelle gdal-bin et non plus gdal c'est un méta paquet : https://launchpad.net/ubuntu/+source/gdal

Donc si tu fais

apt-cache policy gdal-bin 

tu devrais avoir une réponse ou encore

apt-cache policy gdal*

Je suis content que certaines personnes puissent utiliser apt-cache policy à présent. Est-ce de ma faute ou pas ?

Oui j'ai bien un retour, merci de ton explication.

Je suis content que certaines personnes puissent utiliser apt-cache policy à présent. Est-ce de ma faute ou pas ?

Disons que je t'ai fais une confiance aveugle pour avancer dans ma démarche, quitte à faire des con...ries (c'est comme ça que j'apprends)
Donc je fais et j’essaye de comprendre le pourquoi après (surtout quand ça ne fonctionne pas)... Linux est encore sombre pour moi.

Comme je vois que tu t’intéresse à la géomatique, pense tu pouvoir m'orienter et m’éclaircir sur l'utilisation d'un mapserver et de Maestro?
J'ouvrirais un autre fil bien sur. (en soirée)

Encore merci de ta réactivité.

Hors ligne

#147 Le 17/10/2013, à 13:12

Manush

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Oui merci encore Kikislater!

Je viens d'installer Qgis sur la machine d'un collègue désormais converti à Ubuntu et Qgis fonctionne maintenant parfaitement avec les ecw et ça c'est grâce à toi oui !
bonne suite et à +;)

Hors ligne

#148 Le 04/09/2014, à 09:13

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Bonjour à tous,

Je reviens à la charge car je suis passé à Xubuntu 14.04 et QGIS 2.4 et je n'arrive plus à lire les ECW...

Merci pour votre aide.


Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

#149 Le 04/09/2014, à 09:34

kikislater

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Salut Silvio,

En effet ça a changé un petit peu. Je te donne la méthode ici :
Si tu n'as pas compilé la lib ECW il faut que tu fasses ça :

### ECW source : https://aur.archlinux.org/packages/li/libecwj2/
sudo mkdir -p /opt/compil-sig
sudo chown $USER -R /opt/compil-sig
cd /opt/compil-sig
wget -c http://mirror.ovh.net/gentoo-distfiles/distfiles/libecwj2-3.3-2006-09-06.zip
wget -c https://aur.archlinux.org/packages/li/libecwj2/libecwj2.tar.gz
unzip libecwj2-3.3-2006-09-06.zip
tar zvxf libecwj2.tar.gz
cd libecwj2-3.3/
# Memory leak patches from http://trac.osgeo.org/mapserver/ticket/3245
patch -p0 -i ../libecwj2/libecwj2-3.3-3245a.patch
patch -p0 -i ../libecwj2/libecwj2-3.3-3245b.patch
# Memory overflow patch from http://trac.osgeo.org/gdal/ticket/3366
patch -p0 -i ../libecwj2/libecwj2-3.3-NCSPhysicalMemorySize-Linux.patch
# Fix crash creating 16bit JP images on x86_64 from http://trac.osgeo.org/gdal/ticket/2593
patch -p0 -i ../libecwj2/libecwj2-3.3-2593.patch
# Gentoo patch
patch -Np 0 -i ../libecwj2/libecwj2-3.3-nolcms.patch
rm -rf Source/C/libjpeg Source/C/NCSEcw/lcms
# Gentoo bug 328075
sed -i -e "s:includeHEADERS_INSTALL:INSTALL_HEADER:" \
Source/NCSBuildGnu/Makefile.am || return 1
# std::length_error bug
patch -p0 -i ../libecwj2/libecwj2-3.3-wcharfix.patch
autoreconf -i
./configure --prefix=/usr
make -j8 # j8 = nombre de cores
sudo checkinstall -D -y --install=yes --maintainer=sylvain.poulain@yahoo.fr --pkgname=libecwj2 --pkgversion=3.3
sudo ldconfig
sudo mv *.deb ../

Puis le plugin ECW pour gdal :

#Ajout du dépôt 
sudo add-apt-repository -y ppa:ubuntugis/ubuntugis-unstable 
sudo apt-get -y update 
sudo apt-get install -y gdal-bin
wget -c http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/pool/main/libg/libgdal-ecw/libgdal-ecw-src_1.10.0-1~quantal3_all.deb
dpkg-deb -x libgdal-ecw-src_1.10.0-1~quantal3_all.deb ecw-src
sudo cp ecw-src/usr/bin/gdal-ecw-build /usr/local/bin/
sudo cp ecw-src/usr/src/libgdal-ecw-1.10.0.tar.gz /usr/src/
sudo gdal-ecw-build /usr
sudo mkdir -p /usr/lib/gdalplugins/1.11/
sudo cp /usr/lib/gdalplugins/1.10/gdal_ECW_JP2ECW.so /usr/lib/gdalplugins/1.11/
gdalinfo --formats | grep ECW # Vérification

Dernière modification par kikislater (Le 04/09/2014, à 09:40)

Hors ligne

#150 Le 04/09/2014, à 16:35

Silvio66

Re : [QGis 1.8] Lire ECW sous Ubuntu 12.10

Merci Kickslater,

je vais essayer la manip demain.

Par contre j'ai un doute, tu marque:

### ECW source : https://aur.archlinux.org/packages/li/libecwj2/

Je suis sous Xubuntu, le fait de travailler sous Archlinux ne vas pas poser un problème?


Silvio
Xubuntu 14.04 sur TERRA mobile 1562P Pro (qui marche encore à pétrole...) 32 bit et avec la RAM qui rame.

Hors ligne

Haut de page ↑