Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#26 Le 25/01/2013, à 14:05

ky

Re : [RESOLU]Erreur "sudo"

Pour le mode recovery, si j'ai bien compris c'est au démarrage de ma machine je choisis le mode dépannage et après root et c'est ici que je pourrais rajouter la commande " adduser nagios admin " ? Ou il y a d'autres étapes ? Ou j'ai rien compris à ce mode ?

Hors ligne

#27 Le 25/01/2013, à 14:17

tiramiseb

Re : [RESOLU]Erreur "sudo"

Il me semble que tu as bien compris.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#28 Le 25/01/2013, à 14:21

ky

Re : [RESOLU]Erreur "sudo"

D'accord merci bien.

Par contre pour voir ces modes faut appuyer sur esc au démarrage ou pas?

Hors ligne

#29 Le 25/01/2013, à 15:49

tiramiseb

Re : [RESOLU]Erreur "sudo"

Je ne sais plus trop comment ça se présente. Ça fait trop longtemps que je n'ai pas eu besoin de ça.
Il y a quelque chose dans le genre mais je ne saurais plus dire quoi exactement...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#30 Le 26/01/2013, à 08:57

J5012

Re : [RESOLU]Erreur "sudo"

tiramiseb a écrit :

J5012 : tu pars dans une mauvaise voie. As-tu bien lu les messages #16 et surtout #18 ?

oui bien sur, mais j'ai aussi lu le tuto donne plus haut, et celui-ci ne parle pas de creer un user nagios ! je voulais verifier qu'il en avait vraiment cree un, et la liste du home permet de s'en assurer avec certitude, la commande adduser creant par defaut le repertoire utilisateur qui va bien ...

bon puisque l'utilisateur nagios est certain , il n'y a plus qu'a le mettre dans le sudoers avec la commande ou a passer nagios en admin, mais cela est dangereux puisque nagios est cense faire de la supervision ! celui-ci ne devrait avoir acces qu'au service web (donc uniquement les droits www-data), et non pas a la totalite des acces ...

c'est un mauvais service a lui rendre que de passer l'utilisateur nagios en admin ...

@ky : je te conseille plutot de relire calmement le tuto sur nagios et de comprendre a partir de quand tu t'es trompe et pourquoi ... une fois que tu auras compris, tu pourras recreer un user admin separe, modifier le user nagios de sorte qu'il n'ait que les acces web (droits www-data) ...

En ligne

#31 Le 26/01/2013, à 09:29

tiramiseb

Re : [RESOLU]Erreur "sudo"

J5012 a écrit :

j'ai aussi lu le tuto donne plus haut, et celui-ci ne parle pas de creer un user nagios !

Si, PART 1, titre "Installation de pré-requis système", dernier bloc "code", avant la fin de l'article.

J5012 a écrit :

je voulais verifier qu'il en avait vraiment cree un, et la liste du home permet de s'en assurer avec certitude, la commande adduser creant par defaut le repertoire utilisateur qui va bien ...

bon puisque l'utilisateur nagios est certain , il n'y a plus qu'a le mettre dans le sudoers avec la commande ou a passer nagios en admin, mais cela est dangereux puisque nagios est cense faire de la supervision ! celui-ci ne devrait avoir acces qu'au service web (donc uniquement les droits www-data), et non pas a la totalite des acces ...

Si tu relis les messages #10, #12, #14, #15, #16, tu verras que c'est un peu plus tordu que ça : il semble que nagios soit devenu (je ne sais par quel miracle) l'utilisateur qu'elle (ky, en lisant les accords dans tes messages j'ai cru comprendre qu'il faut écrire "elle", j'espère ne pas avoir mal compris smile ) utilise au jour le jour est celui-ci...
(uid 1000, champ descriptif qui contient "PGA" qui semble être le nom affiché du précédent utilisateur...)

Dernière modification par tiramiseb (Le 26/01/2013, à 09:31)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#32 Le 26/01/2013, à 09:35

tiramiseb

Re : [RESOLU]Erreur "sudo"

ky: peux-tu nous montrer l'intégralité du retour de "getent passwd" ?
Peut-être qu'on trouverait une explication à cette bizarre rien là-dedans.

Pour être bien clair sur les risques à nous montrer ça:
Cette commande nous montrera les paramètres de l'ensemble des utilisateurs (y compris utilisateurs système) présents sur ta machine (à part les mots de passe).
Dans la mesure où il semble que tu as une config plutôt standard, cela ne devrait pas être un gros risque de sécurité de nous montrer ça (les utilisateurs système sont les mêmes partout et tu as juste un utilisateur "nagios" en plus), sauf si sur le même serveur tu as des trucs inhabituels ou spécifiques pour les utilisateurs, ou si ce serveur contient la liste complète des utilisateurs de la boîte, par exemple.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#33 Le 26/01/2013, à 12:13

ky

Re : [RESOLU]Erreur "sudo"

Oui tu as bien compris pour le "elle".

Je vous mettrai ça lundi quand je serai à l'entreprise je n'ai pas accès au serveur là.

Merci en tout cas de vos réponses !!

Hors ligne

#34 Le 28/01/2013, à 08:22

ky

Re : [RESOLU]Erreur "sudo"

Voilà ce que me donne la commande getent passwd (j'effacerai ce message suite à vos réponses pour la sécurité) : 

root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/bin/sh
bin:x:2:2:bin:/bin:/bin/sh
sys:x:3:3:sys:/dev:/bin/sh
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/bin/sh
man:x:6:12:man:/var/cache/man:/bin/sh
lp:x:7:7:lp:/var/spool/lpd:/bin/sh
mail:x:8:8:mail:/var/mail:/bin/sh
news:x:9:9:news:/var/spool/news:/bin/sh
uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
proxy:x:13:13:proxy:/bin:/bin/sh
www-data:x:33:33:www-data:/var/www:/bin/sh
backup:x:34:34:backup:/var/backups:/bin/sh
list:x:38:38:Mailing List Manager:/var/list:/bin/sh
irc:x:39:39:ircd:/var/run/ircd:/bin/sh
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
libuuid:x:100:101::/var/lib/libuuid:/bin/sh
syslog:x:101:103::/home/syslog:/bin/false
messagebus:x:102:105::/var/run/dbus:/bin/false
avahi-autoipd:x:103:106:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/bin/false
usbmux:x:104:46:usbmux daemon,,,:/home/usbmux:/bin/false
whoopsie:x:105:110::/nonexistent:/bin/false
kernoops:x:106:65534:Kernel Oops Tracking Daemon,,,:/:/bin/false
rtkit:x:107:114:RealtimeKit,,,:/proc:/bin/false
speech-dispatcher:x:108:29:Speech Dispatcher,,,:/var/run/speech-dispatcher:/bin/sh
colord:x:109:117:colord colour management daemon,,,:/var/lib/colord:/bin/false
lightdm:x:110:118:Light Display Manager:/var/lib/lightdm:/bin/false
avahi:x:111:120:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false
hplip:x:112:7:HPLIP system user,,,:/var/run/hplip:/bin/false
pulse:x:113:121:PulseAudio daemon,,,:/var/run/pulse:/bin/false
saned:x:114:123::/home/saned:/bin/false
nagios:x:1000:1000:PGA,,,:/home/nagios:/bin/bash
postfix:x:115:125::/var/spool/postfix:/bin/false
snmp:x:116:127::/var/lib/snmp:/bin/false
mysql:x:117:128:MySQL Server,,,:/nonexistent:/bin/false
sshd:x:118:65534::/var/run/sshd:/usr/sbin/nologin

Hors ligne

#35 Le 28/01/2013, à 08:27

tiramiseb

Re : [RESOLU]Erreur "sudo"

On voit donc bien qu'il n'y a qu'un seul utilisateur "non-système" (UID numérique au-dessus de 999), c'est "nagios". Comme écrit plus haut, je ne sais pas comment tu t'es débrouillée mais tu as "changé" ton utilisateur habituel en "nagios" OU ALORS tu as remplacé ton utilisateur habituel par l'utilisateur "nagios".

PS : Pas besoin d'effacer, tout cela n'est que parfaitement standard et on a tous la même chose sur nos PC smile


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#36 Le 28/01/2013, à 08:36

ky

Re : [RESOLU]Erreur "sudo"

D'accord. Merci.
Si je fais un mode recovery je pourrai réavoir les droits ?

Hors ligne

#37 Le 28/01/2013, à 08:46

tiramiseb

Re : [RESOLU]Erreur "sudo"

Tu peux ajouter l'utilisateur "nagios" au groupe "admin", ce qui devrait lui donner les bons droits.

Je crois qu'en mode "recovery" tu démarres en lecture seule, une fois dans ce mode les commandes seraient donc a priori :

mount -o remount,rw /
adduser nagios admin
mount -o remount,ro /
reboot

(la première pour remonter le répertoire racine en lecture-écriture, la seconde pour l'ajout au groupe, la troisième pour remettre en lecture seule, la quatrième pour redémarrer)

Sans aucune assurance que ces commandes soient suffisantes bien sûr, il faut essayer pour valider smile


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#38 Le 28/01/2013, à 10:08

ky

Re : [RESOLU]Erreur "sudo"

J'essayerai ça, j'ai lu la doc sur le mode recovery en espérant que ça marchera.

Sinon, j'ai vu sur l'une des docs d'ubuntu la commande "pkexec visudo", je ne pourrai pas modifier le fichier sudoers avec cette commande?

Je suis désolée de déranger encore et encore...

Hors ligne

#39 Le 28/01/2013, à 10:10

tiramiseb

Re : [RESOLU]Erreur "sudo"

ky a écrit :

Sinon, j'ai vu sur l'une des docs d'ubuntu la commande "pkexec visudo", je ne pourrai pas modifier le fichier sudoers avec cette commande?

Non, car tu n'es pas dans le groupe "admin" smile
pkexec, sudo, gksudo, tout ça se sont des manières différentes de faire la même chose : exécuter une commande en tant qu'un autre utilisateur, à partir du moment où on y est autorisé.

ky a écrit :

Je suis désolée de déranger encore et encore...

Le jour où ça nous embêtera trop on arrêtera de répondre big_smile


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#40 Le 28/01/2013, à 12:22

ky

Re : [RESOLU]Erreur "sudo"

D'accord merci de l'explication.

Pour le mode recovery est-ce qu'il y a une importance de l'ordre des arguments des commandes ?

Tu m'as dit de mettre "mount -o remount, rw /"

Sur ce site http://www.psychocats.net/ubuntu/fixsudo

Ils mettent "mount -o rw, remount /"

Hors ligne

#41 Le 28/01/2013, à 12:23

tiramiseb

Re : [RESOLU]Erreur "sudo"

L'ordre des arguments à l'option "-o" n'importe pas.

Attention par contre, pas d'espace après la virgule.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#42 Le 29/01/2013, à 11:20

ky

Re : [RESOLU]Erreur "sudo"

Bon le problème à l'air beaucoup plus important que ça finalement ...

J'ai eu accès à l'ordinateur de mon tuteur donc j'ai essayé le mode recovery mais plutôt décevant...

Lorsque je tape les commandes pour remettre mon utilisateur en admin ça me met "adduser : l'utilisateur nagios existe déjà"

Il me reste plus qu'à tout recommencer ?

Hors ligne

#43 Le 29/01/2013, à 11:26

tiramiseb

Re : [RESOLU]Erreur "sudo"

As-tu bien tapé

adduser nagios admin

?

l'utilisateur "nagios" existe déjà, alors "adduser nagios" ne marchera pas.
"adduser nagios admin" ajouter l'utilisateur "nagios" dans le groupe "admin".

Si tu as vraiment fait "adduser nagios admin" et que tu as obtenu le résultat que tu montres (ce qui me semble très très étonnant), tu peux faire :

usermod nagios -a -G admin

qui aura le même résultat.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#44 Le 29/01/2013, à 11:30

ky

Re : [RESOLU]Erreur "sudo"

J'ai essayé deux commandes :

adduser nagios sudo

qui m'a  retourné "adduser : nagios existe déjà"

et

adduser nagios admin

qui m'a retourné "adduser : le groupe admin n'existe pas"

Je suis désespérée... J'ai pas trop envie de demander de refaire un serveur mais bon je sens que je vais finir pas y être obligée.

Hors ligne

#45 Le 29/01/2013, à 11:32

tiramiseb

Re : [RESOLU]Erreur "sudo"

"adduser : le groupe admin n'existe pas"

Merde désolé je me suis gouré.

Tu peux tenter :

adduser nagios sudo

La config par défaut de sudo évoque un groupe "admin", mais celui-ci n'existe en effet pas par défaut - je m'étais arrêté là.
Par contre cette config évoque aussi le groupe "sudo", qui existe par défaut...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#46 Le 29/01/2013, à 11:41

ky

Re : [RESOLU]Erreur "sudo"

Dès que je pourrai reprendre l'ordi pour redémarrer mon serveur j'essayerai adduser nagios sudo je crois que quand je l'ai essayé j'ai inversé la commande surement pour ça que j'ai eu le "adduser : nagios existe déjà".

Je vais essayer de voir s'il peut me laisser sa session d'ouverte quand il ira manger pour essayer.

Par contre, je me suis demandée si c'était normal qu'au démarrage de mon serveur quand j'ai appuyé sur esc que j'avais 3 modes de dépannage (différentes versions) ?

Hors ligne

#47 Le 29/01/2013, à 11:42

tiramiseb

Re : [RESOLU]Erreur "sudo"

j'ai appuyé sur esc que j'avais 3 modes de dépannage (différentes versions) ?

Différentes versions du noyau Linux probablement.
Quand tu mets à jour le noyau Linux ça ne désinstalle pas tout seul les anciennes versions.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#48 Le 29/01/2013, à 11:53

ky

Re : [RESOLU]Erreur "sudo"

D'accord. Merci.

Dès que j'ai testé "adduser nagios sudo" je metterai le résultat.

Et si ça ne marche pas, y a  pas moyen d'éditer le fichier sudoers à partir du mode recovery ?

Hors ligne

#49 Le 29/01/2013, à 11:54

tiramiseb

Re : [RESOLU]Erreur "sudo"

Oui tu peux aussi faire ça, avec la commande visudo.
Ou alors tu peux directement éditer le fichier /etc/groups pour mettre "nagios" dans le groupe "sudo".

Mais bon la commande devrait marcher.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#50 Le 29/01/2013, à 15:11

ky

Re : [RESOLU]Erreur "sudo"

YOUUUUHOUUU !!!!

Merci énormement !!!

C'est bon j'ai récupéré les droits !!

La commande sudo marche très bien maintenant je te remercie vraiment !!

Hors ligne

Haut de page ↑