Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 23/01/2013, à 10:34

Fanuilos

[Résolu] Clavier K400 non détecté

Bonjour,

J'ai acheté il y a peu un clavier Logitech K400 pour mon portable (le clavier du portable est en qwerty, je voulais un clavier azerty), mais il n'est pas détecté sous mon Ubuntu 10.04.

Je trouve cela très bizarre, car au grub de démarrage, mon clavier est détecté et je peux l'utiliser. Cependant, une fois arrivé sous Ubuntu, le clavier ne répond plus...

Voici mon lsusb quand le clavier et son receveur USB sont branchés :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 011: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 001 Device 003: ID 187c:0520 Alienware Corporation 
Bus 002 Device 004: ID 8087:07da Intel Corp. 
Bus 001 Device 004: ID 064e:8127 Suyin Corp. 
Bus 003 Device 012: ID 046d:c52b Logitech, Inc. Unifying Receiver

Et voilà mon lsmod :

]Module                  Size  Used by
hid_apple              13375  0 
bbswitch               13396  0 
rfcomm                 47604  12 
bnep                   18281  2 
parport_pc             32866  0 
ppdev                  17113  0 
binfmt_misc            17540  1 
snd_hda_codec_hdmi     32474  1 
snd_hda_codec_ca0132    18365  1 
joydev                 17693  0 
arc4                   12529  2 
iwlwifi               397059  0 
snd_hda_intel          33773  3 
snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_ca0132,snd_hda_intel
uvcvideo               72627  0 
snd_hwdep              17764  1 snd_hda_codec
videodev               98259  1 uvcvideo
v4l2_compat_ioctl32    17128  1 videodev
mac80211              506862  1 iwlwifi
snd_pcm                97275  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
i915                  477602  2 
drm_kms_helper         46978  1 i915
snd_seq_midi           13324  0 
drm                   241971  3 i915,drm_kms_helper
snd_rawmidi            30748  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
hid_logitech_dj        18730  0 
snd_timer              29990  2 snd_pcm,snd_seq
dell_wmi               12681  0 
i2c_algo_bit           13423  1 i915
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
sparse_keymap          13890  1 dell_wmi
btusb                  18332  1 
video                  19596  1 i915
mac_hid                13253  0 
mei                    41616  0 
cfg80211              205774  2 iwlwifi,mac80211
snd                    79041  16 snd_hda_codec_hdmi,snd_hda_codec_ca0132,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
lp                     17799  0 
rts_pstor             445241  0 
wmi                    19256  1 dell_wmi
parport                46562  3 parport_pc,ppdev,lp
psmouse                97485  0 
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
serio_raw              13211  0 
bluetooth             180153  23 rfcomm,bnep,btusb
sdhci_pci              18826  0 
sdhci                  33205  1 sdhci_pci
atl1c                  41718  0 
usbhid                 47238  1 hid_logitech_dj
hid                    99636  3 hid_apple,hid_logitech_dj,usbhid

Et le dmesg quand je branche le receveur usb (le clavier est allumé) pendant ma session:

[ 4294.911160] usb 3-4: new low-speed USB device number 11 using xhci_hcd
[ 4294.932498] usb 3-4: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
[ 4294.935693] input: Microsoft  Microsoft Basic Optical Mouse v2.0  as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/input/input18
[ 4294.936138] generic-usb 0003:045E:00CB.0013: input,hidraw2: USB HID v1.11 Mouse [Microsoft  Microsoft Basic Optical Mouse v2.0 ] on usb-0000:00:14.0-4/input0
[ 5114.001458] usb 3-1: new full-speed USB device number 12 using xhci_hcd
[ 5114.024038] logitech-djreceiver 0003:046D:C52B.0016: hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
[ 5114.024330] logitech-djreceiver 0003:046D:C52B.0016: logi_dj_probe:logi_dj_recv_query_paired_devices error:-32
[ 5114.024654] logitech-djreceiver: probe of 0003:046D:C52B.0016 failed with error -32
[ 5116.525900] usb 3-2: USB disconnect, device number 9
[ 5116.525906] usb 3-2.2: USB disconnect, device number 10

Ce même clavier fonctionne sur Debian Squeeze, et je souhaiterai rester sur Ubuntu 10.04 (dernière version compatible CUDA)

Pourriez-vous m'aider?

Merci :-)

Edit :
Après avoir lu ceci : http://ubuntuforums.org/showthread.php?t=2044922, je me suis rendu compte que j'ai exactement le même problème. En rebranchant le receveur 6 ou 7 fois, le clavier est finalement détecté... Il semblerait que le conflit soit dû à mon installation de bumblebee (que je n'ai effectivement pas installé sous Debian) pour gérer ma carte graphique... Je ne suis pas sûr de voir le rapport... Personne n'aurait une idée?

Dernière modification par Fanuilos (Le 25/01/2013, à 09:29)

Hors ligne

#2 Le 24/01/2013, à 18:20

Roguntu

Re : [Résolu] Clavier K400 non détecté

Salut Fanuilos,
j'ai été confronté au même problème sous linux Mint. Toujours cette error -32 dans dmesg.


Certains vont se tirer les cheveux, mais ce petit script devrait corriger ton problème:


/usr/sbin/unifix

#/bin/bash
function checkError32() {
	cat /var/log/syslog | grep logitech-djreceiver | tail -n 1 | grep "error -32" | wc -l 
}

while [[ $(checkError32) -gt 0 ]]; do
	echo "reloading module hid_logitech_dj ..."
	modprobe -r hid_logitech_dj 
	modprobe -a hid_logitech_dj
	
done

echo "The unifying system should work now !"

Tu branche ton adapteur et en root tu fait

# unifix

Hors ligne

#3 Le 25/01/2013, à 09:28

Fanuilos

Re : [Résolu] Clavier K400 non détecté

Tout simplement parfait smile

Merci beaucoup!

Hors ligne

#4 Le 03/03/2013, à 11:06

Zangror

Re : [Résolu] Clavier K400 non détecté

Je me permets de rebondir sur cette discussion...

J'ai également acheté un clavier Logitech k400 et j'avais aussi des problèmes de détection (chose que j'ai résolu en utilisant le script donné par Roguntu). Une fois le clavier détecté, je sais l'utiliser quelques secondes, puis après impossible de faire bouger la souris (ou utiliser le clavier) pendant quelques secondes à quelques minutes... sad

J'utilise un Ubuntu 12.10 sur un Dell inspiron 15R SE.
Je pense que mon problème vient du fait que je n'ai que des ports USB3 sur mon ordinateur... mais je n'en suis absolument pas sur hmm

Quelqu'un saurait m'aider?
Merci! smile

Hors ligne

#5 Le 04/03/2013, à 10:17

Fanuilos

Re : [Résolu] Clavier K400 non détecté

Visiblement, c'était un bug dans le kernel qui gérait mal l'USB3, et il y a l'air qu'une solution a été trouvée (https://bugs.launchpad.net/ubuntu/+sour … ug/1039143).

Le script proposé ici doit fonctionner chez moi car je suis sur Ubuntu 10.04, avec une ancienne version du kernel (3.2).

Probablement que le patch qui a été proposé pour résoudre le problème sera ajouté dans une prochaine mise à jour :-)

Hors ligne

Haut de page ↑