Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 26/01/2013, à 20:16

Hada de la Luna

[résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Bonjour à tous big_smile

Mon changeur de bureau affiche 7 bureaux dans les réglages, mais les noms de bureaux ont disparus sauf un(1), cependant qu'on ne peut plus changer de bureau (2).

Comment rétablir le fonctionnement des bureaux ?

Notes :

  1. il n'y a que le bureau 1 à être affiché dans la liste de noms

  2. plus de menu pour le faire lorsqu'on clique sur un fenêtre d'application pour la changer de bureau

Dernière modification par Hada de la Luna (Le 31/01/2013, à 19:00)


Hada de la Luna :o)

Hors ligne

#2 Le 28/01/2013, à 13:14

Hada de la Luna

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Bonjour, big_smile

le problème semble exister dans cette FAQ :

Fag Xfce a écrit :

Les panneaux ont disparu ! Comment les rétablir ?

(xfce 4.4 et 4.6)(toutes versions xubuntu) Appuyez sur les touches ALT+F2 - ceci lancera la fenêtre pour ouvrir un programme - tapez-y la commande xfce4-panel puis cliquez sur le bouton Lancer.

Si ce sont les bords des fenêtres et les bureaux virtuels, tapez la commande xfwm4 –replace puis cliquez sur le bouton lancer. Si le problème persiste à chaque démarrage, allez dans les préférences du bureau et activez la case "Autoriser Xfce à gérer le bureau".

ATTENTION: si vous utilisez la commande "kill" (tuer une application) ,c.f. astuces, et cliquez sur l'écran, vous obtiendrez cette disparition.

Sauf que xfwm4 –replace n'existe pas chez moi en tout cas... sad


Hada de la Luna :o)

Hors ligne

#3 Le 28/01/2013, à 14:45

The Uploader

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Salut

C'est xfwm4 --replace (avec deux tirets, vu que c'est une "option longue". Les options courtes ont une seule lettre et un seul tiret, comme dans xfce4-panel -r qui recharge tous les tableaux de bords Xfce). Ceci dit, xfwm4 --replace sert uniquement si tu as perdus les décorations autours des fenêtres (impossible de les réduire, de les agrandir, et de les fermer. Sans compter la perte du titre de la fenêtre et de la gestion de l'ordre des fenêtres)

Ensuite, tu peux vérifier ton nombre de bureaux et leurs noms dans le gestionnaire de paramètres => Espaces de travail.

Dernière modification par The Uploader (Le 28/01/2013, à 14:52)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/Xfce sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#4 Le 31/01/2013, à 15:56

Hada de la Luna

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Merci ! big_smile

The Uploader a écrit :

C'est xfwm4 --replace (avec deux tirets, vu que c'est une "option longue".

ça n'existe pas non plus ! En fait c'est xfce4-untructoutattaché mais aucun de résout le problème et celui indiqué dans la FAQ n'existe pas (ou plus) si c'était une application différente donc tout attaché (j'ai aussi essayé)...

The Uploader a écrit :

Ensuite, tu peux vérifier ton nombre de bureaux et leurs noms dans le gestionnaire de paramètres => Espaces de travail.

Comme dit plus haut

Hada de la Luna a écrit :

Mon changeur de bureau affiche 7 bureaux dans les réglages, mais les noms de bureaux ont disparus sauf un(1), cependant qu'on ne peut plus changer de bureau (2).

Quelqu'un a t'il des idées de pistes de résolution ? Car là Xfce est inutilisable : plus qu'un seul bureau, et bordures des fenêtre invisibles car fenêtres collées en haut à gauche sous les lanceurs... roll


Hada de la Luna :o)

Hors ligne

#5 Le 31/01/2013, à 16:00

The Uploader

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

ça n'existe pas non plus !

Ça devrait.

Tu peux retourner le résultat de la commande :

which xfwm4

?

Dans une console TTY par exemple (Ctrl + Alt + F1)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/Xfce sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#6 Le 31/01/2013, à 18:59

Hada de la Luna

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

$ which xfwm4
/usr/bin/xfwm4

Je viens de recommencer

$ xfwm4 --replace
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:50: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:51: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
/usr/share/themes/Murrina-Tangoesque/gtk-2.0/gtkrc:63: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.

Cela a l'air de fonctionner finalement... je viens de récupérer des fenêtres et des bureaux fonctionnels wink


Hada de la Luna :o)

Hors ligne

#7 Le 31/01/2013, à 20:02

The Uploader

Re : [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Le mieux dans un terminal est de faire :

xfwm4 --replace &

Le '&' démarre xfwm4 dans un nouveau processus, indépendant de celui du terminal. Cela permet de ne pas perdre les décorations des fenêtres quand tu quittes le terminal.

Quant à pourquoi xfwm4 a bogué (normalement il est démarré automatiquement à l'ouverture de la session), ça peut être le "bug de session" (je crois qu'il est résolu une fois pour toute dans Xfce 4.12, qui n'est pas encore sorti), ou un thème xfwm4 bogué (ça se sélectionne dans gestionnaire de paramètres => Gestionnaire de fenêtres => Style).

Je te recommanderai
1.D'effacer les fichiers contenus dans ~/.cache/sessions/ (ce qui vide le cache de session). Ignore les éventuels sous-dossiers.
2.De toujours faire attention à ce que la case à cocher "Enregistrer la session pour les prochaines connexions" soit décochée lors d'une fermeture de session ou d'une extinction. Heureusement le paramètre est sauvegardé, donc il n'y pas à la décocher à chaque fois.
3.de choisir un autre thème pour xfwm4. Tel que Greybird (fourni avec Xubuntu)

Tout cela pour éviter que cette situation ne se reproduise à l'avenir.

Au pire, tu peux rajouter dans le gestionnaire de paramètres => Session et démarrage => Démarrage automatique, une nouvelle entrée qui aura pour commande "xfwm4 --replace" (sans les guillemets) ce qui aura pour effet de redémarrer xfwm4 à chaque ouverture de session.

Dernière modification par The Uploader (Le 31/01/2013, à 20:05)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/Xfce sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [résolu]12.04LTS : Changeur de bureaux "réduit" à un seul bureau

Haut de page ↑