Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 27/01/2013, à 16:23

28marc28

Probleme config postfix

Bonjour à tous,

je suis en train de de configurer un serveur ubuntu avec postfix,

j'ai utilisé le tut suivant :  ici

je suis bloqué, je ne peux pas envoyer de mail...

le telnet <adresse ip de mon poste> 25, et 110 ou 143 fonctione.

J'ai des erreurs dans le mail.log que je n'arrive pas à interpréter. 
Les lignes en question:


Jan 27 15:20:05 sweb2 postfix/smtpd[20669]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jan 27 15:20:05 sweb2 postfix/smtpd[20669]: fatal: /etc/postfix/mysql_virtual_alias_maps.cf: bad string length 0 < 1: where_field =
Jan 27 15:20:06 sweb2 postfix/master[19947]: warning: process /usr/lib/postfix/smtpd pid 20669 exit status 1
Jan 27 15:20:06 sweb2 postfix/master[19947]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jan 27 15:20:22 sweb2 postfix/pickup[19950]: AE3DF142947: uid=1000 from=<sweb2>
Jan 27 15:20:22 sweb2 postfix/cleanup[19988]: AE3DF142947: message-id=<20130127142022.AE3DF142947@mondomaine.com>
Jan 27 15:20:22 sweb2 postfix/cleanup[19988]: warning: mysql:/etc/postfix/mysql_virtual_alias_maps.cf lookup error for "root@mondomaine.com"
Jan 27 15:20:22 sweb2 postfix/cleanup[19988]: warning: AE3DF142947: virtual_alias_maps map lookup problem for root@mondomaine.com -- deferring delivery
Jan 27 15:21:06 sweb2 postfix/smtpd[20683]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jan 27 15:21:06 sweb2 postfix/smtpd[20683]: fatal: /etc/postfix/mysql_virtual_alias_maps.cf: bad string length 0 < 1: where_field =
Jan 27 15:21:07 sweb2 postfix/master[19947]: warning: process /usr/lib/postfix/smtpd pid 20683 exit status 1
Jan 27 15:21:07 sweb2 postfix/master[19947]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling


Je ne comprends pas ou est le soucis, il me parle sans arret de mysql_virtual_alias_maps.cf dont voici le contenu:

user = postfixadmin
password = <mon mot de passe>
hosts = 127.0.0.1
dbname = postfixadmin
table = alias
select_field = goto where_field = address additional_conditions = and active = '1'


mon posconf n:


append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
disable_vrfy_command = yes
dovecot_destination_recipient_limit = 1
enable_original_recipient = no
header_checks = regexp:/etc/postfix/header_checks
inet_interfaces = all
mailbox_size_limit = 0
maximal_backoff_time = 8000s
maximal_queue_lifetime = 7d
minimal_backoff_time = 1000s
mydestination = localhost
myhostname = mondomaine.com
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mynetworks_style = host
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
smtp_helo_timeout = 60s
smtp_tls_security_level = may
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_client_restrictions = reject-rbl_client sbl.spamhaus.org, reject_rbl_client blackholes.easynet.nl, reject_rbl_client dnsbl.njabl.org
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_delay_reject = yes
smtpd_hard_error_limit = 12
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks, warn_if_reject reject_nonfqdn_hostname, reject_invalid_hostname, permit
smtpd_recipient_limit = 16
smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_unauth_destination, check_policy_service inet:127.0.0.1:10023, permit
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = mondomaine.com
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks, warn_if_reject reject_non_fqdn_sender, reject_unknown_sender_domain, reject_unauth_pipelining, permit
smtpd_soft_error_limit = 3
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 450
virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf, mysql:/etc/postfix/mysql_virtual_alias_domainaliases_maps.cf
virtual_gid_maps = static:8
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = mysql:/etc/postfix/mysql_virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf, mysql:/etc/postfix/mysql_virtual_mailbox_domainaliases_maps.cf
virtual_transport = dovecot
virtual_uid_maps = static:150



Avez-vous des idées ???? Je ne sais plus ou chercher.

28marc28

Dernière modification par 28marc28 (Le 27/01/2013, à 16:36)

Hors ligne

#2 Le 27/01/2013, à 17:05

28marc28

Re : Probleme config postfix

Précision  utile je viens de m'apercevoir qu'il manquait dans le main.cf par rapport au tuto

smtpd_tls_note_starttls_offer=yes

quand je fais un restart de postfix il me répond:

* Stopping Postfix Mail Transport Agent postfix                                                                                      /usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
                                                                                                                               [ OK ]
* Starting Postfix Mail Transport Agent postfix                                                                                      postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: smtpd_tls_note_starttls_offer=yes
                                                                                                             


Peut être que cela à rapport avec mon problème ?

28marc28

Dernière modification par 28marc28 (Le 27/01/2013, à 17:05)

Hors ligne

#3 Le 27/01/2013, à 17:33

tiramiseb

Re : Probleme config postfix

28marc28 a écrit :

Je ne comprends pas ou est le soucis, il me parle sans arret de mysql_virtual_alias_maps.cf dont voici le contenu:

user = postfixadmin
password = <mon mot de passe>
hosts = 127.0.0.1
dbname = postfixadmin
table = alias
select_field = goto where_field = address additional_conditions = and active = '1'

Compare ton fichier avec celui du tuto.

Il y a des retours à la ligne que tu n'as pas faits.

Le tuto a écrit :
user = postfixadmin
password = mot_de_passe_administrateur_postfix
hosts = 127.0.0.1
dbname = postfixadmin
table = alias
select_field = goto
where_field = address
additional_conditions = and active = '1'


PS: As-tu vraiment besoin de MySQL ? Rares sont les cas où on en a besoin (grosses infrastructures, notamment)...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 27/01/2013, à 17:59

28marc28

Re : Probleme config postfix

merci tiramiseb,

j'ai tout remodifié ca à l'air mieux.

en revanche ça ne passe toujours pas et j'ai maintenant les message d'erreur suivant:


Jan 27 16:55:12 sweb2 postfix/master[23330]: terminating on signal 15
Jan 27 16:55:12 sweb2 postfix/master[23481]: daemon started -- version 2.9.3, configuration /etc/postfix
Jan 27 16:55:18 sweb2 postfix/smtpd[23487]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jan 27 16:55:18 sweb2 postfix/smtpd[23487]: connect from unknown[192.168.3.54]
Jan 27 16:55:19 sweb2 postfix/smtpd[23487]: warning: unknown smtpd restriction: "reject-rbl_client"
Jan 27 16:55:19 sweb2 postfix/smtpd[23487]: NOQUEUE: reject: RCPT from unknown[192.168.3.54]: 451 4.3.5 Server configuration error; from=<contact@mondomaine.com> to=<contact@mondomaine.com> proto=ESMTP helo=<[192.168.3.54]>
Jan 27 16:55:21 sweb2 postfix/cleanup[23496]: AB3CE14294C: message-id=<20130127155521.AB3CE14294C@mondomaine.com>
Jan 27 16:55:21 sweb2 postfix/smtpd[23487]: disconnect from unknown[192.168.3.54]
Jan 27 16:55:21 sweb2 postfix/qmgr[23485]: AB3CE14294C: from=<double-bounce@mondomaine.com>, size=922, nrcpt=1 (queue active)
Jan 27 16:55:21 sweb2 postfix/smtp[23498]: AB3CE14294C: to=<postmaster@change-this-to-your.domain.tld>, relay=none, delay=0.25, delays=0.07/0.06/0.12/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=change-this-to-your.domain.tld type=AAAA: Host not found)
Jan 27 16:55:21 sweb2 postfix/bounce[23499]: warning: AB3CE14294C: undeliverable postmaster notification discarded
Jan 27 16:55:21 sweb2 postfix/qmgr[23485]: AB3CE14294C: removed

je continue a chercher.

Encore merci.

Hors ligne

#5 Le 27/01/2013, à 18:06

28marc28

Re : Probleme config postfix

Pour le PS, en fait j'utilise Mysql aussi pour du web.

voila.

Hors ligne

#6 Le 27/01/2013, à 18:12

tiramiseb

Re : Probleme config postfix

Tu as plusieurs messages d'erreurs qui me semblent assez parlants...
Tu peux chercher sur le texte de ces messages...

28marc28 a écrit :

Pour le PS, en fait j'utilise Mysql aussi pour du web.

Mais ça ne t'oblige pas à stocker des éléments de configuration de Postfix dans MySQL smile
Pour ma part je trouve que c'est un peu ardu de commencer direct avec MySQL (voire inutile, ça dépend des cas), mais tu peux aussi faire ça pour le fun...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 27/01/2013, à 18:14

28marc28

Re : Probleme config postfix

je suis en train de faire, pour l'instant, la recherche sur le forum du message : warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

Hors ligne

#8 Le 27/01/2013, à 18:19

tiramiseb

Re : Probleme config postfix

N'hésite pas à chercher sur Google aussi (et surtout) !


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#9 Le 27/01/2013, à 18:23

28marc28

Re : Probleme config postfix

je pense avoir compris qu'il fallait mettre dict_nis_init = mondomaine.com quelque part le seul problème c'est que je ne sais pas encore dans quel fichier.

Pour répondre à ta question sur mysql, en fait j'ai suivi le tu ni plus ni moins, venant du monde windows c'est la premiere fois que je fais un serveur postfix, d'habitude je travail avec hmailserver ...

Hors ligne

#10 Le 27/01/2013, à 18:26

tiramiseb

Re : Probleme config postfix

Pour ma part je n'ai jamais rien configuré de relatif à nis dans Postfix (en 10 ans de son utilisation).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 27/01/2013, à 18:27

28marc28

Re : Probleme config postfix

bon c'est trouvé en fait il fallait  ajouter au fichier main.cf:

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

le reste maintenant ...

warning: unknown smtpd restriction: "reject-rbl_client"

Hors ligne

#12 Le 27/01/2013, à 18:35

28marc28

Re : Probleme config postfix

alors j'en ai trouvé encor deux, que des problèmes de syntaxe. Faut dire que je me suis tout tapé à la main ....

bon maintenant j'ai :
Jan 27 17:32:32 sweb2 postfix/master[24816]: terminating on signal 15
Jan 27 17:32:32 sweb2 postfix/master[25006]: daemon started -- version 2.9.3, configuration /etc/postfix
Jan 27 17:32:39 sweb2 postfix/smtpd[25018]: connect from unknown[192.168.3.54]
Jan 27 17:32:39 sweb2 postfix/smtpd[25018]: warning: connect to 127.0.0.1:10023: Connection refused
Jan 27 17:32:39 sweb2 postfix/smtpd[25018]: warning: problem talking to server 127.0.0.1:10023: Connection refused
Jan 27 17:32:40 sweb2 postfix/smtpd[25018]: warning: connect to 127.0.0.1:10023: Connection refused
Jan 27 17:32:40 sweb2 postfix/smtpd[25018]: warning: problem talking to server 127.0.0.1:10023: Connection refused
Jan 27 17:32:40 sweb2 postfix/smtpd[25018]: NOQUEUE: reject: RCPT from unknown[192.168.3.54]: 451 4.3.5 Server configuration problem; from=<contact@mondomaine.com> to=<contact@mondomaine.com> proto=ESMTP helo=<[192.168.3.54]>
Jan 27 17:32:42 sweb2 postfix/smtpd[25018]: disconnect from unknown[192.168.3.54]


ça promet ...

Hors ligne

#13 Le 27/01/2013, à 18:39

tiramiseb

Re : Probleme config postfix

connect to 127.0.0.1:10023: Connection refused

Le truc qui devrait écouter sur le port 10023 n'y écoute pas.
Postgrey selon ton tuto.

Dernière modification par tiramiseb (Le 27/01/2013, à 18:39)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#14 Le 27/01/2013, à 19:10

28marc28

Re : Probleme config postfix

alors il manquait : postgray donc j'ai fait un sudo apt-get install postgray

Maintenant j'ai lemessage d'erreur suivant:
Jan 27 18:05:21 sweb2 postgrey[27652]: Process Backgrounded
Jan 27 18:05:21 sweb2 postgrey[27652]: 2013/01/27-18:05:21 postgrey (type Net::Server::Multiplex) starting! pid(27652)
Jan 27 18:05:21 sweb2 postgrey[27652]: Resolved [localhost]:10023 to [127.0.0.1]:10023, IPv4
Jan 27 18:05:21 sweb2 postgrey[27652]: Binding to TCP port 10023 on host 127.0.0.1 with IPv4
Jan 27 18:05:21 sweb2 postgrey[27652]: Setting gid to "133 133"
Jan 27 18:05:21 sweb2 postgrey[27652]: Setting uid to "123"
Jan 27 18:05:28 sweb2 postfix/master[25696]: terminating on signal 15
Jan 27 18:05:29 sweb2 postfix/master[27809]: daemon started -- version 2.9.3, configuration /etc/postfix
Jan 27 18:05:35 sweb2 postfix/smtpd[27824]: connect from unknown[192.168.3.54]
Jan 27 18:05:36 sweb2 postgrey[27652]: action=greylist, reason=new, client_name=unknown, client_address=192.168.3.54, sender=contact@mondomaine.com, recipient=contact@mondomaine.com
Jan 27 18:05:36 sweb2 postfix/smtpd[27824]: NOQUEUE: reject: RCPT from unknown[192.168.3.54]: 450 4.2.0 <contact@mondomaine.com>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/asubstra.com.html; from=<contact@mondomaine.com> to=<contact@mondomaine.com> proto=ESMTP helo=<[192.168.3.54]>
Jan 27 18:05:58 sweb2 postfix/smtpd[27824]: disconnect from unknown[192.168.3.54]

oualou ... c'est sans fin ... même si cela progresse !

Hors ligne

#15 Le 27/01/2013, à 19:13

tiramiseb

Re : Probleme config postfix

Ben non, là ça a bien marché...
Le message a été bloqué par le mécanisme de greylisting, c'est normal.

Sais-tu ce qu'est le greylisting ?
Si tu ne sais pas ce que c'est, alors c'est normal que tu crois que ça ne marche pas.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#16 Le 27/01/2013, à 20:16

28marc28

Re : Probleme config postfix

En effet, je l'ai installé et n'est pas encore eu le temps de regarder ce que c'est exactement.
Je suppose que c'est lié avec spamassasin que je connais par aileur sur windows.

Hors ligne

#17 Le 27/01/2013, à 20:25

tiramiseb

Re : Probleme config postfix

Aucun lien avec spamassassin smile
(À part que les deux font du filtrage de messages...)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#18 Le 27/01/2013, à 21:02

28marc28

Re : Probleme config postfix

Mon message pouvais être pris pour du spam donc il est bien parti ...

Maintenant c'est sur la réception que cela bloque, il me demande le mot de ase d'abuse alorsque je suis sur le compte contact@mondomaine.com, visiblement le message indique qu'il n'arrive pas connecter au mysql, ca doit être une erreur de conf du pop (erreur de syntaxe)?

Jan 27 19:56:27 sweb2 postfix/master[27809]: warning: process /usr/lib/postfix/smtpd pid 28825 exit status 1
Jan 27 19:56:27 sweb2 postfix/master[27809]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jan 27 19:57:25 sweb2 dovecot: auth-worker(28833): mysql(localhost): Connected to database postfixadmin
Jan 27 19:57:25 sweb2 dovecot: auth-worker(28833): Warning: mysql: Query failed, retrying: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\ SELECT username as user, password, '/home/vmail//abuse' as userdbhome, \ 'mail' at line 1
Jan 27 19:57:25 sweb2 dovecot: auth-worker(28833): Error: sql(abuse,192.168.3.54): Password query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\ SELECT username as user, password, '/home/vmail//abuse' as userdbhome, \ 'mail' at line 1
Jan 27 19:57:27 sweb2 postfix/smtpd[28835]: fatal: invalid "-o content_filter" option value: missing '=' after attribute name
Jan 27 19:57:28 sweb2 postfix/master[27809]: warning: process /usr/lib/postfix/smtpd pid 28835 exit status 1
Jan 27 19:57:28 sweb2 postfix/master[27809]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

Dernière modification par 28marc28 (Le 27/01/2013, à 21:07)

Hors ligne

#19 Le 27/01/2013, à 22:22

28marc28

Re : Probleme config postfix

bon, a priori j'ai corrigé deux ou erreurs de syntaxes et il ne me reste plus que ce message:

Jan 27 21:17:00 sweb2 dovecot: pop3-login: Disconnected (auth failed, 1 attempts in 4 secs): user=<contact@mondomaine.com>, method=PLAIN, rip=192.168.3.54, lip=192.168.3.54, secured, session=<tLyc10rUjQDAqAM2>

Je crois comprendre qu'il y a une erreur d'authentification ...
Dans la création du compte mail je n'ai pas mis d'alias, faut-il en mettre un et le mettre dans la config du soft de messagerie ?

Hors ligne

#20 Le 27/01/2013, à 22:38

28marc28

Re : Probleme config postfix

plus qu'un message d'erreur :
Jan 27 21:37:07 sweb2 postfix/smtpd[30426]: fatal: invalid "-o content_filter" option value: missing '=' after attribute name

Thurdenberd me dit qu'il n'y a aucun message ...
Alors que je me suis envoyé plein de message à moi même ...

la je sèche net !

Dernière modification par 28marc28 (Le 27/01/2013, à 23:14)

Hors ligne

#21 Le 28/01/2013, à 22:00

28marc28

Re : Probleme config postfix

bilan des courses, j'ai fais une recherche avec un grep et toute les lignes de postfix qui contiennent  "-o content_filter =" avec rien ont été misent en commentaire ...
Le message dans le log est toujours là.

De plus j'ai créer deux compte de messagerie visiblement quand j'envoi un message à l'autre il n'y a pas d'erreur.
En revanche, le compte destinataire ne reçoit rien ...

Avez-vous des idées ce ce que je peux avoir oublié ou pas bien compris.

28marc28

Hors ligne

#22 Le 28/01/2013, à 22:01

tiramiseb

Re : Probleme config postfix

Que dit la file d'attente de Postfix ?

postqueue

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#23 Le 28/01/2013, à 22:11

28marc28

Re : Probleme config postfix

alors j'ai fais un postqueue -s mondomaine.com:

Reponse : postqueue: fatal: flush service is not configured  for destination  "mondomaine.com"

Si je comprends bien il y a un service qui n'est pas configuré pour recevoir sur "mondomaine.com", mais lequel Flush ?

Hors ligne

#24 Le 28/01/2013, à 22:12

tiramiseb

Re : Probleme config postfix

postqueue -p

ou alors

mailq

?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#25 Le 28/01/2013, à 22:18

28marc28

Re : Probleme config postfix

alors avec l'option -p j'ai:

-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
D088E142961      303 Sun Jan 27 21:51:45  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=05439-01 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=05439-01 (in reply to end of DATA command))
                                         toto@mondomaine.com

943EB142959      327 Sun Jan 27 21:33:04  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=05440-01 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=05440-01 (in reply to end of DATA command))
                                         contact@mondomaine.com

1D31A14294A      468 Sun Jan 27 19:17:40  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=05440-02 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=05440-02 (in reply to end of DATA command))
                                         contact@mondomaine.com

72F61142967      330 Mon Jan 28 20:49:28  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=03143-01 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=03143-01 (in reply to end of DATA command))
                                         toto@mondomaine.com

E21AD14295D      321 Sun Jan 27 21:34:24  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=05439-02 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=05439-02 (in reply to end of DATA command))
                                         contact@mondomaine.com

35689142965      407 Sun Jan 27 22:00:10  contact@mondomaine.com
(host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=05440-03 - Temporary MTA failure on relaying, From MTA() during fwd-connect (Negative greeting:  at (eval 110) line 479.): id=05440-03 (in reply to end of DATA command))
                                         toto@mondomaine.com

687E7142947      479 Sun Jan 27 14:27:24  sweb2@mondomaine.com
(temporary failure. Command output: lda: Error: user root@mondomaine.com: Error reading configuration: Invalid settings: postmaster_address setting not given lda: Fatal: Internal error occurred. Refer to server log for more information.)
                                         root@mondomaine.com

-- 6 Kbytes in 7 Requests.

Hors ligne

Haut de page ↑