Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 31/01/2013, à 03:06

fenix122

erreur avec apache2 : « Unable to open logs » [RESOLU]

bonjours mon serveur marcher super bien j'avais mis ispconfig sa fait des mois que tout marche super bien  mais la plus rien marche je ne peux accédé que par ssh

et j'ai un gros message inscrit en vert skynet et quand je demare apache car il ne veut plus démaré aprés un reboot suite au bug j'ai redémaré le serveur

voila le message

[warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Thu Jan 31 00:57:31 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(20)Not a directory: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.


si quelqu'un peux me donner les lignes de code a faire etc je suis ouvert svp j'ai besoin d'aide merci beaucoup

edit modo : puisqu'il faut que ça soit moi qui le fasse… changement du titre

Dernière modification par fenix122 (Le 02/02/2013, à 12:54)

Hors ligne

#2 Le 31/01/2013, à 03:09

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

capture message erreur

Hors ligne

#3 Le 31/01/2013, à 03:45

nesthib

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

1- commence par lire les règles du forum
2- choisis un titre explicite
3- donne le retour de :

sudo netstat -tulpn

en utilisant des balises [ code ]


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdnGMT-4

Hors ligne

#4 Le 31/01/2013, à 03:48

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

resultat

merci encore de ton aide et désolé si j'ai pas bien respecté les règles

Hors ligne

#5 Le 31/01/2013, à 04:11

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Que donne la commande :

ls -ld /var/log/apache2

PS : poste ta réponse entre balises [ code ] et non sous forme d'image. Tu obtiendras ces balises avec l'icône "< >"  au-dessus du champ où tu tapes ton texte


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#6 Le 31/01/2013, à 04:13

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

-rw-r--r-- 1 root root 0 Jan 30 23:08 /var/log/apache2

merci

Hors ligne

#7 Le 31/01/2013, à 04:14

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

je sais même pas c'est quoi de se message en gros en vert écrit skynet j'ai jamais eu sa

Hors ligne

#8 Le 31/01/2013, à 04:30

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Sur ta capture d'écran avec "skynet" il y a d'autres choses écrites. Je ne sais pas si c'est ton image ou si c'est parce que je suis sur mon téléphone,  mais je n'arrive pas à lire ce texte, c'est particulièrement flou. Peux-tu nous montrer plus clairement cette partie-là ?


Pour ton problème avec Apache, exécute les commandes suivantes :

rm /var/log/apache2
mkdir /var/log/apache2

C'est vraiment très étrange si tu nous dis que c'est venu tout seul : Dans ce cas il y a quelque chose qui ne va pas sur ton serveur...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#9 Le 31/01/2013, à 04:32

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

[warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Thu Jan 31 00:57:31 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(20)Not a directory: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.

Hors ligne

#10 Le 31/01/2013, à 04:35

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

oui j'ai mis ya quelque moi ispconfig tout marcher bien et la boum le site est devenu inaccessible j''avais l'erreur 500 je me connecte par ssh j'ai direct le truc en gros skynet je n'est jamais eu sa c'est quoi skynet c'est bizard du coup j'ai dit je vais donc redémarré mon serveur j'ai taper reboot et au démarrage apache démarrer plus
et j'avais le message comme j'ai mis juste au dessus

Hors ligne

#11 Le 31/01/2013, à 04:39

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Tu ne m'as pas montré le détail de ce qu'il y a juste avant et juste après "skynet".

Pour Apache,  as-tu exécuté les commandes que j'ai données ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#12 Le 31/01/2013, à 04:42

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

oui j'ai excuté putty et demande mon mot de passe et m'affiche sa aprés

                            **** Connected to ****

               ### #  ### ##   ###  ##  ### ###  ######  ######
               ##  #   ## #     ##  ##   ##  #    ##    # # ## #
               ####    ###       ####    ### #    ####     ##
                 ###   ####       ##     #####    ##       ##
               #  ##   ## ##      ##     ## ##    ## ##    ##
               ####   #### ##    ####   ### ##   ######   #### 1.0
                 **** Linux server1.domaine.com 3.2.0-36-generic x86_64 ****

aprés j'ai taper

sudo /etc/init.d/apache2 restart

et la j'ai eu le message

[warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Thu Jan 31 00:57:31 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(20)Not a directory: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.

Dernière modification par fenix122 (Le 31/01/2013, à 04:46)

Hors ligne

#13 Le 31/01/2013, à 04:43

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

et tes ligne de code sa na rien fait c'est passer a la ligne

Hors ligne

#14 Le 31/01/2013, à 04:55

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Pour Apache : as-tu essayé de le relancer ?

Pour SKYNET : je ne trouve rien de ce genre...
Tu es sûr que tu n'as rien installé de spécial avant ça ?
Ton serveur est-il bien sécurisé ? Le mot de passe est-il robuste ?
Quelle est la version de ton système d'exploitation ? Maintiens-tu bien les paquets à jour ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#15 Le 31/01/2013, à 05:06

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

oui j'ai mis 12 chiffre et lettre et j'ai tout qui est a jour de plus oui je fait constamment les mis a jour j'ai ubuntu server 12 en 64 et

après le reste j'ai suivi ce tuto pour l'installation de ispconfig

http://www.zenzla.com/linux/70-un-serve … erver.html et tout fonctionnais depuis plusieurs moi c'est d'un seul coup

d’après ce que j'ai trouver sur le net sa serait une histoire de certificat ssl lorsque j'avais terminer de faire mon serveur j'ai redémarré et même pas eu de message skynet tout marcher super bien

aprés si tu es sous pc je veux bien te donné mon mot de passe je le changerais après que tu as fini

et a part le mettre a jour de temps en temps c'est tout ce que je fait dessus je n'est rien installer depuis l'installation de ispconfig puis la quand je démarre je démarre direct en tant que root alors que avant si je voulais être en route je devrai taper sudo su et le mot de passe  et oui j'ai tenté de le relancé toujours le meme message d'erreur

root@server1:~# sudo /etc/init.d/apache2 start
 * Starting web server apache2                                                  [Thu Jan 31 03:04:53 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
Action 'start' failed.
The Apache error log may have more information.
                                                                         [fail]
root@server1:~#

Hors ligne

#16 Le 31/01/2013, à 05:10

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Non ce n'est pas le même message d'erreur. Maintenant il doit que les logs peuvent contenir des informations. Alors jetez un oeil aux logs... smile

... Et moi je vais essayer de dormir.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#17 Le 31/01/2013, à 05:15

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

ok ben je vais aussi faire de même j'ai contacté mon hébergeur qui lui a accès a l'occasion ya une erreur aussi sur leur système peut être ils sont gentil je te remercie de ton aide mais je galère pas mal a trouver les log j'ai essayé de faire

j'ai juste trouver dans var/log/apache2/error.log

(20)Not a directory: apache2: could not open error log file /var/log/ispconfig/httpd/monsite.com/error.log.
Unable to open logs

(20)Not a directory: apache2: could not open error log file /var/log/ispconfig/httpd/monsite.com/error.log.
Unable to open logs
(20)Not a directory: apache2: could not open error log file /var/log/ispconfig/httpd/monsite.com/error.log.
Unable to open logs

(20)Not a directory: apache2: could not open error log file /var/log/ispconfig/httpd/monsite.com/error.log.
Unable to open logs

encore merci de ton aide et passe une bonne nuit

Dernière modification par fenix122 (Le 31/01/2013, à 05:17)

Hors ligne

#18 Le 31/01/2013, à 17:52

Elder

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Salut,

Skynet c'est ou la belgique ou terminator

Tu ne te serais pas fait rooter !

En tout état de cause l'erreur viens d'apache dont la conf du/des virtual hosts semble foireuse.
Comme le message parle du port 443 je dirais une embrouille de ce genre...

Pour les logs, le serveur apache a t-il les droits ? Les dossiers vers lesquels il essaye d'écrire existent ils ?
@+

Dernière modification par Elder (Le 31/01/2013, à 17:58)

Hors ligne

#19 Le 31/01/2013, à 18:09

sorrodje

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

C't'un souci de configuration d'apache ça .. avec plusieurs sites en ssl qui se marchent sur les pied du coup.

Peut on avoir le contenu de /etc/apache2/ports.conf et des virtualhosts qui utiliseraient ssl ( en particulier le s'il te plait ? ) et puis le résultat de :

ls -la /etc/apache2/sites-enabled

pendant qu'on y est smile

Dernière modification par sorrodje (Le 31/01/2013, à 18:09)


Utilisateur Debian/Ubuntu depuis 2008 - http://sorrodje.alter-it.org

Hors ligne

#20 Le 31/01/2013, à 18:19

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

fenix122 : tu as plein de répertoires qui manquent dans tes logs, c'est étrange que ça soit venu tout seul... le problème qui génère cette erreur et qui bloque Apache est là.

Pour la ligne suivante, oui c'est un souci de virtualhost qui se marchent dessus, clairement :

[warn] _default_ VirtualHost overlap on port 443, the first has precedence

mais ce n'est qu'un warning, ce n'est pas ça qui bloque Apache.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#21 Le 31/01/2013, à 18:30

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

ben je sais ce que c'est mon hebergeur ma contacter me disant que mon serveur avait un vers et donc j'ai demandais a reinstaller

Hors ligne

#22 Le 31/01/2013, à 18:37

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

je vous remerci mais bon voila j'ai pas trouver par contre c'était quoi la faiblesse de mon serveur j'ai sa comme serveur http://www.zenzla.com/linux/70-un-serve … erver.html

sous ubuntu x64 12

encore merci a tout le monde de votre aide si quelqu'un peut m'orienté vers un bon tuto plus sécurisé

Hors ligne

#23 Le 01/02/2013, à 13:28

Elder

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

Salut,

T'as une page "Skynet" que tu n,'as apparemment jamais vue

fenix122 a écrit :

je n'est jamais eu sa c'est quoi skynet c'est bizard

Apparement ton /etc/motd a été modifié (vu l'ascii-art skynet au login via ssh)...
Vu de ma fenêtre ton serveur a chopé la peste.

AMHA ce n'est pas le moment de chercher la faiblesse mais de nettoyer !!!

@+

Hors ligne

#24 Le 01/02/2013, à 13:31

fenix122

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

merci j'ai demander a mon hébergeur de réinstaller tout comment empêcher sa par la suite

Hors ligne

#25 Le 01/02/2013, à 13:32

tiramiseb

Re : erreur avec apache2 : « Unable to open logs » [RESOLU]

fenix122 a écrit :

quelqu'un peut m'orienté vers un bon tuto plus sécurisé

Un tuto je ne sais pas, je n'ai jamais utilisé de tuto. Je préfère apprendre les choses plutôt que dérouler bêtement des instructions qui viennent d'un tiers.

Un conseil que je peux te donner, c'est de n'utiliser que des outils qui proviennent des paquets fournis par Ubuntu et de maintenir ces paquets à jour dès qu'une mise à jour est disponible. Donc de surveiller le serveur au moins quotidiennement.

Je te conseille de ne pas utiliser de logiciel style ispconfig, webmin ou autre pour configurer ton serveur : ces logiciels sont forcément des failles de sécurité en plus... Surtout si tu les installes indépendamment des paquets (comme le fait le tuto que tu montres).

Et si tu dois absolument utiliser un logiciel provenant d'ailleurs (non fourni par la distribution ou alors si tu as besoin d'une version plus récente), il faut que tu appliques les mises à jour manuellement à chaque fois qu'une nouvelle version sort (il faut donc t'abonner aux annonces du logiciel en question).

Gérer un serveur, ce n'est pas une tâche banale, ce n'est pas une tâche facile.

Dernière modification par tiramiseb (Le 01/02/2013, à 13:33)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

Haut de page ↑