Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 04/02/2013, à 23:00

Newbie67

Problème développement en local : rester sur le localhost

Bonjour,

J'espère publier dans le bon endroit. roll

J'ai un petit serveur avec quelques petits sites web sur Wordpress (site perso et pour des asso). J'envisage de déménager mes sites et d'en profiter pour faire des ravalements de façade, mettre à jour des plug-ins, etc. Tout ça en local pour ne pas prendre le risque de tout faire bugger. Je suis amateur je précise. ^^

Bref. J'ai installé LAMP, j'ai d'ailleurs eu de l'aide sur ce forum. Puis j'ai créé un dossier (monsite.com) où j'ai mis Wordpress. J'ai modifié wp-config.php, je suis allé sur install.php et, super, tout fonctionne !

localhost/private/monsite.com fonctionne bien.

Puis j'ai remplacé les dossiers wp-content et wp-includes. Tout est bon, je retrouve tout comme il faut.

Ensuite j'ai exporté ma base de données (du serveur) pour l'importer sur la version locale et là, rien ne va plus ! Quoique je fasse, au lieu d'arriver sur localhost/private/monsite.com, j'arrive irrémédiablement sur monsite.com (sur le serveur et non sur le localhost). Du coup je suis coincé.

Comment faire pour qu'il cesse de me renvoyer en-dehors du localhost ?

Merci d'avance. Désolé si ce n'est pas très claire. J'imagine que la solution doit être simple et connue, mais comme je n'arrive pas à formuler mon problème, je ne parviens pas à faire des recherches pertinentes.


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

#2 Le 04/02/2013, à 23:25

Maisondouf

Re : Problème développement en local : rester sur le localhost

Est ce que tu as gardé le fichier .sql de ton export de la base du serveur ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 04/02/2013, à 23:29

xavier4811

Re : Problème développement en local : rester sur le localhost

Bonsoir,

Newbie67 a écrit :

Ensuite j'ai exporté ma base de données (du serveur) pour l'importer sur la version locale et là, rien ne va plus !

Donc l'adresse du site doit être stockée dans des champs texte de la BDD. Reste qu'a savoir ou.

Hors ligne

#4 Le 04/02/2013, à 23:38

Newbie67

Re : Problème développement en local : rester sur le localhost

C'était dans la table options.

Du coup, quand je remettrai tout ça sur le nouveau serveur, faudra que je fasse gaffe de ne pas oublier de remettre le NDD.


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

#5 Le 04/02/2013, à 23:38

tiramiseb

Re : Problème développement en local : rester sur le localhost

Et localhost/wp-admin ça ne marche pas ?
C'est dans l'interface d'administration de WordPress que tu peux configurer cette adresse.

EDIT : Oups j'étais pas assez rapide smile

Dernière modification par tiramiseb (Le 04/02/2013, à 23:39)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#6 Le 05/02/2013, à 00:00

Maisondouf

Re : Problème développement en local : rester sur le localhost

Par sécurité mets un coup de grep sur le fichier sql pour savoir si il n'y en a pas d'autre...


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 05/02/2013, à 00:23

Newbie67

Re : Problème développement en local : rester sur le localhost

Comment fait-on un grep sur le fichier sql ?

Car je me suis réjouis trop vite, si je peux accéder, naviguer sur et utiliser le backoffice de Wordpress, la navigation sur le site me pose problème : à part la page d'accueil, il ne trouve rien. big_smile

Merci pour votre aide. smile


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

#8 Le 05/02/2013, à 00:28

Maisondouf

Re : Problème développement en local : rester sur le localhost

Newbie67 a écrit :

Comment fait-on un grep sur le fichier sql ?

Le fichier .sql que t'as récupéré du serveur contient toute la base en clair, donc tu peux chercher dedans.
Si ton site s'appelle "www.machin.truc", tu fais

grep www.machin.truc mon_fichier.sql

ça va te sortir toutes les lignes qui contiennent www.machin.truc


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#9 Le 05/02/2013, à 04:40

Newbie67

Re : Problème développement en local : rester sur le localhost

Je n'ai pas réussi à faire ce grep. Depuis le terminal il me dit qu'il n'y a aucun dossier ou fichier de ce type.

Sinon j'ai recherché directement sur PHPmyadmin dans toutes les tables. Il y avait bien 2 occurences, toutes deux changées correctement.

Serveur Apache redémarré. Toujours le même problème : not found (sauf pour le backoffice et la page d'accueil).

EDIT : serait-il possible que ce soit une histoire d'URL rewriting ?

Dernière modification par Newbie67 (Le 05/02/2013, à 06:04)


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

#10 Le 05/02/2013, à 08:50

tiramiseb

Re : Problème développement en local : rester sur le localhost

Newbie : peut-être une histoire de rewriting en effet.

Dans l'interface d'administration de WordPress :
- dans l'écran "Réglages » Général", les champs "Adresse web de WordPress" et "Adresse web du site" sont-ils bons (a priori ça correspond aux champs que tu as modifiés manuellement dans la base) ;
- dans l'écran "Réglages » Permaliens", tente de remettre "valeur par défaut" puis à nouveau la configuration qui était en place avant (c'est, je crois, le seul écran par lequel WordPress modifie les règles de rewrite).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 05/02/2013, à 17:35

Newbie67

Re : Problème développement en local : rester sur le localhost

Avec les réglages des permaliens sur défaut, tout fonctionne. En revanche, dès que je change ce paramètre, j'en reviens au même problème.

La solution serait-elle d'activer le mod rewrite ? Si oui, comment faire ?

J'ai trouvé ceci : http://codex.wordpress.org/Using_Permal … her_Issues

Wordpress a écrit :

Your server may not have the AllowOverride directive enabled. If the AllowOverride directive is set to None in your Apache httpd.config file, then .htaccess files are completely ignored.

Mais où trouver ce fichier ?


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

#12 Le 05/02/2013, à 17:37

tiramiseb

Re : Problème développement en local : rester sur le localhost

La solution serait-elle d'activer le mod rewrite ?

Il est en effet possible qu'il ne soit pas activé par défaut

Si oui, comment faire ?

sudo a2enmod rewrite

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#13 Le 05/02/2013, à 17:53

Newbie67

Re : Problème développement en local : rester sur le localhost

Ca marche ! smile

Ah ah, c'est trop cool. smile

Merci beaucoup pour votre aide. Votre aide rapide en plus.


Nouveau sur Ubuntu. En phase d'acclimatation.

Hors ligne

Haut de page ↑