Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 05/02/2013, à 01:09

Vinceg76

Menu de netboot vide [RESOLU]

Bonjour à tous !

J'ai décidé d'installer un boot PXE sur mon serveur local, celui-ci fonctionne d'ailleurs très bien quand il n'a qu'une architecture à distribuer.
Cependant, j'ai des ordinateurs 32 et 64 bits et j'ai donc décidé de faire comme dans la documentation du site sauf que je pêche sur un point : le fichier /var/lib/tftpboot/pxelinux.cfg/default

ll PXE boot
DEFAULT vesamenu.c32
# liste des choix 
label Boot sur disque local
    kernel chain.c32
    append hd0

label Installer Ubuntu 1204 Precise 32bits
        kernel ubuntu/precise/ubuntu-installer/i386/boot-screens/vesamenu.c32
        append ubuntu/precise/ubuntu-installer/i386/boot-screens/menu.cfg

label Installer Ubuntu 1204 Precise 64bits
        kernel ubuntu/precise/ubuntu-installer/amd64/boot-screens/vesamenu.c32
        append ubuntu/precise/ubuntu-installer/amd64/boot-screens/menu.cfg

Tous ces fichiers existe mais, quand je sélectionne l'une des deux entrèes lors d'un boot en PXE, je tombe sur un menu désespérément vide...

Si quelqu'un à la moindre idée du pourquoi du comment, je lui en serais très reconnaissant !

Merci d'avance.

Dernière modification par Vinceg76 (Le 05/02/2013, à 11:27)

Hors ligne

#2 Le 05/02/2013, à 01:16

Maisondouf

Re : Menu de netboot vide [RESOLU]

Quand tu mets ce chemin:

ubuntu/precise/ubuntu-installer/i386/boot-screens/vesamenu.c32

ça veut dire que le fichier vesamenu.c32 se trouve dans:

/var/lib/tftpboot/ubuntu/precise/ubuntu-installer/i386/boot-screens/vesamenu.c32

C'est bien ça ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 05/02/2013, à 01:17

Vinceg76

Re : Menu de netboot vide [RESOLU]

oui !

Hors ligne

#4 Le 05/02/2013, à 01:22

Maisondouf

Re : Menu de netboot vide [RESOLU]

Regardes du coté des droits de lecture

ls -l /var/lib/tftpboot/ubuntu/precise/ubuntu-installer/i386/boot-screens/

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#5 Le 05/02/2013, à 01:23

Vinceg76

Re : Menu de netboot vide [RESOLU]

tout le monde à le droit de lecture sur l'intégralité du dossier.

Hors ligne

#6 Le 05/02/2013, à 01:28

Maisondouf

Re : Menu de netboot vide [RESOLU]

J'ai compris....
Dans les menus de l'installer, il font des "include" sur des fichiers qui sont censé se trouver sur la racine du serveur tftp, par exemple:

include ubuntu-installer/amd64/boot-screens/stdmenu.cfg

Donc il faut créer un lien symbolique pour que les menus des installer retrouvent leurs petits.

ln -s  /var/lib/tftpboot/ubuntu/precise/ubuntu-installer  /var/lib/tftpboot/ubuntu-installer

EDIT : ou modifier tous les menus des installer

Dernière modification par Maisondouf (Le 05/02/2013, à 01:29)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#7 Le 05/02/2013, à 01:34

Vinceg76

Re : Menu de netboot vide [RESOLU]

Je viens de tester le lien symbolique, aucun changement... Je vais essayer de modifier un des menus...

EDIT : Je regarderai ça demain, je tombe de fatigue... Merci quand même pour ton aide !

Dernière modification par Vinceg76 (Le 05/02/2013, à 01:37)

Hors ligne

#8 Le 05/02/2013, à 01:46

Maisondouf

Re : Menu de netboot vide [RESOLU]

ERREUR de ma part ....
Le lien doit être relatif sinon il sort du cadre du serveur tftp...

cd /var/lib/tftpboot
sudo rm ubuntu-installer
sudo ln -s  ubuntu/precise/ubuntu-installer  ubuntu-installer

ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#9 Le 05/02/2013, à 11:26

Vinceg76

Re : Menu de netboot vide [RESOLU]

Merci beaucoup ! Tout fonctionne maintenant !

Hors ligne

Haut de page ↑