Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 13/02/2013, à 22:56

guillaumec38

sso Kerberos/ldap/nfs4

Bonjour.

Je travaille sur virtualbox avec des images ubuntu 12.04 (une image server et une client).
J'ai configuré le serveur et le client apparemment bien.

Aprs m'être occupé de kerberos et ldap, j'ai configuré autofs afin de charger le dossier /home de chaque client a la connexion.

Ainsi, sur mon poste client, je dois renseigner le nom d'utilisateur et le mot de passe. Ces derniers sont verifié via le serveur, et ca marche. Ensuite ubuntu m'affiche un écran noir, comme quand il charge la session, puis revient a l'écran de log hmm

Je suppose que le problème vient uniquement du cote "graphique" car la connexion fonctionne a merveille sur un terminal.

Je precise que c'est pour un projet de Master.

Auriez vous des pistes a me suggérer afin de résoudre mon soucis? hmm

Cordialement,
Guillaume.

Hors ligne

#2 Le 14/02/2013, à 00:09

Maisondouf

Re : sso Kerberos/ldap/nfs4

Chronologiquement sur le client, tu démarres la VM, tu te logues en tant que USER_X, autofs te demande les ID et lors du montage la session s'arrête...
C'est ça ?


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 14/02/2013, à 09:28

guillaumec38

Re : sso Kerberos/ldap/nfs4

Voilà c est bien ca. Le mot de passe est correctement vérifié (si j en met un faux Ubuntu m affiche bien que c est incorrect). Puis le client commence la phase de démarrage comme il ke ferai sur un client local classique, il affiche l écran qui vérifie la batterie, mais la j ai un écran noir et je reviens sur l écran qui demande les logins.
J ai essayé de lire /var/log/auth.log et /var/log/syslog mais je ne trouve rien de probant.

J en ai quand même déduis que le problème doit être lié à l interface graphique vu que le terminal (ctrl+alt+1) fonctionne niquel.

Hors ligne

#4 Le 14/02/2013, à 10:27

guillaumec38

Re : sso Kerberos/ldap/nfs4

Visiblement mon montage nfs est foireux puisque quand je me connecte via le terminal, un message m indique que le system ne trouve pas de dossier home.
Je vais creuser de ce cote la.

Hors ligne