Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 15/02/2013, à 09:36

Sciensous

dev audio

suis-je au bon endroit ? smile

bonjour,

je suis sur la 12.04; il n'y a plus de /dev/audio
quelqu'un sait par quoi est-il remplacé ?

je voulais tester:

VOIP
Il est possible d’utiliser netcat pour la VOIP \o/ Pour cela rien de bien compliquer.

Sur notre serveur :

nc -l -u -p 1337 < /dev/audio > /dev/audio
Et sur notre client :

nc -u IP_SERV 1337 < /dev/audio > /dev/audio

Hors ligne

#2 Le 16/02/2013, à 05:24

Hibou57

Re : dev audio

Alors ce que je constate chez moi, m’est étrange.

Si je fais

ls -l /dev

… le listing ne renvoi rien pour “audio*

Si je me rend dans le répertoire /dev depuis Nautilus, je vois pourtant apparaitre des éléments audio, audio1, audio2, audio3 et audioctl.

Si depuis cet emplacement depuis Nautilus, je fais un clique‑droit sur le fond du répertoire et choisi « Ouvrir dans un terminal », le répertoire de travail indiqué n’est pas “/dev” mais :

/media/546091c4-6381-4612-8113-d51340167237/dev

Pourtant, je ne vois rien de tel quand je me rend dans /media avec Nautilus, qui m’affiche un répertoire vide, du même nom que mon login.

Mais quand je fais ce qui suit depuis une console :

ls -l /media

… je vois bien apparaitre un répertoire de ce nom :

546091c4-6381-4612-8113-d51340167237

Et la commande suivante :

ls -l /media/546091c4-6381-4612-8113-d51340167237/dev

… me renvoit (extrait) ceci :

crw-rw---- 1 root audio 14,   4 oct.  17 16:56 audio
crw-rw---- 1 root audio 14,  20 oct.  17 16:56 audio1
crw-rw---- 1 root audio 14,  36 oct.  17 16:56 audio2
crw-rw---- 1 root audio 14,  52 oct.  17 16:56 audio3
crw-rw---- 1 root audio 14,   7 oct.  17 16:56 audioctl

Ce que je voit présent dans les répertoires, dépend de l’environnement, console ou Nautilus, en particulier les répertoires /media et /dev. Et je me demande ce que viens faire le répertoire /media dans cette histoire.

C’est une vrai purée de pois tout ça 8-O


-- edit --

J’ai compris une partie de ce que je voyais. Je me suis embrouillé depuis Nautilus, en cliquant sur une partition voisine au lieu de cliquer sur la racine. Mais je ne supprime pas ce que j’ai écrit, parce que ce que je voyais correspond quand‑même à quelque chose d’intéressant, c’est la partition d’Ubuntu 12.10, que je teste en ce moment. Il semble alors que les choses soient différentes sur Ubuntu 12.10 et Ubuntu 12.04 (je suis sous 12.04), et que je viens de le remarquer par accident. À investiguer plus en détails plus tard…

Dernière modification par Hibou57 (Le 16/02/2013, à 05:36)


Hajimemashteeeee… \(^o^)/ Tachikoma desu (^_^;)
Le saviez‑vous : le j’m’en foutisme est la cause de la plupart des fléaux du monde contemporain.
Mangez des standards : un grand bol de Standard tous les matins, et vous débutez la journée en pleine forme !
bulleforum.net — Forum de discussions, La Bulle (papotage de la vie courante ou choses trop sérieuses)

Hors ligne

#3 Le 16/02/2013, à 07:30

nesthib

Re : dev audio

Il n'y a plus de /dev/{dsp,audio} depuis qu'Ubuntu utilise pulseaudio. Tu peux utiliser la commande padsp pour simuler le fichier.


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdnGMT-4

Hors ligne

#4 Le 17/02/2013, à 00:41

Sciensous

Re : dev audio

merci netshib (encore une fois wink - et bonjour à bordeaux )

donc sur le client il suffirait de mettre:

padsp -s IP_SERV:1337
#au lieu de:
nc -u IP_SERV 1337 < /dev/audio > /dev/audio

j'essaye à l'occasion; n'hésite pas à confirmer si je ne donne pas de résultat concluant ou non de l'essai...

Dernière modification par Sciensous (Le 17/02/2013, à 00:41)

Hors ligne

#5 Le 17/02/2013, à 03:31

nesthib

Re : dev audio

Je ne sais pas si ça fonctionnera comme ça (je pense que pulseaudio attend l'adresse d'un serveur pulseaudio, pas le numéro de port sur lequel netcat écoute), à toi d'essayer.

NB. je passerai le bonjour à Bordeaux si j'y retourne tongue


GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdnGMT-4

Hors ligne

#6 Le 19/02/2013, à 09:53

Sciensous

Re : dev audio

bon j'ai essayé rapidement et ça n'a pas l'air de fonctionner effectivement sad

par contre, à moins qu'il y ait un équivalent aussi simple, je trouve dommage de ne plus pouvoir utiliser cette pseudo-VOIP via nc et /dev/audio
(l'idée étant de rester en ligne de commande)

Hors ligne