Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 15/02/2013, à 16:50

Venus75

Executable "Littre" ne se lance pas !

Bonjour,

J'ai décompressé "Littre-linux-2.0.tar.bz2" dans mon dossier personnel, puis lancé "Littre" comme indiqué dans la doc -après avoir accordé les permissions sur le fichier- , mais rien ne se passe !
Le contrôle du type de fichier donne :

ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped

J'ai procédé à l'installation sur un autre machine identique (Ubuntu 12.04) et cela fonctionne.
Merci de votre aide

Hors ligne

#2 Le 15/02/2013, à 17:46

gigiair

Re : Executable "Littre" ne se lance pas !

Exécute dans une console:

wget http://dictionnaire-le-littre.googlecode.com/files/Littre-linux-2.0.tar.bz2
tar xvjf  Littre-linux-2.0.tar.bz2
./Littre-linux-2.0/Littre 

Ça doit marcher

Peut-être essayes-tu de le lancer depuis le répertoire Littre-linux-2.O, dans ce cas, il faut précéder la commande de ./

./Littre

Dernière modification par gigiair (Le 15/02/2013, à 17:52)


--
JJR.

Hors ligne

#3 Le 15/02/2013, à 17:57

gigiair

Re : Executable "Littre" ne se lance pas !

gigiair a écrit :

Exécute dans une console:

wget http://dictionnaire-le-littre.googlecode.com/files/Littre-linux-2.0.tar.bz2
tar xvjf  Littre-linux-2.0.tar.bz2
./Littre-linux-2.0/Littre 

Ça doit marcher

Peut-être essayes-tu de le lancer depuis le répertoire Littre-linux-2.O, dans ce cas, il faut précéder la commande de ./

./Littre

Tu peux aussi cliquer bêtement sur l'icône.


--
JJR.

Hors ligne

#4 Le 15/02/2013, à 18:14

Venus75

Re : Executable "Littre" ne se lance pas !

Bonjour gigiair,

J'ai exécuté toute ta procédure et la réponse du shell :

bash: ./Littre-linux-2.0/Littre: Aucun fichier ou dossier de ce type 

Quand à bêtement cliquer sur l'icone, c'est la première chose que j'ai faite, évidemment. Comme je l'ai dit, j'ai procédé de la même façon sur deux PC, sur l'un cela fonctionne parfaitement... sur l'autre rien !
Si tu as une autre idée, je suis preneuse.

Hors ligne

#5 Le 15/02/2013, à 18:44

gigiair

Re : Executable "Littre" ne se lance pas !

Il y a forcément eu une erreur, soit au  wget, soit á la décompression.
Essaie ls -l  ./Littre-linux-2.0/Littre
Normalement il ne devrait rien répondre.
Poste ici le retour de la décompression.


--
JJR.

Hors ligne

#6 Le 15/02/2013, à 18:45

moko138

Re : Executable "Littre" ne se lance pas !

Venus75 a écrit :
GNU/Linux 2.6.15

(Ubuntu 12.04)

  C'est compatible ???

Hors ligne

#7 Le 15/02/2013, à 19:12

Venus75

Re : Executable "Littre" ne se lance pas !

@gigiair, je n'ai eu aucun message d'erreur hormis celui en #4.
Voici la réponse de la console à "ls -l  ./Littre-linux-2.0/Littre" :

-rwxr-xr-x 1 (user) (user) 12392819 juil. 29  2009 ./Littre-linux-2.0/Littre

@moko138, ...n'en sais rien !

Hors ligne

#8 Le 15/02/2013, à 19:15

Venus75

Re : Executable "Littre" ne se lance pas !

... Lorsque je tape dans la console "./Littre-linux-2.0/Littre"  = bash: ./Littre-linux-2.0/Littre: Aucun fichier ou dossier de ce type.. alors qu'il figure bien dans le dossier !

Hors ligne

#9 Le 15/02/2013, à 22:47

gigiair

Re : Executable "Littre" ne se lance pas !

C'est bizarre,je dirais même plus très bizarre.
Ce que je trouve encore plus bizarre c'est que dans le retour de ls -l, il y ait (user) (user) comme nom d'USER. Je n'ai jamais vu ça. Il est vrai que je suis loin d'avoir tout vu.
AMHA le problème vient de là, tu dois avoir une identité qui ne permet pas d'exécuter un programme. Je ne sais pas si ça se peut, mais quand on essaye d'exécuter sous un compte USER un programme qui exige d'être root, on peut avoir ce genre de réponse.
Que retourne la commande

whoami

Dernière modification par gigiair (Le 15/02/2013, à 22:52)


--
JJR.

Hors ligne

#10 Le 17/02/2013, à 22:25

Venus75

Re : Executable "Littre" ne se lance pas !

Bonsoir gigair,

J'ai du m'absenter...
Pour le retour console, j'ai remplacé mon login par "USER", mais il y a effectivement mon nom de connexion à la place.:)
La commande "whoami" me renvoie :

******

Non, le problème ne vient pas de là... d'où vient-il ?

****** = mon login

Hors ligne

#11 Le 18/02/2013, à 12:30

gigiair

Re : Executable "Littre" ne se lance pas !

C'est une bonne question. Il y a forcément quelque chose qui ne tourne pas rond dans ta configuration. Le plus vraisemblable est un problème de droits d'exécution.
Et en super-utilisateur, ça ne se lance  pas non plus ?


--
JJR.

Hors ligne

#12 Le 19/02/2013, à 13:53

Venus75

Re : Executable "Littre" ne se lance pas !

Non plus !

Hors ligne

#13 Le 19/02/2013, à 16:18

gigiair

Re : Executable "Littre" ne se lance pas !

Littre doit faire appel à une bibliothèque qui n'est pas installée sur ta machine. D'après la doc, les sources sont disponibles et il est possible de compiler sur la machine en installant qt-sdk.
Chez moi, ça entraîne la désinstallation d'une bibliothèque dont vlc dépend. Je n'ai pas envie d'essayer.
Je ne vois pas d'autre explication.
L'auteur donne son adresse courriel sur la page  http://code.google.com/p/dictionnaire-le-littre/ . Elle saurait sûrement répondre.


--
JJR.

Hors ligne

#14 Le 19/02/2013, à 16:29

gl38

Re : Executable "Littre" ne se lance pas !

Le Littré est dans synaptic avec stardict, ça fonctionne même si stardict en fond de tâche est plus qu'agaçant puisqu'il ouvre le Littré dès qu'on fait un copier-coller, mais on peut arrêter stardict.
Cordialement,
Guy

En ligne

Haut de page ↑