Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 20/02/2013, à 13:18

chiraz

sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bonjour
je suis debutante au ubuntu ,j'ai installe ubuntu 11.04
j'ai essai d'installer ns3 et j'ai suivi les etapes. les trois premiers instruction sont passée :
sudo apt-get install gcc g++ python python-dev
sudo apt-get install mercurial
sudo apt-get install bzr
sudo apt-get install gdb valgrind
sudo apt-get install gsl-bin libgsl0-dev libgsl0ldbl
mais lorsque j'ai saisi: user@user-VPCEB1J1E:~$  sudo apt-get install flex bison libfl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libfl-dev
alors qu'est ce que je fais pour passer de ce probleme

Dernière modification par chiraz (Le 27/02/2013, à 20:25)

Hors ligne

#2 Le 20/02/2013, à 13:21

xabilon

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Salut

Quelle est ta version d'Ubuntu, et que contient ton fichier /etc/apt/sources.list ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 20/02/2013, à 13:36

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bonjour
la version d'ubuntu c'est 11.04
peut etre mon probleme s'est rtesolu car j'ai telecharger le paquet libfl dev puis il est isntalle dans ubuntu pauis j'ai saisi # sudo apt-get update

# sudo apt-get install libfl-dev
le resultat est:
user@user-VPCEB1J1E:~$ sudo apt-get install libfl-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libfl-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-2.6.38-8 linux-headers-2.6.38-8-generic-pae
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Hors ligne

#4 Le 20/02/2013, à 13:43

xabilon

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Si ça marche, tant mieux, mais tu as donc dû télécharger le paquet d'une version plus récente d'Ubuntu, car ce paquet n'existe pas dans les dépôts de Ubuntu 11.04 (d'où ton message d'erreur) ; il n'y est présent que depuis Ubuntu 12.04.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 20/02/2013, à 13:51

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

sincerement ,c'est la premier fois que je travaille sur l'ubuntu. je ne connais pas comment il marche,mais mon but d'installer ns3 .
j'ai trouve des problemes à chaque isntruction.est ceque vous etes d'idée pour me sauver de ce truc.
user@user-VPCEB1J1E:~$ sudo apt-get install g++-3.4 gcc-3.4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet g++-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « g++-3.4 »
E: Impossible de trouver le paquet gcc-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « gcc-3.4 »
et merci

Hors ligne

#6 Le 20/02/2013, à 14:05

xabilon

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Ah oui, d'accord, j'avais même pas percuté ... Ubuntu 11.04 est une version obsolète et n'est plus maintenue depuis 3 mois, ses dépôts n'existent plus, il est donc normal que les paquets ne soient pas trouvés.

tu as 2 solutions :
- ou tu réinstalles une version plus récente (la 12.04 par exemple, durera encore 4 ans)
- ou tu restes avec la 11.04, mais il faudra que tu changes les dépôts, et tu n'auras plus de mises à jour


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#7 Le 20/02/2013, à 14:18

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

merci pour votre reponse ,donc je choisi de reinstaller une autre version d'ubuntu comme 12.04 car mon projet de fin d'etude se base sur le ns3 ( vanet  highway) et j'ai pas le temps suffisant pour rester dans ce type de problème

Hors ligne

#8 Le 20/02/2013, à 23:05

xabilon

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Ok, c'est un bon choix smile


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#9 Le 20/02/2013, à 23:57

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

smile

Hors ligne

#10 Le 27/02/2013, à 16:03

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bonjour,
j'installe ubuntu 12.04 et j'aessai d'installer ns3 :
user@user-VPCEB1J1E:~$  sudo apt-get install g++-3.4 gcc-3.4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet g++-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « g++-3.4 »
E: Impossible de trouver le paquet gcc-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « gcc-3.4 »

Hors ligne

#11 Le 27/02/2013, à 17:36

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Il te faut absolument la version 3.4 ?

Pour trouver les versions disponibles :

apt-cache search g++|grep ^g++-[0-9]
apt-cache search gcc|grep ^gcc-[0-9]

En ligne

#12 Le 27/02/2013, à 17:46

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bonjour ,je  saisi ses instructions mais meme resultat: user@user-VPCEB1J1E:~$ apt-cache search g++|grep ^g++-[0-9]
g++-4.4 - GNU C++ compiler
g++-4.5 - GNU C++ compiler
g++-4.6 - GNU C++ compiler
g++-4.6-multilib - GNU C++ compiler (multilib files)
g++-4.4-arm-linux-gnueabi - GNU C++ compiler
g++-4.4-arm-linux-gnueabihf - GNU C++ compiler
g++-4.4-multilib - GNU C++ compiler (multilib files)
g++-4.5-arm-linux-gnueabi - GNU C++ compiler
g++-4.5-arm-linux-gnueabihf - GNU C++ compiler
g++-4.5-multilib - GNU C++ compiler (multilib files)
g++-4.6-arm-linux-gnueabi - GNU C++ compiler
g++-4.6-arm-linux-gnueabihf - GNU C++ compiler
g++-4.6-multilib-arm-linux-gnueabi - GNU C++ compiler (multilib files)
g++-4.6-multilib-arm-linux-gnueabihf - GNU C++ compiler (multilib files)
user@user-VPCEB1J1E:~$ apt-cache search gcc|grep ^gcc-[0-9]
gcc-4.4 - GNU C compiler
gcc-4.4-base - GCC, the GNU Compiler Collection (base package)
gcc-4.4-doc - Documentation for the GNU compilers (gcc, gobjc, g++)
gcc-4.5 - The GNU C compiler
gcc-4.5-base - The GNU Compiler Collection (base package)
gcc-4.5-doc - Documentation for the GNU compilers (gcc, gobjc, g++)
gcc-4.5-plugin-dev - Files for GNU GCC plugin development.
gcc-4.6 - GNU C compiler
gcc-4.6-base - GCC, the GNU Compiler Collection (base package)
gcc-4.6-doc - Documentation for the GNU compilers (gcc, gobjc, g++)
gcc-4.6-multilib - GNU C compiler (multilib files)
gcc-4.6-plugin-dev - Files for GNU GCC plugin development.
gcc-4.6-source - Source of the GNU Compiler Collection
gcc-4.4-arm-linux-gnueabi - GNU C compiler
gcc-4.4-arm-linux-gnueabi-base - GCC, the GNU Compiler Collection (base package)
gcc-4.4-arm-linux-gnueabihf - GNU C compiler
gcc-4.4-arm-linux-gnueabihf-base - GCC, the GNU Compiler Collection (base package)
gcc-4.4-locales - GCC, the GNU compiler collection (native language support files)
gcc-4.4-multilib - GNU C compiler (multilib files)
gcc-4.4-source - Source of the GNU Compiler Collection
gcc-4.5-arm-linux-gnueabi - The GNU C compiler
gcc-4.5-arm-linux-gnueabi-base - The GNU Compiler Collection (base package)
gcc-4.5-arm-linux-gnueabihf - The GNU C compiler
gcc-4.5-arm-linux-gnueabihf-base - The GNU Compiler Collection (base package)
gcc-4.5-locales - GNU C compiler (native language support files)
gcc-4.5-multilib - The GNU C compiler (multilib files)
gcc-4.5-source - Source of the GNU Compiler Collection
gcc-4.6-arm-linux-gnueabi - GNU C compiler
gcc-4.6-arm-linux-gnueabi-base - GCC, the GNU Compiler Collection (base package)
gcc-4.6-arm-linux-gnueabihf - GNU C compiler
gcc-4.6-arm-linux-gnueabihf-base - GCC, the GNU Compiler Collection (base package)
gcc-4.6-locales - GCC, the GNU compiler collection (native language support files)
gcc-4.6-multilib-arm-linux-gnueabi - GNU C compiler (multilib files)
gcc-4.6-multilib-arm-linux-gnueabihf - GNU C compiler (multilib files)
gcc-4.7-base - GCC, the GNU Compiler Collection (base package)
user@user-VPCEB1J1E:~$ sudo apt-get install g++-3.4 gcc-3.4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet g++-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « g++-3.4 »
E: Impossible de trouver le paquet gcc-3.4
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « gcc-3.4 »

Hors ligne

#13 Le 27/02/2013, à 17:56

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

apt-cache search ne sert qu'à lister les paquets disponibles. La version 3.4 de g++/gcc n'est pas disponible, mais les autres (4.4 à 4.6) le sont.
Hors avis contraire, installe la 4.6, c'est la dernière en date. Elle devrait pallier facilement la 3.4 (après je n'en sais rien, hein, je n'utilise pas ces logiciels).

En conclusion, lance :

sudo apt-get install g++-4.6 gcc-4.6

En ligne

#14 Le 27/02/2013, à 18:03

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

merci bcp,ça marche et je suis mainteneat d'isntaller les autres paquets de ns3

Hors ligne

#15 Le 27/02/2013, à 19:01

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

quand je saisi la dernier instruction dans l'installation de ns3 ,la resulat :user@user-VPCEB1J1E:~$ sudo apt-get install openmpi*
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note : sélection de libmeep-openmpi6 pour l'expression rationnelle « openmpi* »
Note : sélection de libmeep-openmpi-dev pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi1.5-checkpoint pour l'expression rationnelle « openmpi* »
Note : sélection de meep-openmpi pour l'expression rationnelle « openmpi* »
Note : sélection de openmpipython pour l'expression rationnelle « openmpi* »
Note : sélection de yorick-mpy-openmpi pour l'expression rationnelle « openmpi* »
Note : sélection de gromacs-openmpi pour l'expression rationnelle « openmpi* »
Note : sélection de mpqc-openmpi pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi1.3 pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-checkpoint pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi1.5-bin pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi1.5-doc pour l'expression rationnelle « openmpi* »
Note : sélection de libhdf5-openmpi-dev pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-libs0 pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi1.5-2 pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-mpidoc pour l'expression rationnelle « openmpi* »
Note : sélection de libhdf5-openmpi-1.8.4 pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi1.5-dbg pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-bin pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-dbg pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi1.5-dev pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-dev pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-doc pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi-common pour l'expression rationnelle « openmpi* »
Note : sélection de openmpi1.5-common pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi-dbg pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi-dev pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi1 pour l'expression rationnelle « openmpi* »
Note : sélection de libopenmpi2 pour l'expression rationnelle « openmpi* »
Note : sélection de « libopenmpi-dev » au lieu de « openmpi-dev »
Note : sélection de « libopenmpi-dbg » au lieu de « openmpi-dbg »
Note : sélection de « libopenmpi1.3 » au lieu de « openmpi-libs0 »
Note : sélection de « openmpi-doc » au lieu de « openmpi-mpidoc »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
libopenmpi1.5-2 : Est en conflit avec: libopenmpi1.3 mais 1.4.3-2.1ubuntu3 devra être installé
                   Est en conflit avec: openmpi-libs0
libopenmpi1.5-dbg : Est en conflit avec: libopenmpi-dbg mais 1.4.3-2.1ubuntu3 devra être installé
                     Est en conflit avec: openmpi-dbg
libopenmpi1.5-dev : Est en conflit avec: libopenmpi-dev mais 1.4.3-2.1ubuntu3 devra être installé
                     Est en conflit avec: openmpi-dev
openmpi1.5-bin : Est en conflit avec: openmpi-bin mais 1.4.3-2.1ubuntu3 devra être installé
openmpi1.5-checkpoint : Est en conflit avec: openmpi-checkpoint mais 1.4.3-2.1ubuntu3 devra être installé
openmpi1.5-common : Est en conflit avec: openmpi-common mais 1.4.3-2.1ubuntu3 devra être installé
openmpi1.5-doc : Est en conflit avec: openmpi-checkpoint (< 1.5.4-1) mais 1.4.3-2.1ubuntu3 devra être installé
                  Est en conflit avec: openmpi-doc mais 1.4.3-2.1ubuntu3 devra être installé
                  Est en conflit avec: openmpi-mpidoc
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#16 Le 27/02/2013, à 23:13

xabilon

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Tu t'y prends mal pour installer les paquets.
Le fait de mettre un joker (*) dans le nom du paquet a installer, amène APT a tenter d'installer différentes paquets qui sont en conflits entre eux.
Par exemple libopenmpi1.5-2 et libopenmpi1.3 ne peuvent pas être installés en même temps, c'est l'un ou l'autre.
Mais comme tu as demandé d'installer tous les paquets contenant "openmpi", il essaye de les installer tous les deux, et ça ne passe pas.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#17 Le 27/02/2013, à 23:25

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bon c'est une instruction dans le guide d'isntaller nsr c'est ne  pas ma faute enfin,je suis debutante et je suivi tous les isntructions ,bon comment , je sors de ce truc alors et merci

Hors ligne

#18 Le 28/02/2013, à 09:46

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Donne-nous le lien vers le guide d'installation, qu'on regarde ça wink

On verra ce qu'on peut faire.

En ligne

#19 Le 28/02/2013, à 14:55

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

bonjour
ce ça le lien:
http://www.nsnam.org/wiki/index.php/Installation
la dernier isntruction dans l'instalation de ns3 avant le mots Fedora/RedHat

Hors ligne

#20 Le 28/02/2013, à 15:07

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

A priori , je ferais :

sudo apt-get install openmpi-bin openmpi-checkpoint openmpi-common openmpi-doc

En ligne

#21 Le 28/02/2013, à 15:19

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

merci bcp normalement ça marche et à la suite la resultat du terminal:
user@user-VPCEB1J1E:~$ sudo apt-get install openmpi-bin openmpi-checkpoint openmpi-common openmpi-doc
[sudo] password for user:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  blcr-util libcr0 libibverbs1 libnuma1 libopenmpi1.3 libtorque2
Paquets suggérés :
  blcr-dkms gfortran
Les NOUVEAUX paquets suivants seront installés :
  blcr-util libcr0 libibverbs1 libnuma1 libopenmpi1.3 libtorque2 openmpi-bin
  openmpi-checkpoint openmpi-common openmpi-doc
0 mis à jour, 10 nouvellement installés, 0 à enlever et 468 non mis à jour.
Il est nécessaire de prendre 2 176 ko dans les archives.
Après cette opération, 5 648 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/universe libcr0 i386 0.8.2-15ubuntu2.1 [21,3 kB]
Réception de : 2 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/universe blcr-util i386 0.8.2-15ubuntu2.1 [27,5 kB]
Réception de : 3 http://fr.archive.ubuntu.com/ubuntu/ precise/main libnuma1 i386 2.0.8~rc3-1 [23,5 kB]
Réception de : 4 http://fr.archive.ubuntu.com/ubuntu/ precise/universe libtorque2 i386 2.4.16+dfsg-1build1 [87,4 kB]
Réception de : 5 http://fr.archive.ubuntu.com/ubuntu/ precise/main libibverbs1 i386 1.1.5-1ubuntu1 [28,5 kB]
Réception de : 6 http://fr.archive.ubuntu.com/ubuntu/ precise/universe libopenmpi1.3 i386 1.4.3-2.1ubuntu3 [1 290 kB]
Réception de : 7 http://fr.archive.ubuntu.com/ubuntu/ precise/universe openmpi-common all 1.4.3-2.1ubuntu3 [84,4 kB]
Réception de : 8 http://fr.archive.ubuntu.com/ubuntu/ precise/universe openmpi-bin i386 1.4.3-2.1ubuntu3 [152 kB]
Réception de : 9 http://fr.archive.ubuntu.com/ubuntu/ precise/universe openmpi-checkpoint i386 1.4.3-2.1ubuntu3 [38,8 kB]
Réception de : 10 http://fr.archive.ubuntu.com/ubuntu/ precise/universe openmpi-doc all 1.4.3-2.1ubuntu3 [423 kB]
2 176 ko réceptionnés en 12s (169 ko/s)                                       
Sélection du paquet libcr0 précédemment désélectionné.
(Lecture de la base de données... 196263 fichiers et répertoires déjà installés.)
Dépaquetage de libcr0 (à partir de .../libcr0_0.8.2-15ubuntu2.1_i386.deb) ...
Sélection du paquet blcr-util précédemment désélectionné.
Dépaquetage de blcr-util (à partir de .../blcr-util_0.8.2-15ubuntu2.1_i386.deb) ...
Sélection du paquet libnuma1 précédemment désélectionné.
Dépaquetage de libnuma1 (à partir de .../libnuma1_2.0.8~rc3-1_i386.deb) ...
Sélection du paquet libtorque2 précédemment désélectionné.
Dépaquetage de libtorque2 (à partir de .../libtorque2_2.4.16+dfsg-1build1_i386.deb) ...
Sélection du paquet libibverbs1 précédemment désélectionné.
Dépaquetage de libibverbs1 (à partir de .../libibverbs1_1.1.5-1ubuntu1_i386.deb) ...
Sélection du paquet libopenmpi1.3 précédemment désélectionné.
Dépaquetage de libopenmpi1.3 (à partir de .../libopenmpi1.3_1.4.3-2.1ubuntu3_i386.deb) ...
Sélection du paquet openmpi-common précédemment désélectionné.
Dépaquetage de openmpi-common (à partir de .../openmpi-common_1.4.3-2.1ubuntu3_all.deb) ...
Sélection du paquet openmpi-bin précédemment désélectionné.
Dépaquetage de openmpi-bin (à partir de .../openmpi-bin_1.4.3-2.1ubuntu3_i386.deb) ...
Sélection du paquet openmpi-checkpoint précédemment désélectionné.
Dépaquetage de openmpi-checkpoint (à partir de .../openmpi-checkpoint_1.4.3-2.1ubuntu3_i386.deb) ...
Sélection du paquet openmpi-doc précédemment désélectionné.
Dépaquetage de openmpi-doc (à partir de .../openmpi-doc_1.4.3-2.1ubuntu3_all.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libcr0 (0.8.2-15ubuntu2.1) ...
Paramétrage de blcr-util (0.8.2-15ubuntu2.1) ...
Paramétrage de libnuma1 (2.0.8~rc3-1) ...
Paramétrage de libtorque2 (2.4.16+dfsg-1build1) ...
Paramétrage de libibverbs1 (1.1.5-1ubuntu1) ...
Paramétrage de libopenmpi1.3 (1.4.3-2.1ubuntu3) ...
Paramétrage de openmpi-common (1.4.3-2.1ubuntu3) ...
Paramétrage de openmpi-bin (1.4.3-2.1ubuntu3) ...
update-alternatives: utilisation de « /usr/bin/mpirun.openmpi » pour fournir « /usr/bin/mpirun » (mpirun) en mode automatique.
Paramétrage de openmpi-checkpoint (1.4.3-2.1ubuntu3) ...
Paramétrage de openmpi-doc (1.4.3-2.1ubuntu3) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
user@user-VPCEB1J1E:~$

Hors ligne

#22 Le 28/02/2013, à 15:20

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Ca m'a l'air bon en effet wink

En ligne

#23 Le 28/02/2013, à 15:26

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

ah ce bien,autre fois je vous remercie wink;)bouquet de fleur

Hors ligne

#24 Le 28/02/2013, à 16:02

chiraz

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

ah je m'excuse le probleme de l'installation de ns3 ne cesse pas à cause que je suis debutante et je n'etudierai jmais ubuntu ou ns3.
user@user-VPCEB1J1E:~$ cd
user@user-VPCEB1J1E:~$  mkdir repos
user@user-VPCEB1J1E:~$  cd repos
user@user-VPCEB1J1E:~/repos$  hg clone http://code.nsnam.org/ns-3-allinone

destination directory: ns-3-allinone
requesting all changes
adding changesets
adding manifests
adding file changes
added 55 changesets with 78 changes to 7 files
updating to branch default
7 files updated, 0 files merged, 0 files removed, 0 files unresolved
user@user-VPCEB1J1E:~/repos$
user@user-VPCEB1J1E:~/repos$ build.py*  constants.py  dist.py*  download.py*  README  util.py
build.py* : commande introuvable
user@user-VPCEB1J1E:~/repos$

Hors ligne

#25 Le 28/02/2013, à 17:03

miniSeb

Re : sudo apt-get install flex bison libfl-dev >E: Imposs- trouv- [Résolu]

Doc a écrit :

After the clone command completes, you should have a directory called ns-3-allinone under your ~/repos directory, the contents of which should look something like the following:

 build.py*  constants.py  dist.py*  download.py*  README  util.py

Autrement dit, tu as dans le dossier ~/repos le contenu cité (pour vérifier, il y a la commande ls).

Maintenant tu fais, comme mentionné dans la doc :

./download.py -n ns-3-dev

qui te crée un dossier nommé ns-3-allinone et qui contient (utilise ls ns-3-allinone pour voir)

 build.py*     constants.pyc  download.py*  nsc/        README      util.pyc
 constants.py  dist.py*       ns-3-dev/     pybindgen/  util.py

Après tu suis la doc, donc :

./build.py

qui te retournera

Doc a écrit :

Build finished successfully (00:02:37)
Leaving directory `./ns-3-dev'

Puis,

 ./test.py

qui va tester l'installation

Et de ce que je vois dans la doc, là l'installation sera finie.

Après je ne peux vraiment plus t'aider, je ne connais pas du tout ces logiciels...

En ligne

Haut de page ↑