Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 21/02/2013, à 09:37

alexxcool

Restaurer le bureau de l'installation de base

Bonjour,
A l'installation basique de Ubuntu 12.10 j'avais activé les drivers graphiques libres et tout a fonctionné correctement. Notamment un beau bureau avec la barre en haut de titre ou barre des tâches avec tout ce quiu va bien et le lanceur Unity sur la gauche. Bref un truc normal.

Puis pour des raisons de performances j'ai voulu essayer les drivers propriétaires Nvidia et ils n'ont pas marchés. Du coup je suis repassé sur les drivers libres et hop ça remarche. Sauf qu'entre-temps la barre de titre ou barre des tâches en haut et le lanceur Unity sur la gauche ne s'affichent plus du tout.

J'ai essayé les choses suivantes toutes en vain :
- Alt + F2
- unity --reset
- gnome-control-center
- sudo apt-get install gnome

Rien à faire mon bureau ne s'affiche pas comme au début.

Comment puis-je réactiver ses 2 petites barres qui ont disparues lors de la tentative du passage sur les drivers Nvidia ?
Je galère depuis hier soir sur ce problème.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#2 Le 21/02/2013, à 10:56

LapiGNU

Re : Restaurer le bureau de l'installation de base

Salut Alexxcool,

avant toute chose, essaie de fermer la session. Une fois arrivé au gestionnaire de connexion, clique sur le rond à droite de ton nom d'utilisateur, il va te proposer la liste des sessions disponibles. Choisis la session Ubuntu et vois ce que ça donne.

Parce que si tu as installé d'autres environnements (tu mentionnes Gnome), tu n'es peut-être pas actuellement dans une session Unity ...

Alors, pour te déconnecter d'une session Unity sans avoir de lanceur ni de panneau en haut de l'écran, c'est pas compliqué : Ctrl + Alt + Suppr

Dis-nous ce que ça donne, hoplà !


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#3 Le 21/02/2013, à 11:12

Tristan07

Re : Restaurer le bureau de l'installation de base

Bonjour,
De mémoire n'y a t-il pas une commande du style "uniti --replace" qui pourrait éventuellement et SI c'est le problème recharger le bureau et t'aider !


Desktop : Fedora 20 Gnome 64 bits
                ThinkPad Lenovo : Voyager 14.04
Portable Asus de madame: OpenSuse 12.3, 64 bits, KDE 4.10

Hors ligne

#4 Le 21/02/2013, à 12:07

alca94

Re : Restaurer le bureau de l'installation de base

Bonjour
@ Tristan07
C'est unity et non uniti

sinon vous pouvez essayer ceci au paragraphe 4
http://www.le-libriste.fr/ubuntu/configuration-dunity/

Dernière modification par alca94 (Le 21/02/2013, à 12:09)

Hors ligne

#5 Le 21/02/2013, à 13:34

alexxcool

Re : Restaurer le bureau de l'installation de base

Alors en fait en lançant GNOME comme bureau j'ai ma barre en haut ce qui rend effectivement le PC plus exploitable que sans rien. Je pensais que c'était ce bureau là sous Ubuntu 12.10 par défaut mais visiblement pas tout à fait.
J'ai vu qu'en fait ça devrait être le bureau Ubuntu (par défaut) mais ce dernier n'a plus le lanceur et la barre en haut.
Je croyais qu'il s'agissait de Unity mais visiblement non du moi l'écran de connexion ne le nomme pas ainsi sinon.

Donc comment restaurer le bureau Ubuntu 12.10 (par défaut) dans sa configuration par défaut justement ? A part de tout réinstaller si possible.

Pensez-vous qu'un apt-get install unity pourrait me sauver la mise ?


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#6 Le 21/02/2013, à 13:42

alca94

Re : Restaurer le bureau de l'installation de base

vous avez essayer ce qui est indiqué dans le lien du post 4

Hors ligne

#7 Le 21/02/2013, à 13:46

alexxcool

Re : Restaurer le bureau de l'installation de base

C'est fou qu'un simple changement de drivers pète le bureau comme ça.
J'ai aussi testé ceci

gconftool-2a --recursive-unset /apps/compiz
unity --reset (qui me répond Deprecated)
(du coup j'ai fait) unity --reset-icons
sudo service ligthdm restart

Aucun changement.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#8 Le 21/02/2013, à 13:52

alca94

Re : Restaurer le bureau de l'installation de base

vous l'avez fait en console ou avec le terminal ?

Hors ligne

#9 Le 21/02/2013, à 14:03

alexxcool

Re : Restaurer le bureau de l'installation de base

En console en y accédant par Ctrl + Alt + F1

Dernière modification par alexxcool (Le 21/02/2013, à 14:04)


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#10 Le 21/02/2013, à 14:09

alexxcool

Re : Restaurer le bureau de l'installation de base

Sinon au pire méthode bourrin je reconfigure tout Unity manuellement en remettant la configuration de base. Mais pour ça il me faudrait tout les fichiers de configurations avec leurs chemins d'accès car visiblement il semblerait que le retour en arrière soit impossible.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#11 Le 21/02/2013, à 14:42

LapiGNU

Re : Restaurer le bureau de l'installation de base

Je ne situe pas exactement le problème ... Sous Unity (qui s'appelle la session Ubuntu dans le gestionnaire de connexion), tu n'as pas de launcher (à gauche), et pas de panneau (en haut).

Est-ce que tu as un bureau, et des icônes sur ce bureau ?
Est-ce que tu as un menu quand tu fais un clic droit sur le bureau ?
Si tu arrives à lancer une appli, est-ce que sa fenêtre possède toutes ses décorations, autour de son contenu (les bords de la fenêtre, la barre de titre ...) ?


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

#12 Le 21/02/2013, à 18:10

alexxcool

Re : Restaurer le bureau de l'installation de base

LapiGNU a écrit :

Je ne situe pas exactement le problème ... Sous Unity (qui s'appelle la session Ubuntu dans le gestionnaire de connexion), tu n'as pas de launcher (à gauche), et pas de panneau (en haut).

En fait si mon bureau ressemblait à ça juste après l'installation
Bureau Ubuntu 12.10
Il y a bien le launcher à gauche et la barre en haut que vous appelez panneau.

LapiGNU a écrit :

Est-ce que tu as un bureau, et des icônes sur ce bureau ?

J'ai mon bureau avec le fond d'écran et mes icônes des 2 programme qui en s'installant ont placés leurs raccourcis dessus.

LapiGNU a écrit :

Est-ce que tu as un menu quand tu fais un clic droit sur le bureau ?

Oui j'ai un menu avec le clic droit sur le bureau dont voici la liste qu'il me propose
-Créer un nouveau dossier
-Créer un nouveau document
-Organiser le bureau par nom
-Garder aligné
-Coller
-Modifier l'arrière-plan du bureau

LapiGNU a écrit :

Si tu arrives à lancer une appli, est-ce que sa fenêtre possède toutes ses décorations, autour de son contenu (les bords de la fenêtre, la barre de titre ...) ?

J'arrive à lancer des applications par le terminal (Ctrl+Alt+T) mais je n'ai aucune décorations et c'est bien ce qui me ge le plus dans toute cette histoire.

Personne n'aurait les fichiers de configuration de Unity de base à l'issu d'une installation car franchement je remettrais ces fichiers en place et on en parle plus je vais pas non plus passer 3 jours à rétablir ce fichu bureau qui saute à cause de drivers NVIDIA.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#13 Le 21/02/2013, à 21:37

LapiGNU

Re : Restaurer le bureau de l'installation de base

D'après ce que tu décris, c'est à dire pas de launcher, pas de panneau, pas de décorations aux fenêtres mais un environnement complet par ailleurs, il semble que ce soit le gestionnaire de fenêtres qui te fasse défaut, en l'occurence Compiz.

En fait, l'interface Unity développée par Canonical se repose sur des Composants de Gnome 3, Compiz pour gérer les fenêtres et le plugin Compiz Unity, qui affiche le lanceur et les différents dashs (je dis ça très à la louche ...) ; tout cela s'appelle la session "Ubuntu" dans le gestionnaire de connexion.

Pour les contextes où l'accélération graphique matérielle indispensable à Compiz n'est pas supportée, il existe une session "Ubuntu 2d" qui remplace Compiz + le plugin Compiz Unity par Metacity et je ne sais quelles autres joyeusetés.

Logiquement, en choisissant une session Ubuntu 2d dans le gestionnaire de connexion, tu dois avoir tout ce qu'il faut ; le gestionnaire de fenêtres ne sera plus Compiz mais Metacity, et tu n'auras pas les effets graphiques liés à l'accélération matérielle apportés par Compiz. Mais tu devrais retrouver le launcher, le panneau et les décorations des fenêtres, en plus du reste.

Si c'est bien le cas, reste à trouver pourquoi Compiz ne fonctionne pas dans la session Ubuntu, ou simplement à lui restituer une configuration saine comme tu le suggères.

Dans une session Ubuntu, lance un terminal, essaie "compiz --replace" et voie ce que ça donne, juste pour le principe ...

Je ne peux malheureusement rien te dire de plus précis, je n'utilise pas Unity. Eventuellement, depuis le terminal essaie "sudo apt-get install compizconfig-settings-manager", ça t'installera le gestionnaire de configuration de config. Tu le démarres en tapant ccsm, et tu cherches dans ce fouilli s'il n'y a pas un truc flagrant, ou bien tu t'en sers pour rétablir une configuration par défaut (via "préférences" en bas à gauche). Hoplà !


frenchKISS sur www.tchitcha.info, Ubuntu clé en main pour les réseaux de postes de travail.
et surtout : Sauvez les arbres, mangez des castors. Sauvez les castors, ne mangez pas d'arbres !

Hors ligne

Haut de page ↑