Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 25/02/2013, à 14:38

aladuce

[Résolu] VirtualBox, pas d'accès Internet

Bonjour,
VirtualBox me donnait entière satisfaction avec Ubuntu 12.04 64 bits.
Après l'installation de Ubuntu 12.10 64 bits, l'installation de VirtualBox sur un disque reformaté, et la création d'une machine virtuelle avec Windows xp comme OS, la machine virtuelle n'a pas accès à Internet.
Pourtant, elle a été créée avec la carte réseau activée et le mode d'accès réseau NAT.
Après avoir cherché sans succès une cause du côté de Windows xp, le système invité, je me suis interrogé sur Ubuntu 12.10. J'ai transféré, sur mon ordinateur, la machine virtuelle fonctionnant bien sur un autre ordinateur muni de Ubuntu 12.04.
Résultat: la machine virtuelle fonctionne, mais n'a pas, non plus, accès à Internet.
Y aurait-il un problème dans mon installation de Ubuntu 12.10 ?
Merci de m'aider.

Dernière modification par aladuce (Le 25/02/2013, à 21:20)


Ubuntu 13.10 64 bit sur Dell Inspiron 580 MT et Ubuntu 13.10 64 bit sur Dell Studio 1555

Hors ligne

#2 Le 25/02/2013, à 17:42

malbo

Re : [Résolu] VirtualBox, pas d'accès Internet

Si tu n'as pas une version de VirtualBox supérieure ou égale à 4.2.2, il est possible que tu souffres d'un bug de VirtualBox qui affecte Ubuntu 12.10 (mais pas Ubuntu 12.04) dont on parle dans cette discussion : http://forum.ubuntu-fr.org/viewtopic.ph … #p11531511
La solution est alors donnée dans le post #11 de la même discussion

Dernière modification par malbo (Le 25/02/2013, à 17:46)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#3 Le 25/02/2013, à 21:18

aladuce

Re : [Résolu] VirtualBox, pas d'accès Internet

Ma version de VirtualBox est la 4.1.18, fournie par l'intermédiaire de la logithèque Ubuntu.
J'ai appliqué la méthode de déboguage que vous m'avez suggérée. Elle donne des résultats parfaits, à un point de détail près: j'ai dû fermer toutes les fenêtres concernant VirtualBox, pour que la commande VBoxManage modifyvm aboutisse. Sinon, j'avais la réponse:
"VBoxManage: error: Could not find a registered machine named myvm".
La solution est, donc:
1 - fermer VirtualBox;
2 - taper dans un terminal:
alain@Fixe:~$ VBoxManage modifyvm "nom de la machine virtuelle" --natdnshostresolver1 on

Et l'accès Internet est rétabli.
Merci pour votre aide.


Ubuntu 13.10 64 bit sur Dell Inspiron 580 MT et Ubuntu 13.10 64 bit sur Dell Studio 1555

Hors ligne

Haut de page ↑