Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 01/03/2013, à 18:31

maxonz

[RESOLU] Serveur accessible depuis exterieur mais pas en local

Bonjour,
ce nouveau post fait suite à ce thread: http://forum.ubuntu-fr.org/viewtopic.php?id=1201061
Je juge utile d'en créer un nouveau suite à mes recherches...

Le réseau est le suivant: j'ai un routeur/livebox (192.168.1.1) et un point d'accès wifi (192.168.1.3). Le point d'accès Wifi est relié en filaire à ma livebox.
J'ai sur ce réseau un serveur connecté en wifi et nommé asus-serv à l'IP Locale 192.168.1.10 ainsi que de nombreux périphériques.
J'ai également deux ordinateurs reliés en filaire à la livebox par le biais d'un switch.
Voila un schéma pour synthétiser:
Schema reseau

Mon problème est qu'il est impossible de contacter le serveur (192.168.1.10) depuis le réseau local.
PC de papa (192.168.1.22) et PC de Maman (192.168.1.21) se pinguent bien (et de grâce, épargnez moi vos jeux de mots douteux que je sens venir à des kilomètres).
En revanche, impossible de pinguer quoi que ce soit qui est connecté au point d'accès, bien que mon point d'accès soit des plus basiques (Trendnet TEW-638APB).

Mais le plus bizarre dans tout ça, c'est que j'ai mis en place une règle NAT/PAT sur la livebox pour que toutes les requêtes HTTP (port 80) soient renvoyées sur le serveur (192.168.1.10), et lorsque j'attaque l'IP de ma box depuis un réseau exterieur (le réseau mobile dans mon test), cela fonctionne ! La page d'accueil d'Apache du serveur s'affiche ! Donc du coup, l'idée du pare-feu en prend un coup... Non?

Donc voila, je suis un peu paumé là, je ne sais pas ce qu'il s'est passé. La livebox a été remise aux réglages d'origine, le serveur ubuntu est fraichement installé, le mac aussi...

J'ai eu l'assistance Orange pro au téléphone, ils n'ont pas su me dire pourquoi, ils m'ont juste dit de vérifier les pare-feu (pas de pare feu installé après l'install sur le serveur, ni sur mon android, donc ce n'est pas ça...) et de vérifier la connexion des cables (a partir du moment ou j'arrive à pinguer 192.168.1.1 et que j'ai internet, je pense qu'on peut mettre les cables hors de cause, non?).

Toutes les pistes sont bonnes à prendre ! smile Merci d'avoir tout lu, dans l'espoir de lire vos pistes...

Dernière modification par maxonz (Le 01/03/2013, à 20:09)

Hors ligne

#2 Le 01/03/2013, à 18:50

toutafai

Re : [RESOLU] Serveur accessible depuis exterieur mais pas en local

Bonjour,

Cela ne peut pas fonctionner comme cela (a moins que ton point d'acces fasse du dhcp relay, et du nat/pat) car ta livebox et ton point d'acces sont tous les 2 sur le meme sous reseau !

Change de sous reseau sur ton point d'acces, pour te mettre par exemple en 192.168.0/24 (en fait n'importe quel autre sous reseau, sauf le meme que ta livebox).

Enfin pas de pare-feu installer par défaut sur ton serveur ? et iptables/netfilter alors, il ne sont pas la que pour faire joli, mais bine pour remplir le role de pare-feu


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 01/03/2013, à 19:09

maxonz

Re : [RESOLU] Serveur accessible depuis exterieur mais pas en local

Pardonne mon ignorance mais en quoi le fait qu'ils soient sur le même sous réseau pose t-il problème?
Et j'ai essayé de passer l'ip fixe du PA en 192.168.0.3 /24 et il me l'a refusé en disant le PA et la passerelle devaient être sur le même sous réseau justement... hmm

Quant à netfilter et iptables, effectivement ils sont là, mais de base je doute qu'ils bloquent les pings et les requêtes http non? Parce que je n'y ai pas touché, donc je voulais dire que je n'avais rien configuré sur le pare-feu.

Hors ligne

#4 Le 01/03/2013, à 19:15

piolet

Re : [RESOLU] Serveur accessible depuis exterieur mais pas en local

bonjour
si mon routeur wifi il y a un paramètre qui peut expliquer ton problème
<<AP Isolation  This isolates all wireless clients and wireless
devices on your network from each other. Wireless devices
will be able to communicate with the Router but not with
each other. >>

Hors ligne

#5 Le 01/03/2013, à 19:58

maxonz

Re : [RESOLU] Serveur accessible depuis exterieur mais pas en local

Je suis allé connecter mon serveur et mon mac en wifi directement à la livebox, et tout à fonctionné !
Le problème provient donc en effet très certainement du PA...

J'ai cherché un peu partout mais je n'ai rien trouvé concernant une AP Isolation... hmm Du coup je fais des recherches google pour voir à quoi correspondent tous ces réglages.

Voila la page des paramètres avancés, si cela vous parle... wink
Paramètres AP

EDIT: C'était l'IAPP, je l'ai désactivé, et tout roule ! Merci beaucoup, ca faisait des semaines que je galérais, vous me sauvez là ! smile

Dernière modification par maxonz (Le 01/03/2013, à 20:09)

Hors ligne

#6 Le 01/03/2013, à 21:04

piolet

Re : [RESOLU] Serveur accessible depuis exterieur mais pas en local

les forums c'est magique !!

Hors ligne

Haut de page ↑