Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 03/03/2013, à 19:26

renaud07

serveur mail : envoie impossible

Bonjour,

Désolé si je poste dans le café mais je n'ai pas eu de réponse dans la partie serveur.

Je me suis installé un serveur mail en suivant ce tuto

J'arrive bien à recevoir les mails mais impossible d'en envoyer, ça mouline pendant un moment et après ça me met délai d'attente expiré (thunderbird) alors que les ports sont bien ouverts sur le serveur ainsi que la box (993 et 465)

J'ai également ouvert le port 25 sur la box et fait une redirection sur le port 465 sur le serveur pour recevoir les mail, mais je pense que ça n'a pas de rapport avec mon problème.

Je suis chez orange et vu le blocage avec le port 25 j'ai configuré postfix en smarthost.

Voici le main.cf :

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/private/mondomaine.homeftp.net.cert
smtpd_tls_key_file=/etc/ssl/private/mondomaine.homeftp.net.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

append_dot_mydomain = no
biff = no
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix
queue_directory = /var/spool/postfix

myhostname = mondomaine.homeftp.net
mydomain = mondomaine.homeftp.net
masquerade_domains = mondomaine.homeftp.net
mydestination = $myhostname, $mydomain, localhost.$mydomain, localhost
inet_interfaces = all
#mynetworks = 192.168.1.0/24, 127.0.0.0/8, 0.0.0.0
myorigin = /etc/mailname
relayhost = smtp.orange.fr
home_mailbox = Maildir/
#mailbox_command = 

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
setgid_group = postdrop
mail_owner = postfix
mailbox_size_limit = 5368709120
mail_spool_directory = /var/spool/mail
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
delay_warning_time = 4h
recipient_delimiter = 


inet_protocols = ipv4

Merci d'avance.

Dernière modification par renaud07 (Le 03/03/2013, à 19:52)


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#2 Le 03/03/2013, à 20:17

renaud07

Re : serveur mail : envoie impossible

Thunderbird me met une erreur lorsque je clique sur le compte, késako ?
1362334508.png


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#3 Le 04/03/2013, à 17:38

GrainChieux

Re : serveur mail : envoie impossible

renaud07 a écrit :

Thunderbird me met une erreur lorsque je clique sur le compte, késako ?
http://pix.toile-libre.org/upload/img/1362334508.png

parametre d'envoi :
smtp.orange.fr
port 25
aucune sécurité
pas de connexion obligatoire

cela sur mon smartphone

est ce que cela vient de ce réglage ?


Là où on ergote il n'y a plus de vraie science. La vérité n'a qu'un seul terme qui une fois trouvé détruit le litige à jamais. S'il peut renaître il s'agit d'une science bavarde et confuse, non la certitude née. Les vraies sciences sont celles que l'expérience fait pénétrer par les sens et qui imposent silence à la langue des argumentateurs et ne nourrissent pas de songes ses investigateurs VINCI

Hors ligne

#4 Le 05/03/2013, à 19:37

renaud07

Re : serveur mail : envoie impossible

@GrainChieux : ça ne change rien pour le message, par contre je peux envoyer les mails, vu que ça passe directement par orange et non plus par mon serveur puis orange.


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#5 Le 06/03/2013, à 13:18

Ayral

Re : serveur mail : envoie impossible

Trouvé dans l'assistance Orange:
- modifier l'adresse du serveur d'envoi : smtp-msa.orange.fr au lieu de smtp.orange.fr,
- modifier le port utilisé par l'envoi : 587 au lieu de 25,
- activer l'Authentification.

Voir aussi là

http://assistance.orange.fr/resoudre-le … n-4701.php

Hors ligne

#6 Le 06/03/2013, à 18:21

renaud07

Re : serveur mail : envoie impossible

whoies a écrit :

et en ligne de commande ça dit quoi ?

echo "test d envoi" | mail -s test adresse@.........

fais un test sur compte gmail ou un serveur sans restrictions, les autres bloquent les domaines privés.

Lorsque je le fais à partir du serveur ça ne me renvoie rien du tout bizarre hmm

root@serveur:~# echo "test d envoi" | mail -s test renaud@mondomaine.homeftp.net
root@serveur:~# 

voilà tout ce que j'obtiens.

EDIT : Je viens de regarder la boite mail et je reçois bien le test venant de root@mondomaine.homeftp.net

Dernière modification par renaud07 (Le 06/03/2013, à 18:38)


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#7 Le 06/03/2013, à 18:47

renaud07

Re : serveur mail : envoie impossible

J'avance doucement mais sûrement, avec le test en ligne de commande, j'arrive à envoyer le mail de test à mes 3 adresses (orange, hotmail, gmail) en mettant comme réglage dans le main.cf de postfix :

relayhost = smtp.orange.fr:25

par contre toujours pas moyen d'en envoyer un depuis thunderbird avec mon adresse renaud@mondomaine.homeftp.net hmm

ça me mets ça dans les logs :

Mar  6 17:30:15 serveur postfix/smtpd[26650]: connect from ALyon-X-1-X-X.wX-X.abo.wanadoo.fr[X.X.X.X]
Mar  6 17:30:38 serveur postfix/smtpd[26650]: lost connection after UNKNOWN from ALyon-X-1-X-X.wX-X.abo.wanadoo.fr[X.X.X.X]
Mar  6 17:30:38 serveur postfix/smtpd[26650]: disconnect from ALyon-X-1-X-X.wX-X.abo.wanadoo.fr[X.X.X.X]

-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#8 Le 06/03/2013, à 19:31

Kanor

Re : serveur mail : envoie impossible

dans ton fichier master.cf rajouter un -v sur smtpd tu aura des log un peu plus parlante.

Hors ligne

#9 Le 06/03/2013, à 19:56

renaud07

Re : serveur mail : envoie impossible

Je crois que j'ai trouvé le coupable : c'est le smtps, car je viens de tester sans ssl et ça fonctionne, par contre ça n'a marché que 3 fois après j'ai un acces denied lorsque je veux envoyer un mail, mais le plus bizarre c'est que la ligne de commande marche toujours hmm Alors qu'il s'agit de la même ip et du même nom de domaine. Peut-être que c'est parce que c'est root@mondomaine.homeftp.net que ça passe ?

@Kanor : j'ai voulu effacer le contenu de mail.log pour y voir plus clair et maintenant ça ne les enregistre plus, j'ai essayé de recréer le fichier, changer les droits mais rien y fait sad une idée ?

Dernière modification par renaud07 (Le 06/03/2013, à 19:57)


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#10 Le 07/03/2013, à 18:35

renaud07

Re : serveur mail : envoie impossible

@whoies : ce n'est pas l'imap qui pose problème puisque la connexion ssl marche très bien avec un certif autosigné (à accepter lorsque le compte est créé) mais bien le smtp; qui lorsque j'envoie un message ne me propose pas de valider le certificat c'est sans doute ça qui fait tout bloquer.

Mais maintenant j'aimerais bien savoir quel serveur smtp prendre vu qu’apparemment celui d'orange bloque l'envoi.


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#11 Le 07/03/2013, à 19:13

Kanor

Re : serveur mail : envoie impossible

renaud07 a écrit :

j'ai voulu effacer le contenu de mail.log pour y voir plus clair et maintenant ça ne les enregistre plus, j'ai essayé de recréer le fichier, changer les droits mais rien y fait sad une idée ?

tu a ce genre de config pour ton fichier

-rw-r----- 1 syslog ad

sinon tu a peut étre aussi les log dans le fichier syslog

Hors ligne

#12 Le 07/03/2013, à 19:46

renaud07

Re : serveur mail : envoie impossible

@Kanor : C'est bon, je viens d'aller vérifier et ça s'est remis tout seul sans que je fasse quoi que ce soit smile


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#13 Le 07/03/2013, à 22:20

renaud07

Re : serveur mail : envoie impossible

whoies a écrit :

je viens d' installer postfix pour essayer, (supprimé sendmail) et cela fonctionne émission/réception, mais je n' arrive pas à configurer thunderbird pour qu' il aille chercher les messages dans Maildir, tu as fais quoi pour ça ?

Il faut que tu es cette ligne dans le main.cf :

home_mailbox = Maildir/

tu as configuré procmail ?

Pourquoi faire ? C'est pas indispensable d'après la doc.

Dernière modification par renaud07 (Le 07/03/2013, à 22:25)


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

#14 Le 08/03/2013, à 19:16

renaud07

Re : serveur mail : envoie impossible

Je n'ai pas de nom de domaine et pour ce qui est de startcom, ça fait plusieurs mois (années peut-être même) qu'il y a un problème avec l'authentification : https://auth.startssl.com/ du coup impossible de faire signer quoi que ce soit.


-AMD FX 3850 4 Ghz Black Edition - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 12.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 12.04 64 bits/windows 7 64 bits

Hors ligne

Haut de page ↑