Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 05/03/2013, à 01:04

cmd-R

Apache2 - L'URL rewriting ne fonctionne pas

Bonjour à tous,

Je suis parti d'un VPS cloud d'OVH avec uniquement Ubuntu 12.04 de fourni et petit à petit j'ai installé un serveur LAMP avec Apache 2, plus des babioles comme Webmin, qmail et j'en passe. Je précise que c'était ma première fois, je n'avais pas réellement touché à Linux depuis mon IUT y'a euh… longtemps (à part des babioles en SSH).

Tout allait bien dans le meilleur des mondes, pour installer un site Wordpress que je dois migrer, je crée un utilisateur et je place le site dans son dossier /home/tartampion/www/, je défini dans /etc/apache2/sites-available un fichier host définissant la chose, etc… bref tout fonctionne, mis à part les urls sous la forme domain.tld/nom-de-larticle… Je me dis que c'est peut-être à cause du fait que j'accède via l'adresse ip (erreur de newbie).

Migration du ndd faite… "ah bah merde ça ne fonctionne toujours pas…". Je cherche, je trouve qu'il faut activer l'url rewriting dans la conf de Apache 2. Je fais donc un a2enmod rewrite, apparemment ça le lance bien (il est dans mods-enable et si je relance la commande ça me dit que c'est déjà activé). Manque de bol, ça ne fonctionne toujours pas…

Me demandant si ça vient bien du serveur, j'installe un SPIP tout frais, et lors de l'installation ce brave petit me fait remarquer que ma config Apache ne tient pas compte des .htaccess ! Gai comme un pho… pinson, je m'attelle à résoudre ce problème via le fichier créé dans /sites-available/ en modifiant uniquement le AllowOverride de /home/tartampion/www/ en All (je laisse les autres en None).

Suspense inutile, puisque si je lui là, c'est parce que ça n'a pas fonctionné… moquette.gif

Est-ce que j'ai loupé un truc ? Beaucoup d'articles sur le net parlent d'éditer le httpd.conf, mais dans le cas de Apache 2, il est vide. Tout le reste j'ai essayé, ça ne change rien.

Des idées ? scandalol.gif

Merci !

Hors ligne

#2 Le 05/03/2013, à 10:37

fridobox

Re : Apache2 - L'URL rewriting ne fonctionne pas

Dans Apache2, le fichier que tu as créé dans /etc/apache2/sites-available est l'équivalant de httpd.conf d'Apache 1.
Dans ce fichier ou dans les .htaccess, cherche les directives commencant par "Rewrite" dont la plus important : RewriteEngine On

Regade : http://httpd.apache.org/docs/2.0/misc/rewriteguide.html


Lubuntu 12.10 @ Dell Inspiron, Lubuntu 12.10 @ EEE1015PED, Sony Xperia U @ Android 2.3.
Ubuntero depuis 7.04. Linux registered user number 486328

Hors ligne

#3 Le 05/03/2013, à 16:41

cmd-R

Re : Apache2 - L'URL rewriting ne fonctionne pas

Il faut aussi l'écrire dans le host ? Je pensais que RewriteEngine On ne s'écrivait que dans le .htaccess ?

Hors ligne

#4 Le 05/03/2013, à 16:49

tiramiseb

Re : Apache2 - L'URL rewriting ne fonctionne pas

.htaccess est juste un fichier qui permet de modifier la configuration quand on n'a pas accès aux fichiers de configuration d'Apache. Une directive dans un .htaccess est prise en compte de la même manière que dans les fichiers de configuration d'Apache à partir du moment où AllowOverride est bien défini.

Cela dit, quand on a accès à la configuration d'Apache,  il est préférable de ne pas utiliser les .htaccess...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 05/03/2013, à 17:06

cmd-R

Re : Apache2 - L'URL rewriting ne fonctionne pas

Ah oui je comprends mieux. Mais si le .htaccess est bien pris en compte, je ne pense pas que ça changera quelque chose à mon problème, mais je vais quand même essayer.

Edit : Bon voilà, ça n'a rien changé… Toujours cette erreur "Not Found"…

S'il n'y a pas d'autres idées, je me demande si je ne vais pas demander le reformatage et recommencer l'installation de zéro.

Dernière modification par cmd-R (Le 05/03/2013, à 17:29)

Hors ligne

#6 Le 05/03/2013, à 18:28

fridobox

Re : Apache2 - L'URL rewriting ne fonctionne pas

Quelles sont les autres directives Rewrite ?
Tu peux tracer le rewriting avec :

RewriteLog /tmp/rewrite.log
RewriteLogLevel 1

Lubuntu 12.10 @ Dell Inspiron, Lubuntu 12.10 @ EEE1015PED, Sony Xperia U @ Android 2.3.
Ubuntero depuis 7.04. Linux registered user number 486328

Hors ligne

#7 Le 05/03/2013, à 18:35

cmd-R

Re : Apache2 - L'URL rewriting ne fonctionne pas

La directive RewriteLog n'est pas reconnue !

Hors ligne

#8 Le 21/03/2013, à 18:22

Vuel

Re : Apache2 - L'URL rewriting ne fonctionne pas

Bonjour, j'avais le même problème que toi et voilà ce qui m'a aidé : http://doc.ubuntu-fr.org/apache2#active … s_htaccess

Cordialement.

Hors ligne

#9 Le 22/03/2013, à 02:05

cmd-R

Re : Apache2 - L'URL rewriting ne fonctionne pas

Merci pour le lien !

C'est également quelque chose que j'avais essayé sans succès… Au final, j'ai switché sur une Débian et j'ai suivi ce tuto : http://library.linode.com/lamp-guides/debian-6-squeeze

Résultat, aucun soucis pour l'url rewriting. Vraiment bizarre, mais bon en informatique des fois faut pas trop se poser de questions…

Hors ligne

#10 Le 22/03/2013, à 12:04

Vuel

Re : Apache2 - L'URL rewriting ne fonctionne pas

De rien, c'est surtout cette partie là qui m'a aidé dans la page

Si vous souhaitez autoriser les fichiers .htaccess partout (et pas uniquement dans un unique répertoire) il vous faudra remplacer "AllowOverride none" par "AllowOverride All" entre les balises <Directory />…</Directory> et <Directory /var/www/>…</Directory> du fichier /etc/apache2/sites-enabled/000-default.

Après tant mieu si tout fonctionne chez toi sous debian smile
Cordialement

Hors ligne

#11 Le 22/03/2013, à 19:13

cmd-R

Re : Apache2 - L'URL rewriting ne fonctionne pas

Bah je ne sais pas si c'est le fait d'être sous Debian ou le tuto, mais bon, du moment que ça marche ^^

Hors ligne

#12 Le 22/03/2013, à 19:17

tiramiseb

Re : Apache2 - L'URL rewriting ne fonctionne pas

Sinon, je me permets de répéter mon message #4 :
Quand on a accès à la configuration d'Apache, il est préférable de ne pas utiliser les .htaccess... smile

(pour des raisons évidentes de performance quand on sait comment ça marche)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#13 Le 17/10/2013, à 08:54

charguie

Re : Apache2 - L'URL rewriting ne fonctionne pas

Vuel a écrit :

De rien, c'est surtout cette partie là qui m'a aidé dans la page

Si vous souhaitez autoriser les fichiers .htaccess partout (et pas uniquement dans un unique répertoire) il vous faudra remplacer "AllowOverride none" par "AllowOverride All" entre les balises <Directory />…</Directory> et <Directory /var/www/>…</Directory> du fichier /etc/apache2/sites-enabled/000-default.

Après tant mieu si tout fonctionne chez toi sous debian smile
Cordialement

Je viens de faire une install wordpress en local et effectivement j'avais ce problème de rewriting url qui ne marchait pas.

En modifiant le fichier comme indiqué ci-dessus, tout est nickel.

Merci, ma journée démarre bien grâce à vous!

Hors ligne

Haut de page ↑