Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 19/03/2013, à 15:04

Silverscott

Package vala-1.0 was not found in the pkg-config

Bonjour,

Je suis actuellement en formation professionnelle (TSRIT) et j'ai actuellement un projet de portail captif à faire avec la solution Kanet

Je me suis donc installé une image VirtualBox avec Ubuntu Server 12.04 LTS et j'ai commencé à installer Kanet en suivant la procédure de la page http://perso.ens-lyon.fr/thomas.bellemb … et_install

Tout allait bien jusqu’à l'installation de Kanet. Quand je lance le .waf configure j'ai le message d'erreur suivant :

Checking for vala-1.0 >= 0.7.10             : Package vala-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `vala-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'vala-1.0' found
/usr/local/src/kanet-0.2.3/wscript:40: error: the configuration failed (see '/usr/local/src/kanet-0.2.3/build/config.log')

J'ai pourtant bien installé la dernière version de vala (Vala 0.19.0 released)

Par avance merci de votre aide

Dernière modification par Silverscott (Le 19/03/2013, à 15:05)

Hors ligne

#2 Le 20/03/2013, à 14:48

Guilro

Re : Package vala-1.0 was not found in the pkg-config

Bonjour Silverscott,

Paradoxalement, il est possible que la version installée de Vala est trop récente, et l'API vala-1.0 n'existe plus.

Il faudrait peut-être désinstaller vala-0.19.0

sudo apt-get remove vala*

puis recompiler la 0.11.2

wget http://ftp.acc.umu.se/pub/GNOME/sources/vala/0.11/vala-0.11.2.tar.gz
tar jxvf vala-0.11.2.tar.gz
cd vala-0.11.2/
./configure
make
sudo make install

Puis recompiler kanet.

Dernière modification par Guilro (Le 20/03/2013, à 14:50)

Hors ligne

Haut de page ↑