Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#451 Le 01/03/2014, à 21:43

ek0892

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

je viens de mettre en ligne la  V167 de Cubuntu 14.04 LST avec Nvidia 331 et Nvidia-prime .6.1 + deux icones pour forcer la commutation
Cubuntu 14.04 Nvidia Optimus

  j'espère qu'elle vous plaira..   à télécharger sur http://cubuntu.fr

Dernière modification par ek0892 (Le 21/04/2014, à 20:02)


►CUBUNTU 14.10 & 14.04  = 100% Ubuntu + MATE + CINNAMON  + Cube 3D +  Extras: Flash VLC Skype Nemo Tweak Geany Putty Applet luminosité NumLock RadioTray RSS Spotify, Openshot, kazam, Chromecast
►Pilotes Nvidia 340 Optimus, Kernel 3.16, Haswell, Clevo, imprimantes HP & Samsung, wifi 7260, OsUninstaller, Boot-repair, prime-indicator..
►A TELECHARGER http://cubuntu.fr

Hors ligne

#452 Le 06/03/2014, à 15:07

Romaiiin_

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bon j'ai réussi à régler mon problème de surchauffe: remplacement de la pâte thermique.
J'ai installé la version 12.04 LTS de ubuntu et tout marche niquel big_smile

Vraiment beau travail Archange !

Bonne continuation

P.S: je me suis réessayé à l'installation des drivers NVIDIA sur Windows, je n'y suis même pas parvenu :s   smile


Laptop : Dell Vostro 3500 / i5-M 450 / 4Go RAM / nVidia GT 310M / Ubuntu 13.10 (saucy)

Hors ligne

#453 Le 07/03/2014, à 08:33

LePgMoi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonjour,

Je rejoins ce topic car comme beaucoup, optimus me pose problème.
J'ai un ubuntu 13.10 tout frais. C'est dire que j'ai juste chrome et vlc. Auparavant j'étais sous linux 15 (car impossibilité de booter le 16 en livecd), je viens de passer sous ubuntu en passant par le mode "nomodeset" pour le boot cd.

Je décide d'installer bumbeblee avec cette méthode http://www.jonathanlinat.net/2014-02-20 … bumblebee/ en modifiant sudo apt-get install nvidia-331 nvidia-settings-331 par sudo apt-get install nvidia-331 sinon ça voulait pas.

Voilà ce que j'obtient en test :

flo@flo-GE60-2OC-2OE:~$ glxgears
4951 frames in 5.0 seconds = 990.158 FPS
5746 frames in 5.0 seconds = 1149.071 FPS
5645 frames in 5.0 seconds = 1128.514 FPS
5636 frames in 5.0 seconds = 1125.794 FPS
5576 frames in 5.0 seconds = 1114.161 FPS
5685 frames in 5.0 seconds = 1136.262 FPS
5701 frames in 5.0 seconds = 1138.789 FPS
5703 frames in 5.0 seconds = 1140.545 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 135514 requests (135512 known processed) with 0 events remaining.

Du coup je me dis que c'est élevé, est-ce que je suis pas déjà sur ma nVidia, je test avec optirun et primusrun, voilà le résultat :

flo@flo-GE60-2OC-2OE:~$ optirun glxgears
[   28.331186] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[   28.331207] [ERROR]Could not connect to bumblebee daemon - is it running?

flo@flo-GE60-2OC-2OE:~$ primusrun glxgears
2014/03/06 20:10:46 socat[2215] E connect(3, AF=1 "/var/run/bumblebee.socket", 27): No such file or directory
primus: fatal: failed to connect to Bumblebee daemon: No such file or directory

Comme d'hab, les commandes merdes. J'ai essayé avec des softs, rien à faire..... des idées? Je sèche et ça me soul depuis le temps que je suis dessus et que je lis des topics en français et en anglais.

Merci de votre aide

Ps : voici mon pc http://www.ldlc.com/fiche/PB00161485.html

Flo

Dernière modification par LePgMoi (Le 09/03/2014, à 21:56)

Hors ligne

#454 Le 07/03/2014, à 10:45

cdjklm

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

salut ton fichier /etc/bumblebee/bumblebee.conf est il bien configurer pour utiliser le 331 ?


Benq joybook lite Xubuntu 12.04  32bits , intel N270 1.66GHz x 2 , 945 GMA intégré 256 MO , 2GO Ram , HDD 250 GO , WIFI ,BLUETOOTH,modem 3G MC8775  intégré.

Hors ligne

#455 Le 07/03/2014, à 10:50

Fireweasel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Sur la 14.04 il ne sera plus nécessaire d'utiliser bumblebee si on a optimus ?

Hors ligne

#456 Le 07/03/2014, à 11:01

ek0892

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Effectivement Nvidia-prime .6 remplace bumblebee , les deux ne cohabitent pas . il faut desinstaller l'un pour installer l'autre.

Ps j'ai ajouter dans Cubuntu 14.04 LTS V150 un indicateur qui permet de sélectionner facilement entre intel/Nvidia

Cubuntu 14.04 LST Nvidia prime-indicator

Dernière modification par ek0892 (Le 09/03/2014, à 21:58)


►CUBUNTU 14.10 & 14.04  = 100% Ubuntu + MATE + CINNAMON  + Cube 3D +  Extras: Flash VLC Skype Nemo Tweak Geany Putty Applet luminosité NumLock RadioTray RSS Spotify, Openshot, kazam, Chromecast
►Pilotes Nvidia 340 Optimus, Kernel 3.16, Haswell, Clevo, imprimantes HP & Samsung, wifi 7260, OsUninstaller, Boot-repair, prime-indicator..
►A TELECHARGER http://cubuntu.fr

Hors ligne

#457 Le 07/03/2014, à 12:01

LePgMoi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

@cdjklm : oui j'ai bien configuré mon bumbeblee pour la version 331 comme le tuto le spécifie

Je me suis taté à essayer la 14.04 mais j'ai préféré attendre la version stable.

Dernière modification par LePgMoi (Le 07/03/2014, à 13:28)

Hors ligne

#458 Le 07/03/2014, à 13:20

Fireweasel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Ouais enfin il reste quand même un gros problème c'est qu'on est obligé de redémarrer le serveur X (fermer la session ou reboot) pour que le changement soit pris en compte avec nvidia-prime.

J'aimerai savoir au passage, c'est normale que j'ai le problème de synchro verticale quand je suis avec le chipset intel ? (je parle de ça : http://oxoty.free.fr/film.png )

Hors ligne

#459 Le 07/03/2014, à 13:31

LePgMoi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Tout comme toi j'ai l'image qui bug. De plus, j'ai regardé un film mardi, au bout de 40min mon pc coupe car plus de batterie. Il a tout juste  1 mois...... Peut etre un probleme de composant, en l’occurrence la batterie, mais je trouve ça quand même bizard..... Bumblebee??

Hors ligne

#460 Le 07/03/2014, à 15:26

cdjklm

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

je ne pense pas que prime remplacera bumblebee je dirrai plutot que ce serront 2  facon differente d aborder le probleme optimus et ceci temp qu il faudra rebooter ou redemarrer le serverX pour choisir la carte dans prime.
je dis cela mais au faite y a t il vraiment des difference de performance entre les 2?


Benq joybook lite Xubuntu 12.04  32bits , intel N270 1.66GHz x 2 , 945 GMA intégré 256 MO , 2GO Ram , HDD 250 GO , WIFI ,BLUETOOTH,modem 3G MC8775  intégré.

Hors ligne

#461 Le 07/03/2014, à 15:56

GP974

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

oui les performance avec Prime sont vraiment plis élevé


Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

#462 Le 08/03/2014, à 00:46

toinou879

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonjour,

j'ai un pc portable un asus "N750JV-T4222H" avec la puce nvidia GEFORCE 750m

j'ai utilisé le tutoriel 

http://doc.ubuntu-fr.org/bumblebee

j'ai par contre du utiliser les drivers nvidia-319 pour que ma carte soit reconnue

sudo apt-get install nvidia-319 nvidia-settings-319

il a fallut aussi que je modifie le "/etc/bumblebee/bumblebee.conf" en remplacent "current" par le numéro de version "319"

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-319
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-319:/usr/lib32/nvidia-319
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-319/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

après je lance les programmes avec la commande "optirun"

si sa peut aider smile

Toinou879

Dernière modification par toinou879 (Le 08/03/2014, à 00:47)


- Ubuntu 14.04 - PC portable ASUS N750JV -
- Mac os X 10.8.5 - Imac -
- Mac os X 10.8.5 - mac mini -

Hors ligne

#463 Le 08/03/2014, à 13:11

ArchangeGabriel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

LePgMoi a écrit :

Bonjour,

Je rejoins ce topic car comme beaucoup, optimus me pose problème.
J'ai un ubuntu 13.10 tout frais. C'est dire que j'ai juste chrome et vlc. Auparavant j'étais sous linux 15 (car impossibilité de booter le 16 en livecd), je viens de passer sous ubuntu en passant par le mode "nomodeset" pour le boot cd.

Je décide d'installer bumbeblee avec cette méthode http://www.jonathanlinat.net/2014-02-20 … bumblebee/ en modifiant sudo apt-get install nvidia-331 nvidia-settings-331 par sudo apt-get install nvidia-331 sinon ça voulait pas.

Voilà ce que j'obtient en test :
flo@flo-GE60-2OC-2OE:~$ glxgears
4951 frames in 5.0 seconds = 990.158 FPS
5746 frames in 5.0 seconds = 1149.071 FPS
5645 frames in 5.0 seconds = 1128.514 FPS
5636 frames in 5.0 seconds = 1125.794 FPS
5576 frames in 5.0 seconds = 1114.161 FPS
5685 frames in 5.0 seconds = 1136.262 FPS
5701 frames in 5.0 seconds = 1138.789 FPS
5703 frames in 5.0 seconds = 1140.545 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 135514 requests (135512 known processed) with 0 events remaining.

Du coup je me dis que c'est élevé, est-ce que je suis pas déjà sur ma nVidia, je test avec optirun et primusrun, voilà le résultat :
flo@flo-GE60-2OC-2OE:~$ optirun glxgears
[   28.331186] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[   28.331207] [ERROR]Could not connect to bumblebee daemon - is it running?

flo@flo-GE60-2OC-2OE:~$ primusrun glxgears
2014/03/06 20:10:46 socat[2215] E connect(3, AF=1 "/var/run/bumblebee.socket", 27): No such file or directory
primus: fatal: failed to connect to Bumblebee daemon: No such file or directory

Comme d'hab, les commandes merdes. J'ai essayé avec des softs, rien à faire..... des idées? Je sèche et ça me soul depuis le temps que je suis dessus et que je lis des topics en français et en anglais.

Merci de votre aide

Ps : voici mon pc http://www.ldlc.com/fiche/PB00161485.html

Flo

Tu peux donner le résultat de :

sudo bumblebeed -vv

Pour tout ceux qui posent des questions sur les performances, quelqu’un a trouvé un moyen d’estimer les pertes dues à une solution de type Bumblebee dans certains types de situations.

Il faut installer glmark2 (ou en fait n’importe quel outil de bench qui donne ses résultats en ligne de commande et ne nécessite pas de configuration graphique).

Test des performances Intel :

vblank_mode=0 glmark2

Test des performances Bumblebee :

vblank_mode=0 optirun glmark2

Test des performances NVIDIA :

optirun -b none env DISPLAY=:8 glmark2

Quelques commentaires :
– C’est normal d’avoir des perfs Intel supérieures sur la carte Intel que via Bumblebee, c’est l’exemple même d’application ou le transfert du rendu via Bumblebee coûte plus cher que le rendu lui-même ;
– Ce n’est pas un benchmark absolu, il ne teste que quelque petites choses. Il donne juste une indication grossière du rapport de performances entre les deux cartes ;
– Tout ce que j’ai déjà dit s’applique toujours : primus n’est pas optimisé pour dépasser 60 fps, dans un certain nombre d’applications le transfert coûte plus cher que le rendu et il est normal d’avoir de meilleures performances avec la carte Intel ; enfin une solution type Bumblebee implique forcément une perte de performances par rapport à ce que peut délivrer la carte NVIDIA.

Hors ligne

#464 Le 09/03/2014, à 21:55

LePgMoi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonsoir,

Avant cette instal, j'avais déjà essayé http://doc.ubuntu-fr.org/bumblebee, mais ça ne marchait pas.

En utilisant cette commande :

sudo bumblebeed -vv

j'obtient :

[  149.554153] [DEBUG]Found card: 01:00.0 (discrete)
[  149.554184] [DEBUG]Found card: 00:02.0 (integrated)
[  149.554196] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  149.554744] [INFO]Configured driver: nvidia
[  149.554767] [DEBUG]Skipping auto-detection, using configured driver 'nvidia'
[  149.554958] [DEBUG]Process /sbin/modprobe started, PID 2570.
[  149.555051] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  149.557668] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  149.557813] [DEBUG]bbswitch has been detected.
[  149.557884] [INFO]Switching method 'bbswitch' is available and will be used.
[  149.557932] [DEBUG]Active configuration:
[  149.557972] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  149.558011] [DEBUG] X display: :8
[  149.558050] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331:/usr/lib32/nvidia-331
[  149.558083] [DEBUG] Socket path: /var/run/bumblebee.socket
[  149.558118] [DEBUG] pidfile: /var/run/bumblebeed.pid
[  149.558144] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.nvidia
[  149.558175] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[  149.558203] [DEBUG] ModulePath: /usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules
[  149.558236] [DEBUG] GID name: bumblebiaee
[  149.558270] [DEBUG] Power method: auto
[  149.558303] [DEBUG] Stop X on exit: 1
[  149.558338] [DEBUG] Driver: nvidia
[  149.558366] [DEBUG] Driver module: nvidia-331
[  149.558400] [DEBUG] Card shutdown state: 1
[  149.558601] [DEBUG]Process /sbin/modprobe started, PID 2571.
[  149.558694] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  149.561231] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  149.561321] [DEBUG]Configuration test passed.
[  149.562169] [ERROR]Success
[  149.562213] [ERROR]There is no "bumblebiaee" group

C'est grave docteur hmm?

Dernière modification par LePgMoi (Le 09/03/2014, à 21:56)

Hors ligne

#465 Le 09/03/2014, à 23:33

Nepenthes

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

@ArchangeGabriel :
J'ai un petit problème avec optirun et le lanceur d'un jeu :

./manager.py fso://settings/Media%20VPs%202014
#fonctionne

otpirun ./manager.py fso://settings/Media%20VPs%202014
#ne fonctionne pas

optirun bash
./manager.py fso://settings/Media%20VPs%202014
#fonctionne

Le message d'erreur est celui-ci :

INFO:MainThread:windows.run_mod: Launching...
loris@loris-SATELLITE-S50t-A-117:~/fs2mod-py-develop$ XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":8"
      after 75 requests (75 known processed) with 0 events remaining.
AL lib: ReleaseALC: 1 device not closed

Une idée ?

Dernière modification par Nepenthes (Le 09/03/2014, à 23:33)


Ancien PC portable : Asus N43SL (Intel i7 2630QM, 4Go RAM, nVidia GeForce GT 540M, DD 640Go 5400tpm) - Ubuntu 14.04
Nouveau PC portable : Toshiba SATELLITE S50t-A-117 (Intel i7 3630QM, 6Go RAM, nVidia GeForce GT 740M, DD 1To 5400tpm) - Ubuntu 14.10

Suivi régulier de Bumblebee (gestion de PC portables hybrides Intel/nvidia).

Hors ligne

#466 Le 11/03/2014, à 22:18

mayladon

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

@ GP974: Bonjour GP974

Désolé de relancer le problème sur l'écran noir. Au fait je ne sais pas comment tu as finalement réussi à régler ton problème par rapport l 'écran noir.

J'ai un macbook pro 6.2 (mid 2010). j'ai essayé des tas de solutions pour faire fonctionner les pilotes propriétaires.
J'ai installé bumblebee en suivant bumblebee avec les pilotes nvidia-current, nvidia-319 et nvidia-331 (via ppa:xorg-edgers/ppa).
A chaque fois j'ai installé d'abord le pilote propriétaire avant d'installer bumblebee bumblee-nvidia primus. Et j'ai pris soin de configurer le fichier bumblebee.conf.
Mais je me retrouve dans tous les cas avec l'écran noir juste après le logo ubuntu avec les points clignotants.
Là j'ai tout désinstallé et je n'utilise aucun pilote propriétaire.

Je ne sais pas si tu pourrais m'aider. Merci

Hors ligne

#467 Le 11/03/2014, à 23:53

Fireweasel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonjour,

Je suis avec Xubuntu 14.04 beta et les derniers pilote nvidia (dc nividia-prime) voici les scores que j'obtiens avec les 2 benchmarks "glxgears" et "glxspheres" :

Mode carte intel (intel HD 4000) :
Glxgears : ~7800 fps
Glxspheres : ~265 fps

Mode carte nvidia (GeForce 650m GT) :
Glxgears : ~14640 fps
Glxspheres : ~1500 fps

est ce que ces scores vous paraisses bon par rapport a mon matos ?

Hors ligne

#468 Le 12/03/2014, à 14:49

GP974

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

mayladon a écrit :

@ GP974: Bonjour GP974

Désolé de relancer le problème sur l'écran noir. Au fait je ne sais pas comment tu as finalement réussi à régler ton problème par rapport l 'écran noir.

J'ai un macbook pro 6.2 (mid 2010). j'ai essayé des tas de solutions pour faire fonctionner les pilotes propriétaires.
J'ai installé bumblebee en suivant bumblebee avec les pilotes nvidia-current, nvidia-319 et nvidia-331 (via ppa:xorg-edgers/ppa).
A chaque fois j'ai installé d'abord le pilote propriétaire avant d'installer bumblebee bumblee-nvidia primus. Et j'ai pris soin de configurer le fichier bumblebee.conf.
Mais je me retrouve dans tous les cas avec l'écran noir juste après le logo ubuntu avec les points clignotants.
Là j'ai tout désinstallé et je n'utilise aucun pilote propriétaire.

Je ne sais pas si tu pourrais m'aider. Merci

Désolé
mais je ne vois pas de quoi tu parle je n'ai pas de problème d’écran noir .
Ce qui fonctionne chez moi c'est de tous installer en même temps et laissez la configuration par défaut
je fais donc une purge puis une installation de base

sudo apt-get purge nvidia*
sudo apt-get install bumblebee primus bumblebee-nvidia nvidia-331

Edit :
Je viens de voir ca sur le web (arch wiki)
Macbook 6.2 on  EFI
As of 4/30/2011, the proprietary nvidia driver is not known to work under X with this model in efi mode. The nouveau driver should work out of the box, but dri should be installed from the mesa-git package

Donc il est possible que le drivers nvidia ne gère pas ton macbook

Dernière modification par GP974 (Le 12/03/2014, à 14:53)


Ubunteros depuis 10.04 Restez libre avec Linux :)
Fixe : i7 i930@2.8ghz | 8go(1866Mhz) |Gtx 570@nvidia-340 | Samsung 840evo(120Go) | Ubuntu 12.04.4 & 14.04
Portable(asus N75SF) : i5 2410@2.3ghz | 8go(1333Mhz)  | IntelHD3000/GT555m@nvidia-340 | Vertex2(180go)| Arch & 12.04.4 & 14.10(dev)
Développeur de nvidiux

Hors ligne

#469 Le 12/03/2014, à 15:12

mayladon

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

OK. Je pense que c'est vrmt un problème avec les drivers et la carte gfx Nvidia du macbook.

Merci pour ta réponse!

Hors ligne

#470 Le 12/03/2014, à 22:59

ArchangeGabriel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

LePgMoi a écrit :

Bonsoir,

Avant cette instal, j'avais déjà essayé http://doc.ubuntu-fr.org/bumblebee, mais ça ne marchait pas.

En utilisant cette commande :

sudo bumblebeed -vv

j'obtient :

[  149.554153] [DEBUG]Found card: 01:00.0 (discrete)
[  149.554184] [DEBUG]Found card: 00:02.0 (integrated)
[  149.554196] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  149.554744] [INFO]Configured driver: nvidia
[  149.554767] [DEBUG]Skipping auto-detection, using configured driver 'nvidia'
[  149.554958] [DEBUG]Process /sbin/modprobe started, PID 2570.
[  149.555051] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  149.557668] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  149.557813] [DEBUG]bbswitch has been detected.
[  149.557884] [INFO]Switching method 'bbswitch' is available and will be used.
[  149.557932] [DEBUG]Active configuration:
[  149.557972] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  149.558011] [DEBUG] X display: :8
[  149.558050] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331:/usr/lib32/nvidia-331
[  149.558083] [DEBUG] Socket path: /var/run/bumblebee.socket
[  149.558118] [DEBUG] pidfile: /var/run/bumblebeed.pid
[  149.558144] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.nvidia
[  149.558175] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[  149.558203] [DEBUG] ModulePath: /usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules
[  149.558236] [DEBUG] GID name: bumblebiaee
[  149.558270] [DEBUG] Power method: auto
[  149.558303] [DEBUG] Stop X on exit: 1
[  149.558338] [DEBUG] Driver: nvidia
[  149.558366] [DEBUG] Driver module: nvidia-331
[  149.558400] [DEBUG] Card shutdown state: 1
[  149.558601] [DEBUG]Process /sbin/modprobe started, PID 2571.
[  149.558694] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  149.561231] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  149.561321] [DEBUG]Configuration test passed.
[  149.562169] [ERROR]Success
[  149.562213] [ERROR]There is no "bumblebiaee" group

C'est grave docteur hmm?

Hum, tu as dû modifier le groupe dans /etc/bumblebee/bumblebee.conf. La valeur par défaut est : ServerGroup=bumblebee

Nepenthes a écrit :

@ArchangeGabriel :
J'ai un petit problème avec optirun et le lanceur d'un jeu :

./manager.py fso://settings/Media%20VPs%202014
#fonctionne

otpirun ./manager.py fso://settings/Media%20VPs%202014
#ne fonctionne pas

optirun bash
./manager.py fso://settings/Media%20VPs%202014
#fonctionne

Le message d'erreur est celui-ci :

INFO:MainThread:windows.run_mod: Launching...
loris@loris-SATELLITE-S50t-A-117:~/fs2mod-py-develop$ XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":8"
      after 75 requests (75 known processed) with 0 events remaining.
AL lib: ReleaseALC: 1 device not closed

Une idée ?

Hum je ne sais pas, c’est pareil avec vgl et primus ? En fonction de cela, ouvre une issue sur le tracker de primus ou celui de Bumblebee.

Hors ligne

#471 Le 14/03/2014, à 23:39

LePgMoi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonsoir,

Problème résolu d'une autre manière.
En voulant viré bumblebee, j'ai crashé le pc et plus moyen de booter. Je me suis dis, autant tenter ubuntu 14.04. Je l'installe donc et bonne surprise, pas de problème avec "nomodeset" pour booter le live.
Je tombe sur ce site  "http://jedepannetonordi.fr/architecture … dia-prime/", je fais tout comme c'est écrit, pas d'erreur.

J'installe glxgears et prime-indicator puis je test en mode intel. Un résultat de 60fps. Je passe en nvidia via la petite app, et la un résultat de 15000fps.

Tout laisse donc à penser qu'avec cette méthode et sous ubuntu 14.04, tout roule big_smile par contre niveau autonomie je n'ai pas fait le test.
Ici la démarche est avec Nvidia prime et non pas Bumblebee

Bonne soirée

Hors ligne

#472 Le 31/03/2014, à 10:32

Jitsumi

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Salut à tous.
J'ai réussi à faire fonctionné optirun, mais récemment, comme pas mal, j'obtiens ce message quand j'utilise optirun:
[  726.231060] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[  726.231168] [ERROR]Could not connect to bumblebee daemon - is it running?


J'ai essayer pas mal de choses (les conseils dans la doc, les conseils que j'ai pu trouver dans des forums) mais je garde le même message d'erreur.

En fait je pense que ce qui a changé, c'est mon kernel que j'ai du manuellement téléchargé pour pouvoir utiliser le driver de ma carte wifi.
(Je suis en 12.04 avec un kernel 3.11.0-15-generic)

En effet, si je fait sudo bumblebeed -vv j'obtiens:

[  447.615948] [DEBUG]Found card: 04:00.0 (discrete)
[  447.616073] [DEBUG]Found card: 00:02.0 (integrated)
[  447.616152] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  447.617237] [DEBUG]Process /sbin/modprobe started, PID 21155.
[  447.617325] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  447.619771] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  447.619990] [DEBUG]Process /sbin/modprobe started, PID 21156.
[  447.620099] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  447.622459] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  447.622832] [INFO]Loading driver bbswitch (module bbswitch)
[  447.623009] [DEBUG]Process modprobe started, PID 21157.
FATAL: Error inserting bbswitch (/lib/modules/3.11.0-15-generic/updates/dkms/bbswitch.ko): No such device
[  447.656868] [DEBUG]Process with PID 21157 returned code 1
[  447.657237] [ERROR]Module bbswitch could not be loaded (timeout?)
[  447.657251] [DEBUG]bbswitch is not available, perhaps you need to insmod it?
[  447.657262] [INFO]Skipping switcheroo PM method because it is not explicitly selected in the configuration.
[  447.657272] [WARN]No switching method available. The dedicated card will always be on.
[  447.657282] [DEBUG]Active configuration:
[  447.657290] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  447.657299] [DEBUG] X display: :8
[  447.657308] [DEBUG] LD_LIBRARY_PATH: 
[  447.657316] [DEBUG] Socket path: /var/run/bumblebee.socket
[  447.657325] [DEBUG] pidfile: /var/run/bumblebeed.pid
[  447.657334] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.DRIVER
[  447.657343] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[  447.657351] [DEBUG] ModulePath: 
[  447.657360] [DEBUG] GID name: bumblebee
[  447.657369] [DEBUG] Power method: auto
[  447.657377] [DEBUG] Stop X on exit: 1
[  447.657386] [DEBUG] Driver: 
[  447.657394] [DEBUG] Driver module: 
[  447.657403] [DEBUG] Card shutdown state: 1
[  447.657411] [ERROR]Invalid configuration: no driver configured.

La ligne:

FATAL: Error inserting bbswitch (/lib/modules/3.11.0-15-generic/updates/dkms/bbswitch.ko): No such device

est particulièrement intéressante je pense.

EDIT: achang que j'ai bbswitch-dkms d'installé:

dpkg -l | grep -i bbswitch
ii  bbswitch-dkms                          0.8-1~preciseppa1                       Interface for toggling the power on NVIDIA Optimus video cards

Que puis-je faire???

Merci!

Dernière modification par Jitsumi (Le 31/03/2014, à 10:34)

Hors ligne

#473 Le 31/03/2014, à 16:59

Mr_fish77

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Bonjour à tous,

Je débute actuellement avec Linux. J'ai donc installé Ubuntu 13.10 et je ne regrette pas mon choix.

Je suis également fan de jeux vidéo mais mon pc étant équipé de la technologie nvidia optimus (intel 4000 et Geforece 630 GT) , j'ai des problèmes d’installation de driver pour ma carte graphique.
J'ai suivi un tutoriel sur internet détaillant la procédure pour une carte graphique sans savoir que la technologie optimums n’était pas supportée nativement par Linux. Mon manque de recherches approfondies provoqua un plantage de Linux que  je dus réinstaller.

J'ai par la suite découvert le projet Bumblebee permettant le support de cette technologie.
N'étant pas encore très à l'aise avec l'invité de commande je voudrais connaître votre avis sur le sujet et savoir s'il existe des tutoriels simples et détaillés sur le sujet.

J'ai également vus que la technologie optimus serai compatible avec ubuntu 14.04
Faudra-il installer des drivers spéciaux pour pouvoir bénéficier de l'optimus sur la 14.04? Ou les driver "classique" réalisent la prise en charge de l'optimus automatiquement?
Cette prise en charge est-elle disponible sur la version Beta 14.04?

Merci d'avance pour vos réponses:)

Hors ligne

#474 Le 31/03/2014, à 17:12

alca94

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

@ Mr_fish77
peut-être une réponse au post ci-dessus 471

Hors ligne

#475 Le 02/04/2014, à 01:20

ArchangeGabriel

Re : Ordinateurs Portables - Deux cartes graphiques - NVIDIA Optimus

Jitsumi a écrit :

Salut à tous.
J'ai réussi à faire fonctionné optirun, mais récemment, comme pas mal, j'obtiens ce message quand j'utilise optirun:
[  726.231060] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[  726.231168] [ERROR]Could not connect to bumblebee daemon - is it running?


J'ai essayer pas mal de choses (les conseils dans la doc, les conseils que j'ai pu trouver dans des forums) mais je garde le même message d'erreur.

En fait je pense que ce qui a changé, c'est mon kernel que j'ai du manuellement téléchargé pour pouvoir utiliser le driver de ma carte wifi.
(Je suis en 12.04 avec un kernel 3.11.0-15-generic)

En effet, si je fait sudo bumblebeed -vv j'obtiens:

[  447.615948] [DEBUG]Found card: 04:00.0 (discrete)
[  447.616073] [DEBUG]Found card: 00:02.0 (integrated)
[  447.616152] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  447.617237] [DEBUG]Process /sbin/modprobe started, PID 21155.
[  447.617325] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  447.619771] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  447.619990] [DEBUG]Process /sbin/modprobe started, PID 21156.
[  447.620099] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[  447.622459] [DEBUG]SIGCHILD received, but wait failed with No child processes
[  447.622832] [INFO]Loading driver bbswitch (module bbswitch)
[  447.623009] [DEBUG]Process modprobe started, PID 21157.
FATAL: Error inserting bbswitch (/lib/modules/3.11.0-15-generic/updates/dkms/bbswitch.ko): No such device
[  447.656868] [DEBUG]Process with PID 21157 returned code 1
[  447.657237] [ERROR]Module bbswitch could not be loaded (timeout?)
[  447.657251] [DEBUG]bbswitch is not available, perhaps you need to insmod it?
[  447.657262] [INFO]Skipping switcheroo PM method because it is not explicitly selected in the configuration.
[  447.657272] [WARN]No switching method available. The dedicated card will always be on.
[  447.657282] [DEBUG]Active configuration:
[  447.657290] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  447.657299] [DEBUG] X display: :8
[  447.657308] [DEBUG] LD_LIBRARY_PATH: 
[  447.657316] [DEBUG] Socket path: /var/run/bumblebee.socket
[  447.657325] [DEBUG] pidfile: /var/run/bumblebeed.pid
[  447.657334] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.DRIVER
[  447.657343] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[  447.657351] [DEBUG] ModulePath: 
[  447.657360] [DEBUG] GID name: bumblebee
[  447.657369] [DEBUG] Power method: auto
[  447.657377] [DEBUG] Stop X on exit: 1
[  447.657386] [DEBUG] Driver: 
[  447.657394] [DEBUG] Driver module: 
[  447.657403] [DEBUG] Card shutdown state: 1
[  447.657411] [ERROR]Invalid configuration: no driver configured.

La ligne:

FATAL: Error inserting bbswitch (/lib/modules/3.11.0-15-generic/updates/dkms/bbswitch.ko): No such device

est particulièrement intéressante je pense.

EDIT: achang que j'ai bbswitch-dkms d'installé:

dpkg -l | grep -i bbswitch
ii  bbswitch-dkms                          0.8-1~preciseppa1                       Interface for toggling the power on NVIDIA Optimus video cards

Que puis-je faire???

Merci!

Le problème vient du noyau. Il faut que tu télécharges et installes les headers correspondant à ton noyau. Si tu me dis exactement quel fichier tu as téléchargé et où je devrais pouvoir t’indiquer la procédure à suivre.

@Mr_fish77 : Si Bumblebee et son guide dans le wiki ne te conviennent pas, tu peux toujours essayer ce que LePgMoi propose effectivement.

Hors ligne

Haut de page ↑