Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/03/2013, à 22:17

agensbur

[RESOLU] Groupe "admin" absent

Une curiosité que je "vérifie" à l'occasion d'un autre fil.

Le groupe "admin" est absent par défaut dans mes configs xfce (xubuntu 12.04 lts en 32 bits - donc XFCE 4.8 et xubuntu 12.10 64 bits - XFCE 4.10)

On a bien "adm" ou "lpadmin" qui ont l'un comme l'autre une autre fonction.

Conséquences : des prises de têtes quand on débute pour créer de nouveaux "sudoers" via "users-admin". On paramètre un "administrateur" et on obtient pas un nouveau 'sudoer'.

Dans "/etc/sudoers" on a bien %admin, cela devrait donc passer par là, mais "admin" n'existe pas.

On pourrait le créer mais on a aussi %sudo et je m'en tire depuis longtemps par là pour créer un nouveau "sudoers" via "users-admin" (ou en console) - on pourrait s'y prendre d'autres façons, mais cette absence du groupe 'admin' m'intrigue.

- "Bug" ?
- "Spécificité" XFCE ?
- "Volonté" Ubuntu de "sécuriser", au dela de sudo, l'accès au root en faisant que par défaut ce privilège ne puisse être redistribué de façon trop intuitive  (au prix d'une doc et d'une interface graphique incohérente ?)

Quelqu'un a une idée ?

Dernière modification par agensbur (Le 24/03/2013, à 01:01)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 13.10-64 bits
NetBook Samsung NC -10 - Xubuntu 13.10-32 bits

Hors ligne

#2 Le 23/03/2013, à 22:52

xavier4811

Re : [RESOLU] Groupe "admin" absent

Volonté de d'Ubuntu pour compatibilité avec Debian :

wiki.ubuntu.com a écrit :

Up until Ubuntu 11.10, administrator access using the sudo tool was granted via the "admin" Unix group. In Ubuntu 12.04, administrator access will be granted via the "sudo" group. This makes Ubuntu more consistent with the upstream implementation and Debian. For compatibility purposes, the "admin" group will continue to provide sudo/administrator access in 12.04.

Source

Dernière modification par xavier4811 (Le 23/03/2013, à 23:46)

Hors ligne

#3 Le 23/03/2013, à 23:37

The Uploader

Re : [RESOLU] Groupe "admin" absent

Salut

Rien à voir avec Xfce, et je ne pense pas que ce soit un bug.

http://doc.ubuntu-fr.org/sudoers aide ?


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/Xfce sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#4 Le 24/03/2013, à 00:37

agensbur

Re : [RESOLU] Groupe "admin" absent

Vu merci Xavier24, ma curiosité est satisfaite - évolution normale (un peu chaotique, le groupe censé être maintenu en 12.04 ne l'est que 'potentiellement' via visudo mais a déjà 'effectivement' disparu) - je mets en résolu.

Effets collatéraux ?
- je ne sais pas si "users-admin" fonctionnait correctement quand ce groupe était présent - aujourd'hui cela mouline clairement de l'air si on se contente de cocher "administrateur".
- pas mal de doc avec des syntaxes type "sudo adduser toto admin" qui échoueront - c'est normal.

Dernière modification par agensbur (Le 24/03/2013, à 01:06)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 13.10-64 bits
NetBook Samsung NC -10 - Xubuntu 13.10-32 bits

Hors ligne

Haut de page ↑