Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 27/03/2013, à 19:25

dodovolant

[RESOLU] upgrade php à 5.3.7 minimum ?

Bonsoir,
j'ai installé (sous 11.10 oneiric) un serveur lamp qui démarre correctement.
Mais il contient la version  de php 5.3.6, et j'ai besoin de la 5.3.7 minimum pour démarrer le logiciel "galette" que j'ai vraiment envie de tester.
Et je n'arrive pas à upgrader php au-delà de la 5.3.6....
Un tuyau svp ?
(faut-il passer  sous 12.04 pangolin pour avoir une chance? mes premiers essais de cette version m'avaient découragé... comme bcp à l'époque... peut-être a t-elle évolué de manière plus satisfaisante? Merci de vos avis)

Dernière modification par dodovolant (Le 28/03/2013, à 16:23)


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#2 Le 28/03/2013, à 15:26

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

(sous 11.10 oneiric)

Le support de cette version s'arrête dans moins d'un mois, il faut mettre à jour.
Ce qui t'apportera une version plus récente de PHP également.

mes premiers essais de cette version m'avaient découragé

Dans quel sens ? S'il s'agit de l'interface graphique Unity, bah de toute manière sur un serveur on ne met pas d'interface graphique...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#4 Le 28/03/2013, à 15:50

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Smon : moi-même je ne comprend pas ton message... Peut-être peux-tu préciser ce que tu veux dire par ce lien ?
J'ai peur que dodovolant ne comprenne pas mieux que moi...

Surtout que le sites que tu cites est fait pour Debian 6, il n'y a aucune assurance que ça marche sous Ubuntu - quelque version que ce soit.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 28/03/2013, à 16:09

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

tiramiseb a écrit :

Le support de cette version s'arrête dans moins d'un mois, il faut mettre à jour.
Ce qui t'apportera une version plus récente de PHP également.

par "mettre à jour" tu entends 'upgrader à 12.04' ?? et penses-tu que la php sera 5.3.7 au moins (ce serait le minimum logique puisque je suis déjà à 5.3.6) ?

Dans quel sens ? S'il s'agit de l'interface graphique Unity, bah de toute manière sur un serveur on ne met pas d'interface graphique...

Non, je me suis bien fait à unity.... et j'avais d'abord installé la  12.04 après ma 10.04  puisque je suis plutôt fan des versions LTS.  Simplement j'ai réinstallé la 11.10 au bout d'une semaine à cause de "bugs écran noir" que bcp d'utilisateurs annonçaient aussi à l'époque (problème de carte graphique si je me souviens bien...) et qui n'avaient pas de solution.
C'est vrai que j'avais fait la bêtise de 'sauter sur Pangolin' dès sa sortie....  Mais les bugs ont duré plusieurs mois dans mon souvenir (j'ai suivi les forums après avoir réinstallé la 11.10) et j'ai jeté un coup d'oeil cette semaine, je vois encore pas mal de problèmes.... Or la 11.10 ne m'a posé aucun problème.... à mon grand plaisir....
Comme j'ai deux UC, je vais tester sur celle que j'utilise le moins..... Dur, dur la vie de linuxien de base.... mdr...
Merci d'avance des conseils et retours sur Pangolin...


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#6 Le 28/03/2013, à 16:11

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Ca je dois dire, il a été "bref" le Smon tongue
Et savoir où sont les versions de php ne sert à rien si ma version d'ubuntu ne les accepte pas !! lol


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#7 Le 28/03/2013, à 16:13

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

par "mettre à jour" tu entends 'upgrader à 12.04' ??

Oui.


http://packages.ubuntu.com/precise/php5
Dans la 12.04, PHP est en version 5.3.10


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#8 Le 28/03/2013, à 16:23

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

OK, mille mercis...... Ben plus qu'à remettre les mains dans le cambouis.... roll
Salut et merci


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#9 Le 28/03/2013, à 16:24

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

J'accepte quand même d'être rassuré par qqes retours de "Pangolin sans problèmes".... hmm


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#10 Le 28/03/2013, à 16:25

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

En voilà quelques-uns :

Pangolin sans problèmes
Pangolin sans problèmes
Pangolin sans problèmes
Pangolin sans problèmes
Pangolin sans problèmes
Pangolin sans problèmes

Encore un peu plus ? lol


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 28/03/2013, à 17:48

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

mdr.....
je charge un alternate 12.04 pour me risquer dans le upgrade!!
Heureusement qu'on est jeudi saint, je vais dire des prières!! roll

Dernière modification par dodovolant (Le 28/03/2013, à 17:49)


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#12 Le 28/03/2013, à 17:49

Smon

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Dotdeb ce sont des dépots qui peuvent être utilisés pour Debian ou Ubuntu, il te permettent (entre autre) d'avoir les dernières versions d'Ubuntu

deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all

Et de toutes façon, un bon serveur est un serveur Debian tongue

Edit : J'ai oublié ça

wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | sudo apt-key add -

Edit 2 : Bande de noobs tongue

Dernière modification par Smon (Le 28/03/2013, à 17:52)

Hors ligne

#13 Le 28/03/2013, à 17:55

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Merci des infos....
Comme je ne suis qu'un modeste ex-windowsien qui ne raffole pas de la ligne de commande, j'ai choisi ubuntu pour mes débuts sous linux, et ma foi, ça se passe pas trop mal.  J'ai bien compris que Debian est plus.... 'parfaite'? (lol) Faudra que je teste, ça doit pas être pire que Fedora, Mint, ou Mandriva que j'avais juste testées quand j'avais un peu de temps.... Tiens j'ai un CD Debian 6.0.3.... C'est du siècle dernier? lol
... mais non, ma foi.... Est-ce que c'est moins "remuant" qu'ubuntu en termes de mises à jour?

Dernière modification par dodovolant (Le 28/03/2013, à 17:58)


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#14 Le 28/03/2013, à 19:19

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Smon a écrit :

Edit 2 : Bande de noobs tongue

Je me permettrai simplement de citer la page http://www.dotdeb.org/about/ (l'emphase est de moi) :

« The packages from Dotdeb should work on Ubuntu, but no additional support will be provided. »

Donc : aucune assurance de fonctionnement, aucun support.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#15 Le 28/03/2013, à 19:23

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

dodovolant a écrit :

J'ai bien compris que Debian est plus.... 'parfaite'?

Une nouvelle version de Debian ne sort que quand elle est estimée suffisamment stable par les développeurs/mainteneurs.

Du coup, là où une Ubuntu je conseille d'attendre un peu après la sortie (histoire de laisser passer les premiers bugs), je n'ai pas de mal à conseiller d'installer une nouvelle Debian dès sa sortie...

dodovolant a écrit :

Est-ce que c'est moins "remuant" qu'ubuntu en termes de mises à jour?

Pendant un moment une même version de Debian restait longtemps (4 ans pour Woody), mais aujourd'hui il faut s'attendre à un rythme proche de celui des Ubuntu LTS (par contre, pas de support pendant 5 ans comme les LTS : le support de la version N-1 dure 1 an après la sortie de la version N).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#16 Le 28/03/2013, à 19:38

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Mille mercis, je suis quasiment convaincu !! hmm
yapluka.... roll


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#17 Le 28/03/2013, à 19:56

Smon

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Ubuntu c'est le top pour un poste client.
Debian c'est le top pour un serveur.

Voilà, c'est tout smile

Hors ligne

#18 Le 28/03/2013, à 20:23

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Mille mercis des avis et conseils....


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#19 Le 29/03/2013, à 12:21

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

bon, ben juste pour dire la 12.04.2 s'est installée sans moufter sur mon UC2.... Je ne sais pas comment vérifier la version de php incluse (j'ai installé le 'lamp-server' qui me dit 'OK ça roule'....)
Je vais donc tenter le upgrade sur mon UC principale.... Avec les rosaires de cet après-midi, ça devrait passer ?? roll tongue cool


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#20 Le 29/03/2013, à 13:52

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

C'est quoi « le 'lamp-server' » ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#21 Le 29/03/2013, à 14:38

dodovolant

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

un ensemble Linux Apache Mysql Php (wamp sous windows) qui permet de simuler sur son poste le fonctionnement d'un site contenant du php et une base de données....
(excuse, je file au tennis "ace-server" !! mdr...)


hiroshima45, tchernobyl86, windows2000, Vista12 (mois!! mdr)
(piqué ailleurs:) si microsoft invente un truc qui "plante pas"... ce sera un clou !!
sites : nivoyousnisoumis.re - dodosvolants.free.fr
sur facebook : Dod o'Volant

Hors ligne

#22 Le 29/03/2013, à 14:46

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Je demande ça car il y a une horreur qui s'appelle "lampp" (ou "xampp"), et j'ai peur que tu aies choisi d'utiliser cette horreur.

Linux, Apache MySQL et PHP sont disponibles dans les dépôts d'Ubuntu non pour simuler quoi que ce soit mais pour desservir un site, comme n'importe quel serveur web LAMP...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#23 Le 29/03/2013, à 16:00

Smon

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

lamp-server^ c'est un meta package dans Ubuntu, il t'installe un lamp complet en une commande cool

Hors ligne

#24 Le 29/03/2013, à 16:18

tiramiseb

Re : [RESOLU] upgrade php à 5.3.7 minimum ?

Il faut une source spéciale pour l'avoir, ce méta-paquet ?

sebastien@amaretto:~$ apt-cache show lamp-server
N: Impossible de trouver le paquet lamp-server
E: Aucun paquet n'a été trouvé
sebastien@amaretto:~$ apt-cache search lamp-server
sebastien@amaretto:~$ apt-cache search lamp server
sebastien@amaretto:~$

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#25 Le 29/03/2013, à 16:29

Smon

Hors ligne

Haut de page ↑