Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 15/04/2013, à 09:43

antoine.moens

Package dependencies cannot be resolved [Résolu]

Bonjour à tous

Bon bug en pagaille pour l'instant, je me permet de vous poser une petite question.

---------------------------
Remarque (1) je suis en RD Congo et j'ai une connexion de 15 ko/sec ce qui rend l'installation leeeeeeeeeeente
Remarque (2), j'ai également un problème d'installation du Français. Voir ici

---------------------------

Alors lorsque je veux installer un nouveau programme sur Ubuntu, je recois le message d'erreur suivant:

Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

gimp: Depends: libbabl-0.1-0 (>= 0.1.10) but it is not going to be installed
      Depends: libc6 (>= 2.15) but 2.15-0ubuntu20 is to be installed
      Depends: libfontconfig1 (>= 2.9.0) but 2.10.1-0ubuntu3 is to be installed
      Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.26.4-0ubuntu1 is to be installed
      Depends: libgegl-0.2-0 (>= 0.2.0) but it is not going to be installed
      Depends: libglib2.0-0 (>= 2.31.8) but 2.34.1-1ubuntu1 is to be installed
      Depends: libgs9 (>= 8.61.dfsg.1) but 9.06~dfsg-0ubuntu4 is to be installed
      Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.13-0ubuntu2 is to be installed
      Depends: libgudev-1.0-0 (>= 147) but 1:175-0ubuntu13 is to be installed
      Depends: libjpeg8 (>= 8c) but 8c-2ubuntu7 is to be installed
      Depends: librsvg2-2 (>= 2.14.4) but 2.36.3-0ubuntu1 is to be installed
      Depends: libtiff5 (> 4.0.0-1~) but 4.0.2-1ubuntu2.1 is to be installed
      Depends: zlib1g (>= 1:1.1.4) but 1:1.2.7.dfsg-13 is to be installed

Alors j'ai googlisé et j'ai tapé

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f

Mais cela ne fait rien. Quelqu'un à une idée ?

Dernière modification par antoine.moens (Le 23/04/2013, à 12:06)

Hors ligne

#2 Le 15/04/2013, à 11:54

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Salut

Montre le contenu de ton fichier /etc/apt/sources.list


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 15/04/2013, à 12:57

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Voici

# deb cdrom:[Ubuntu 12.10 _Quantal Quetzal_ - Release i386 (20121017.2)]/ quantal main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ quantal main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ quantal-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ quantal universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal universe
deb http://fr.archive.ubuntu.com/ubuntu/ quantal-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ quantal multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ quantal-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu quantal-security main restricted
deb-src http://security.ubuntu.com/ubuntu quantal-security main restricted
deb http://security.ubuntu.com/ubuntu quantal-security universe
deb-src http://security.ubuntu.com/ubuntu quantal-security universe
deb http://security.ubuntu.com/ubuntu quantal-security multiverse
deb-src http://security.ubuntu.com/ubuntu quantal-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu quantal partner
# deb-src http://archive.canonical.com/ubuntu quantal partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu quantal main
deb-src http://extras.ubuntu.com/ubuntu quantal main

Hors ligne

#4 Le 15/04/2013, à 16:22

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Le sources.list est ok, et ta liste d'erreurs laisse perplexe : il se plaint de ne pouvoir installer les dépendances indiquées, alors qu'elles sont toutes bonnes.
Montre le contenu de ton dossier /etc/apt/sources.list.d
As-tu installé des paquets depuis des dépôts non officiels ? C'est peut-être un conflit entre 2 paquets qui ne peuvent pas être installés en même temps.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 16/04/2013, à 09:09

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Non je n'ai pas installé de dépot non-officiels
Le dossier source.list.d est vide

Hors ligne

#6 Le 16/04/2013, à 12:59

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Bizarre... as-tu installé quoi que ce soit qui ne viennent pas des dépôts officiels ?
Essaye d'installer l'une des dépendances de Gimp :

sudo apt-get install libbabl-0.1-0

Qu'est-ce qu'il te répond ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#7 Le 17/04/2013, à 17:51

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Voici ce qu'il me dit

HP-500B-Microtower:~$ sudo apt-get install libbabl-0.1-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libbabl-0.1-0 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libbabl-0.1-0 » n'a pas de version susceptible d'être installée

Hors ligne

#8 Le 17/04/2013, à 18:04

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Maintenant, en regardant l'historique dans la logitèque, je vois qu'Ubuntu a effacé deux documents (voir photo ci-dessous)

Peux être faut il les reinstaller ?

http://img706.imageshack.us/img706/5775/screenshotfrom201304171.png

Dernière modification par antoine.moens (Le 17/04/2013, à 18:06)

Hors ligne

#9 Le 17/04/2013, à 21:49

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Non, ce sont les headers de vieux noyaux, ils ne servent plus.
En revanche, cette histoire de libbabl-0.1-0 est très étrange, ce paquet est dans le dépôt "main", et ton sources.list est ok
Peux-tu re-essayer en faisant un update avant ?

sudo apt-get update
sudo apt-get install libbabl-0.1-0

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#10 Le 18/04/2013, à 11:50

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Toujours le meme problème.

Vous êtes sur qu'il y a un lien avec la désintalation du linux header car c'est la dernière opération qui a fonctionné et juste après ca a bloqué. C'est troublant quand même

2-HP-500B-Microtower:~$ sudo apt-get update
[sudo] password : 
Réception de :1 http://security.ubuntu.com quantal-security Release.gpg [933 B]
Réception de :2 http://extras.ubuntu.com quantal Release.gpg [72 B]            
Atteint http://archive.canonical.com quantal Release.gpg                       
Atteint http://extras.ubuntu.com quantal Release                               
Réception de :3 http://security.ubuntu.com quantal-security Release [49,6 kB]  
Atteint http://fr.archive.ubuntu.com quantal Release.gpg                       
Atteint http://archive.canonical.com quantal Release                           
Atteint http://extras.ubuntu.com quantal/main Sources                          
Réception de :4 http://fr.archive.ubuntu.com quantal-updates Release.gpg [933 B]
Réception de :5 http://fr.archive.ubuntu.com quantal-backports Release.gpg [933 B]
Atteint http://fr.archive.ubuntu.com quantal Release                           
Atteint http://archive.canonical.com quantal/partner i386 Packages             
Réception de :6 http://security.ubuntu.com quantal-security/main Sources [39,9 kB]
Atteint http://extras.ubuntu.com quantal/main i386 Packages                    
Réception de :7 http://fr.archive.ubuntu.com quantal-updates Release [49,6 kB] 
Réception de :8 http://fr.archive.ubuntu.com quantal-backports Release [49,6 kB]
Réception de :9 http://security.ubuntu.com quantal-security/restricted Sources [1 833 B]
Réception de :10 http://security.ubuntu.com quantal-security/universe Sources [16,1 kB]
Ign http://extras.ubuntu.com quantal/main Translation-fr_FR                    
Ign http://extras.ubuntu.com quantal/main Translation-fr                       
Ign http://archive.canonical.com quantal/partner Translation-fr_FR             
Ign http://archive.canonical.com quantal/partner Translation-fr                
Ign http://archive.canonical.com quantal/partner Translation-en                
Ign http://extras.ubuntu.com quantal/main Translation-en                       
Réception de :11 http://security.ubuntu.com quantal-security/multiverse Sources [704 B]
Réception de :12 http://security.ubuntu.com quantal-security/main i386 Packages [106 kB]
Atteint http://fr.archive.ubuntu.com quantal/main Sources                      
Atteint http://fr.archive.ubuntu.com quantal/restricted Sources                
Atteint http://fr.archive.ubuntu.com quantal/universe Sources                  
Atteint http://fr.archive.ubuntu.com quantal/multiverse Sources                
Atteint http://fr.archive.ubuntu.com quantal/main i386 Packages                
Atteint http://fr.archive.ubuntu.com quantal/restricted i386 Packages          
Atteint http://fr.archive.ubuntu.com quantal/universe i386 Packages            
Atteint http://fr.archive.ubuntu.com quantal/multiverse i386 Packages          
Réception de :13 http://security.ubuntu.com quantal-security/restricted i386 Packages [3 531 B]
Atteint http://fr.archive.ubuntu.com quantal/main Translation-fr        
Réception de :14 http://security.ubuntu.com quantal-security/universe i386 Packages [46,6 kB]
Atteint http://fr.archive.ubuntu.com quantal/main Translation-en        
Atteint http://fr.archive.ubuntu.com quantal/multiverse Translation-fr         
Réception de :15 http://security.ubuntu.com quantal-security/multiverse i386 Packages [1 402 B]
Atteint http://fr.archive.ubuntu.com quantal/multiverse Translation-en         
Réception de :16 http://security.ubuntu.com quantal-security/main Translation-en [56,6 kB]
Atteint http://fr.archive.ubuntu.com quantal/restricted Translation-fr         
Atteint http://fr.archive.ubuntu.com quantal/restricted Translation-en       
Réception de :17 http://security.ubuntu.com quantal-security/main Translation-en [56,6 kB]
Atteint http://security.ubuntu.com quantal-security/multiverse Translation-en  
Atteint http://fr.archive.ubuntu.com quantal/universe Translation-fr           
Atteint http://security.ubuntu.com quantal-security/restricted Translation-en  
Atteint http://fr.archive.ubuntu.com quantal/universe Translation-en           
Réception de :18 http://fr.archive.ubuntu.com quantal-updates/main Sources [88,4 kB]
Réception de :19 http://fr.archive.ubuntu.com quantal-updates/restricted Sources [2 564 B]
Réception de :20 http://fr.archive.ubuntu.com quantal-updates/universe Sources [81,8 kB]
Réception de :21 http://fr.archive.ubuntu.com quantal-updates/multiverse Sources [3 661 B]
Réception de :22 http://fr.archive.ubuntu.com quantal-updates/main i386 Packages [225 kB]
Réception de :23 http://security.ubuntu.com quantal-security/universe Translation-en [28,7 kB]
Réception de :24 http://fr.archive.ubuntu.com quantal-updates/restricted i386 Packages [4 841 B]
Réception de :25 http://fr.archive.ubuntu.com quantal-updates/universe i386 Packages [179 kB]
Ign http://security.ubuntu.com quantal-security/main Translation-fr_FR  
Ign http://security.ubuntu.com quantal-security/main Translation-fr            
Ign http://security.ubuntu.com quantal-security/multiverse Translation-fr_FR   
Ign http://security.ubuntu.com quantal-security/multiverse Translation-fr
Ign http://security.ubuntu.com quantal-security/restricted Translation-fr_FR   
Ign http://security.ubuntu.com quantal-security/restricted Translation-fr      
Ign http://security.ubuntu.com quantal-security/universe Translation-fr_FR     
Ign http://security.ubuntu.com quantal-security/universe Translation-fr        
Réception de :26 http://fr.archive.ubuntu.com quantal-updates/multiverse i386 Packages [10,8 kB]
Atteint http://fr.archive.ubuntu.com quantal-updates/main Translation-en       
Atteint http://fr.archive.ubuntu.com quantal-updates/multiverse Translation-en 
Atteint http://fr.archive.ubuntu.com quantal-updates/restricted Translation-en
Atteint http://fr.archive.ubuntu.com quantal-updates/universe Translation-en
Réception de :27 http://fr.archive.ubuntu.com quantal-backports/main Sources [14 B]
Réception de :28 http://fr.archive.ubuntu.com quantal-backports/restricted Sources [14 B]
Réception de :29 http://fr.archive.ubuntu.com quantal-backports/universe Sources [8 895 B]
Réception de :30 http://fr.archive.ubuntu.com quantal-backports/multiverse Sources [781 B]
Réception de :31 http://fr.archive.ubuntu.com quantal-backports/main i386 Packages [14 B]
Réception de :32 http://fr.archive.ubuntu.com quantal-backports/restricted i386 Packages [14 B]
Réception de :33 http://fr.archive.ubuntu.com quantal-backports/universe i386 Packages [13,0 kB]
Réception de :34 http://fr.archive.ubuntu.com quantal-backports/multiverse i386 Packages [1 118 B]
Atteint http://fr.archive.ubuntu.com quantal-backports/main Translation-en     
Atteint http://fr.archive.ubuntu.com quantal-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com quantal-backports/restricted Translation-en
Réception de :35 http://fr.archive.ubuntu.com quantal-backports/universe Translation-en [10,5 kB]
Ign http://fr.archive.ubuntu.com quantal/main Translation-fr_FR                
Ign http://fr.archive.ubuntu.com quantal/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-updates/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-updates/main Translation-fr
Ign http://fr.archive.ubuntu.com quantal-updates/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-updates/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com quantal-updates/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-updates/restricted Translation-fr
Ign http://fr.archive.ubuntu.com quantal-updates/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-updates/universe Translation-fr
Ign http://fr.archive.ubuntu.com quantal-backports/main Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-backports/main Translation-fr
Ign http://fr.archive.ubuntu.com quantal-backports/multiverse Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-backports/multiverse Translation-fr
Ign http://fr.archive.ubuntu.com quantal-backports/restricted Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-backports/restricted Translation-fr
Ign http://fr.archive.ubuntu.com quantal-backports/universe Translation-fr_FR
Ign http://fr.archive.ubuntu.com quantal-backports/universe Translation-fr
1 057 ko réceptionnés en 8min 26s (2 086 o/s)
Lecture des listes de paquets... Fait

HP-500B-Microtower:~$ sudo apt-get install libbabl-0.1-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet libbabl-0.1-0 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libbabl-0.1-0 » n'a pas de version susceptible d'être installée

Hors ligne

#11 Le 18/04/2013, à 11:53

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Et quand j'essaye d'installer gimp depuis le terminal, il m'indique ceci

HP-500B-Microtower:~$ sudo apt-get install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libbabl-0.1-0 (>= 0.1.10) mais il n'est pas installable
        Dépend: libgegl-0.2-0 (>= 0.2.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Hors ligne

#12 Le 18/04/2013, à 20:00

xabilon

Re : Package dependencies cannot be resolved [Résolu]

On va s'occuper de ces headers, mais à priori il n'y a pas de raison que ça bloque tout.
Renvoie le résultat de ces commandes :

uname -r
dpkg-query -l *headers*

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#13 Le 19/04/2013, à 03:46

Mpok

Re : Package dependencies cannot be resolved [Résolu]

Ça semble être PLUS qu'un simple pbm de 'headers'.
Il y a un paquet qui "fout le bordel".
My 2 cents : passer sur aptitude (en ligne de commande) qui va dire explicitement ce qui merde.

Hors ligne

#14 Le 19/04/2013, à 10:40

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Voici la réponse que je recois à la ligne de commanse

uname -r
dpkg-query -l *headers*

La réponse est

HP-500B-Microtower:~$ uname -r
3.5.0-27-generic
HP-500B-Microtower:~$ dpkg-query -l *headers*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom            Version      Architecture Description
+++-==============-============-============-=================================
un  linux-headers  <aucun>                   (aucune description n'est disponi
un  linux-headers- <aucun>                   (aucune description n'est disponi
un  linux-headers- <aucun>                   (aucune description n'est disponi
ii  linux-headers- 3.5.0-27.46  all          Header files related to Linux ker
ii  linux-headers- 3.5.0-27.46  i386         Linux kernel headers for version 
ii  linux-headers- 3.5.0.27.43  i386         Generic Linux kernel headers
ii  linux-headers- 3.5.0.27.43  i386         Transitional package
un  linux-kernel-h <aucun>                   (aucune description n'est disponi

Sinon comment je fais pour installer Aptitude (en sachant que je ne sais rien installer pour l'instant, voir mon premier post)

Dernière modification par antoine.moens (Le 19/04/2013, à 10:43)

Hors ligne

#15 Le 19/04/2013, à 12:23

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Il n'y a rien à signaler dans les headers. Tu tournes sur le noyau 3.5.0-27, tu as donc les headers 3.5.0-27
Aptitude peut être une bonne idée, à la différence de apt-get, il propose des solutions pour résoudre les dépendances.
Il n'est plus installé par défaut, mais tu peux l'installer comme tu as installé Gimp : sudo apt-get install aptitude
Peut-être que ça marchera...

En revanche, je trouve ton problème toujours aussi étrange : libbabl-0.1-0 est dans les dépôts, ton sources.list est bon, et le sudo apt-get update aussi, mais apt-get te dit « E: Le paquet « libbabl-0.1-0 » n'a pas de version susceptible d'être installée »

Au pire, télécharge directement le paquet : http://packages.ubuntu.com/quantal/i386 … 0/download
Ensuite, en cliquant dessus, il devrait s'installer... ou pas, mais il faut qu'on trouve pourquoi il ne s'installe pas.

Et salut Mpok wink !


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#16 Le 19/04/2013, à 12:45

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Installation Aptitude fonctionne pas

HP-500B-Microtower:~$ sudo apt-get install aptitude
[sudo] password : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet aptitude n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « aptitude » n'a pas de version susceptible d'être installée

Par contre quand je clique sur le lien que tu as envoyé, le fichier est installé.

D'ailleurs, lorsque j'ai voulu réinstaller GIMP, il me dit toujours que c'est impossible et me donne le même message sauf qu'il ne mentionne plus la première ligne avec libbabl-0.1-0, ce qui veut dire qu'il est installé. (j'ai mis la phrase qui n'existe plus en rouge). Bref cet élément est installé

The following packages have unmet dependencies:

gimp: Depends: libbabl-0.1-0 (>= 0.1.10) but it is not going to be installed
      Depends: libc6 (>= 2.15) but 2.15-0ubuntu20 is to be installed
      Depends: libfontconfig1 (>= 2.9.0) but 2.10.1-0ubuntu3 is to be installed
      Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.26.4-0ubuntu1 is to be installed
      Depends: libgegl-0.2-0 (>= 0.2.0) but it is not going to be installed
      Depends: libglib2.0-0 (>= 2.31.8) but 2.34.1-1ubuntu1 is to be installed
      Depends: libgs9 (>= 8.61.dfsg.1) but 9.06~dfsg-0ubuntu4 is to be installed
      Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.13-0ubuntu2 is to be installed
      Depends: libgudev-1.0-0 (>= 147) but 1:175-0ubuntu13 is to be installed
      Depends: libjpeg8 (>= 8c) but 8c-2ubuntu7 is to be installed
      Depends: librsvg2-2 (>= 2.14.4) but 2.36.3-0ubuntu1 is to be installed
      Depends: libtiff5 (> 4.0.0-1~) but 4.0.2-1ubuntu2.1 is to be installed
      Depends: zlib1g (>= 1:1.1.4) but 1:1.2.7.dfsg-13 is to be installed

Je peux installer chaque élément en le téléchargeant à la main mais cela risque d'être un peu long hmm

Hors ligne

#17 Le 19/04/2013, à 15:29

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Alors c'est peut-être apt-get qui ne marche pas bien, ou qui est mal configuré.
Tu as la même erreur avec :

sudo apt-get install --ignore-hold libtiff5

?
As-tu déjà "gelé" des paquets dans ton système (les forcer à ne pas être mis à jour) ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#18 Le 19/04/2013, à 16:07

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Voici la réponse.

etoiledusud2@etoiledusud2-HP-500B-Microtower:~$ sudo apt-get install --ignore-hold libtiff5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libtiff5 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 5 non mis à jour.

Mais bon je pense qu'il faut que je répare Ubuntu (genre retour installation CD). C'est possible ? Sachant que l'ordinateur est partitionné Windows/ubuntu

Hors ligne

#19 Le 19/04/2013, à 17:39

xabilon

Re : Package dependencies cannot be resolved [Résolu]

De mieux en mieux : libtiff5 est en fait déjà installé sad

Tu peux éventuellement réinstaller Ubuntu, en choisissant "Partitionnement manuel" lors de l'installation et en utilisant les mêmes partitions.
Mais nous n'en sommes pas encore là...

Peux-tu essayer d'installer, par la même commande (sudo apt-get install --ignore-hold ****), quelque chose qui n'est pas installé... comme par exemple aptitude ?


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#20 Le 20/04/2013, à 09:42

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Toujours le même problème.

HP-500B-Microtower:~$ sudo apt-get install --ignore-hold aptitude
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet aptitude n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « aptitude » n'a pas de version susceptible d'être installée
HP-500B-Microtower:~$ 

Entre paranthèse,je vous suis très reconnaissant de m'aider à résoudre mon problème

Hors ligne

#21 Le 20/04/2013, à 11:55

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Oui, sauf que j'ai quand même du mal à voir d'où ça vient... le problème vient bien du téléchargement de paquets par apt-get. Donc soit c'est un problème de apt-get, soit de connexion internet.
Ça peut être beaucoup de choses... proxy, configuration de apt...

Je vois que tu as 5 paquets à mettre à jour... as-tu essayé de faire la mise à jour ?

sudo apt-get upgrade

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#22 Le 20/04/2013, à 14:12

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Toujours le même soucis

HP-500B-Microtower:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront mis à jour :
  libcurl3 libcurl3-gnutls libcurl3-nss xserver-common xserver-xorg-core
5 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 550 ko/2 332 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  libcurl3-gnutls libcurl3 libcurl3-nss xserver-common xserver-xorg-core
Faut-il installer ces paquets sans vérification (o/N) ? o
Réception de :1 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/main xserver-xorg-core i386 2:1.13.0-0ubuntu6.2 [1 550 kB]
176 ko réceptionnés en 34s (5 112 o/s)                                         
(Lecture de la base de données... 156052 fichiers et répertoires déjà installés.)
Préparation du remplacement de libcurl3-gnutls:i386 7.27.0-1ubuntu1.1 (en utilisant .../libcurl3-gnutls_7.27.0-1ubuntu1.2_i386.deb) ...
Dépaquetage de la mise à jour de libcurl3-gnutls:i386 ...
Préparation du remplacement de libcurl3:i386 7.27.0-1ubuntu1.1 (en utilisant .../libcurl3_7.27.0-1ubuntu1.2_i386.deb) ...
Dépaquetage de la mise à jour de libcurl3:i386 ...
Préparation du remplacement de libcurl3-nss:i386 7.27.0-1ubuntu1.1 (en utilisant .../libcurl3-nss_7.27.0-1ubuntu1.2_i386.deb) ...
Dépaquetage de la mise à jour de libcurl3-nss:i386 ...
Préparation du remplacement de xserver-common 2:1.13.0-0ubuntu6.1 (en utilisant .../xserver-common_2%3a1.13.0-0ubuntu6.2_all.deb) ...
Dépaquetage de la mise à jour de xserver-common ...
Préparation du remplacement de xserver-xorg-core 2:1.13.0-0ubuntu6.1 (en utilisant .../xserver-xorg-core_2%3a1.13.0-0ubuntu6.2_i386.deb) ...
Dépaquetage de la mise à jour de xserver-xorg-core ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libcurl3-gnutls:i386 (7.27.0-1ubuntu1.2) ...
Paramétrage de libcurl3:i386 (7.27.0-1ubuntu1.2) ...
Paramétrage de libcurl3-nss:i386 (7.27.0-1ubuntu1.2) ...
Paramétrage de xserver-common (2:1.13.0-0ubuntu6.2) ...
Paramétrage de xserver-xorg-core (2:1.13.0-0ubuntu6.2) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
HP-500B-Microtower:~$ sudo apt-get install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gimp : Dépend: libgegl-0.2-0 (>= 0.2.0) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Dernière chose, le problème de connexion est bien possible. C'est très très lent la connexion ici (15 ko/sec)

Dernière modification par antoine.moens (Le 20/04/2013, à 14:14)

Hors ligne

#23 Le 21/04/2013, à 01:32

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Alors là, c'est très intéressant : les mises à jour se sont faites sans aucune erreur ; apt-get a téléchargé et installé les paquets sans broncher...

Je sais pas si je suis juste, mais j'ai une petite idée :
Les mises à jour qui ont été faites sans problème, sont des paquets provenant des dépôts "quantal-updates" ou "quantal-security"
Le paquet qui avait bien été correctement installé comme dépendance de Gimp (libtiff5) provient lui aussi de "quantal-updates"
En revanche, les paquets qu'il n'arrive pas à trouver (comme libbabl-0.1-0 ou aptitude), proviennent du dépôt "quantal"

Apt-get a peut-être un problème à joindre ce dépôt, mais :
- l'adresse du dépôt dans le sources.list est correcte
- le "sudo apt-get update" ne donne aucune erreur concernant le dépôt "quantal", donc il arrive bien à l'atteindre.

Il faut chercher pourquoi... que renvoie cette commande ?

apt-cache policy

Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#24 Le 22/04/2013, à 13:54

antoine.moens

Re : Package dependencies cannot be resolved [Résolu]

Voici la réponse

HP-500B-Microtower:~$ sudo apt-cache policy
[sudo] password for etoiledusud2: 
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://extras.ubuntu.com/ubuntu/ quantal/main i386 Packages
     release v=12.10,o=LP-PPA-app-review-board,a=quantal,n=quantal,l=Application Review Board PPA,c=main
     origin extras.ubuntu.com
 500 http://archive.canonical.com/ubuntu/ quantal/partner i386 Packages
     release v=12.10,o=Canonical,a=quantal,n=quantal,l=Partner archive,c=partner
     origin archive.canonical.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/universe Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/restricted Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/multiverse Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/main Translation-en
 100 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/multiverse i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-backports,n=quantal,l=Ubuntu,c=multiverse
     origin fr.archive.ubuntu.com
 100 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/universe i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-backports,n=quantal,l=Ubuntu,c=universe
     origin fr.archive.ubuntu.com
 100 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/restricted i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-backports,n=quantal,l=Ubuntu,c=restricted
     origin fr.archive.ubuntu.com
 100 http://fr.archive.ubuntu.com/ubuntu/ quantal-backports/main i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-backports,n=quantal,l=Ubuntu,c=main
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/universe Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/restricted Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/multiverse Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/main Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/multiverse i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-updates,n=quantal,l=Ubuntu,c=multiverse
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/universe i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-updates,n=quantal,l=Ubuntu,c=universe
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/restricted i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-updates,n=quantal,l=Ubuntu,c=restricted
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal-updates/main i386 Packages
     release v=12.10,o=Ubuntu,a=quantal-updates,n=quantal,l=Ubuntu,c=main
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/universe Translation-fr
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/universe Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/restricted Translation-fr
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/restricted Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/multiverse Translation-fr_FR
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/multiverse Translation-fr
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/multiverse Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/main Translation-fr
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/main Translation-en
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/multiverse i386 Packages
     release v=12.10,o=Ubuntu,a=quantal,n=quantal,l=Ubuntu,c=multiverse
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
     release v=12.10,o=Ubuntu,a=quantal,n=quantal,l=Ubuntu,c=universe
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/restricted i386 Packages
     release v=12.10,o=Ubuntu,a=quantal,n=quantal,l=Ubuntu,c=restricted
     origin fr.archive.ubuntu.com
 500 http://fr.archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
     release v=12.10,o=Ubuntu,a=quantal,n=quantal,l=Ubuntu,c=main
     origin fr.archive.ubuntu.com
Paquets épinglés :

Avec toutes ces questions, j'ai l'impression de devenir un cas d'école pour la communauté ubuntu cool

Hors ligne

#25 Le 22/04/2013, à 14:15

xabilon

Re : Package dependencies cannot be resolved [Résolu]

Tout est à 500, sauf les "quantal-backports"... donc c'est normal
Je sais pas si tu es un "cas d'école", mais en tout cas je me creuse la tête.
Essayons de faire un peu le ménage :

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update
sudo apt-get install -V gimp

Donne les réponses à la 2e et 3e commande.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

Haut de page ↑