Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 03/05/2013, à 11:59

melkhatt

(openbox) obmenu-generator- dépendance "perl-linux-desktopfiles" ?

Bonjour

Je voudrais utiliser "obmenu-generator" pour avoir un menu dynamique avec icônes cô sous manjaro.

Dans les dépendances :
    openbox
    perl>=5.10.0
    perl-data-dump
    perl-linux-desktopfiles

je ne sais pas à quoi ça correspond le dernier dans ubuntu !?

Sinon, sans ça, j'ai une erreur à l'execution :

Can't locate Linux/DesktopFiles.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/bin/obmenu-generator line 30.

Merci

Hors ligne

#2 Le 03/05/2013, à 12:17

Kooothor

Re : (openbox) obmenu-generator- dépendance "perl-linux-desktopfiles" ?

Salut,

Il faut que tu installes le module Linux::Desktopfiles avec CPAN.
http://perl.about.com/od/packagesmodule … rlcpan.htm

@+
~ktr


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 03/05/2013, à 17:08

melkhatt

Re : (openbox) obmenu-generator- dépendance "perl-linux-desktopfiles" ?

Kooothor a écrit :

Salut,

Il faut que tu installes le module Linux::Desktopfiles avec CPAN.
http://perl.about.com/od/packagesmodule … rlcpan.htm

@+
~ktr

Merci , j'ai téléchargé "Linux-DesktopFiles-0.07.tar.gz" et je vais essayer

perl Build.PL
         ./Build
         ./Build test
         ./Build install

Je croyais qu'il y avait une lib équivalente sous ubuntu ?! parceque ce gars a l'air de l'utiliser sous debian sans compiler.

Dernière modification par melkhatt (Le 03/05/2013, à 17:08)

Hors ligne