Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 08/05/2013, à 18:28

etienoo

[Résolu] iBus ne fonctionne que sous Kate et autres applications KDE

Bonjour,

Depuis que j'ai mis Kubuntu à jour de la version 12.10 à la nouvelle version 13.04, iBus ne se lance plus au démarrage, et ne fonctionne que sous Kate (ou Kile). Mais ni sous Firefox, ni sous Skype, etc.

Je ne peux ni lancer le mode chinois (j'utilise le raccourci contrôle-espace), ni écrire en chinois alors même que le mode est activé, ailleurs que dans une application KDE.
Ce n'était pas le cas avant.

En outre, iBus ne se lance plus au démarrage ; il faut que je le lance manuellement via le menu KDE.

Enfin, notons que le même problème apparaît sur une autre machine où j'ai installé kubuntu 13.04 from scratch ; le problème ne vient donc pas de la migration 12.10 --> 13.04 mais bien de la version 13.04 elle-même.

Ma config :
Kubuntu 13.04 64 bits
MacBook Pro 6.2
2.66GHz Intel Core I7

Merci de vos suggestions !

Dernière modification par etienoo (Le 11/05/2013, à 11:59)

Hors ligne

#2 Le 08/05/2013, à 23:40

Keiser

Re : [Résolu] iBus ne fonctionne que sous Kate et autres applications KDE

Hors ligne

#3 Le 11/05/2013, à 11:14

etienoo

Re : [Résolu] iBus ne fonctionne que sous Kate et autres applications KDE

Ce sujet ne m'a pas aidé sad

Ce sujet a écrit :

dans "configuration du système" "localisation" "langue du système", j'ai installé le chinois, et, dans l'onglet "default system", j'ai paramétré le français et le chinois comme utilisant la méthode de saisi "ibus" (en bas à droite de la fenêtre).

Sauf que ces différents onglets n'existent pas chez moi…

En revanche, cette solution a résolu le problème, à savoir :

sudo im-config

et changer la méthode par défaut à iBus.
(J'ai dû installer zenity au passage.)

Effet de bord : l'accent circonflexe ne fonctionne plus dans les applications non KDE sad
Mais bon, avec les commandes clavier (altgr + U pour Û, par exemple), ça reste utilisable.

謝謝!

Hors ligne

#4 Le 11/05/2013, à 11:57

Keiser

Re : [Résolu] iBus ne fonctionne que sous Kate et autres applications KDE

Salut,

C'est curieux que ça n'a pas marché chez toi, ils ont peut être changé leur méthode sad.
Bon, tu as pu trouvé, c'est le principal.
Si c'est résolu, pense à marqur [résolu] dans le titre de ton post.

Hors ligne

#5 Le 11/05/2013, à 11:59

etienoo

Re : [Résolu] iBus ne fonctionne que sous Kate et autres applications KDE

Done!
(Et merci de tes réponses rapides.)

Hors ligne