Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 13/05/2013, à 13:55

aRn0D

Problème Dual screen (carte graphique ATI)

Bonjour à tous,

Je n'arrive pas à configurer mon dual screen! je viens d'installer la 13.04, j'ai un carte graphique ATI et j'utilise le pilote propriétaire. Quand je branche mon second écran la résolution des deux écrans passent 640x320, du coup je ne peux plus rien faire....

boulot@aRn0D:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [Radeon HD 6600M/6700M/7600M Series]

Voila mon xorg.conf, j'ai essayé de modifier en mettant les bonnes résolutions et position mais rien n'y fais... pour info au début je n'avais de xorg.conf il a été généré après un modif via l'inteface du pilote propriétaire. Mes connaissances restent quand même très limitées, je vous l'accorde... Je préfère vous demander conseil avant.

Section "ServerLayout"
        Identifier     "amdcccle Layout"
        Screen      0  "amdcccle-Screen[1]-0" 0 0
EndSection

Section "Monitor"
        Identifier   "0-LVDS"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1440x900"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Monitor"
        Identifier   "0-DFP1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1920x1080"
        Option      "TargetRefresh" "60"
        Option      "Position" "1440 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Device"
        Identifier  "amdcccle-Device[1]-0"
        Driver      "fglrx"
        Option      "Monitor-LVDS" "0-LVDS"
        Option      "Monitor-DFP1" "0-DFP1"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "amdcccle-Screen[1]-0"
        Device     "amdcccle-Device[1]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual   3360 1980
                Depth     24
                Modes    "1920x1080"
        EndSubSection
EndSection

Ah petite précision, avant d'installer ubuntu j'étais sous mint et ça fonctionnait bien pourtant...
Merci pour votre aide.

Dernière modification par aRn0D (Le 13/05/2013, à 13:56)

Hors ligne

#2 Le 15/05/2013, à 13:55

aRn0D

Re : Problème Dual screen (carte graphique ATI)

Bonjour,
Personne n'a une idée, s'il vous plaît? Après avoir fait plusieurs bidouille avec xrandr... j'ai réussi à avoir un mon second écran affiché en 1440x900. J'ai fais :

xrandr --addmode "1440x900"

Du coup la résolution était diponible dans catalyst (j'ai fais la modif via cette interface). La résolution n'existait pas en 1920x1080 (c'est que xrandr m'a dit quand j'ai voulu ajouter ce nouveau mode) alors j'ai fais xrandr --newmode mais je pense m'y être mal pris (je n'ai pas bien suivi la procédure : https://wiki.ubuntu.com/X/Config/Resolution)... J'ai voulu la supprimer pour bien la créer en utilisant l'option rmmode et delmode mais c'est impossible, j'obtiens une erreur de ce type là :

X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  141 (RANDR)
  Minor opcode of failed request:  19 (RRDeleteOutputMode)
  Serial number of failed request:  61
  Current serial number in output stream:  62

Voici ce que me donne un xrandr -q

LVDS connected 1440x900+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1440x900       59.9*+
   1280x800       59.9  
   1280x768       59.9  
   1280x720       59.9  
   1024x768       59.9  
   1024x600       59.9  
   800x600        59.9  
   800x480        59.9  
   640x480        59.9  
DFP1 connected 1440x900+1440+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080      60.0 +
   640x480        59.9 +
   1680x1050      60.0  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9* 
   1280x960       60.0  
   1280x768       59.9  
   1280x720       59.9  
   1024x768       59.9  
   1024x600       59.9  
   800x600        59.9  
   800x480        59.9  
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
DFP5 disconnected (normal left inverted right x axis y axis)
DFP6 disconnected (normal left inverted right x axis y axis)
DFP7 disconnected (normal left inverted right x axis y axis)
DFP8 disconnected (normal left inverted right x axis y axis)
DFP9 disconnected (normal left inverted right x axis y axis)
DFP10 disconnected (normal left inverted right x axis y axis)
DFP11 disconnected (normal left inverted right x axis y axis)
DFP12 disconnected (normal left inverted right x axis y axis)
  1920x1080_59.90 (0xe8)  172.8MHz
        h: width  1920 start 2048 end 2248 total 2576 skew    0 clock   67.1KHz
        v: height 1080 start 1083 end 1088 total 1120           clock   59.9Hz

Bizarre le résultat obtenu pour DFP12, non?
Merci pour votre aide.

Hors ligne

#3 Le 15/05/2013, à 14:10

aRn0D

Re : Problème Dual screen (carte graphique ATI)

Ah je viens de penser à quelque chose qui pourait être important quand j'ai installé le pilote ati, j'ai eu droit au message hardware unsupported. Du coup après quelques recherches j'ai installé le paquet fglrx-update... Au final je n'ai pas le bon driver non ?

Hors ligne

Haut de page ↑