Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 28/12/2004, à 20:40

Cougar

[Résolu]USB ne marche pas

Bonjour,

j'ai un joli ordinateur avec 6 ports USB compatibles USB 2.
Malheureusement, je crois que Ubuntu ne les gère pas alors qu'ils marchaient sur une Mandrake 10.

Les indices:
- je n'arrive pas à brancher mon imprimante en USB. Elle n'est pas détectée par l'utilitaire d'imprimante.
   elle est détectée automatiquement et marche très bien sur port parallèle ( pour info:  HP 920C )
- la clef USB de ma soeur n'a provoqué aucune réaction

Le matos:( ce que me dit usbview )

Silicon Integrated Systems [SiS] USB 2.0 Controller
Manufacturer: Linux 2.6.8.1-4-686 ehci_hcd
Serial Number: 0000:00:03.3
Speed: 480Mb/s (high)
Number of Ports: 6
Bandwidth allocated: 0 / 800 (0%)
Total number of interrupt requests: 0
Total number of isochronous requests: 0
USB Version:  2.00
Device Class: 09(hub  )
Device Subclass: 00
Device Protocol: 01
Maximum Default Endpoint Size: 8
Number of Configurations: 1

Config Number: 1
    Number of Interfaces: 1
    Attributes: e0
    MaxPower Needed:   0mA

    Interface Number: 0
        Name: hub
        Alternate Number: 0
        Class: 09(hub  )
        Sub Class: 0
        Protocol: 0
        Number of Endpoints: 1

            Endpoint Address: 81
            Direction: in
            Attribute: 3
            Type: Int.
            Max Packet Size: 2
            Interval: 256ms

Résultat d'un lsmod | grep usb

usbcore               115684  4 ohci_hcd,ehci_hcd

Comment savoir si ça marche et comment faire marcher ?

Merci d'avance


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#2 Le 28/12/2004, à 20:57

chris19

Re : [Résolu]USB ne marche pas

Bonsoir
Tapes en console cat /proc/bus/usb/devices et donnes nous le résultat
A+

Hors ligne

#3 Le 28/12/2004, à 21:17

Cougar

Re : [Résolu]USB ne marche pas

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 6
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 2.06
S:  Manufacturer=Linux 2.6.8.1-4-686 ehci_hcd
S:  Product=Silicon Integrated Systems [SiS] USB 2.0 Controller
S:  SerialNumber=0000:00:03.3
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=256ms

Merci de ton aide chris


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#4 Le 28/12/2004, à 22:07

chris19

Re : [Résolu]USB ne marche pas

En effet il n'y a pas grand chose.
J'ai 4 ports usb2 + 2 usb1 avec imprimante, scanner ( problème ), appareil numérique, clé et joystick. Ca marche sans aucun problème .
La seule chose que je trouve différent c'est le noyau.
J'ai un noyau 2.6.8.1-3-386. Voila ce que donne les 2 commandes :

christian@ubuntu:~ $ lsmod | grep usb
usb_storage            59200  0
scsi_mod              115148  2 sd_mod,usb_storage
usblp                  12032  0
usbhid                 28864  0
usbcore               104292  7 usb_storage,usblp,usbhid,ehci_hcd,ohci_hcd
ide_core              125272  5 usb_storage,ide_cd,ide_generic,ide_disk,amd74xx
christian@ubuntu:~ $ uname -r
2.6.8.1-3-386
Problème de noyau ? compilation ?

Hors ligne

#5 Le 28/12/2004, à 22:19

Cougar

Re : [Résolu]USB ne marche pas

Nop ! Je ne pense pas...
D'ailleurs, à propos de ton noyau, tu devrais peut-être mettre à jour via Synaptic wink


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#6 Le 28/12/2004, à 22:52

chris19

Re : [Résolu]USB ne marche pas

Il me va très bien mon noyau
Pas envie de me coltiner nvidia.
A+

Hors ligne

#7 Le 28/12/2004, à 23:59

nucle

Re : [Résolu]USB ne marche pas

Moi j'ai ca:

nucle@vorbarra:~ $ lsmod | grep usb
usb_storage            59840  2
usblp                  12032  0
usbhid                 29248  0
usbcore               104804  6 usb_storage,usblp,usbhid,uhci_hcd
scsi_mod              115660  4 usb_storage,sbp2,sr_mod,sd_mod
ide_core              128240  5 usb_storage,ide_cd,ide_generic,piix,ide_disk
nucle@vorbarra:~ $ uname -a
Linux vorbarra 2.6.9-1-386 #1 Thu Dec 16 11:09:45 UTC 2004 i686 GNU/Linux

et tt fonctionne tres bien:
- Imprimante: HP1220c
- Souris USB
- Lecteur multicartes PEAK
- Lecteur multimedia Archos
- APN casio EX-P700

A noter ke tt est en USB 1.1
Et tt est reperé tt de suite.. (ca me change de gentoo)
Je ne sais pas si j'aide sad


Ce qui vaut la peine d'être fait, vaut la peine d'être bien fait. (Loïs McMaster Bujold)

Hors ligne

#8 Le 29/12/2004, à 00:16

fays

Re : [Résolu]USB ne marche pas

Pour la clé USB tu as besoin de faire un prob d'usb-storage
pour le reste essaie de faire un prob d'usbhid.

Par ailleurs ton imprimante est peut etre en uhci (et non ohci ou ehci) donc essaie l'uhci_hcd aussi


Fays

Hors ligne

#9 Le 29/12/2004, à 11:41

Cougar

Re : [Résolu]USB ne marche pas

Non, fait après avoir Googlelisé avec le mot-cléf "T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00"   (Véridique ) wink

J'ai trouvé la solution, il fallait envoyer l'argument "acpi=off" au kernel smile

Merci tlm


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#10 Le 29/12/2004, à 12:43

fays

Re : [Résolu]USB ne marche pas

Décidément acpi entre en conflit avec beaucoup de choses


Fays

Hors ligne

#11 Le 29/12/2004, à 12:44

x4m

Re : [Résolu]USB ne marche pas

chris19 a écrit :

Il me va très bien mon noyau
Pas envie de me coltiner nvidia.
A+

Il comporte une faille de sécurité.

Hors ligne

Haut de page ↑